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Welcome to Survey Crafter 
Professional

Welcome to Survey Crafter Professional, the complete survey and 
analysis tool from Survey Crafter.

Survey Crafter Professional is a powerful yet simple-to-use tool for 
survey research that enables you to quickly collect and easily understand 
critical information about your customers, prospects, employees, and 
other audiences. By helping you get closer to your customers and 
employees, Survey Crafter Professional lets you empower your 
decision-making with real data and enables you to win in a competitive 
environment.

Read this preface for an overview of the Survey Crafter Professional 
User’s Guide.

Preface Contents

• Audience  viii

• Purpose  ix

• Using This Manual  ix

• Typographical Conventions  xi 
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Audience

Survey Crafter Professional is designed for a variety of users including:

• People with customer service responsibilities

• People with product and marketing strategy development 
responsibilities

• People who need a better understanding of their customers’ needs

• Organizations and individuals who previously have had little time, 
money, or expertise for conducting surveys

• Organizations or individuals interested in retaining customers

• Organizations or managers interested in employee satisfaction and other 
human resource issues

• Organizations who are in a very fast-paced market or who are facing 
increased competition

• Organizations that have a new or growing need for survey automation

• Organizations or individuals who may have done simple surveys before 
by hand but are now using larger or more complex surveys

• Organizations and individuals who need to turn information into results 
quickly

• Organizations or individuals who are interested in reducing consultant 
costs
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Purpose

The Survey Crafter Professional User’s Guide features step-by-step 
instructions for a wide range of Survey Crafter Professional tasks 
including: 

• Creating surveys

• Building or importing and editing a database of survey responses

• Analyzing survey data

To use Survey Crafter Professional, you should have experience using 
software with a graphical user interface like Microsoft Windows or the 
Macintosh. You should also have a basic understanding of the survey 
research process. To learn more about the survey research process, see 
Understanding Survey Research:  A Primer for Success.

Using This Manual

The chapters of the Survey Crafter Professional User’s Guide cover the 
following information:

Part I  Learning the Basics

• Chapter 1, “Survey Crafter Professional Basics,” explains procedures 
common to all studies including opening and closing files, printing, and 
saving.

Part II  Working with a Study

• Chapter 2, “Surveys,” explains how to create a survey in Survey Crafter 
Professional.
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• Chapter 3, “Data,” explains how to populate a study database by 
entering survey responses manually or by importing a data file 
containing them and how to edit and export survey data.

• Chapter 4, “Analyses: Tables,” explains how to perform calculations on 
survey data and present the results in formatted tables.

• Chapter 5, “Analyses: Charts,” explains how to show the results of an 
analysis as a chart and how to format charts.

• Chapter 6, “Variables,” explains how to create variables to store 
imported data and variables to store the results of calculations.

Part III  Working with Expressions

• Chapter 7, “Expressions,” explains how to write formulae Survey 
Crafter Professional uses to perform calculations. This chapter includes 
examples of expressions.

Part IV  Reports

• Chapter 8, “Batch Reports,” explains how to design, print and export 
batch reports.

Appendices

• Appendix A, “About Import Files and Data Dictionary Files,” describes 
the structure of import files and data dictionary files, which are used 
when you import data into a Survey Crafter Professional study.

• Appendix B, “Setting Startup Preferences,” explains how to set 
preferences for your copy of Survey Crafter Professional.

• Appendix C, “Glossary,” defines Survey Crafter Professional and 
survey research terms.
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Typographical Conventions 

Before you start using Survey Crafter Professional, read Table P - 1 to 
familiarize yourself with the conventions used in the Survey Crafter 
Professional User’s Guide. 

Table P - 1: Conventions followed in the Survey Crafter Professional User’s Guide.

Convention Type of information Example

Square brackets [ ] Keyboard keys Press [Enter].

Italic type Variable names The variable age stores respondents’ ages.

Courier type • An expression, function, 
or function argument

• Parameters in supporting 
files like a data 
dictionary file.

Use the MEAN() function to compute an 
average.

Define the Text Qualifier parameter.

CAPITAL LETTERS File names or path names C:\SURVEY\PROJ1.MKT

Bold type Text you type In the Units field, type US dollars. (In this case, 
you would type the letters “US” and then a 
space and then the word “dollars”.)

Warning appearing 
as the first word in a 
shaded box with an 
exclamation mark in a 
triangle

Caution against possible 
data loss

Note appearing as the 
first word in a shaded 
box

Extra information

Warning Pressing the Reset 
button deletes all of the chart’s 
current formatting and cannot be 
undone.

Note If a cell contains the message 
#Update, its value needs to be 
recalculated. Choose the Update 
command from the Edit menu.



xii Welcome to Survey Crafter Professional
  
Tip appearing as the 
first word in a shaded 
box

Hints for using Survey 
Crafter Professional more 
efficiently

Cross-reference to 
Understanding Survey 
Research:  A Primer for 
Success

For guidelines on writing 
effective survey questions, see 
the section “Designing, 
Writing, and Testing the 
Survey” in Chapter 4 of 
Understanding Survey 
Research:  A Primer for 
Success.

Table P - 1: Conventions followed in the Survey Crafter Professional User’s Guide. (Continued)

Convention Type of information Example

Tip To print a survey quickly, click the 
Print button on the toolbar.

In the Primer In the Primer



1 Survey Crafter Professional Basics

A Survey Crafter Professional file is called a study. This chapter covers 
basic procedures for working with Survey Crafter Professional studies.

Chapter Contents

• Creating and Opening Studies  1 - 2

• Using the Study Window  1 - 4

• Organizing a Study’s Windows  1 - 9

• Printing Surveys, Tables, Charts and Batch Reports  1 - 10

• Updating a Study  1 - 33

• Saving Your Work  1 - 34

• Compacting a Study  1 - 36

• Closing Studies and Exiting Survey Crafter Professional  1 - 37
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Creating and Opening Studies

You can have only one Survey Crafter Professional study open at a time. 
If you have a study open and try to create or open another, Survey Crafter 
Professional prompts you to save any changes to the open study and then 
closes it before creating or opening the other study.

Creating a New Study

Use the File menu’s New command to create a new study.

• To create a new study

From the File menu, choose New or click on the New Study button on the 
toolbar.

An untitled study appears in the Study window.

Opening an Existing Study

Use the Open command from the File menu to open a study saved on 
disk.

• To open an existing study

1 From the File menu, choose Open or click on the Open Study button 
on the toolbar.

2 From the Locations (Look in) drop-down list, select the location that 
contains the study you want to open.

New Study button

Open Study button
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All the locations connected to your machine appear in the list.

Figure 1 - 1: The Open dialog box.

3 In the Folders list, select the folder that contains the study.

4 In the Folders list, select the study.

5 Click on the Open button.
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Using the Study Window

The Study window is your home base in Survey Crafter Professional. Its 
tabs organize and provide access to the four categories of study 
components (surveys, the data set, analyses, and variables).

Access any category of study components by doing one of the following:

• Clicking on the Study window tab corresponding to the category you 
want.

• When the Study window is the active window, choosing the View 
menu’s command corresponding to the category you want.

Each tab is described below.
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Surveys Tab

From the Surveys tab, you can create, rename, edit, copy and delete the 
study’s surveys.

Figure 1 - 2: The Surveys tab of the Study window.

Click on the Edit 
button to edit an 
existing survey, 
the Info button to 
change a 
survey’s name 
and description, 
the New button 
to create a 
survey, the Copy 
button to make a 
copy of a survey 
and the Delete 
button to delete a 
survey.
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Data Tab

From the Data tab, you can enter the name and description of the study’s 
data set. Click on the Edit button to have Survey Crafter Professional 
display the Data window.

Figure 1 - 3: The Data tab of the Study window.

Click on the Edit 
button to enter 
or import, view, 
and edit the 
study’s data set.
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Analyses Tab

From the Analyses tab, you can create, rename, edit, copy and delete 
analysis tables, charts and batch reports.

Figure 1 - 4: The Analyses tab of the Study window.

Click on the Edit button 
to open or edit an 
existing analysis, the 
Info button to edit an 
analysis’ name and 
description, the Copy 
button to make a copy 
of an analysis, and the 
Delete button to delete 
an analysis.

This tab lists 
analyses currently 
in the study. The 
icon indicates 
whether the 
analysis is in table 
or chart format, or 
if the analysis is a 
batch report.
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Variables Tab

From the Variables tab, you can create, rename, edit, copy and delete the 
study’s imported and computed variables, which store responses to survey 
questions or results of calculations.

Figure 1 - 5: The Variables tab of the Study window.

Click on the Edit 
button to open or edit 
an existing variable, 
the Info button to edit a 
variable’s name and 
description, the Copy 
button to make a copy 
of a variable, and the 
Delete button to delete 
a variable.

This tab lists 
variables 
currently in the 
study. The letter 
indicates the 
variable’s type.
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Organizing a Study’s Windows

While working in Survey Crafter Professional, you may have several 
windows open at once. To make it easy to find the window you want, you 
can arrange the windows by using the Window menu’s Cascade 
command.

• To organize a study’s windows 

From the Window menu, choose Cascade.

Survey Crafter Professional arranges all of the study’s open windows so 
that they overlap but have their title bars visible.

Figure 1 - 6: Cascaded windows.
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Printing Surveys, Tables, Charts and Batch 
Reports

This section covers the following procedures for setting print options and 
for printing surveys, tables, charts and batch reports:

• Selecting a Printer

• Previewing a Printed Survey

• Previewing a Printed Analysis Table

• Printing a Survey, Table, Chart, or Batch Report

• Specifying the Page Orientation and Size

• Reducing or Enlarging What You Want to Print

• Controlling the Alignment of Printed Surveys, Tables, Charts and Batch 
Reports

• Setting the Page Printing Order for Tables

• Creating Headers and Footers for Printed Surveys, Tables and Batch 
Reports

• Printing a Table’s Grid Lines, Row Numbers, and Column Letters

• Controlling Color in Printed Tables

• Printing Multiple Copies

Selecting a Printer

Selecting a printer for surveys, tables, charts and batch reports requires 
different procedures. Each procedure appears below.

• To select a printer for surveys

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.



      Survey Crafter Professional Basics 1 - 11 
Printing Surveys, Tables, Charts and Batch Reports
3 From the File menu, choose Print Setup.

4 Under Printer, select a printer.

Figure 1 - 7: The Survey Print Setup dialog box.

5 Click on the OK button.

• To select a printer for tables and charts

1 Open the table or chart to print.

Make sure that the Analysis window that contains the table or chart is 
the active window.

2 From the File menu, choose Print.
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3 Under Printer, select a printer.

Figure 1 - 8: The Table Print dialog box.

4 Click on the OK to print now. Click on the Cancel to abort the 
operation.

• To select a printer for batch reports

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.

4 Complete the Batch Report Print/Export dialog box.

5 Click on the Finish button.

Survey Crafter Professional displays the Print dialog box.
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6 Under Printer, select a printer.

Figure 1 - 9: The Batch Report Print dialog box.

7 Click on the OK button to print now. Otherwise, Click on the Cancel 
button to abort the operation.

Previewing a Printed Survey

By previewing the printed survey, you can see what your survey will look 
like on paper before sending it to your printer.

• To preview a printed survey

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.

3 From the File menu, choose Print Preview.

4 To print the survey, click on the Print button.

5 To edit the survey, click on the Edit button.
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Previewing a Printed Analysis Table

By previewing the printed analysis table, you can see what your table will 
look like on paper before sending it to your printer.

• To preview a printed analysis table

1 Open the analysis table to print.

Make sure that the Analysis window is the active window.

2 From the File menu, choose Print Preview.

3 To print the table, click on the Print button.

4 To edit the table without printing, click on the Close button.

Printing a Survey, Table, Chart, or Batch Report

You can print an entire survey, table, chart, or batch report. If you want, 
you can print a selected portion of a survey or table. Charts and batch 
reports can be printed in their entirety only.

Printing an Entire Survey, Table, Chart, or Batch Report
Printing a survey, table, chart or batch report requires different 
procedures. Each procedure appears below.

• To print a survey or table

1 Open the survey or table to print.

Make sure that the Survey Designer window or the Analysis window 
that contains the table is the active window. Also make sure that the 
Survey Designer window is in the Print Layout mode.

2 From the File menu, choose Print.

3 Under Print Range, select the All option.

4 Click on the OK button.

Tip  For a printing short cut, open the survey, table, chart, or batch report 
to print. Then click on the Print button on the toolbar. 

Print button
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• To print a chart

1 Open the chart to print.

Make sure that the Analysis window that contains the chart is the 
active window.

2 From the File menu, choose Print.

3 Click on the OK button.

• To print a batch report

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.

4 Complete the Batch Report Print/Export dialog box.

5 Click on the Finish button.

Printing a Range of Pages from a Survey or Table
You can print a selected page or range of pages from a survey or table. 
Charts and batch reports, however, can be printed in their entirety only.

• To print a range of pages from a survey or table

1 Open the survey or table to print.

Make sure that the Survey Designer window or the Analysis window 
that contains the table is the active window. Also make sure that the 
Survey Designer window is in the Print Layout mode.

2 From the File menu, choose Print.

3 Under Print Range, select the Pages option.

4 In the From field, enter the number of the first page in the print range.

5 In the To field, enter the number of the last page in the print range.
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To print a single page, enter the same number in the From and To 
fields.

6 To print the range, click on the OK button.

Specifying the Page Orientation and Size

You can print surveys, tables, charts and batch reports in portrait or 
landscape view. You can also choose a paper size and source.

Specifying page orientation and size for surveys, tables, charts and batch 
reports requires different procedures. Each procedure appears below.

The location and names of some of the features described below can vary 
depending on the printer you have selected.

• To specify page orientation and size for surveys

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.

3 From the File menu, choose Print Setup.

4 Under Paper, select a paper size.

5 Under Orientation, select either the Portrait or Landscape option.

6 Click on the OK button to close the Print Setup dialog box.

• To specify page orientation and size for tables

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Page tab.

4 Under Orientation, select either the Portrait or Landscape option.

5 From the Paper Size drop-down list, select a paper size.

Portrait view

Landscape view
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6 Click on the OK button to close the Page Setup dialog box.

7 To print the table, choose Print from the File menu and then click on 
the OK button.

• To specify page orientation and size for charts

1 Open the chart to print.

Make sure that the Analysis window that contains the chart is the 
active window.

2 From the File menu, choose Print.

3 Click on the Layout button on the Print dialog box.

4 Under Orientation, select either the Portrait or Landscape option.

5 Click on the OK button to close the Print Layout dialog box.

6 Click on the Properties button on the Print dialog box.

7 From the Paper Size drop-down list, select a paper size.

8 Click on the OK button to close the Printer Properties dialog box.

9 To print the chart, click on the OK button.

• To specify page orientation for batch reports

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.

4 Click on the Print Setup tab.

5 Under Set the orientation, select either the Portrait or Landscape 
option.

6 Complete the Batch Report Print/Export dialog box.

7 To print the batch report, Click on the Finish button.
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Reducing or Enlarging What You Want to Print

You can reduce or enlarge a survey, table, or chart by a percentage. You 
can also fit a table to a specified number of pages or have Survey Crafter 
Professional automatically size a chart.

These options are not available for batch reports. In addition, some 
printers do not support reducing or enlarging what you want to print.

Reducing or enlarging surveys, tables, and charts requires different 
procedures. Each procedure appears below.

• To reduce or enlarge a survey

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.

3 From the File menu, choose Print Setup.

4 Click on the Properties button.

5 In the Printer Properties dialog box, click on the Options button.

6 In the Scaling field, enter the percentage by which to reduce or 
enlarge the survey.

100 percent prints the survey at normal size.

7 Click on the OK button to close the Options dialog box.

8 Click on the OK button to close the Printer Properties dialog box.

9 Click on the OK button to close the Print Setup dialog box.

• To reduce or enlarge a table

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Page tab.

4 Do one of the following:
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• To fit the printed table to a number of pages, select the Fit To Pages 
radio button. Then go to step 5.

• To reduce or enlarge the table by a percentage, select the Adjust To 
% Normal Size radio button. Enter the percentage in the Scale field. 
Then go to step 7.

5 In the Pages Wide field, enter the number of pages wide you want the 
printed table to be.

6 In the Pages High field, enter the number of pages high you want the 
printed table to be.

7 Click on the OK button.

8 To print the table, choose Print from the File menu, and then click on 
the OK button.

• To reduce or enlarge a chart

1 Open the chart to print.

Make sure that the Analysis window that contains the chart is the 
active window.

2 From the File menu, choose Print.

3 Do one of the following:

• To have Survey Crafter Professional automatically size the chart, 
click on the Layout button. Then go to step 4.

• To reduce or enlarge the chart by a percentage, select the Print 
Setup tab. Then go to step 6.

4 Under Scaling, select a sizing option.
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Best Fit scales the chart proportionately to fit the page. Actual Size 
prints the chart using the current size in the Analysis window. 

Figure 1 - 10: The Print Layout dialog box.

5 Go to step 9. 

6 Click on the Printer Properties button.

7 In the Scaling field, enter the percentage by which to reduce or 
enlarge the chart.

8 Click on the OK button.

9 To print the chart, click on the OK button.

Controlling the Alignment of Printed Surveys, 
Tables, Charts and Batch Reports

You can center and set margins for printed surveys, tables, charts and 
batch reports. Aligning surveys, tables, charts and batch reports requires 
different procedures. Each procedure appears below.

• To control the alignment of printed surveys

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.

Select an automatic 
sizing option here.
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3 From the File menu, choose Page Setup. 

Figure 1 - 11: The Survey Page Setup dialog box.

4 If you want to change the page's margins, enter new values under 
Margins.

5 If you want to change the distance between the edge of the page and 
the header and footer, enter new values under Distance From Page 
Edge.

6 Click on the OK button.

7 To print the survey, choose Print from the File menu, and then click 
on the OK button.

• To control the alignment of printed tables

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Margins tab.
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4 If you want to center the table, select one or both check boxes under 
Center on page.

5 If you want to define the table's margins, enter values in the margin 
fields.

6 Click on the OK button.

7 To print the table, choose Print from the File menu, and then click on 
the OK button.

• To control the alignment of printed charts

1 Open the chart to print.

Make sure that the Analysis window that contains the chart is the 
active window.

2 From the File menu, choose Print.

3 Click on the Layout button.

4 If you want to define the chart's margins, enter values in the fields 
under Margins.

5 Click on the OK button.

6 To print the chart, click on the OK button.

• To control the alignment of batch reports

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.
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4 Select the Print Setup tab. 

Figure 1 - 12: The Print Setup tab of the Batch Report Print/Export dialog box.

5 Specify the orientation, centering, margins, headers and footers.

6 Complete the Batch Report Print/Export dialog box.

7 To print the batch report, click on the Finish button.
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Setting the Page Printing Order for Tables

If a table is more than one page wide and long, you can specify whether 
Survey Crafter Professional prints the table’s pages by row or by column. 

• To set the page printing order for tables

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Sheet tab.

4 Under Page Order, select one of the following options:

• Top To Bottom to print the pages by column

• Left To Right to print the pages by row

5 Click on the OK button.

6 To print the table, choose Print from the File menu, and then click on 
the OK button.

Creating Headers and Footers for Printed 
Surveys, Tables and Batch Reports

Creating headers and footers for printed surveys, tables and batch reports 
requires different procedures. Each procedure appears below.

• To create headers and footers for printed surveys

1 Open the survey to print.

Make sure that the Survey Designer window is the active window.

2 From the View menu, choose Print Layout.

3 From the Edit menu, choose Edit Header and Footer.

Survey Crafter Professional draws a line at the top and a line at the 
bottom of the Survey Designer window to mark the header and footer 
areas.

Printing by row

Printing by column
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4 Type text for the header and footer inside the header and footer areas 
in the Survey Designer window.

5 From the Edit menu, choose Edit Header and Footer.

• To create headers and footers for printed tables

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Header/Footer tab.

4 Enter codes and text for the header and footer in the Header and 
Footer fields, respectively. 

Enter an alignment code first, followed by one or more font codes, 
and then one or more text codes. If you do not enter the codes in this 
order, the text may not display correctly. Table 1 - 1, Table 1 - 2, and 
Table 1 - 3 show the available codes for headers’ and footers’ 
alignments, fonts, and text. For example, to create a header showing 
the analysis’ name in 14 point bold type right justified on the page, 
type the following in the Header field:  &R&B&14&F.

By default, text is centered unless you specify &L or &R.

Table 1 - 2 shows codes for controlling the font used in a table’s 
header and footer. Font codes must appear before text or text codes. 
Otherwise, Survey Crafter Professional ignores them.

Table 1 - 1: Alignment codes for the Header and Footer fields. 

Alignment code Description

&L Left-aligns the characters that follow

&C Centers the characters that follow

&R Right-aligns the characters that follow

Table 1 - 2: Font codes for the Header and Footer fields. 

Font code Description

&B Uses a bold font.
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The text codes in Table 1 - 3 determine what prints. You can also 
display text you enter in a header or footer by typing the text in the 
Header or Footer fields.

5 Click on the OK button.

6 To print the table, choose Print from the File menu, and then click on 
the OK button.

&I Uses an italic font.

&U Underlines the header.

&O Ignored.

&H Ignored.

&“name of font” Uses the font named between the double quotes.

&nn Used the specified point size. The point size must be 
a two digit number like 08 or 14.

Table 1 - 3: Text codes for the Header and Footer fields. 

Text code Description

&& Prints an ampersand.

&D Prints the current date.

&F Prints the table’s name.

&N Prints the total number of pages in the table.

&P Prints the page number.

&P+number Prints the page number plus the number you enter. 
For example, &P+2 prints 3 on the table’s first page.

&P-number Prints the page number minus the number you enter. 
For example, &P-2 prints 3 on the table’s fifth page.

&T Prints the current time.

Table 1 - 2: Font codes for the Header and Footer fields.  (Continued)

Font code Description
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• To create headers and footers for printed batch reports

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.

4 Select the Print Setup tab.

5 Enter the codes for the headers and footers for the table of contents 
and analysis tables. Print headers and footers are not used by the 
batch report’s analysis charts.

You can enter text and format it by using the codes in the tables 
below. Enter an alignment code first, followed by one or more font 
codes, and then one or more text codes. If you do not enter the codes 
in this order, the text may not display correctly. Table 1 - 1, Table 
1 - 2, and Table 1 - 3 show the available codes for headers’ and 
footers’ alignments, fonts, and text. For example, to create a header 
showing the current analysis table’s name in 14 point bold type right 
justified on the page, type the following in the Print header for the 
analysis tables field: &R&B&14&F.

By default, text is centered unless you specify &L or &R.

Table 1 - 4: Alignment codes for the Header and Footer fields. 

Alignment code Description

&L Left-aligns the characters that follow

&C Centers the characters that follow

&R Right-aligns the characters that follow
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Table 1 - 2 shows codes for controlling the font used in an analysis 
table’s header and footer. Font codes must appear before text and text 
codes. Otherwise, Survey Crafter Professional ignores them.

The text codes in Table 1 - 3 determine what prints. You can also 
display the text you enter.

Table 1 - 5: Font codes for the Header and Footer fields. 

Font code Description

&B Uses a bold font.

&I Uses an italic font.

&U Underlines the header.

&O Ignored.

&H Ignored.

&“name of font” Uses the font named between the double quotes.

&nn Used the specified point size. The point size must be 
a two digit number like 08 or 14.

Table 1 - 6: Text codes for the Header and Footer fields. 

Text code Description

&& Prints an ampersand.

&A Prints the title of the batch report.

&D Prints the current date.

&F Prints the title of the batch report.

&J Prints a newline character.

&N Prints the total number of pages in the current table.

&P Prints the current table’s page number.

&P+number Prints the page number plus the number you enter. 
For example, &P+2 prints 3 on the current table’s 
first page.
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6 Complete the Batch Report Print/Export dialog box.

7 To print the batch report, click on the Finish button.

&P-number Prints the page number minus the number you enter. 
For example, &P-2 prints 3 on the current table’s 
fifth page.

&T Prints the current time.

&X Prints the total number of tables and charts in the 
batch report

Table 1 - 6: Text codes for the Header and Footer fields.  (Continued)

Text code Description
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Printing a Table’s Grid Lines, Row Numbers, and 
Column Letters

You can show or hide a printed table’s grid lines, row numbers, and 
column letters. Row numbers appear to the left of the table’s rows and 
column letters appear above the table’s columns.

• To print a table’s grid lines, row numbers, and column letters

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Sheet tab.

4 Under Print Options, select one or all of the following:

• The Grid Lines check box to print grid lines

• The Row Headings check box to print row numbers

• The Column Headings check box to print column letters

Figure 1 - 13: The Sheet tab of the Page Setup dialog box.

Specify whether you want to 
print grid lines, row numbers, 
or column letters here.
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5 Click on the OK button.

6 To print the table, choose Print from the File menu, and then click on 
the OK button.

Controlling Color in Printed Tables

On a black and white printer, colors in tables typically print as gray 
shading. However, you can print the table in black and white only, making 
colors and gray shading in the table print as white.

• To control color in printed tables

1 Open the table to print.

Make sure that the Analysis window that contains the table is the 
active window.

2 From the File menu, choose Page Setup.

3 Select the Sheet tab.

4 Under Print Options, do one of the following:

• To print the table using black and white only, select the Black & 
White check box.

• To print the table using colors (if a color printer is available) or gray 
shading, clear the Black & White check box.

5 Click on the OK button.

6 To print the table, choose Print from the File menu, and then click on 
the OK button.

Printing Multiple Copies

You can print several copies of a survey, table, chart or batch report at 
once. Printing multiple copies of surveys, tables, charts and batch reports 
requires a different procedure. Each procedure appears below.

• To print multiple copies of a survey or table

1 Open the survey or table to print.
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Make sure that the Survey Designer window or the Analysis window 
that contains the table is the active window. Also make sure that the 
Survey Designer window is in the Print Layout mode.

2 From the File menu, choose Print.

3 In the Copies field, enter the number of copies to print.

4 If you want to print all of the pages of one copy before printing the 
next copy, select the Collate Copies check box.

5 To print the survey or table, click on the OK button.

• To print multiple copies of a chart

1 Open the chart to print.

Make sure that the Analysis window that contains the chart is the 
active window.

2 From the File menu, choose Print.

3 In the Number of Copies field, enter the number of copies to print.

4 To print the copies, click on the OK button.

• To print multiple copies of a batch report

1 Open the batch report to print.

Make sure that the Batch Report Designer window is the active 
window.

2 From the File menu, choose Print.

3 In the Print/Export tab of the Batch Report Print/Export dialog box, 
select the Print the tables and charts check box.

4 Complete the Batch Report Print/Export dialog box.

5 Click on the Finish button.

6 In the Number of Copies field, enter the number of copies to print.

7 To print the copies, click on the OK button.
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Updating a Study

A study may contain several calculated items including computed 
variables, edited survey responses, and analyses of survey data. As you 
work on a study, you can change or add new calculated items. For 
example, you might edit a table showing the results of an analysis on 
survey data or create 12 new computed variables.

Each time you edit or create a calculated item, you need to update 
(calculate or recalculate) the item’s values. You can update each 
calculated item’s values individually or edit and create several calculated 
items and update them all at once.

The procedure below explains how to update all the calculated items in a 
study at once. For instructions on updating individual analyses or the Data 
window only, see the sections “Updating Tables” on page 4 - 78, 
“Updating Charts” on page 5 - 124, “Editing Data Sets” on page 3 - 33, 
and “Updating Variables’ Values” on page 6 - 68.

• To update a study

1 Select any tab of the Study window.

To update a study, the Study window must be the active window.

2 From the Edit menu, choose Update Study or click on the Update 
Study button on the toolbar.

In addition to calculating values, the Update Study command applies 
color coding to values in the Data window. For more on color coding, 
see the section “Color Coding in the Data Window” on page 3 - 6.

Update Study button
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Saving Your Work

You can save changes to the current study or save a study under a 
different name.

Saving the Current Study

Save your work often to guard against data loss should your computer fail 
or lose power. You should also periodically back up your files in a 
location other than your computer’s hard disk.

• To save your work

From the File menu, choose Save or click on the Save Study button on the 
toolbar.

If you are saving an untitled study, the Save As dialog box appears. For 
instructions on completing the Save As dialog box, see the section 
“Saving a Study under a Different Name” below.

Saving a Study under a Different Name

To make changes to a study while saving the original version, save the 
study under a different name before making the changes.

• To save a study under a different name

1 From the File menu, choose Save As.

2 In the File name field, type the name of the new version of the study. 

Save Study button
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Include the .MKT extension with the new version’s name.

Figure 1 - 14: The Save As dialog box.

3 From the Locations (Save in) drop-down list, select the location 
where you want to save the version of the study.

4 In the Folders list, select the folder in which you want to save the new 
version of the study.

5 Choose Save.
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Compacting a Study

If you frequently import different data sets into a study or if you 
frequently add and delete study components such as variables and 
analyses, the study can become fragmented. A fragmented study typically 
uses disk space inefficiently and can affect Survey Crafter Professional’s 
performance.

Compacting a study corrects any fragmentation, often reducing the disk 
space a study uses and improving Survey Crafter Professional’s 
performance.

• To compact a study

1 Run Survey Crafter Professional but do not open or create a study.

2 From the File menu, choose Compact.

3 In the Compact dialog box, select the study you want to compact.

4 Click on the OK button.

After Survey Crafter Professional finishes compacting the study, you 
can open any study or create a new study.
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Closing Studies and Exiting Survey Crafter 
Professional

This section explains how to end the session with a current study and how 
to quit Survey Crafter Professional.

Closing a Study

You must close the current study before opening or creating another 
study.

• To close a study

1 Save any changes to the study.

2 From the File menu, choose Close.

Exiting Survey Crafter Professional

Use the File menu’s Exit command to quit Survey Crafter Professional.

• To exit Survey Crafter Professional

1 If a study is open, save any changes to the study.

2 From the File menu, choose Exit.
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2 Surveys

Before creating a survey, it is important to clearly define its purpose. This 
ensures that the data the survey gathers addresses the project’s key issues. 
For more on the relationship between a survey’s questions and a project’s 
key issues, see Chapter 2, “Identifying the Problem,” in Understanding 
Survey Research:  A Primer for Success. After defining the survey’s 
purpose, you are ready to create the survey in Survey Crafter 
Professional.

This chapter explains how to create and edit a survey in Survey Crafter 
Professional. Read the section “Survey Basics” first to learn key concepts 
about working with a survey in Survey Crafter Professional.

Chapter Contents

• Survey Basics  2 - 2

• Creating, Opening and Copying Surveys  2 - 44

• Deciding What Types of Questions to Write  2 - 58

• Inserting Survey Blocks  2 - 67

• Using the Question Library  2 - 83

• Inserting Pictures  2 - 91

• Inserting Hyperlinks and Targets  2 - 96

• Adding Custom Rules  2 - 101

• Inserting Survey Fields  2 - 137

• Editing Survey Questions  2 - 150

• Changing a Survey’s Language Settings  2 - 177

• Changing How a Survey Looks  2 - 181

• Exporting a Survey  2 - 190  

In the Primer
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Survey Basics

This section introduces key features and concepts that will help you as 
you enter your surveys in Survey Crafter Professional.

This section introduces the following features and concepts:

• The Survey Designer Window

• Survey Blocks

• Survey Block Layouts

• Primary and Secondary Blocks

• Survey Layout Modes

• The Question Block Layouts Toolbar

• The Survey Explorer Toolbar

• The Question Block Wizard

• The List Library
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The Survey Designer Window

The Survey Designer window is where you enter and format your survey. 
It has many features that you can use to arrange and format the titles, 
instructions, pictures and questions that make up your survey.

Figure 2 - 1: Survey Crafter Professional’s Survey Designer window.
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Typing Directly in the Survey Designer Window
You can type titles, section headings, instructions and other text directly 
in the Survey Designer window.

Figure 2 - 2: Typing and formatting directly in the Survey Designer window.

You can format the text by changing its font, font size, style, spacing, 
foreground and background colors. You can format a paragraph of the text 
by changing its alignment, indentation, spacing, borders and shading. You 
can use tables, tab stops, bullets and numbering to organize and align the 
text. You can also have Survey Crafter Professional automatically check 
your spelling as you type.

You can also insert pictures, hyperlinks, hyperlink targets, bookmarks, 
frames, drawing objects, page breaks, page numbers, page counts, and 
dates in your survey.

Text that was 
typed and 
formatted 
directly in the 
Survey 
Designer 
window.
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Inserting Pictures in the Survey Designer Window
You can insert, resize and format pictures like a company logo just about 
anywhere in your survey. When you insert a picture, you either embed it 
in or link it to the survey. An embedded picture is stored with the survey. 
A linked picture has only its location stored with the survey.

Figure 2 - 3: An embedded picture in the Survey Designer window.

You can insert a picture if it is in one of the following file formats:

• Windows Bitmap (*.bmp)

• JPEG File Interchange Format (*.jpg; *.jpeg)

• Graphic Interchange Format (*.gif)

• Portable Network Graphics (*.png)

• Windows Metafile Format (*.wmf)

• Windows Enhanced Metafile Format (*.emf)

Ross Printers’ 
company 
logo.
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Survey Blocks

You can type and format titles, section headings, instructions and other 
text directly in the Survey Designer window. However, when you want to 
enter a question, you must use a survey block.

A survey block in the Survey Designer window is a special table that can 
contain one or more survey questions, or just text or pictures.

When the cursor is inside a block in the Survey Designer window, Survey 
Crafter Professional draws a border around the block.

Figure 2 - 4: A survey in the Survey Designer window.

Question Blocks
A block that contains one or more survey questions is called a question 
block.
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Table 2 - 1 lists the 7 types of questions Survey Crafter Professional 
supports.

Table 2 - 1: The 7 types of questions Survey Crafter Professional supports.

Question Type Description

All-That-Apply A question that asks the respondent to check one or more prompts from a 
predefined list of prompts. For example, "Which of the following 
restaurants have you visited? Burger World, King Taco, Broilin' Bill's, The 
Chicken Coop, Marsha's Mex."

Closed-End A question that requires the respondent to pick at most one prompt from a 
predefined list of prompts. Also called a forced choice or multiple-choice 
question. For example, "Which of the following restaurants is your favorite? 
Burger World, King Taco, Broilin' Bill's, The Chicken Coop, Marsha's 
Mex."

Constant Sum A question that respondents reply to by assigning points to a series of items. 
The points they assign across items add up to a total you decide. For 
example: "Divide 100 points among the following three fast food restaurants 
according to how likely you are to visit them (the more points, the more 
likely you are to visit): Burger World, Marsha's Mex, Broilin' Bill's."

Open-End A question that respondents answer in their own words rather than by 
selecting an answer from a list of choices or stating a number. For example, 
"What is your name?"

Quantity A question a respondent answers with a number. For example, "What is your 
age?"

Ranking Respondents reply to a ranking question by ordering a list of items according 
to some criterion. For example, "Please rank the following three fast food 
restaurants according to how likely you are to visit them (1 is most likely to 
visit, 3 least likely):  Burger World, Marsha's Mex, Broilin' Bill's."

Rating A question respondents reply to by picking a point on a scale. For example, 
"Please rate the importance you place on customer service at fast food 
restaurants on a scale of 1 to 5. (1 = Not at all important, 5 = Extremely 
important.)"
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When you use a question block for a survey question, Survey Crafter 
Professional automatically creates and maintains the necessary imported 
variables in the study’s database to store the responses to the question. 
These variables are called imported because they store data coming from 
outside Survey Crafter Professional. 

The type and number of imported variables associated with a question 
block depend on the types and number of questions contained by the 
block. For example, Survey Crafter Professional would automatically 
create and maintain 7 imported category variables for a block that 
contains 7 closed-end questions.

Figure 2 - 5: A block that contains 7 closed-end questions in the Survey Designer window.

Tip  You will use the imported variables associated with your survey’s 
question blocks in a variety of ways. For example, you may use a few 
of the variables in expressions for skipping and branching rules. If you 
use Survey Crafter Professional’s analysis wizards, the wizards will 
ask you to select the variables you want to analyze.

A block of 
type For 
Multiple 
Closed-End 
questions that 
contains 7 
closed-end 
questions.

The Survey 
Explorer 
toolbar lists 
the 7 imported 
category 
variables 
associated 
with the 
question 
block.
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Table 2 - 2 lists the 14 types of question blocks Survey Crafter 
Professional provides and the number and type of imported variables the 
program would automatically create and maintain for the block.

Table 2 - 2: The 14 types of question blocks Survey Crafter Professional provides.

The Type of Question Block The imported variable(s) Survey Crafter 
Professional would automatically create and 
maintain for the block

• For 1 All-That-Apply Question

• For Multiple All-That-Apply 
Questions

• 1 imported category variable for each prompt of each 
all-that-apply question in the block.

• For example, Survey Crafter Professional would 
create and maintain 5 imported category variables 
for a block of type For 1 All-That-Apply Question 
that contains 1 all-that-apply question having 5 
prompts.

• Another example, Survey Crafter Professional would 
create and maintain 24 imported category variables 
for a block of type For Multiple All-That-Apply 
Questions that contains 4 all-that-apply questions, 
each having 6 prompts.

• For 1 Closed-End Question

• For Multiple Closed-End Questions

• 1 imported category variable for each closed-end 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 4 imported category variables 
for a block of type For Multiple Closed-End 
Questions that contains 4 closed-end questions, each 
having any number of prompts.

• For 1 Constant Sum Question

• For Multiple Constant Sum Questions

• 1 imported quantity variable for each prompt of each 
constant sum question in the block

• For example, Survey Crafter Professional would 
create and maintain 6 imported quantity variables for 
a block of type For 1 Constant Sum Question that 
contains 1 constant sum question having 6 prompts.

• For 1 Open-End Question

• For Multiple Open-End Questions

• 1 imported literal variable for each open-end 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 1 imported literal variable for a 
block of type For 1 Open-End Question that contains 
1 open-end question.
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To read more about variable types, see the section “Variable Basics” on 
page 6 - 2. Also see the section “Understanding Variables and Scales” in 
Chapter 4 of Understanding Survey Research:  A Primer for Success.

Instructions-Only Blocks
A survey block can also contain no questions. A block that contains no 
questions is called an instructions-only block. Typically, instructions-only 
blocks contain instructions, pictures, section headings, tables, lists or 
other text.

• For 1 Quantity Question

• For Multiple Quantity Questions

• 1 imported quantity variable for each quantity 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 10 imported quantity variables 
for a block of type For Multiple Quantity Questions 
that contains 10 quantity questions.

• For 1 Ranking Question

• For Multiple Ranking Questions

• 1 imported quantity variable for each prompt of each 
ranking question in the block.

• For example, Survey Crafter Professional would 
create and maintain 15 imported quantity variables 
for a block of type For Multiple Ranking Questions 
that contains 3 ranking questions, each having 5 
prompts.

• For 1 Rating Question

• For Multiple Rating Questions

• 1 imported quantity variable for each rating question 
in the block.

• For example, Survey Crafter Professional would 
create and maintain 7 imported quantity variables for 
a block of type For Multiple Rating Questions that 
contains 7 rating questions, each having any number 
of prompts.

Note  Survey Crafter Professional does not create and maintain any 
imported variables for an instructions-only block.

Table 2 - 2: The 14 types of question blocks Survey Crafter Professional provides. (Continued)

The Type of Question Block The imported variable(s) Survey Crafter 
Professional would automatically create and 
maintain for the block

In the Primer
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Use an instructions-only block when:

• you want the instructions to be the origin or destination of a custom 
branching or skipping rule. For more information, see the section 
“Custom branching, skipping and hiding rule issues” on page 2 - 134.

• you want the instructions displayed in the built-in Interviewer when the 
Interviewer is in its block-only mode. The Interviewer has an optional 
data-entry mode in which only blocks are displayed.

• you want to use the numbering or some of the other features offered by 
the instructions-only block. Other features include splitting the block 
into multiple rows and columns, having the rows and/or columns 
displayed in random order and having a subset of the rows and/or 
columns displayed depending on the answer to another question.

• you want to be able to save the instructions in the Question Library. The 
Question Library only stores blocks.

• you want to see the instructions listed in the Blocks tab of the Survey 
Explorer toolbar.

Otherwise, consider typing directly in the Survey Designer window.

Survey Block Layouts

Before you insert a block into the Survey Designer window, you must 
choose a layout for the block. You can choose a layout for your block 
from Survey Crafter Professional’s gallery of block layouts. Survey 
Crafter Professional displays the gallery on the Question Block Layouts 
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toolbar as well as on the Type tab of the Question Block Wizard dialog 
box.
 

Figure 2 - 6: The gallery of block layouts in the Question Block Wizard dialog box.

A block layout represents a particular organization and presentation of the 
components of a survey block. A block layout dictates how the 
instructions, questions, prompts and other components of a block are 
arranged. For example, one block layout may display a closed-end 
question’s prompts in a single column below the question whereas 
another may display the prompts in a single row to the right of the 
question.

A block layout can also dictate the type and location of the block’s 
controls. For example, when the Survey Designer window is in Web 
Layout or Interviewer Layout mode, many of the block layouts designed 
for 1 closed-end question employ radio button controls while others 
employ single-selection list box controls.

Most block layouts are designed to work with one or more of just one type 
of question. However, there are several block layouts that are designed to 
work with more than one type of question. For example, there is a block 
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layout that combines multiple closed-end questions with one ranking 
question.

Figure 2 - 7: A block that combines multiple closed-end questions with one ranking question.

Optional Block Components
Blocks can include an area for a block number as well as areas for 
additional instructions.

• Including an area for a block number

Lists the 5 
imported 
category 
variables and 
5 imported 
quantity 
variables 
associated 
with the 
question 
block.

This question 
block contains 
5 closed-end 
questions and 
1 ranking 
question.

These block 
layouts 
combine 
question 
types.
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When you include an area in a block for a block number, Survey Crafter 
Professional can automatically number the block for you or you can 
number the block yourself.

Figure 2 - 8: Blocks in the Survey Designer window that each include an area for a block number.

When you choose to have Survey Crafter Professional number a block 
for you, Survey Crafter Professional calculates the number to be one 
greater than the number of the last automatically numbered block. The 
calculation does not include blocks you number yourself.

When you choose to number a block yourself, it is up to you to update 
the block's number if you move or insert other blocks before the block.

• Including an area for additional instructions on top

Including an additional area at the top of a block can be useful for 
labeling the block or for including additional instructions or pictures.

These 
question 
blocks each 
include an 
area for a 
block number 
that is 
automatically 
calculated by 
Survey Crafter 
Professional.
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For example, let's say you have a numbered question that asks for the 
respondent's age. For a paper version of the survey, you could label the 
question by writing [AGE] in this area and have skip logic instructions 
elsewhere in the survey tell the respondent to jump to the label rather 
than to the number of the question. If the block's number were to 
change, there would be no need to revise the skip logic instructions.

• Including an area for additional instructions on the bottom

Including an additional area at the bottom of a block can be useful for 
providing skip logic or other instructions to interviewers and 
respondents.

For example, you might want to instruct respondents to skip a section of 
questions on home loans if they have never bought a house.
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Showing Associated Variable Information
You can have Survey Crafter Professional display information about each 
question block’s associated imported variables in the Survey Designer 
window. This information includes the name and code as well as the 
values and limits of each variable.

Figure 2 - 9: The Survey Designer window showing associated variable information.

To have Survey Crafter Professional display information about each 
question block’s associated variables, choose Survey Options from the 
View menu when the Survey Designer window is active. Choose the 
options you want under Display Options in the General tab of the Survey 
Options dialog box.

Information 
about the 
variables 
associated 
with the 
question 
blocks
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Primary and Secondary Blocks

A primary block is a block that serves as the primary source of 
information for its associated imported variables. Survey Crafter 
Professional uses primary blocks in the Survey Designer window to set 
the properties of the blocks' associated variables.

A newly inserted question block is by default a primary block. However, 
if you copy a block from one Survey Designer window and paste it inside 
another Survey Designer window from the stame study, the pasted block 
is by default a secondary block. A secondary block's associated variables 
are the same as those associated with the original primary block in the 
other Survey Designer window.

Secondary blocks are useful when you want to administer your survey in 
more than one language or you want to create another variation of your 
survey. Changes made to question and prompt text in a secondary block 
are not reflected in the block's associated variables.

To show when the cursor is inside a primary block, Survey Crafter 
Professional displays a blue rectangle around the block. To show when 
the cursor is inside a secondary block, Survey Crafter Professional 
displays a green rectangle around the block.

Identifiers for secondary blocks in the Blocks tab of the Survey Explorer 
toolbar are colored green.

You can click inside a secondary block and then click on Primary Block 
from the Block menu to convert the block to a primary block. When a 
secondary block is converted to a primary block, the block that shares the 
associated variables and is the primary block is automatically converted 
to a secondary block.

Survey Layout Modes

The Survey Designer window’s layout modes allow you to tailor your 
survey for printing, the World Wide Web and telephone interviewing. 
This means you can use Survey Crafter Professional to simultaneously 
administer paper, Web and telephone interview versions of your survey.
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Survey Crafter Professional displays the current layout mode in the 
caption of the Survey Designer window. You can change the current 
layout mode by choosing a different layout mode from the View menu or 
by clicking on one of the layout mode buttons on the Survey Question 
toolbar.

Figure 2 - 10: The Survey Designer window in Print Layout mode.

When the Survey Designer window is in one layout mode and you choose 
a block layout for a question block that is not compatible with another 
layout mode, Survey Crafter Professional automatically assigns a similar 
but compatible block layout for the question block when the Survey 
Designer window is switched to the other layout mode.

For example, if you choose a block layout that has respondents circle the 
prompts for a question block when the Survey Designer is in the Print 
Layout mode, Survey Crafter Professional automatically assigns a block 
layout that uses radio button or check box controls for the question block 
when the Survey Designer window is switched to the Web Layout or 
Interviewer Layout modes.

The caption 
indicates the 
Survey 
Designer 
window is in 
Print Layout 
mode.

The Survey 
Question 
toolbar 
indicates the 
Survey 
Designer 
window is in 
Print Layout 
mode.

The last 4 
block layouts 
are only for 
the Print 
Layout mode.
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Survey Crafter Professional displays the same survey text and graphics in 
all layout modes. If you change the survey text or graphics when the 
Survey Designer window is in one layout mode, the same change appears 
when the Survey Designer window is switched to the other layout modes. 
Survey Crafter Professional only allows a question block’s layout to be 
different between layout modes.

You can view the Survey Designer window at any time in Print Layout, 
Web Layout or Interviewer Layout mode.

Print Layout
Use the Print Layout mode to tailor your survey for printing. When in 
Print Layout mode, the Survey Designer window offers question block 
layouts that are compatible with printed surveys. For example, you can 
choose a question block layout that has respondents circle the prompts. 
When in Print Layout mode, the Survey Designer window also offers 
page size and orientation options and automatic pagination. The Survey 
Designer window must be in Print Layout mode for you to configure, 
preview and print your survey on paper.

Web Layout
Use the Web Layout mode to tailor your survey for the World Wide Web. 
When in Web Layout mode, the Survey Designer window offers question 
block layouts that are compatible with web surveys. For example, you can 
choose a question block layout that uses drop-down, single selection or 
multiple selection list box controls. The Survey Designer window must be 
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in Web Layout mode for you to configure, preview and publish your 
survey for the World Wide Web.

Figure 2 - 11: The Survey Designer window in Web Layout mode.

Interviewer Layout
Use the Interviewer Layout mode to tailor your survey for the built-in 
Interviewer. When in Interviewer Layout mode, the Survey Designer 
window offers question block layouts that are compatible with the built-in 

The caption 
indicates the 
Survey 
Designer 
window is in 
Web Layout 
mode.

The Survey 
Question 
toolbar 
indicates the 
Survey 
Designer 
window is in 
Web Layout 
mode.

A few of the 
layouts are 
only for the 
Web and 
Interviewer 
Layout 
modes.
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Interviewer. For example, you can choose a question block layout that 
uses drop-down, single selection or multiple selection list box controls.

Figure 2 - 12: The Survey Designer window in Interviewer Layout mode.

The Question Block Layouts Toolbar

Use the Question Block Layouts toolbar to drag new blocks into the 
Survey Designer window. 

Tip  To show or hide the Question Block Layouts toolbar, when the 
Survey Designer window is active, click on the View menu, Toolbars 
and then on Question Block Layouts.

The caption 
indicates the 
Survey 
Designer 
window is in 
Interviewer 
Layout mode.

The Survey 
Question 
toolbar 
indicates the 
Survey 
Designer 
window is in 
Interviewer 
Layout mode.

A few of the 
layouts are 
only for the 
Web and 
Interviewer 
Layout 
modes.
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The Question Block Layouts toolbar displays pictures of all of the 
available block layouts for each of the 15 types of blocks Survey Crafter 
Professional provides.

Figure 2 - 13: The Survey Designer window’s Question Block Layouts toolbar.

To drag and drop a block into the Survey Designer window, click on and 
drag the block layout you want into the Survey Designer window. If you 
would like the Survey Designer window to scroll, move the mouse 
pointer near an edge of the window and press the [ALT] key. If you want, 
you can configure the block by right-clicking on the layout's picture and 
choosing Settings from the pop-up menu.

You can also drag the block layout you want over another block in the 
Blocks tab of the Survey Explorer toolbar. Survey Crafter Professional 
inserts the new block before the block in the Survey Designer window.

Alternatively, you can move the cursor to the location in the Survey 
Designer window where you want to insert a new block and double-click 
on the block layout you want.

The Question 
Block Layouts 
toolbar 
displays all of 
the available 
block layouts 
for the current 
layout mode 
and the  
selected type 
of block.
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Moving the Question Block Layouts Toolbar
You can anchor the Question Block Layouts toolbar to the top, bottom, 
right or left of the Survey Designer window or even have the toolbar float 
over the Survey Designer window. To move the Question Block Layouts 
toolbar, click on and drag the toolbar to the location where you want it to 
appear.

Figure 2 - 14: The Question Block Layouts toolbar floating over the Survey Designer window.

If you want, you can change the default starting position of the toolbar in 
Survey Crafter Professional's Preferences dialog box.

The Question 
Block Layouts 
toolbar 
floating over 
the Survey 
Designer 
window.
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The Survey Explorer Toolbar

Use the Survey Explorer toolbar to manage the blocks, imported 
variables, custom rules, survey fields, bookmarks and hyperlink targets in 
the Survey Designer window.

The Survey Explorer toolbar lists all of the blocks, imported variables, 
rules, survey fields, bookmarks and hyperlink targets in your survey.

Figure 2 - 15: The Survey Designer window’s Survey Explorer toolbar.

Tip  To show or hide the Survey Explorer toolbar, when the Survey 
Designer window is active, click on the View menu, Toolbars and then 
on Survey Explorer.

The Survey 
Explorer 
toolbar lists all 
of the blocks, 
imported 
variables, 
rules, survey 
fields, 
bookmarks 
and hyperlink 
targets in your 
survey.
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Whenever you insert, cut, paste, move or delete a block, custom rule, 
survey field, bookmark or target in the Survey Designer window, Survey 
Crafter Professional automatically synchronizes the Survey Explorer 
toolbar with your survey.

You can use the Survey Explorer toolbar to drag and drop as well as copy 
and paste blocks, custom rules and survey fields.

Table 2 - 3 briefly describes the purpose of as well as some of the ways 
you can use the Survey Explorer toolbar’s tabs.

Note  For information about custom rules, see “Adding Custom 
Rules” on page 2 - 101. For information about survey fields, see 
“Inserting Survey Fields” on page 2 - 137. For information about 
targets, see “Inserting Hyperlinks and Targets” on page 2 - 96.

Table 2 - 3: The Survey Explorer toolbar’s tabs.

Tab Description

Blocks • Displays a list of all of the blocks in your survey.

• Click on a block in the Survey Explorer toolbar to have 
Survey Crafter Professional highlight the block in the Survey 
Designer window.

• Click on the plus sign to the left of the block to see a list of 
the imported variables as well as a list of the custom rules 
associated with the block.

• Double-click on the block to edit the block's settings.

• Right-click on the block for other options.

Variables • Displays a list of all of the imported variables used by your 
survey.

• Click on a variable in the Survey Explorer toolbar to have 
Survey Crafter Professional highlight the block with which 
the variable is associated in the Survey Designer window.

• Double-click on the variable to edit the variable's name, code 
and other properties.

• Right-click on the variable for other options.
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Rules • Displays a list of all of the custom rules used by your survey.

• Click on a rule in the Survey Explorer toolbar to have Survey 
Crafter Professional highlight the block with which the rule is 
associated in the Survey Designer window.

• Click on the plus sign to the left of the rule to see a list of some 
of the rule's settings.

• Double-click on the rule to edit the rule's settings.

• Right-click on the rule for other options.

Fields • Displays a list of all of the survey fields in your survey.

• Click on a survey field in the Survey Explorer toolbar to have 
Survey Crafter Professional highlight the field in the Survey 
Designer window.

• Double-click on the field to edit the field's settings.

• Right-click on the field for other options.

Bookmarks • Displays a list of all of the bookmarks in your survey.

• Click on a bookmark in the Survey Explorer toolbar to have 
Survey Crafter Professional move the cursor to the location of 
the bookmark in the Survey Designer window.

• Right-click on the bookmark for other options.

Targets • Displays a list of all of the targets. in your survey.

• Click on a target in the Survey Explorer toolbar to have 
Survey Crafter Professional move the cursor to the location of 
the target in the Survey Designer window.

• Right-click on the target for other options.

Table 2 - 3: The Survey Explorer toolbar’s tabs. (Continued)

Tab Description
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Moving the Survey Explorer Toolbar
You can anchor the Survey Explorer toolbar to the top, bottom, right or 
left of the Survey Designer window or even have the toolbar float over the 
Survey Designer window. To move the Survey Explorer toolbar, click on 
and drag the toolbar to the location where you want it to appear.

Figure 2 - 16: The Survey Explorer toolbar floating over the Survey Designer window.

If you want, you can change the default starting position of the toolbar in 
Survey Crafter Professional's Preferences dialog box.

The Survey 
Explorer 
toolbar 
floating over 
the Survey 
Designer 
window.
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Using the Survey Explorer Toolbar to Review Your 
Survey
Table 2 - 4 lists a few ways you can use the Survey Explorer toolbar to 
review your survey.

Table 2 - 4: Ways you can use the Survey Explorer toolbar to review your survey.

What to check How to check

Which question blocks are 
configured to require one or more 
answers?

• Click on the Blocks tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the blocks in your 
survey.

• If you see a red R to the left of a block's identifier, the block 
has been configured to require one or more answers. In this 
case, respondents must answer the question(s) in the block in 
order to continue with the survey. If you see a red S, 
answering the question(s) in the block is suggested but not 
mandatory. In this case, respondents are warned but may 
choose to continue with the survey without answering the 
question(s). If you see a green O, answering the question(s) in 
the block is optional.

• To edit the settings for the block, double-click on the block in 
the Survey Explorer toolbar.

What are the types of the blocks? • Click on the Blocks tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the blocks in your 
survey.

• Review the identifiers for the blocks. A block's identifier is 
made up of a letter assigned to the survey that contains the 
block (eg. A), a unique number assigned to the block (eg. 
455), a forward slash (/), and a code that identifies the layout 
selected for the block (eg. M06). Putting this together, A455/
M06 is an example of an identifier for a block.

• The first letter of the layout identifier determines the block's 
type. O indicates closed-end, M indicates all-that-apply, R 
indicates rating, L indicates open-end, Q indicates quantity, K 
indicates ranking and C indicates constant sum.

• For example, the identifier A455/M06 is for an all-that-apply 
block.
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Which question blocks are 
configured to have their prompts 
or questions shown in random 
order when the survey is on the 
Web?

• Click on the Blocks tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the blocks in your 
survey.

• If you see 2 lines crossing each other to the left of a block's 
identifier, the block has been configured to have either its 
prompts or its questions or both shown in random order when 
the survey is on the Web.

• To edit the settings for the block, double-click on the block in 
the Survey Explorer toolbar.

How many imported variables 
are associated with a block?

• Click on the Blocks tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the blocks in your 
survey.

• Click on the plus sign to the left of the block's identifier to 
expand the block's listing. Survey Crafter Professional will 
indicate how many imported variables are associated with the 
block.

How many imported variables 
are used by the survey?

• Click on the Variables tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the imported variables 
used by the survey in the order they are used.

How many custom rules does the 
survey use?

• Click on the Rules tab of the Survey Explorer toolbar. Survey 
Crafter Professional lists all of the custom rules used by the 
survey in the order they are used.

How many survey fields does the 
survey use?

• Click on the Fields tab of the Survey Explorer toolbar. Survey 
Crafter Professional lists all of the survey fields in your 
survey.

Which blocks are primary and 
which are seconday?

• Click on the Blocks tab of the Survey Explorer toolbar. 
Survey Crafter Professional lists all of the blocks in your 
survey.

• Review the identifiers for the blocks. If a block is a primary 
block, its identifier is black. If a block is a secondary block, 
its identifier is green.

Table 2 - 4: Ways you can use the Survey Explorer toolbar to review your survey. (Continued)

What to check How to check
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The Question Block Wizard

Use the Question Block Wizard to configure a newly inserted block or to 
edit an existing block’s settings. For example, after you drag a block 
layout from the Question Block Layouts toolbar into the Survey Designer 
window, double-click on the block and Survey Crafter Professional will 
display the Question Block Wizard dialog box for you to use to configure 
the new block.

The Type Tab
Use the Type tab to choose the block’s type, optional components and 
layout.

The Question Block Wizard uses the block type and the selected block 
layout to determine the remaining tabs to display in the dialog box.

Figure 2 - 17 shows the Type tab of the Question Block Wizard dialog 
box.
 

Figure 2 - 17: The Type tab of the Question Block Wizard dialog box.

To see an example and read about a block layout, double-click on the 
layout’s picture.

Choose the type of 
block you want from 
the drop down.

If you want, 
include an 
area in the 
block for 
optional 
components.

Choose a layout from 
the gallery of block 
layouts. Each type of 
block has its own 
gallery of block 
layouts.

To have more than 
one question in the 
block, choose one of 
the multiple question 
block types.

Double-click on a 
layout’s picture to see 
an example and read 
about the layout.

Use the scroll 
bar to view 
more block 
layouts in the 
gallery.
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The Questions Tab
Use the Questions tab to choose how you want to enter the questions in 
the question block. Survey Crafter Professional displays this tab only 
when the block can contain more than one question.

Figure 2 - 18 shows the Questions tab of the Question Block Wizard 
dialog box.

Figure 2 - 18: The Questions tab of the Question Block Wizard dialog box.

The Prompts Tab
Use the Prompts tab to choose how you want to enter the prompts in the 
question block. Survey Crafter Professional displays this tab only when 
the block contains one or more closed-end, all-that-apply, rating, ranking 
or constant sum questions.

Choose this option if 
you want to type your 
questions directly in 
the Survey Designer 
window.

Choose this option if 
you want Survey 
Crafter Professional 
to use a list to supply 
the questions.

Click on this 
button to 
display the 
List Library 
dialog box.

Select a list 
from the drop 
down.
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Figure 2 - 19 shows the Prompts tab of the Question Block Wizard dialog 
box.

Figure 2 - 19: The Prompts tab of the Question Block Wizard dialog box.

The Prompts 2 Tab
Use the Prompts 2 tab to choose how you want to enter the prompts for 
the second group of questions in the question block. Survey Crafter 
Professional displays this tab only when the block's layout calls for a 
second group of closed-end, all-that-apply, rating, ranking or constant 
sum questions.

Choose this option 
if you want to type 
your prompts 
directly in the 
Survey Designer 
window. 

Choose this option 
if you want Survey 
Crafter Professional 
to use a list to 
supply the prompts.

Click on this 
button to 
display the 
List Library 
dialog box.

Select a list 
from the drop 
down.
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Figure 2 - 20 shows the Prompts 2 tab of the Question Block Wizard 
dialog box.

Figure 2 - 20: The Prompts 2 tab of the Question Block Wizard dialog box.

The Other Tab
Use the Other tab to choose options for the 'Other' prompts in the question 
block. Survey Crafter Professional displays this tab only when the block's 
layout calls for one or more 'Other' prompts.

Choose this option if 
you want Survey 
Crafter Professional 
to use a list to supply 
the prompts.

Choose this option if 
you want to type your 
prompts directly in 
the Survey Designer 
window. Click on this 

button to 
display the 
List Library 
dialog box.

Select a list 
from the drop 
down.
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Figure 2 - 21 shows the Other tab of the Question Block Wizard dialog 
box.

Figure 2 - 21: The Other tab of the Question Block Wizard dialog box.

The All-That-Apply Tabs
Use the All-That-Apply tabs to choose options for the all-that-apply 
questions in the question block. Survey Crafter Professional displays 
these tabs only when the block's type or layout calls for one or more all-

Choose what you 
want to happen when 
a respondent does 
not specify what he 
or she means by 
other.

Enter the number of 
‘Other’ prompts you 
want each question in 
the block to have. Enter the 

height and 
width of the 
box(es) for 
the ‘Other’ 
prompts.
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that-apply questions. Figure 2 - 22 shows an All-That-Apply tab of the 
Question Block Wizard dialog box.

Figure 2 - 22: An All-that-Apply tab of the Question Block Wizard dialog box.

The Closed-End Tabs
Use the Closed-End tabs to choose options for the closed-end questions in 
the question block. Survey Crafter Professional displays these tabs only 
when the block's type or layout calls for one or more closed-end 

If you want, you 
can make one or 
more of the last 
prompts 
exclusive.

Choose how many 
prompts you want the 
respondent to select.
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questions. Figure 2 - 23 shows a Closed-End tab of the Question Block 
Wizard dialog box.

Figure 2 - 23: A Closed-End tab of the Question Block Wizard dialog box.

The Constant Sum Tabs
Use the Constant Sum tabs to choose options for the constant sum 
questions in the question block. Survey Crafter Professional displays 
these tabs only when the block's type or layout calls for one or more 

Choose what you 
want to happen when 
a respondent does 
not answer the 
closed-end 
questions.
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constant sum questions. Figure 2 - 24 shows a Constant Sum tab of the 
Question Block Wizard dialog box.

Figure 2 - 24: A Constant Sum tab of the Question Block Wizard dialog box.

The Open-End Tabs
Use the Open-End tabs to choose options for the open-end questions in 
the question block. Survey Crafter Professional displays these tabs only 
when the block's type or layout calls for one or more open-end questions. 

Enter the number 
you want the points 
to sum to.

Choose how many 
items among which 
you want the 
respondent to 
distribute points.

Have respondents 
see a running total 
for each question.

Link a slider control 
to each quantity box 
for the web version of 
the survey.
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Figure 2 - 25 shows an Open-End tab of the Question Block Wizard 
dialog box.

Figure 2 - 25: An Open-End tab of the Question Block Wizard dialog box.

Choose limits, size 
and behavior options 
for the open-end 
question(s).

Choose what you 
want to happen when 
a respondent does 
not answer the open-
end questions.
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The Quantity Tabs
Use the Quantity tabs to choose options for the quantity questions in the 
question block. Survey Crafter Professional displays these tabs only when 
the block's type or layout calls for one or more quantity questions. Figure 
2 - 26 shows a Quantity tab of the Question Block Wizard dialog box.

Figure 2 - 26: A Quantity tab of the Question Block Wizard dialog box.

Enter the minimum 
and maximum values 
you want to allow in 
each response to the 
quantity questions.

Choose what you 
want to happen when 
a respondent does 
not answer the 
quantity questions.

If your survey will be 
on the web, choose if 
you want to link a 
slider control to each 
quantity box in the 
question block.
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The Ranking Tabs
Use the Ranking tabs to choose options for the ranking questions in the 
question block. Survey Crafter Professional displays these tabs only when 
the block's type or layout calls for one or more ranking questions. Figure 
2 - 27 shows a Ranking tab of the Question Block Wizard dialog box.

Figure 2 - 27: A Ranking tab of the Question Block Wizard dialog box.

Choose how many 
items you want the 
respondent to rank.

If your survey will be 
on the web, choose if 
you want to link a 
slider control to each 
ranking box in the 
question block.

Should the 
respondent receive a 
warning or an error 
message if the 
required number of 
items are not 
ranked?
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The Rating Tabs
Use the Rating tabs to choose options for the rating questions in the 
question block. Survey Crafter Professional displays these tabs only when 
the block's type or layout calls for one or more rating questions. Figure 
2 - 28 shows a Rating tab of the Question Block Wizard dialog box.

Figure 2 - 28: A Rating tab of the Question Block Wizard dialog box.

The List Library

One way to create the questions or prompts for a question block is to use a 
list. A list is a collection of unformatted text fragments. Survey Crafter 
Professional provides several standard lists. You can also create new lists 
to use within a study.

Saving Time by Using Lists
Lists, similar to styles in word processors, allow you to create question 
blocks more quickly. When using a word processor, you apply a style to 
text to format it quickly. When creating a question block in Survey 
Crafter Professional, you can select a list to define the question block’s 
questions or prompts.

Choose how you 
want to assign the 
numbers to the 
prompts.

Choose what you 
want to happen when 
a respondent does 
not answer the rating 
questions.
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Suppose your survey asks several questions in which respondents pick 
from the same list of fast food restaurants. Instead of typing the fast food 
restaurant prompts for each new question, you can create and save the list 
of restaurants as the Fast Food Restaurant list. Survey Crafter 
Professional will automatically type your prompts for you when you 
select the Fast Food Restaurant list.

• Editing Lists

Each Survey Crafter Professional study contains its own library of lists. 
You can create and edit the lists in a study using the List Library dialog 
box. To have Survey Crafter Professional display the List Library dialog 
box, do one of the following:

• Choose List from the Insert menu.

• Click on the Insert List from Library toolbar button.

• Click on the button to the right of the drop down under the A list will 
supply the questions option in the Questions tab of the Question Block 
Wizard dialog box.

• Click on the button to the right of the drop down under the A list will 
supply the prompts option in the Prompts or Prompts 2 tab of the 
Question Block Wizard dialog box.

Figure 2 - 29 shows the List Library dialog box.

Figure 2 - 29: The List Library dialog box

Displays all of the lists 
in the study.

Use these buttons to 
create a new list, 
create a copy of an 
existing list, edit an 
existing list, rename 
an existing list or 
delete an existing list.

Previews the currently 
highlighted list.

Use these buttons to 
import and export lists 
from and to a text file.

Use this button to save 
the current set of lists 
as the default for new 
studies.
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Suppose you create your own list called “Advertising,” and you have 
Survey Crafter Professional automatically type your prompts for you by 
using the list in a few question blocks. Suppose you later add “Saw an ad 
on television” to the “Advertising” list. Survey Crafter Professional 
automatically updates all question blocks that use the “Advertising” list to 
include the newly added list item.
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Creating, Opening and Copying Surveys

This section contains step-by-step instructions for doing the following:

• Creating a New Survey

• Opening an Existing Survey

• Copying an Existing Survey

• Renaming a Survey

• Deleting a Survey

Creating a New Survey

Follow the steps below to create a new survey.

Tip  It is important to know that there is only one data set in a study 
and that all surveys in the study share that data set. Although you can 
create an unlimited number of surveys in one study, if you want to 
keep the data obtained from your next survey separate from that of 
your previous survey, create a new study file first and then create your 
new survey in that.
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• To create a new survey

1 Select the Surveys tab of the Study window.

Figure 2 - 30: The Surveys tab of the Study window.

2 Click on the New button on the tab.

Survey Crafter Professional displays the New Survey Wizard dialog 
box.

The Surveys tab 
lists all of the 
surveys in the 
study.

Click on the New 
button to create a 
new survey.

Typically, you will 
be creating a new 
survey when 
there are no 
surveys in the 
study.
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3 Follow the instructions on the screen to complete the New Survey 
Wizard dialog box.

Figure 2 - 31: Step 1 of the New Survey Wizard.

For help on any of the options, click on the Help button on the dialog 
box.

4 When you have completed the dialog box, click on the Finish button.

Survey Crafter Professional displays the Survey Information dialog 
box.

Choose the initial layout 
mode for the Survey 
Designer window.

Choose how you want 
Survey Crafter 
Professional to help you 
enter your survey.

Click on the Help button 
for detailed explanations 
of the options.
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5 In the Survey Information dialog box, enter a name and description 
for your survey.

Enter a name that has not already been given to another survey in the 
study. The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Figure 2 - 32: The Survey Information dialog box.

The name and description will appear in the Surveys tab of the Study 
window.
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6 Click on the OK button.

Survey Crafter Professional displays the Survey Designer window.

Figure 2 - 33: The Survey Designer window.

You can now enter your survey. For instructions on entering your survey’s 
questions, see the section “Inserting Survey Blocks” on page 2 - 67.

Opening an Existing Survey

You can have an unlimited number of surveys open at the same time.

Tip  You can copy and paste as well as drag and drop text and blocks 
from one survey to another.

Instructional 
block that 
allows you to 
quickly insert 
new survey 
question 
blocks. You 
can remove 
this block.

Survey design 
and Survey 
format 
toolbars.

Survey 
Question 
toolbar.

Survey 
Explorer 
toolbar.

Question 
Block Layouts 
toolbar
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• To open an existing survey

1 Select the Surveys tab of the Study window.

Figure 2 - 34: The Surveys tab of the Study window.

2 Select the survey you want to open.

3 Click on the Edit button on the tab.

The survey appears in the Survey Designer window.

You can now make changes to your survey.

For instructions on entering your survey’s questions, see the section 
“Inserting Survey Blocks” on page 2 - 67. For instructions on editing 
surveys, see the section “Editing Survey Questions” on page 2 - 150.

The Surveys tab 
lists all of the 
surveys in the 
study.

Click on the Edit 
button to open the 
highlighted 
survey.
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Copying an Existing Survey

Copying an existing survey in Survey Crafter Professional creates a new 
survey that is not only identical in appearance but also uses exactly the 
same study variables as the original survey. This is useful when you want 
to offer your respondents different variations of the same survey and you 
want to analyze the data obtained from each together.

Follow the steps below to copy an existing survey.

Tip  If you want to make your survey available to your respondents in 
more than one language, use the New Survey Wizard as described 
previously to create a first or master copy. Then, when your survey has 
been finalized, use the feature described in this section to create a copy 
of it. Translate the copy and then use the copy feature again to create 
another copy to translate. You may create as many copies as you want. 
Because the surveys share exactly the same study variables, you will 
be able to analyze the data obtained from each together.

Although it is recommended, it is not required that you wait until the 
master copy of your survey is finalized before making copies. In the 
first step of the Copy Survey Wizard, you can instruct Survey Crafter 
Professional to maintain the copy you are making as structurally 
identical to the original. Structurally identical surveys share the same 
blocks with the same variables in the same order. Words, pictures and 
formatting may be different. When this relationship has been 
established between two surveys, when you add, move or remove a 
block in one survey, Survey Crafter Professional automatically does 
the same in the other.

Tip  Is is important to know that there is only one data set in a study 
and that all surveys in the study share that data set. If you want to 
create a new version of an existing survey and want to keep the data 
for the new version separate from the data of the original survey, copy 
the study file instead. Alternatively, create a new survey in a new 
study file, copy the original survey to the clipboard and paste it into 
the Survey Designer window of the new survey.
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• To copy an existing survey

1 Select the Surveys tab of the Study window.

2 Click on to select the survey you want to copy.

Figure 2 - 35: The Surveys tab of the Study window.

3 Click on the Copy button on the tab.

Survey Crafter Professional displays the Copy Survey Wizard dialog 
box.

The Surveys tab 
lists all of the 
surveys in the 
study.

Click on the Copy 
button to copy the 
highlighted 
survey.

Click on to select 
the survey you 
want to copy..
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4 Follow the instructions on the screen to complete the Copy Survey 
Wizard dialog box.

Figure 2 - 36: Step 1 of the Copy Survey Wizard.

For help on any of the options, click on the Help button on the dialog 
box.

5 When you have completed the dialog box, click on the Finish button.

Survey Crafter Professional displays the Survey Information dialog 
box.

Discusses what copying 
a survey means in 
Survey Crafter 
Professional..

Choose the relationship 
you want between the 
new survey and the one 
you are copying.

Click on the Help button 
for detailed explanations 
of the options.
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6 In the Survey Information dialog box, enter a name and description 
for the new copy.

Make sure the name has not already been given to another survey in 
the study. The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Figure 2 - 37: The Survey Information dialog box.

The name and description will appear in the Surveys tab of the Study 
window.
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7 Click on the OK button.

Survey Crafter Professional displays the Survey Designer window.

Figure 2 - 38: The Survey Designer window.

You can now modify the survey, perhaps translating it into another 
language.

Renaming a Survey

You can rename a survey at any time. Follow the steps below to rename a 
survey.

The survey 
appears 
exactly as the 
original. All 
study variables 
used by the 
blocks are 
from the 
original survey.

Survey design 
and Survey 
format 
toolbars.

Survey 
Question 
toolbar.

Survey 
Explorer 
toolbar.

Question 
Block Layouts 
toolbar
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• To rename a survey

1 Select the Surveys tab of the Study window.

Figure 2 - 39: The Surveys tab of the Study window.

2 Select the survey you want to rename.

3 Click on the Info button on the tab.

Survey Crafter Professional displays the Survey Information dialog 
box.

The Surveys tab 
lists all of the 
surveys in the 
study.

Click on the Info 
button to rename 
the highlighted 
survey.
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4 In the Survey Information dialog box, type the new name for the 
survey.

Enter a name that has not already been given to another survey in the 
study. The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Figure 2 - 40: The Survey Information dialog box.

5 Click on the OK button.

The new name and description will appear in the Surveys tab of the 
Study window. 

Deleting a Survey

Follow the steps below to delete a survey.

• To delete a survey

1 Select the Surveys tab of the Study window.

2 Select the survey you want to delete

WARNING! This operation cannot be undone.
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3 From the Edit menu, choose Delete or press the [Delete] key.

Survey Crafter Professional removes the survey from the study.

Note Survey Crafter Professional will automatically remove the 
imported variables associated with the survey’s question blocks as long 
as the variables are not used by any analysis tables or charts or computed 
variables.
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Deciding What Types of Questions to Write

This section describes the types of survey questions Survey Crafter 
Professional supports and then explains some of the differences between 
the question types.

For guidelines on writing effective survey questions, see the section 
“Designing, Writing, and Testing the Survey” in Chapter 4 of 
Understanding Survey Research:  A Primer for Success.

Types of Survey Questions Survey Crafter 
Professional Supports

Table 2 - 5 lists the 7 types of questions Survey Crafter Professional 
supports. The Fast Food survey on page 2 - 59 illustrates a few of the 
different types of questions.

Table 2 - 5: The 7 types of questions Survey Crafter Professional supports.

Question Type Description

All-That-Apply A question that asks the respondent to check one or more prompts from a 
predefined list of prompts. For example, "Which of the following 
restaurants have you visited? Burger World, King Taco, Broilin' Bill's, The 
Chicken Coop, Marsha's Mex."

Closed-End A question that requires the respondent to pick at most one prompt from a 
predefined list of prompts. Also called a forced choice or multiple-choice 
question. For example, "Which of the following restaurants is your favorite? 
Burger World, King Taco, Broilin' Bill's, The Chicken Coop, Marsha's 
Mex."

Constant Sum A question that respondents reply to by assigning points to a series of items. 
The points they assign across items add up to a total you decide. For 
example: "Divide 100 points among the following three fast food restaurants 
according to how likely you are to visit them (the more points, the more 
likely you are to visit): Burger World, Marsha's Mex, Broilin' Bill's."

Open-End A question that respondents answer in their own words rather than by 
selecting an answer from a list of choices or stating a number. For example, 
"What is your name?"

In the Primer
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Fast Food Survey

Thank you for participating in this survey.

1.  What is your name? ______________________

2.  What is your age? ____________________

3.  What is your marital status?

o  Never married

o  Married

o  Widowed

o  Divorced

4.  Which of the following fast food restaurants have you 
visited? (Check all that apply.)

o  Burger World

o  King Taco

o  Broilin’ Bill’s

o  The Chicken Coop

o  Marsha’s Mex

5.  Which of the following is your favorite fast food 
restaurant? (SKIP THIS QUESTION IF NO 
RESTAURANTS WERE CHECKED IN QUESTION 4.)

o  Burger World

o  King Taco

o  Broilin’ Bill’s

o  The Chicken Coop

o  Marsha’s Mex

6.  Please rate the importance you place on customer 
service at fast food restaurants. (Choose one.)

1  Not at all important

2  Somewhat important

3  Important

4  Very important

5  Extremely important

Have a good day.

Open-end question

Closed-end question

All-that-apply question

Rating question
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Should I write a closed-end, rating or all-that-
apply question?

Survey Crafter Professional uses imported variables to store the answers 
to survey questions. A Survey Crafter Professional imported variable can 
be of type category, quantity, or literal.

In the Survey Crafter Professional analysis tables and charts, category 
variables are used to filter respondent data as well as to calculate counts 
and frequencies. Quantity variables, on the other hand, are used by the 
analysis tables and charts not only to filter respondent data and to 
calculate counts and frequencies but also to calculate means, medians, 
modes, minimums, maximums, standard deviations and so on.

What does this have to do with choosing between writing your question as 
a closed-end, rating or all-that-apply question?

• When you write a closed-end question, Survey Crafter Professional 
automatically creates and maintains one imported category variable to 
store the answers.

• When you write a rating question, Survey Crafter Professional 
automatically creates and maintains one imported quantity variable to 
store the answers.

Quantity A question a respondent answers with a number. For example, "What is your 
age?"

Ranking Respondents reply to a ranking question by ordering a list of items according 
to some criterion. For example, "Please rank the following three fast food 
restaurants according to how likely you are to visit them (1 is most likely to 
visit, 3 least likely):  Burger World, Marsha's Mex, Broilin' Bill's."

Rating A question respondents reply to by picking a point on a scale. For example, 
"Please rate the importance you place on customer service at fast food 
restaurants on a scale of 1 to 5. (1 = Not at all important, 5 = Extremely 
important.)"

Table 2 - 5: The 7 types of questions Survey Crafter Professional supports. (Continued)

Question Type Description
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• When you write an all-that-apply question, Survey Crafter Professional 
automatically creates and maintains an imported category variable for 
each prompt in the question. For example, if your all-that-apply 
question has a list of 5 prompts, Survey Crafter Professional 
automatically creates and maintains 5 imported category variables.

When should I consider writing my question as a closed-
end question?
You should consider writing your question as a closed-end question when 
all of the following conditions are true:

• The prompts in your question can be listed for the respondent

• The respondent may pick at most one prompt from the list of 
prompts

• The prompts do not lend themselves well to being analyzed as 
numbers

For example, the question "What is your gender? Male, or Female" is an 
example of a closed-end question. Although it makes sense to assign 1 to 
Male and 2 to Female, it does not make sense to calculate the mean.

When should I consider writing my question as a rating 
question?
You should consider writing your question as a rating question when all of 
the following conditions are true:

• The prompts in your question can be listed for the respondent

• The respondent may pick at most one prompt from the list of 
prompts

• The prompts lend themselves well to being analyzed as numbers

For example, the question "How satisfied are you with our customer 
service? Very Satisfied, Satisfied, Neither Satisfied nor Dissatisfied, 
Dissatisfied, or Very Dissatisfied" is an example of a rating question. It 
makes sense to have 1 assigned to Very Satisfied, 2 assigned to Satisfied 
and so on and then to calculate the mean as well as the counts and 
frequencies.
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However, sometimes it makes sense to calculate the mean but there are 
complicating factors. The following are situations where you should 
consider writing your question as a closed-end question instead:

• The list of prompts in your question includes one or more 'Other' 
prompts. It may not make sense to calculate the mean when the list of 
prompts includes 'Other'. If you choose to write the question as a 
closed-end question you can then use the Category to Quantity Variable 
wizard to create a computed quantity variable that automatically takes 
on numbers for all but the 'Other' prompts. You can then use the 
computed quantity variable to calculate the mean.

• Similarily, you want only a subset of the numbers associated with the 
prompts to be included in the statistical calculations. If you choose to 
write the question as a closed-end question you can then use the 
Category to Quantity Variable wizard to create a computed quantity 
variable that automatically takes on numbers for the prompts you want 
to include. You can then use the computed quantity variable in the 
statistical calculations.

When should I consider writing my question as an all-
that-apply question?
You should consider writing your question as an all-that-apply question 
when all of the following conditions are true:

• The prompts in your question can be listed for the respondent

• The respondent may pick one or more prompts from the list of 
prompts

For example, the question "Which restaurants have you visited in the last 
month? Burger World, King Taco, Broilin' Bill's, The Chicken Coop, or 
Marsha's Mex " is an example of an all-that-apply question.

To make it easier to analyze all-that-apply questions, Survey Crafter 
Professional provides the All-that-apply Question analysis wizard.

Should I write a rating or a ranking question?

Unfortunately, the terms rating and ranking are often confused and used 
interchangeably.
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In Survey Crafter Professional a rating question refers to a question that 
asks the respondent to pick at most one prompt from a predefined list of 
prompts. Further, each prompt is coded as a number. When you write a 
rating question, Survey Crafter Professional automatically creates and 
maintains one imported quantity variable to store the answers.

On the other hand, a ranking question in Survey Crafter Professional 
refers to a question that asks the respondent to rank a predefined list of 
items against each other assigning each item a unique number starting 
with 1. When you write a ranking question, Survey Crafter Professional 
automatically creates and maintains an imported quantity variable for 
each item to be ranked. For example, if your ranking question has a list of 
5 items to be ranked, Survey Crafter Professional automatically creates 
and maintains 5 imported quantity variables to store the rankings.

When should I consider writing my question as a ranking 
question?
You should consider writing your question as a ranking question when all 
of the following conditions are true:

• The items to be ranked can be listed for the respondent

• You want the respondent to assign a unique number to each item 
starting with 1

For example, the question "Please rank the following restaurants in order 
of your preference. Burger World, King Taco, Broilin' Bill's, The Chicken 
Coop, and Marsha's Mex" is an example of a ranking question.

To make it easier to analyze ranking questions, Survey Crafter 
Professional provides the Ranking Question analysis wizard.

For more information about writing a rating question, see “Should I write 
a closed-end, rating or all-that-apply question?” on page 2 - 60

Should I write a ranking or a constant sum 
question?

It is sometimes difficult to decide whether or not to write a question as a 
ranking or a constant sum question.
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In Survey Crafter Professional, a ranking question refers to a question that 
asks the respondent to rank a predefined list of items against each other 
assigning each item a unique number starting with 1. When you write a 
ranking question, Survey Crafter Professional automatically creates and 
maintains an imported quantity variable for each item to be ranked. For 
example, if your ranking question has a list of 5 items to be ranked, 
Survey Crafter Professional automatically creates and maintains 5 
imported quantity variables to store the rankings.

On the other hand, a constant sum question in Survey Crafter Professional 
refers to a question that asks the respondent to distribute points among a 
predefined list of items such that the sum of the points equals a number 
you specify. When you write a constant sum question, Survey Crafter 
Professional automatically creates and maintains an imported quantity 
variable for each item in the list. For example, if your constant sum 
question has a list of 5 items, Survey Crafter Professional automatically 
creates and maintains 5 imported quantity variables to store the points.

When should I consider writing my question as a 
constant sum question?
You should consider writing your question as a constant sum question 
when all of the following conditions are true:

• The items can be listed for the respondent

• You would like to know how much respondents prefer one item 
over another item

For example, the question "Please distribute 100 points among the 
following restaurants. Assign the higher points to the restaurants that you 
prefer. Please make sure the total points add to 100. Burger World, King 
Taco, Broilin' Bill's, The Chicken Coop, and Marsha's Mex" is an 
example of a constant sum question.

Please note that in general a constant sum question requires more effort 
from the respondent than a ranking question requires. You should decide 
whether or not finding out how much respondents prefer one item over 
another item is worth the additional effort required of your respondents.

For more information about writing a ranking question, see “Should I 
write a rating or a ranking question?” on page 2 - 62
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Should I write a quantity, closed-end or rating 
question?

In Survey Crafter Professional a quantity question refers to a question that 
asks the respondent to answer with a number. When you write a quantity 
question, Survey Crafter Professional automatically creates and maintains 
an imported quantity variable to store the answers.

When should I consider writing my question as a 
quantity question?
You should consider writing your question as a quantity question when all 
of the following conditions are true:

• The answer to the question will always be a number

• You want respondents to answer with an exact number

• Respondents are generally capable of answering with an exact 
number

• Describing the scale in words is not desirable, not possible or not 
feasible

For example, the question "How many children do you have?" is an 
example of a quantity question. In this example, it is safe to assume 
respondents will provide an exact number.

You can use the Quantity to Category Variable wizard to create a 
computed category variable that groups the answers to a quantity 
question. You can then use the computed category variable to calculate 
counts and frequencies of the groups.

When should I consider writing my question as a rating 
question?
You should consider writing your question as a rating question when all of 
the following conditions are true:

• The answer to the question will always be a number

• Most if not all numbers in the scale can be described in words
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For example, the question "Please indicate on a scale of 1 to 5 the 
importance of sleeping 8 hours a night" is an example of a quantity 
question that can be rewritten as a rating question with a list of predefined 
prompts that describe in words the 1 to 5 scale.

If providing a predefined list of prompts that describe the scale in words 
makes the job of answering the question easier for the respondent, then 
writing the question as a rating question is worth the effort.

When should I consider writing my question as a closed-
end question?
It is often possible to rewrite a quantity question to provide the respondent 
a list of ranges from which to choose. You should consider writing your 
question as a closed-end question when any of the following conditions 
are true:

• The answer to the question may not always be a number

• You do not need respondents to answer with an exact number

• Respondents may not be able to answer with an exact number

For example, the question "What is your annual income?" is an example 
of a quantity question that can be rewritten as a closed-end question with 
a list of ranges from which to choose.

If providing a list of ranges from which to choose makes the job of 
answering the question easier for the respondent and the loss of accuracy 
is not significant, then writing the question as a closed-end question is 
worth the effort.

For information about writing a closed-end, rating or all-that-apply 
question, see “Should I write a closed-end, rating or all-that-apply 
question?” on page 2 - 60
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Inserting Survey Blocks

This section explains how to insert survey blocks into your survey.

For guidelines on writing effective survey questions, see the section 
“Designing, Writing, and Testing the Survey” in Chapter 4 of 
Understanding Survey Research:  A Primer for Success.

Inserting Instructions-Only Blocks

You can type and format instructions, section headings and other text or 
insert pictures, tables and lists directly in the Survey Designer window or 
you can insert one or more instructions-only blocks and add the same 
content inside the blocks.

Figure 2 - 41: An instructions-only block in the Survey Designer window.

In the Primer

A title, 
introduction 
and 
instructions 
inside an 
instructions-
only block.

The 
instructions-
only block is 
listed in the 
Blocks tab of 
the Survey 
Explorer 
toolbar.
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Survey Crafter Professional does not create and maintain any imported 
variables for an instructions-only block.

Tip  Use an instructions-only block when:

• you want the instructions to be the origin or destination of a custom 
branching or skipping rule. For more information, see the section 
“Adding custom branching, skipping and hiding rules” on page 
2 - 104.

• you want the instructions displayed in the built-in Interviewer when 
the Interviewer is in its block-only mode. The Interviewer has an 
optional data-entry mode in which only blocks are displayed.

• you want to use the numbering or some of the other features offered 
by the instructions-only block. Other features include splitting the 
block into multiple rows and columns, having the rows and/or 
columns displayed in random order and having a subset of the rows 
and/or columns displayed depending on the answer to another 
question. For more on a block’s components, see the section 
“Survey Basics” on page 2 - 2.

• you want to be able to save the instructions in the Question Library. 
The Question Library only stores blocks.

• you want to see the instructions listed in the Blocks tab of the Survey 
Explorer toolbar.

Otherwise, consider typing directly in the Survey Designer window.
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• To insert an instructions-only block

1 Select "For No Question - Instructions-Only" from the drop down on 
the Question Block Layouts toolbar.

Figure 2 - 42: Inserting a new instructions-only block into the Survey Designer window.

If the Question Block Layouts toolbar is not visible, click on the View 
menu, Toolbars and then on Question Block Layouts.

2 Choose the components you want to include in the block. Do any of 
the following:

• If you want to include an area in the block for a number, select the 
Number check box. Survey Crafter Professional will automatically 
update the gallery of block layouts on the toolbar to show how each 
layout accommodates the area.

• If you selected the Number check box and you want Survey Crafter 
Professional to automatically number the block for you, select the 
Automatic check box.

Select “For No 
Question - 
Instructions-
Only” from the 
drop down.

Drag the 
layout into the 
Survey 
Designer 
window.

Choose the 
components 
you want  to 
include in the 
block.
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• If you selected both the Number and Automatic check boxes and 
you want to restart the automatic numbering, click on the Restart at 
check box and enter the new starting number.

• If you want to include an additional area at the top of the block for 
instructions, select the Instrs on Top check box. This area can be 
useful for labeling the block or for including additional instructions 
or pictures.

• If you want to include an additional area at the bottom of the block 
for instructions, select the Instrs on Bottom check box. This area 
can be useful for skip logic or other instructions for interviewers 
and respondents. Survey Crafter Professional will automatically 
update the gallery of block layouts on the toolbar to show how each 
layout accommodates the area.

3 Click on the layout from the gallery of block layouts and drag it into 
the Survey Designer window.

If you would like the Survey Designer window to scroll, move the 
mouse pointer near an edge of the window and press the [ALT] key.

Tip  Alternatively, if you drag and release the mouse button over an 
existing block in the Blocks tab of the Survey Explorer toolbar, Survey 
Crafter Professional will insert the new block before the existing block 
in the Survey Designer window.
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4 Release the mouse button over the location where you want to insert 
the new block.

If you release the mouse button over an existing block in the Survey 
Designer window, Survey Crafter Professional will insert the new 
block before the existing block.

If you release the mouse button after the end of the survey, Survey 
Crafter Professional will insert the new block at the end of the survey.

Otherwise, Survey Crafter Professional will insert the new block 
where you release the mouse button.

Figure 2 - 43: A new instructions-only block in the Survey Designer window.

5 In the Survey Designer window, if you included an area in the block 
for a number and chose to number the block yourself, enter the 
number in the block's number cell.

6 Go to the section “Configure the New Block” below.

The new block 
is listed in the 
Blocks tab of 
the Survey 
Explorer 
toolbar.

Type and 
format your 
instructions 
here.

Type and 
format 
additional 
instructions 
here.
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Configure the New Block
Because Survey Crafter Professional remembers the settings of the last 
question block you inserted or updated, you may not need to change the 
settings of the newly inserted instructions-only block.

• To configure the new block

1 Double-click anywhere inside the block or right-click inside the block 
and choose Edit Block from the pop-up menu.

You can also move the cursor inside the block and choose Edit from 
the Block menu.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 44: The Type tab of the Question Block Wizard dialog box.

If you want, you can change the block type, optional components and 
the selected block layout.

2 Click on the Next button.

3 Use the instructions on the screen to complete the Question Block 
Wizard dialog box.

Edit Block button

The block type 
determines the type of 
questions contained by 
the block.

Survey Crafter 
Professional changes the 
pictures in the gallery of 
block layouts when you 
change any of the block 
type or block component 
settings.
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For help on any of the options, click on the Help button on the dialog 
box.

4 When you have completed the dialog box, click on the Finish button.

Survey Crafter Professional updates the instructions-only block in the 
Survey Designer window.

5 Type the information in the block's cells.

Inserting Question Blocks

When you want to add a question to your survey, you must use a question 
block.

Figure 2 - 45: Question blocks in the Survey Designer window.

To add a question to your survey, complete the following tasks:

• Insert a New Question Block

Question 
blocks.

The Survey 
Explorer 
toolbar lists all 
of the blocks 
in the survey.

The Question 
Block Layouts 
toolbar 
displays the 
block layouts 
available for 
the current 
layout mode 
and selected 
block type.
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• Configure the New Block

• Type and Format the Block’s Text

• Review the Block’s Imported Variables

Each of these tasks is explained below.

Insert a New Question Block
The instructions below use just one of the many ways you can insert a 
new question block into the Survey Designer window.

• To insert a new question block

1 Select the type of block you want from the drop down on the 
Question Block Layouts toolbar.

Figure 2 - 46: Inserting a new question block into the Survey Designer window.

If the Question Block Layouts toolbar is not visible, click on the View 
menu, Toolbars and then on Question Block Layouts.

Select the 
type of block 
you want from 
the drop 
down.

Drag a layout 
into the 
Survey 
Designer 
window.

Choose the 
components 
you want  to 
include in the 
block.
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2 Choose the components you want to include in the block. Do any of 
the following:

• If you want to include an area in the block for a number, select the 
Number check box. Survey Crafter Professional will automatically 
update the gallery of block layouts on the toolbar to show how each 
layout accommodates the area.

• If you selected the Number check box and you want Survey Crafter 
Professional to automatically number the block for you, select the 
Automatic check box.

• If you selected both the Number and Automatic check boxes and 
you want to restart the automatic numbering, click on the Restart at 
check box and enter the new starting number.

• If you want to include an additional area at the top of the block for 
instructions, select the Instrs on Top check box. This area can be 
useful for labeling the block or for including additional instructions 
or pictures.

• If you want to include an additional area at the bottom of the block 
for instructions, select the Instrs on Bottom check box. This area 
can be useful for skip logic or other instructions for interviewers 
and respondents. Survey Crafter Professional will automatically 
update the gallery of block layouts on the toolbar to show how each 
layout accommodates the area.

3 Review the available layouts in the gallery of block layouts. You may 
need to scroll the gallery to see all of the layouts.

To read about a block layout, right-click on the layout's picture and 
choose Help from the pop-up menu.

4 Click on the layout you want from the gallery of block layouts and 
drag it into the Survey Designer window.

If you would like the Survey Designer window to scroll, move the 
mouse pointer near an edge of the window and press the [ALT] key.

Tip  Alternatively, if you drag and release the mouse button over an 
existing block in the Blocks tab of the Survey Explorer toolbar, Survey 
Crafter Professional will insert the new block before the existing block 
in the Survey Designer window.
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5 Release the mouse button over the location where you want to insert 
the new block.

If you release the mouse button over an existing block in the Survey 
Designer window, Survey Crafter Professional will insert the new 
block before the existing block.

If you release the mouse button after the end of the survey, Survey 
Crafter Professional will insert the new block at the end of the survey.

Otherwise, Survey Crafter Professional will insert the new block 
where you release the mouse button.

Figure 2 - 47: A new question block in the Survey Designer window.

6 Go to the section “Configure the New Block” below.

Configure the New Block
Because Survey Crafter Professional remembers the settings of the last 
question block you inserted or updated, you may not need to change the 
settings of the newly inserted question block.

The question 
will go here.

The new 
block is 
listed in the 
Blocks tab of 
the Survey 
Explorer 
toolbar.

The prompts 
will go here.
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• To configure the new block

1 Double-click anywhere inside the question block or right-click inside 
the question block and choose Edit Block from the pop-up menu.

You can also move the cursor inside the question block and choose 
Edit from the Block menu.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 48: The Type tab of the Question Block Wizard dialog box.

If you want, you can change the block type, optional components and 
the selected block layout.

2 Click on the Next button.

3 Use the instructions on the screen to complete the Question Block 
Wizard dialog box.

For help on any of the options, click on the Help button on the dialog 
box.

Edit Block button

The block type 
determines the type of 
questions contained by 
the block.

Survey Crafter 
Professional changes the 
pictures in the gallery of 
block layouts when you 
change any of the block 
type or block component 
settings.
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4 When you have completed the dialog box, click on the Finish button.

Survey Crafter Professional updates the question block in the Survey 
Designer window.

5 Go to the section “Type and Format the Block’s Text” below.

Type and Format the Block’s Text
You can type and insert pictures inside the cells of the question block.

Survey Crafter Professional may prevent you from typing over some 
areas in the question block. For example, if you chose to have a list supply 
the question(s), Survey Crafter Professional will prevent you from typing 
over the questions in the Survey Designer window.

If you cannot type over the question(s) in the Survey Designer window 
and you want to change the questions, move the cursor inside the question 
block, click the right mouse button and choose Edit Block from the pop-
up menu. Then click on the Questions tab of the Question Block Wizard 
dialog box and follow the instructions on the screen.

Even if Survey Crafter Professional prevents you from typing over an 
area in the question block, you can still change the area's formatting 
options. For example, if you chose to have Survey Crafter Professional 
automatically number the block for you, you can still change the block 
number's formatting options in the Survey Designer window.

You can also change a block cell's width and height by clicking on and 
dragging its left, right or bottom border. You can also format a cell by 
moving the cursor inside the cell and choosing commands from the Table 
menu.

Note  The organization of the cells of the question block is dictated by 
the block's layout. To change the block's selected layout, move the 
cursor inside the question block, click the right mouse button and 
choose Edit Block from the pop-up menu. Then follow the instructions 
in the Type tab of the Question Block Wizard dialog box.
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• To type and format the block’s text

1 If you chose to include an area in the block for a number and also to 
number the block yourself, enter the number in the block's number 
cell.

Figure 2 - 49: A new question block in the Survey Designer window.

2 If the block is for one question or the block supports more than one 
question and you chose to type the question(s) in the Survey Designer 
window, type the question(s) in the block's question cell(s).

3 If the layout you selected for the block calls for one or more prompts 
and you chose to type the prompts in the Survey Designer window, 
type the prompt(s) in the block's prompt cell(s).

4 If you chose to include additional areas in the block for instructions, 
type the instructions in the block's cells.

5 Go to the section “Review the Block’s Imported Variables” below.

Type and 
format your 
question 
here.

Type and 
format your 
question’s  
prompts 
here.
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Review the Block’s Imported Variables
The type and number of imported variables associated with a question 
block depend on the types and number of questions contained by the 
block.

Table 2 - 6 lists the 14 types of question blocks Survey Crafter 
Professional provides and the number and type of imported variables the 
program would automatically create and maintain for the block.

Table 2 - 6: The 14 types of question blocks Survey Crafter Professional provides.

The Type of Question Block The imported variable(s) Survey Crafter 
Professional would automatically create and 
maintain for the block

• For 1 All-That-Apply Question

• For Multiple All-That-Apply 
Questions

• 1 imported category variable for each prompt of each 
all-that-apply question in the block.

• For example, Survey Crafter Professional would 
create and maintain 5 imported category variables 
for a block of type For 1 All-That-Apply Question 
that contains 1 all-that-apply question having 5 
prompts.

• Another example, Survey Crafter Professional would 
create and maintain 24 imported category variables 
for a block of type For Multiple All-That-Apply 
Questions that contains 4 all-that-apply questions, 
each having 6 prompts.

• For 1 Closed-End Question

• For Multiple Closed-End Questions

• 1 imported category variable for each closed-end 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 4 imported category variables 
for a block of type For Multiple Closed-End 
Questions that contains 4 closed-end questions, each 
having any number of prompts.

• For 1 Constant Sum Question

• For Multiple Constant Sum Questions

• 1 imported quantity variable for each prompt of each 
constant sum question in the block

• For example, Survey Crafter Professional would 
create and maintain 6 imported quantity variables for 
a block of type For 1 Constant Sum Question that 
contains 1 constant sum question having 6 prompts.
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To read more about variable types, see the section “Variable Basics” on 
page 6 - 2. Also see the section “Understanding Variables and Scales” in 
Chapter 4 of Understanding Survey Research:  A Primer for Success.

• For 1 Open-End Question

• For Multiple Open-End Questions

• 1 imported literal variable for each open-end 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 1 imported literal variable for a 
block of type For 1 Open-End Question that contains 
1 open-end question.

• For 1 Quantity Question

• For Multiple Quantity Questions

• 1 imported quantity variable for each quantity 
question in the block.

• For example, Survey Crafter Professional would 
create and maintain 10 imported quantity variables 
for a block of type For Multiple Quantity Questions 
that contains 10 quantity questions.

• For 1 Ranking Question

• For Multiple Ranking Questions

• 1 imported quantity variable for each prompt of each 
ranking question in the block.

• For example, Survey Crafter Professional would 
create and maintain 15 imported quantity variables 
for a block of type For Multiple Ranking Questions 
that contains 3 ranking questions, each having 5 
prompts.

• For 1 Rating Question

• For Multiple Rating Questions

• 1 imported quantity variable for each rating question 
in the block.

• For example, Survey Crafter Professional would 
create and maintain 7 imported quantity variables for 
a block of type For Multiple Rating Questions that 
contains 7 rating questions, each having any number 
of prompts.

Table 2 - 6: The 14 types of question blocks Survey Crafter Professional provides. (Continued)

The Type of Question Block The imported variable(s) Survey Crafter 
Professional would automatically create and 
maintain for the block

In the Primer
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• To review the block’s imported variables

1 Right-click inside the question block and choose Edit Survey/Block 
Variables from the pop-up menu.

Alternatively, you can move the cursor inside the question block and 
choose Edit Survey/Block Variables from the Block menu.

Survey Crafter Professional displays the Survey/Block Variables 
dialog box.
 

Figure 2 - 50: The Survey/Block Variables dialog box.

2 If you want to change the name or description of a variable, click on 
the variable and then click on the Info button.

3 To view the definition of a variable, click on the variable and then 
click on the Edit button.

4 Click on the Close button.

Note  You cannot change the definition of a variable associated with a 
question block.

Survey Crafter 
Professional 
automatically creates 
and maintains an 
imported category 
variable for each 
closed-end question 
in the question block.

Click on the Info 
button to change the 
name or description 
of the highlighted 
variable.

Click on the Edit 
button to view the 
definition of the 
highlighted variable.
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Using the Question Library

Survey Crafter Professional’s Question Library is a collection of common 
survey questions and stand-alone text. The Library is available to all 
studies. By inserting questions from the Library into your survey, you can 
create a survey more quickly.

The Library comes loaded with questions called standard questions. Each 
standard question has its text, layout, and variable(s) already defined. 
After inserting a question in your survey, you can edit it if you want. You 
can also add your own questions (called user-defined questions) to the 
Library and reorganize the Library to suit your needs best.

Figure 2 - 51: The Question Library dialog box.

Note This section uses the term “question” to refer to both question 
blocks and instructions-only blocks. The procedures below apply to both 
types of blocks.

A group of questions. 
Click on the plus sign 
to the left of the group 
to open it.

Each question in a 
group has a name.

View the selected 
question here.

If the Delete 
button is 
disabled, the 
selected group 
or question is 
standard. 
Otherwise, it is 
user-defined.
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Inserting a Question from the Library into Your 
Survey

You can insert a question from the Library anywhere in your survey. 

• To insert a question from the Library into your survey

1 Select the Surveys tab of the Study window.

2 Select the survey you want to change and then click on the Edit 
button on the tab.

3 In the Survey Designer window, move the cursor to the location 
where you want to insert a question from the Library.

4 From the Block menu, choose Insert and then Block from Library or 
click on the Insert Block from Library button on the toolbar.

Survey Crafter Professional displays the Question Library dialog box.

5 In the Blocks list, select the block you want to insert into the survey.

6 Click on the OK button.

Survey Crafter Professional inserts the block in the Survey Designer 
window and adds the block’s imported variable(s) to the study. 
Survey Crafter Professional also adds the variable templates used by 
the block’s variable(s) if the templates are not already in the study.

If the block was numbered manually and then added to the Library, it 
appears with that number in the Survey Designer window. It uses that 
number even if it is not consecutive with the previous block in the 
survey. To change the number, type over the number in the Survey 
Designer window, double-click on the block or right-click inside the 
block and choose Edit Block from the pop-up menu.

Adding a Question to the Library

By adding a question to the Library, you can reuse the question in other 
studies. When you add a block to the Library, Survey Crafter Professional 
also adds the block’s imported variable(s) to the Library.

Insert Block from 
Library button
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• To add a question to the library

1 In the Survey Designer window, move the cursor inside the block you 
want to add to the Library.

2 From the Block menu, choose Add to Library or click on the Add 
Block to Library button on the toolbar.

3 In the Name field, enter a name for the block.

The name is used to help identify the block in the Blocks list in the 
Question Library dialog box. The name may be up to 50 characters 
long and may contain letters, digits, underscores, and spaces.

4 In the Group field, select the group to which you want to assign the 
block.

For example, assign the block to the Behavior group. Each block may 
be assigned to only one group.

If you want to create a new group, click on the New button.

Figure 2 - 52: The Add Question to Library dialog box.

5 Click on the OK button.

Survey Crafter Professional adds the block to the Library.

Organizing the Library

You can customize the Library’s structure by deleting a question or group 
from the Library, changing a question’s group and name, and adding and 
renaming groups.

Add Block to Library 
button

A name and group for the 
question “How many 
times a week do you eat 
at fast food restaurants?”
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These customizations apply only to user-defined questions and groups. To 
find out whether a group or question is user-defined, select it in the 
Blocks list. If the Delete button in the Question Library is available, the 
group or question is user-defined.

Deleting a Question or Group from the Library
You can delete only user-defined questions and groups from the Library. 
Deleting a block or group from the Library does not affect your survey in 
any way.

• To delete a question or group from the Library

1 Select the Surveys tab of the Study window.

2 Select any survey and then click on the Edit button on the tab.

3 From the Block menu, choose Insert and then Block from Library or 
click on the Insert Block from Library button on the toolbar.

Survey Crafter Professional displays the Question Libary dialog box.

4 In the Blocks list, select the user-defined question or group you want 
to delete.

5 Click on the Delete button.

Survey Crafter Professional deletes the question or group from the 
Library.

Changing a Question’s Group or Name
To help you find questions in the Library more easily, a question has two 
properties: a group and a name. Both groups and names appear in the 
Blocks list in the Question Library dialog box. 

Groups are categories that help organize the questions in the Library. For 
example, the Demographics group contains questions like “What is your 
age?” and “What is your gender?”

WARNING! Deleting a group deletes all of the questions in that group.

Insert Block from 
Library button
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Names are text tags that identify each question in a group. For example, 
you could assign the names “age” and “gender” to the questions “What is 
your age?” and “What is your gender?”

You can move user-defined questions to new groups or change their 
names at any time. You cannot move or rename standard questions.

• To change a question’s group or name

1 Select the Surveys tab of the Study window.

2 Select any survey and then click on the Edit button on the tab.

3 From the Block menu, choose Insert and then Block from Library or 
click on the Insert Block from Library button on the toolbar.

Survey Crafter Professional displays the Question Libary dialog box.

4 In the Blocks list, select the user-defined question for which you want 
to change the group or name.

5 Click on the Properties button.

6 If you want to change the question’s name, edit the text in the Name 
field.

Use up to 50 characters for the name. The name may contain letters, 
digits, underscores, and spaces.

7 If you want to change the question’s group, select another group from 
the Groups list.

If you want to create a new group for this question, click on the New 
button.

Figure 2 - 53: The Edit Question Properties dialog box.

8 Click on the OK button on the Edit Question Properties dialog box.

Insert Block from 
Library button
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Survey Crafter Professional makes the changes in the Blocks list.

Adding and Renaming Groups
You can rename only user-defined groups.

The Question Library does not support a hierarchy of groups. You cannot, 
for example, add a subgroup called Home and Family to the 
Demographics group.

• To add a group to the Library

1 Select the Surveys tab of the Study window.

2 Select any survey and then click on the Edit button on the tab.

3 From the Block menu, choose Insert and then Block from Library or 
click on the Insert Block from Library button on the toolbar.

Survey Crafter Professional displays the Question Libary dialog box.

4 Click on the Groups button.

5 In the Edit Groups dialog box, click on the New button.

Figure 2 - 54: The Edit Groups dialog box.

Insert Block from 
Library button

Click on this button to 
display the New Group 
dialog box.
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6 In the Name field, enter the name of the group to add.

Use up to 50 characters for the group name. The name may contain 
letters, digits, underscores, and spaces.

Figure 2 - 55: The New Group dialog box.

7 Click on the OK button.

Survey Crafter Professional adds the group to the Groups list in the 
Edit Groups dialog box.

8 Click on the Close button on the Question Library dialog box.

• To rename a group in the Library

1 Select the Surveys tab of the Study window.

2 Select any survey and then click on the Edit button on the tab.

3 From the Block menu, choose Insert and then Block from Library or 
click on the Insert Block from Library button on the toolbar.

Survey Crafter Professional displays the Question Libary dialog box.

4 In the Edit Groups dialog box, select the group you want to rename.

5 Click on the Rename button.

6 In the Name field, enter the group’s new name.

Enter a unique name for 
the new group.

Insert Library 
Question button
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Use up to 50 characters for the name. The name may contain letters, 
digits, underscores, and spaces.

Figure 2 - 56: The Rename Group dialog box.

7 Click on the OK button.

Survey Crafter Professional updates the group’s name in the Groups 
list in the Edit Groups dialog box.

8 Click on the Close button on the Question Libary dialog box.
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Inserting Pictures

Pictures are useful in many ways including illustrating your survey’s 
questions.

The sections below cover the following:

• Embedding and Linking Picture Files

• Copying and Pasting Pictures 

Embedding and Linking Picture Files

You can embed and link picture files in the Survey Designer window.

When you embed a picture file, Survey Crafter Professional stores the file 
in its entirety with the survey text. When you link a picture file, Survey 
Crafter Professional stores only a reference to the file on your computer.

Embedding a picture file in the Survey Designer window is a good choice 
if the file is not large and you plan to copy the study file to or access the 
study file from other computers. Since the picture file is stored with the 
survey text, copying the study file copies the picture.

Linking a picture file in the Survey Designer window is a good choice if 
the file is large or you do not want to lose any amount of the picture's 
resolution. However, if you copy the study file to another computer and 
the picture file is not in exactly the same location on the other computer, 
Survey Crafter Professional will not display the linked picture.

When publishing web survey files, Survey Crafter Professional creates a 
new picture file for each embedded picture in the Survey Designer 
window. New picture files are created either in JPEG File Interchange 
Format (JPG), Graphic Interchange Format (GIF), Portable Network 
Graphics (PNG) or Windows Metafile File Format (WMF).
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• To embed a picture file in your survey

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the picture file.

Survey Crafter Professional may prevent you from inserting a picture 
in some areas of the Survey Designer window.

2 Choose Embed Picture from the Insert menu.

Survey Crafter Professional displays the Embed Picture dialog box.

Figure 2 - 57: The Embed Picture dialog box.

3 Select the type of picture file you want to insert from the Files of 
Type drop down.

4 Use the Locations (Look in) drop down list and Folders list to find the 
folder containing the picture file.

5 Select the picture file from the Folders list.

6 Click on the Open button.

Survey Crafter Professional inserts the picture file in the Survey 
Designer window.

7 If you want to resize the picture, you can either use the mouse to drag 
the picture's borders or choose Picture from the Format menu.
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• To link a picture file in your survey

1 In the Survey Designer window, move the cursor to the location 
where you want to insert a reference to the picture file.

Survey Crafter Professional may prevent you from inserting a picture 
in some areas of the Survey Designer window.

2 Choose Link Picture from the Insert menu.

Survey Crafter Professional displays the Link Picture dialog box.

Figure 2 - 58: The Link Picture dialog box.

3 Select the type of picture file you want to insert from the Files of 
Type drop down.

4 Use the Locations (Look in) drop down list and Folders list to find the 
folder containing the picture file.

5 Select the picture file from the Folders list.

6 Click on the Open button.

Survey Crafter Professional inserts a reference to the picture file in 
the Survey Designer window.

Note If you copy the study file to another computer and the picture file 
is not in exactly the same location on the other computer, Survey Crafter 
Professional will not display the linked picture.
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7 If you want to resize the picture, you can either use the mouse to drag 
the picture's borders or choose Picture from the Format menu.

Copying and Pasting Pictures

You can copy and paste pictures in the Survey Designer window.

When you paste a picture in the Survey Designer window, Survey Crafter 
Professional stores the picture with the survey text.

Pasting a picture in the Survey Designer window is a good choice if the 
file is not large and you plan to copy the study file to or access the study 
file from other computers. Since the picture is stored with the survey text, 
copying the study file copies the picture.

Alternatively, linking a picture in the Survey Designer window is a good 
choice if the picture is large or you do not want to lose any amount of the 
picture's resolution.

When publishing web survey files, Survey Crafter Professional creates a 
new picture file for each pasted picture in the Survey Designer window. 
New picture files are created either in JPEG File Interchange Format 
(JPG), Graphic Interchange Format (GIF), Portable Network Graphics 
(PNG) or Windows Metafile File Format (WMF).

• To copy a picture from your survey

1 In the Survey Designer window, use the mouse to highlight the 
picture you want to copy to the clipboard.

2 Choose Copy from the Edit menu or press [CTRL-C].

Survey Crafter Professional copies the highlighted picture to the 
clipboard.

• To paste a picture into your survey

1 In the Survey Designer window, move the cursor to the location 
where you want to paste the picture from the clipboard.

Survey Crafter Professional may prevent you from pasting a picture 
in some areas of the Survey Designer window.

Copy button
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2 Choose Paste from the Edit menu or press [CTRL-V].

Survey Crafter Professional pastes the picture from the clipboard into 
the Survey Designer window.

3 If you want to resize the picture, you can either use the mouse to drag 
the picture's borders or choose Picture from the Format menu.

Paste button
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Inserting Hyperlinks and Targets

You may find it useful to allow your respondents to click on a hyperlink 
in your web survey to jump to another location or even to launch a new 
web browser to view additional information about the survey.

The sections below cover the following:

• Inserting Targets

• Inserting Hyperlinks 

Inserting Targets

A target in the Survey Designer window is a named location that you can 
use as a destination for a hyperlink. Use a target as a hyperlink's 
destination when you want your respondents to click on a hyperlink to 
jump to another location in your survey.

Before you can insert a hyperlink to jump to another location in your 
survey, you need to insert a target in your survey.

• To insert a target in your survey

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the new target.

2 Choose Target from the Insert menu.

Survey Crafter Professional displays the Insert Target dialog box.

Figure 2 - 59: The Insert Target dialog box.



      Surveys 2 - 97 
Inserting Hyperlinks and Targets
3 Enter the new target's name in the Target Name field.

Survey Crafter Professional lists all of the targets that you have 
already inserted in your survey.

If you want, you can click on an existing target and then click on the 
Go To button to jump to the target's location in the Survey Designer 
window.

4 Click on the Add button.

Survey Crafter Professional inserts the new target in the Survey 
Designer window.

The new target will appear in the Targets tab of the Survey Explorer 
toolbar.

Inserting Hyperlinks

You can insert a hyperlink in the Survey Designer window to:

• jump to another location in your survey

• launch a new web browser displaying a web page you specify

• launch your respondent's default e-mail program displaying a new 
e-mail message addressed to a recipient you specify

Before you can insert a hyperlink to jump to another location in your 
survey, you need to insert a target in your survey. See “Inserting Targets” 
on page 2 - 96.

• To insert a hyperlink to jump to another location in your survey

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the new hyperlink.

2 Choose Hyperlink from the Insert menu.

Note Respondents only need to single-click on a hyperlink in a 
published web survey whereas you need to double-click on a hyperlink 
in both the Survey Designer window and in the built-in Interviewer.
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Survey Crafter Professional displays the Insert Hyperlink dialog box.

Figure 2 - 60: The Insert Hyperlink dialog box.

3 Enter the text you want your respondents to click on.

4 Select the target you want to use.

Survey Crafter Professional lists all of the targets that you have 
already inserted in your survey.

If the list is empty, click on the Cancel button and insert a target in 
your survey. See “Inserting Targets” on page 2 - 96.

5 Click on the OK button.

Survey Crafter Professional inserts the new hyperlink in the Survey 
Designer window.

6 Double-click on the hyperlink in the Survey Designer window.

Survey Crafter Professional jumps to the location of the target 
selected in step 4.

• To insert a hyperlink to display a web page in a new web browser

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the new hyperlink.

2 Choose Hyperlink from the Insert menu.



      Surveys 2 - 99 
Inserting Hyperlinks and Targets
Survey Crafter Professional displays the Insert Hyperlink dialog box.

Figure 2 - 61: The Insert Hyperlink dialog box.

3 Enter the text you want your respondents to click on.

4 Enter the URL of the web page you want to display in a new web 
browser.

For example, type http://www.surveycrafter.com to have the new web 
browser display Survey Crafter's website.

5 Click on the OK button.

Survey Crafter Professional inserts the new hyperlink in the Survey 
Designer window.

6 Double-click on the hyperlink in the Survey Designer window.

Survey Crafter Professional launches a new web browser displaying 
the web page you specified in step 4.

• To insert a hyperlink for e-mailing a message

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the new hyperlink.

2 Choose Hyperlink from the Insert menu.
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Survey Crafter Professional displays the Insert Hyperlink dialog box.

Figure 2 - 62: The Insert Hyperlink dialog box.

3 Enter the text you want your respondents to click on.

4 Enter mailto: followed by the e-mail address you want your 
respondent to send an e-mail message to.

For example, type mailto:info@surveycrafter.com to have your 
respondent's default e-mail program display a new e-mail message 
addressed to info@surveycrafter.com.

5 Click on the OK button.

Survey Crafter Professional inserts the new hyperlink in the Survey 
Designer window.

6 Double-click on the hyperlink in the Survey Designer window.

Survey Crafter Professional launches your default e-mail program 
displaying a new e-mail message addressed to the recipient you 
specified in step 4.
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Adding Custom Rules

Survey Crafter Professional provides 18 different types of rules for you to 
use to guide your survey’s respondents.

The sections below cover the following:

• Adding custom opening and closing web survey rules

• Adding custom branching, skipping and hiding rules

• Adding custom validation rules 

• Adding custom assignment rules

• Adding custom web cookie rules

• Adding custom data cleaning rules 

• Adding custom commands 

• Custom branching, skipping and hiding rule issues 

Adding custom opening and closing web survey 
rules

You can add rules to your study that have your web surveys automatically 
open or close on specified dates and times or alternatively when custom 
conditions are being met.

These rules are called custom opening and closing web survey rules. You 
can add these kinds of rules to your study from either Survey Crafter 
Professional's Survey Designer window or Survey Crafter Professional's 
Data window.
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• To add custom opening and closing web survey rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 63: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 64: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
are two types of custom opening and closing web survey rules.

• Open Web Survey

Since Survey Crafter Professional web surveys are open by default, 
it is not necessary to use a rule of this type when you want to your 
web survey to start out open. Instead, use a rule of this type when 
you want your web survey to start out closed and then have it open 
at a specific date and time or alternatively when a custom condition 
is being met. Survey Crafter Professional's built-in Interviewer 
ignores rules of this type.

The type of rule you 
choose determines 
the remaining 
options.
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• Close Web Survey

Close your web survey on a specified date and time or while a 
custom condition is being met. Survey Crafter Professional's built-
in Interviewer ignores rules of this type.

4 Select the remaining options for your rule.

Click on the Locate buttons to the right of the drop downs to have 
Survey Crafter Professional display the selected items in the Survey 
Designer window.

If your rule uses an expression, your expression must evaluate to 
either TRUE or FALSE for each respondent in your study's data set. 
For example, the expression FORMAT_UTCTIME(1,1)>="2017/09/
01 00:00" evaluates to TRUE when the current date and time in 
Coordinated Universal Time (UTC) is on or after 12AM, September 
1, 2017.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

5 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

6 Repeat steps 2 through 5 until you are done.

7 Click on the Close button.

Adding custom branching, skipping and hiding 
rules

You can add rules to your study that have Survey Crafter Professional 
automatically take respondents from one question block or page to 
another question block or page. You can also add rules that automatically 
hide some of a block’s questions or prompts.
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These rules are called custom branching, skipping and hiding rules. You 
can add these kinds of rules to your study from either Survey Crafter 
Professional's Survey Designer window or Survey Crafter Professional's 
Data window.

Note When your survey is on the Web, there are browser compatibility 
issues you should be aware of regarding the enforcement of your custom 
branching, skipping and hiding rules.

For more information, see section “Custom branching, skipping and 
hiding rule issues” on page 2 - 134
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• To add custom branching, skipping and hiding rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 65: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 66: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
are nine types of custom branching, skipping and hiding rules.

• After Question Block, Go to Question Block

When a custom condition of your making is met, this rule has the 
survey automatically disable all of the question blocks between the 
block to which the rule is attached and the selected destination 
block as well as skip all of the pages that follow, up to the page that 
contains the destination block, forcing the respondent to skip all of 
the intervening questions and pages.

The type of rule you 
choose determines 
the remaining 
options.
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Note: Since all question blocks are available by default, it is not 
necessary to create and attach a rule of this type to a block in your 
survey when you always want the question(s) in the following 
block to be answered. Instead, create and attach a rule of this type to 
a block when there are times when you want the question(s) in one 
or more of the following blocks to be skipped.

• After Question Block, Go to Page

When a custom condition of your making is met, this rule has the 
survey automatically disable the question blocks between the block 
to which the rule is attached and the end of the page as well as skip 
all of the pages that follow, up to the selected destination page, 
forcing the respondent to skip all of the intervening questions and 
pages.

Note: Since all question blocks and pages are available by default, 
it is not necessary to create and attach a rule of this type to a block 
in your survey when you always want the remaining question(s) on 
the page and the following page to be answered. Instead, create and 
attach a rule of this type to a block when there are times when you 
want the remaining question(s) on the page and one or more of the 
following pages to be skipped.

• After Page, Go to Page

When a custom condition of your making is met, this rule has the 
survey automatically skip all of the pages that follow the page that 
contains the block to which the rule is attached, up to the selected 
destination page, forcing the respondent to skip all of the 
intervening pages.

Note: Since all pages are available by default, it is not necessary to 
create and attach a rule of this type to a block in your survey when 
you always want the following page to be available. Instead, create 
and attach a rule of this type to a block when there are times when 
you want one or more of the following pages to be skipped.

• Skip Question Block

If a condition is met, disable or hide a selected question block.

• Skip Page
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If a condition is met, skip the page that contains a selected question 
block.

• Skip Page, Go to Page

If a condition is met, skip the page that contains question block A 
and take the respondents to page B.

• After Page, End Web Survey

If a condition is met, save and end the web survey after respondents 
complete the page that contains the rule’s selected question block. 
Survey Crafter Professional's built-in Interviewer ignores rules of 
this type.

• After Question Block, Terminate Interview

If a condition is met, terminate the interview after respondents 
complete the rule’s selected question block. Survey Crafter 
Professional web surveys ignore rules of this type.

• Hide Block Components

Have Survey Crafter Professional automatically hide individual 
components such as questions or prompts inside a selected question 
block. When your survey is in Survey Crafter Professional's built-in 
Interviewer, components that would be hidden are disabled instead.

4 Select the remaining options for your rule.

Click on the Locate buttons to the right of the drop downs to have 
Survey Crafter Professional display the selected items in the Survey 
Designer window.

If your rule uses an expression, your expression must evaluate to 
either TRUE or FALSE for each respondent in your study's data set. 
For example, the expression A1_WhatIsYourGender = 'Male' 
evaluates to either TRUE or FALSE.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

5 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.
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6 Repeat steps 2 through 5 until you are done.

7 Click on the Close button.

Adding custom validation rules

In addition to using the built-in validation rules, you can add rules that 
have Survey Crafter Professional validate responses and show 
respondents your own warning and error messages.

These rules are called custom validation rules. You can add these kinds of  
rules to your study from either Survey Crafter Professional's Survey 
Designer window or Survey Crafter Professional's Data window.
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• To add custom validation rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 67: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 68: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
are two types of custom validation rules.

• After Page, Show Error Message

If a condition is met after respondents complete the page that 
contains question block A, have Survey Crafter Professional 
display an error message.

• After Page, Show Warning Message

If a condition is met after respondents complete the page that 
contains question block A, have Survey Crafter Professional 
display a warning message.

The type of rule you 
choose determines 
the remaining 
options.
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4 Select the survey to which you want your rule to belong.

The drop down lists all of the surveys in your study.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional display the currently selected survey in a 
Survey Designer window.

5 Choose the originating question block.

The drop down lists all of the blocks in the survey you selected under 
Survey.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional highlight the currently selected block in 
the Survey Designer window.

6 Enter the message you want Survey Crafter Professional to display.

If you are having Survey Crafter Professional display an error 
message, respondents will not be allowed to continue until the error is 
fixed.

If you are having Survey Crafter Professional display a warning 
message, respondents will be given the option to continue without 
changing their answers.

7 Choose when you want Survey Crafter Professional to display your 
message.

Choose the Always option to have Survey Crafter Professional always 
display your message.

Choose the When the following condition is true option to have 
Survey Crafter Professional display your message when the 
expression you provide evaluates to TRUE.

Your expression must evaluate to either TRUE or FALSE for each 
respondent in your study's data set. For example, the expression 
A1_WhatIsYourGender = 'Male' evaluates to either TRUE or FALSE.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 
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8 If you want, enter a description for your rule.

For example, you might want to enter a description that will help you 
remember the purpose of your rule.

9 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

10 Repeat steps 2 through 9 until you are done.

11 Click on the Close button.

Adding custom assignment rules

You can add rules that have Survey Crafter Professional automatically 
assign values to imported variables as the respondent takes your survey.

These rules are called custom assignment rules. You can add these kinds 
of rules to your study from either Survey Crafter Professional's Survey 
Designer window or Survey Crafter Professional's Data window.
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• To add custom assignment rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 69: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 70: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
are two types of custom assignment rules.

• After Web Page, Assign Variable

If a condition is met after respondents complete the page that 
contains question block A, have Survey Crafter Professional assign 
a value to an imported variable. Survey Crafter Professional's built-
in Interviewer ignores rules of this type.

• After Interviewer Page, Assign Variable

The type of rule you 
choose determines 
the remaining 
options.
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If a condition is met after respondents complete the page that 
contains question block A, have Survey Crafter Professional assign 
a value to an imported variable. Survey Crafter Professional web 
surveys ignore rules of this type.

4 Select the survey to which you want your rule to belong.

The drop down lists all of the surveys in your study.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional display the currently selected survey in a 
Survey Designer window.

5 Choose the originating question block.

The drop down lists all of the blocks in the survey you selected under 
Survey.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional highlight the currently selected block in 
the Survey Designer window.

6 Choose an imported variable.

Click on the Select button to choose an imported variable from a list 
of all of the imported variables in your study. Displays the Select 
Imported Variable dialog box.

7 Enter the value you want to assign the variable.

Enter an expression that will evaluate to a value of the same type as 
the imported variable. For example, if you chose a quantity variable, 
your expression must evaluate to a quantity value. If you chose a 
literal variable, your expression must evaluate to a literal value.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 
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8 Choose when you want Survey Crafter Professional to assign the 
variable.

Choose the Always option to have Survey Crafter Professional always 
assign the variable.

Choose the When the following condition is true option to have 
Survey Crafter Professional assign the variable when the expression 
you provide evaluates to TRUE.

Your expression must evaluate to either TRUE or FALSE for each 
respondent in your study's data set. For example, the expression 
A1_WhatIsYourGender = 'Male' evaluates to either TRUE or FALSE.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

9 If you want, enter a description for your rule.

For example, you might want to enter a description that will help you 
remember the purpose of your rule.

10 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

11 Repeat steps 2 through 10 until you are done.

12 Click on the Close button.

Adding custom web cookie rules

You can add rules that have Survey Crafter Professional get and set 
cookies from your respondent's browser as the respondent takes your 
survey.
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You can add these rules to your study from either the Survey Designer 
window or the Data window.

Note When your survey is on the Web, the mechanism that Survey 
Crafter Professional uses to send and receive cookies to and from your 
respondent's browser is written in JavaScript. Even though it's the 
default setting, you should verify that the Allow the respondent's 
browser to handle page modifying rules such as randomizing and hiding 
prompts (JavaScript) check box in the Navigation tab of the Web Survey 
Setup dialog box is selected. If the check box is cleared, the mechanism 
will not be included in the published HTML and configuration files.

Tip You can use a rule of this type and the settings of the Respondent 
and Data File tabs of the Web Survey Setup dialog box to allow 
respondents to revisit your web survey, see and make changes to their 
answers as well as proceed with the survey, all without their having to 
enter any identifying information. You can also use such a rule and the 
settings to prevent respondents from completing your web survey a 
second time.

Note that cookies can be used this way only when respondents use the 
same device and browser as they did previously.

For more, see the tips below.
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• To add custom web cookie rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional’s Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 71: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 72: The Custom Rule - New dialog box.

3 Click on the drop down to the right of Rule Type and choose Set/Get 
Web Cookie.

4 Select the survey to which you want your rule to belong.

The drop down lists all of the surveys in your study.

If you are adding the rule from the Survey Designer window, the 
survey you are working on will already be selected. Otherwise, select 
the survey to which you want your rule to belong and if you want, 
click on the Locate button to the right of the drop down to have 
Survey Crafter Professional display the survey in a Survey Designer 
window.

The type of rule you 
choose determines 
the remaining 
options.
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5 Choose the block to which you want to attach the rule.

The drop down lists all of the blocks that are in the selected survey.

If you are adding the rule from the Survey Designer window and in 
step 1 the cursor was inside a block, that block will already be 
selected. Otherwise, select the block to which you want to attach the 
rule and if you want, click on the Locate button to the right of the 
drop down to have Survey Crafter Professional move the cursor to 
and highlight the block in the Survey Designer window.

6 Enter a name for the cookie.

In the box under Set the cookie, without using any spaces, enter a 
name for the cookie.

If you want, click on the Insert a unique name button to have Survey 
Crafter Professional generate a unique name for you.

Tip If you want to use this rule to have Survey Crafter Professional 
automatically identify respondents when they revisit your web survey, 
choose a block that is on the first page. It is recommended that the first 
page not contain any questions to which you want the respondents to see 
their previous answers upon revisiting. You can, however, have such 
questions on the first page when you have respondents access your web 
survey using a link that has the Survey Crafter Professional web survey 
script load the first page.

Tip It is recommended that the name be descriptive enough for you to be 
able to identify it in a list of cookies. It is also recommended that you 
enter a name that is not already being used or will likely not be used by 
another cookie in this or another one of your surveys or your website 
unless you are doing this intentionally.

Note The name may also not contain the following additional 
characters: @ ( ) = [ { ] } \ ; : " , < > / ?. Periods are allowed. If the name 
contains a space or any of the characters listed here, Survey Crafter 
Professional will ask you to remove the character(s) when you click on 
the dialog box's OK button.
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7 If you want to have Survey Crafter Professional assign an imported 
variable the same value as the cookie, click to select the and the 
imported variable check box.

8 If you selected the and the imported variable check box, enter a name 
for the variable or click on the Select button to either choose an 
existing imported variable or create a new one.

Tip Assigning an imported variable the same value as the cookie allows 
you to store the value of the cookie in your web survey's data file. In 
addition, you can use the variable to uniquely identify your respondents, 
making it possible for you to prevent respondents from using the same 
browser to complete your survey a second time, for example.

Tip It is recommended that you create a new imported literal or quantity 
variable to store the value of the cookie. Click on the Select button to 
either choose an existing variable or create a new one.

Tip If you decide to have Survey Crafter Professional store the value of 
the cookie in a new imported variable, you will need to add the variable 
to your web survey's data file.

Note You may only use imported variables of type literal or quantity to 
store cookie values.
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9 Enter the value you want to assign the cookie.

In the box under To the result of evaluating the following, enter an 
expression that will evaluate to a value of type literal or quantity. If 
you are having Survey Crafter Professional assign the cookie's value 
to an imported variable, the expression must evaluate to a value of the 
same type as the imported variable you chose to use.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

10 Choose when you want Survey Crafter Professional to create or 
recreate the cookie, calculate a new value for it and send it to the 
respondent's browser.

• Always

Select this option to have Survey Crafter Professional always create 
or recreate the cookie, calculate a new value for it and send it to the 
respondent's browser.

• When the respondent's browser doesn't already have the cookie

Example If you chose to use an imported quantity variable, your 
expression must evaluate to a quantity value. If you chose to use an 
imported literal variable, your expression must evaluate to a literal 
value.

Tip If you want to use the cookie to uniquely identify your web survey's 
respondents, you will want to enter an expression that will evaluate to a 
unique value for each respondent. Click on the Insert an expression that 
evaluates to a unique value button to see the expressions Survey Crafter 
Professional has to offer. If you are having Survey Crafter Professional 
assign the cookie's value to an imported variable, the generated 
expressions will evaluate to the same type as the imported variable you 
chose to use.
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Select this option to have Survey Crafter Professional create or 
recreate the cookie, calculate a new value for it and send it to the 
respondent's browser only when the respondent's browser does not 
already have it.

• When the following is true:

Select this option to have Survey Crafter Professional create or 
recreate the cookie, calculate a new value for it and send it to the 
respondent's browser only when the expression you provide 
evaluates to TRUE.

Your expression must evaluate to either TRUE or FALSE for each 
respondent in your study's data set. For example, the expression 
A1_WhatIsYourGender = 'Male' evaluates to either TRUE or 
FALSE.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

11 Choose when you want the cookie to expire.

• On

Select this option to specify a date and time for the cookie to expire.

• In the following number of days after the cookie has been set

Tip Choose this option if you want to use this rule to have Survey Crafter 
Professional automatically identify respondents when they revisit your 
web survey. 

Tip It is considered good practice to have your cookies expire when they 
are no longer needed.
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Select this option to enter an expression that when evaluated will 
specify the number of days after the cookie has been set for the 
cookie to expire.

Your expression must evaluate to a quantity value. For example, the 
expression 200 evaluates to 200. The expression 
IF(UTCTIME_PART(1)=12,110,100) evaluates to 110 when the 
current month is December and 100, otherwise.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

12 Select the check box When the cookie is not set, get the cookie from 
the respondent's browser and assign its value to the imported variable 
if you want to assign the imported variable the value that the 
respondent's browser has for the cookie when Survey Crafter 
Professional does not calculate a new value for it.

13 If you want, enter a description for your rule.

For example, you might want to enter a description that will help you 
remember the purpose of your rule.

14 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

15 Repeat steps 2 through 14 until you are done.

Example If you enter 100, and on January 1, 2021 a respondent visits 
the page of your web survey that contains the block to which this rule 
attached and the cookie is set, the cookie will expire 100 days later, or 
on April 11, 2021. This means that the respondent's browser will delete 
its copy of the cookie the next time it is run on or after April 11, 2021.

Tip Select this check box if you want to use this rule to have Survey 
Crafter Professional automatically identify respondents when they 
revisit your web survey. Selecting this check box will have Survey 
Crafter Professional assign the imported variable either the cookie's 
newly calculated value that is sent to the respondent's browser or the 
value of the cookie the browser already has.
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16 Click on the Close button.

Adding custom data cleaning rules

In addition to using the built-in data cleaning rules, you can add your own 
rules that have Survey Crafter Professional mark an imported variable's 
response values unexpected in the Data window.

These rules are called custom data cleaning rules. You can add these kinds 
of rules to your study from either Survey Crafter Professional's Survey 
Designer window or Survey Crafter Professional's Data window.
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• To add custom data cleaning rules to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 73: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.
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2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 74: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
is only one type of custom data cleaning rule.

• Mark Variable Unexpected

When a condition is met, have Survey Crafter Professional mark an 
imported variable's value unexpected. Survey Crafter Professional 
colors unexpected values blue in the Data window.

4 Select the data set to which you want your rule to belong.

The drop down lists your study's data set.

The type of rule you 
choose determines 
the remaining 
options.
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5 Choose an imported variable.

Click on the Select button to choose an imported variable from a list 
of all of the imported variables in your study. Displays the Select 
Imported Variable dialog box.

6 Choose when you want Survey Crafter Professional to mark a value 
unexpected.

Choose the Always option to have Survey Crafter Professional mark 
all of the variable's values unexpected.

Choose the When the following condition is true to have Survey 
Crafter Professional mark a value unexpected when the expression 
you provide evaluates to TRUE.

Your expression must evaluate to either TRUE or FALSE for each 
respondent in your study's data set. For example, the expression 
A1_WhatIsYourGender = 'Male' evaluates to either TRUE or FALSE.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

7 If you want, enter a description for your rule.

For example, you might want to enter a description that will help you 
remember the purpose of your rule.

8 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

9 Repeat steps 2 through 8 until you are done.

10 Click on the Close button.

Adding custom commands

You can add rules directly to your web survey's configuration file.

These rules are called custom commands. You can add these kinds of 
rules to your study from either Survey Crafter Professional's Survey 
Designer window or Survey Crafter Professional's Data window. 
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• To add custom commands to your study

1 In the Survey Designer window, choose Custom Rules from Survey 
Crafter Professional's Block menu.

Alternatively, from the Data window, choose Custom Rules from 
Survey Crafter Professional's Edit menu.

Survey Crafter Professional displays the Custom Rules dialog box.
 

Figure 2 - 75: The Custom Rules dialog box.

Survey Crafter 
Professional lists all 
of the custom rules 
that belong to the 
selected rule group.



2 - 132 Surveys
Adding Custom Rules  
2 Click on the New button at the bottom of the Custom Rules dialog 
box.

Survey Crafter Professional displays the Custom Rule - New dialog 
box.
 

Figure 2 - 76: The Custom Rule - New dialog box.

3 Choose the type of rule you want to add to your study.

The type of rule you choose determines the remaining options. There 
is only one type of custom commands rule.

• After Web Page, Custom Commands

After respondents complete the page that contains question block 
A, have Survey Crafter Professional execute commands provided 
by Survey Crafter technical support.

The type of rule you 
choose determines 
the remaining 
options.
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4 Select the survey you want your rule to belong to.

The drop down lists all of the surveys in your study.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional display the currently selected survey in a 
Survey Designer window.

5 Choose when you want the commands to be executed.

Choose the After respondents complete each page option to have 
Survey Crafter Professional execute the commands after the 
respondent completes each page.

Choose the After respondents complete the web page that contains 
question block: option to have Survey Crafter Professional execute 
the commands after the respondent completes the page that contains 
the question block you select.

The drop down lists all of the blocks in the survey you selected under 
Survey.

Click on the Locate button to the right of the drop down to have 
Survey Crafter Professional highlight the currently selected block in 
the Survey Designer window.

6 Enter the commands to add to the configuration file.

You will receive commands from Survey Crafter technical support.

7 If you want, enter a description for your rule.

For example, you might want to enter a description that will help you 
remember the purpose of your rule.

8 Click on the OK button.

Survey Crafter Professional adds the new rule to the end of the list of 
rules in the Custom Rules dialog box.

9 Repeat steps 2 through 8 until you are done.

10 Click on the Close button.
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Custom branching, skipping and hiding rule 
issues

In Survey Crafter Professional, you can create custom rules that have 
your respondents automatically skip over and jump to any question block 
in your survey. However, you should be aware of the following issues.

Skipping over Question Blocks vs. Skipping over Pages 
on Web Surveys
When your survey is on the Web, each of your custom branching and 
skipping rules is enforced by either the web survey script or the 
respondent's browser, or both.

The web survey script will enforce custom branching and skipping rules 
that have respondents skip over pages whereas the respondent's browser 
will enforce these types of rules when respondents are to skip over 
question blocks on the same page.

When called upon, you can expect the web survey script to always 
enforce your custom branching and skipping rules. However, when called 
upon, you should anticipate the possibility that some of your respondents' 
browsers will not enforce these types of rules.

To have the respondent's browser enforce these types of rules, Survey 
Crafter Professional includes JavaScript code with your survey's HTML. 
The JavaScript code is responsible for directing the browser to disable 
form controls when the controls' corresponding question blocks are to be 
skipped. However, a respondent's browser will not disable form controls 
if it:

• does not support JavaScript 1.3 or later

• does not support disabling form controls 
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• supports JavaScript 1.3 or later but the feature has been turned off.

Blocks Used by Custom Hiding Rules that Live on the 
Same Page vs. on a Previous page
As with custom branching and skipping rules, when your survey is on the 
Web, each of your custom hiding rules is enforced by either the web 
survey script or the respondent's browser, or both.

The web survey script will enforce custom hiding rules when the block 
that determines which questions or prompts to hide is on a previous page 
whereas the respondent's browser will enforce these kinds of rules when 
the determining block is on the same page.

Example let's say you have a question that asks for the respondent's 
gender. Immediately following the question are two questions that are 
for males only. Following the two questions is a fourth question that is 
for all respondents. Let's also say that all four of these questions are on 
the same page. Further, you have added a custom branching rule that has 
respondents jump to the fourth question, skipping the two follow-up 
questions, when the respondents are not male.

In this case, your custom branching rule will be enforced by the 
respondent's browser. The browser should automatically disable the two 
follow-up questions when the male option is not selected for the gender 
question.

If you think some of your respondents use browsers that have JavaScript 
turned off, consider inserting a page break between the first and second 
question and also between the third and fourth question. Having the 
second and third questions on their own page will cause your custom 
branching rule to be enforced by the web survey script instead of the 
respondent's browser. 

In this case, when the male option is not selected for the gender question 
and the respondent clicks on your web survey's Next button, the page 
containing the second and third question will be skipped.
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When called upon, you can expect the web survey script to always 
enforce your custom hiding rules. However, when called upon, you 
should anticipate the possibility that some of your respondents' browsers 
will not enforce these types of rules.

To have the respondent's browser enforce these types of rules, Survey 
Crafter Professional includes JavaScript code with your survey's HTML. 
The JavaScript code is responsible for directing the browser to both hide 
and disable form controls when the controls' corresponding questions or 
prompts are to be hidden. However, a respondent's browser will not hide 
or disable form controls if it:

• does not support JavaScript 1.3 or later

• does not support disabling form controls

• supports JavaScript 1.3 or later but the feature has been turned off.

Custom Branching Rules that go Backward
Survey Crafter Professional web surveys support custom branching rules 
that go forward and backward whereas Survey Crafter Professional's 
built-in Interviewer only supports custom branching rules that go 
forward. Survey Crafter Professional's built-in Interviewer ignores 
custom branching rules that go backward.
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Inserting Survey Fields

There are two different types of fields you can insert in your survey: 
variable fields and calculated fields.

Use variable fields to redisplay answers to previous questions in your 
survey. Use calculated fields to display calculated values in your survey.

The sections below cover the following:

• Inserting variable fields

• Inserting calculated fields 

• Editing survey fields

• Copying and pasting survey fields 

• Removing survey fields 

• Survey fields on the Web 

Inserting variable fields

Use a variable field to redisplay the answer to a previous question in your 
survey. You can also use a variable field to display the value of an 
imported variable not associated with any question in your survey.

Variable fields function only when your survey is on the Web or in the 
built-in Interviewer.

Note When your survey is on the Web, survey fields are by default 
updated by both the web survey script and the respondent’s browser. If 
you do not want JavaScript in your web survey’s HTML files, you can 
configure your survey to have only the web survey script update survey 
fields.

For more information, see section “Survey fields on the Web” on page 
2 - 148.
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• To insert a variable field

1 In the Survey Designer window, move the cursor to the location 
where you want Survey Crafter Professional to display the current 
value of an imported variable and choose Field from Survey Crafter 
Professional's Insert menu.

Alternatively, right-click at the location and choose Insert Field from 
the pop-up menu.

Survey Crafter Professional displays the Survey Field dialog box.
 

Figure 2 - 77: The Survey Field dialog box.

2 Choose Variable Value under Field Type.

Enter the name of 
the imported variable 
the current value of 
which you want 
Survey Crafter 
Professional to 
display.
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3 Under Display the value of the imported variable, enter the name of 
the imported variable the current value of which you want Survey 
Crafter Professional to display.

If you do not know the name of the variable, click on the Select 
button.

The following table shows what Survey Crafter Professional displays 
for each of the different types of imported variables.

4 If you want, under Text to display in the Survey Designer window, 
enter the text you would like to see in the gray area that represents the 
survey field in the Survey Designer window.

The text that you see in the Survey Designer window is not what 
respondents will see when the survey is on the Web or in the built-in 
Interviewer. What the respondents will see is instead the current value 

Table 2 - 7: What Survey Crafter Professional displays for each of the different types of variables.

The Variable's type and
configuration

What Survey Crafter Professional displays

Category variable If the variable is associated with a closed-end question block, 
Survey Crafter Professional displays the prompt that 
corresponds to the variable's current value.

Otherwise, Survey Crafter Professional displays the category 
prompt that corresponds to the variable's current value.

Quantity variable with 
scale points

If the variable is associated with a rating question block, 
Survey Crafter Professional displays the prompt that 
corresponds to the variable's current numeric value.

Otherwise, Survey Crafter Professional displays the scale 
label that corresponds to the variable's current numeric value.

Quantity variable without 
scale points

The variable's current numeric value.

Literal variable The variable's current literal value.

If you want Survey Crafter Professional to limit the number 
of characters displayed, consider the Computed Value field 
type, using the LEFT function in your expression.
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of the selected variable. The text Survey Crafter Professional or you 
enter here should help you understand the purpose of the survey field 
when you see it in the Survey Designer window.

If you do nothing, Survey Crafter Professional will automatically 
enter the name of the selected variable. If you want, you can enter 
your own text instead. To have Survey Crafter Professional enter the 
name again, clear the contents of the box.

5 If you want, under Description, enter a description for your survey 
field.

For example, you might want to enter a description that will help you 
remember the purpose of your field.

6 Click on the OK button.

Survey Crafter Professional inserts the new survey field at the current 
location in the Survey Designer window.

The new survey field also appears in the Fields tab of the Survey 
Explorer toolbar.

Inserting calculated fields

Use a calculated field to display a calculated value in your survey.

Calculated fields function only when your survey is on the Web or in the 
built-in Interviewer.

Note When your survey is on the Web, survey fields are by default 
updated by both the web survey script and the respondent’s browser. If 
you do not want JavaScript in your web survey’s HTML files, you can 
configure your survey to have only the web survey script update survey 
fields.

For more information, see section “Survey fields on the Web” on page 
2 - 148.
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• To insert a calculated field

1 In the Survey Designer window, move the cursor to the location 
where you want Survey Crafter Professional to display the calculated 
value and choose Field from Survey Crafter Professional's Insert 
menu.

Alternatively, right-click at the location and choose Insert Field from 
the pop-up menu.

Survey Crafter Professional displays the Survey Field dialog box.
 

Figure 2 - 78: The Survey Field dialog box.

2 Choose Computed Value under Field Type.

3 Under Display the result of evaluating the expression, enter an 
expression that will evaluate to a category, quantity or literal value.

To get help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

Enter an expression 
that will evaluate to a 
category, quantity or 
literal value.



2 - 142 Surveys
Inserting Survey Fields  
4 If you want, under Text to display in the Survey Designer window, 
enter the text you would like to see in the gray area that represents the 
survey field in the Survey Designer window.

The text that you see in the Survey Designer window is not what 
respondents will see when the survey is on the Web or in the built-in 
Interviewer. What the respondents will see is instead the result of 
evaluating the expression. The text Survey Crafter Professional or 
you enter here should help you understand the purpose of the survey 
field when you see it in the Survey Designer window.

If you do nothing, Survey Crafter Professional will automatically 
enter a shortened version of the expression. If you want, you can enter 
your own text instead. To have Survey Crafter Professional 
automatically enter a shortened version of the expression again, clear 
the contents of the box.

5 If you want, under Description, enter a description for your survey 
field.

For example, you might want to enter a description that will help you 
remember the purpose of your field.

6 Click on the OK button.

Survey Crafter Professional inserts the new survey field at the current 
location in the Survey Designer window.

The new survey field also appears in the Fields tab of the Survey 
Explorer toolbar.

Editing survey fields

You can change the settings of a survey field at any time.
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• To edit a survey field (method 1)

1 In the Survey Designer window, double-click on the survey field.

Alternatively, right-click on the survey field and choose Edit Field 
from the pop-up menu.

Survey Crafter Professional displays the Survey Field dialog box.
 

Figure 2 - 79: The Survey Field dialog box.

2 Change any of the field's settings.

3 Click on the OK button.

Survey Crafter Professional updates the survey field in the Survey 
Designer window.

Note if the Field Type drop-down, variable name box and expression 
box are disabled or read-only, the field must have been generated and is 
now being managed by a Survey Crafter Professional component such 
as the Question Block Wizard. For example, when the option to display 
running totals is selected for a block's constant sum questions, the 
Question Block wizard generates and manages a survey field for each 
constant sum question in the block.

Change any of the 
field’s settings.
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• To edit a survey field (method 2)

1 Click on the Fields tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, double-click on the survey field.

Alternatively, right-click on the survey field and choose Edit Field 
from the pop-up menu.

Survey Crafter Professional displays the Survey Field dialog box.
 

Figure 2 - 80: The Survey Field dialog box.

3 Change any of the field's settings.

Note if the Field Type drop-down, variable name box and expression 
box are disabled or read-only, the field must have been generated and is 
now being managed by a Survey Crafter Professional component such 
as the Question Block Wizard. For example, when the option to display 
running totals is selected for a block's constant sum questions, the 
Question Block wizard generates and manages a survey field for each 
constant sum question in the block.

Change any of the 
field’s settings.
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4 Click on the OK button.

Survey Crafter Professional updates the survey field in the Survey 
Designer window.

Copying and pasting survey fields

You can paste any number of copies of a survey field in your survey. You 
can also move a survey field from one location to another.

• To copy a survey field (method 1)

1 In the Survey Designer window, right-click on the survey field you 
want to copy and choose Copy Field from the pop-up menu.

2 Right-click on the location where you want to paste a copy of the 
survey field and choose Paste from the pop-up menu.

Survey Crafter Professional inserts a copy of the field at the new 
location in the Survey Designer window.

The new survey field also appears in the Fields tab of the Survey 
Explorer toolbar.

• To copy a survey field (method 2)

1 Click on the Fields tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the survey field you 
want to copy and choose Copy Field from the pop-up menu.

3 In the Survey Designer window, right-click on the location where you 
want to paste a copy of the survey field and choose Paste from the 
pop-up menu.

Survey Crafter Professional inserts a copy of the field at the new 
location in the Survey Designer window.

The new survey field also appears in the Fields tab of the Survey 
Explorer toolbar.
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• To move a survey field (method 1)

1 In the Survey Designer window, right-click on the survey field you 
want to move and choose Cut Field from the pop-up menu.

Survey Crafter Professional removes the field from the Survey 
Designer window.

2 Right-click on the location where you want to move the survey field 
and choose Paste from the pop-up menu.

Survey Crafter Professional inserts the field at the new location in the 
Survey Designer window.

• To move a survey field (method 2)

1 Click on the Fields tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the survey field you 
want to move and choose Cut Field from the pop-up menu.

3 In the Survey Designer window, right-click on the location where you 
want to move the survey field and choose Paste from the pop-up 
menu.

Survey Crafter Professional inserts the field at the new location in the 
Survey Designer window.

• To copy or move a survey field by dragging and dropping (method 1)

1 In the Survey Designer window, right-click on the survey field you 
want to copy or move and choose Select Field from the pop-up menu.

Survey Crafter Professional highlights the field in the Survey 
Designer window.
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2 Click on the highlighted field, hold the left mouse button down and 
drag the mouse until the pointer is over the location where you want 
to insert a copy of or move the field.

If you want to copy the field, press and hold the [CTRL] key while 
you are dragging the mouse. Survey Crafter Professional displays a 
plus sign next to the pointer.

If you move the mouse pointer just below the top or just above the 
bottom of the Survey Designer window, Survey Crafter Professional 
will scroll the window.

3 Release the left mouse button.

Survey Crafter Professional inserts a copy of the field at or moves the 
field to the new location in the Survey Designer window.

4 If you were holding it down, release the [CTRL] key.

• To copy or move a survey field by dragging and dropping (method 2)

1 Click on the Fields tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, click on the survey field you want to 
move and hold the left mouse button down.

3 Drag the mouse pointer to the location where you want to move the 
field in the Survey Designer window.

If you want to copy the field, press and hold the [CTRL] key while 
you are dragging the mouse. Survey Crafter Professional displays a 
plus sign next to the pointer.

If you move the mouse pointer just below the top or just above the 
bottom of the Survey Designer window, Survey Crafter Professional 
will scroll the window.

4 Release the left mouse button.

Survey Crafter Professional inserts a copy of the field at or moves the 
field to the new location in the Survey Designer window.

5 If you were holding it down, release the [CTRL] key.
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Removing survey fields

You can remove a survey field at any time.

• To remove a survey field (method 1)

1 In the Survey Designer window, right-click on the survey field you 
want to remove and choose Delete Field from the pop-up menu.

Survey Crafter Professional removes the field from the Survey 
Designer window.

• To remove a survey field (method 2)

1 Click on the Fields tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the survey field you 
want to remove and choose Delete Field from the pop-up menu.

Survey Crafter Professional removes the field from the Survey 
Designer window.

Survey fields on the Web

In Survey Crafter Professional, you can insert any number of survey 
fields almost anywhere in your survey

Survey Fields in the Built-In Interviewer
In the built-in Interviewer, survey fields on the current page are updated 
immediately when answers to questions change. For example, when a 
variable field is on the same page as the question with which its variable 
is associated, the built-in Interviewer immediately updates the field with 
the latest value as the answer to the question is typed or selected.
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Survey Fields in a Web Survey
When your survey is on the Web, survey fields are by default updated by 
both the web survey script and the respondent's browser. The web survey 
script updates survey fields with the latest values before the page is shown 
to the respondent and the respondent's browser updates survey fields with 
the latest values as the respondent answers questions on the page.

If you do not want JavaScript in your web survey's HTML files, you can 
configure your survey to have only the web survey script update survey 
fields. If you configure your web survey this way, you will also need to 
arrange your survey fields so the web survey script has an opportunity to 
update the fields before they are shown to the respondent. To do this, you 
will need to do one or both of the following:

• Make sure each survey field lives on a page that follows the pages that 
contain the questions with which the field's source variable(s) are 
associated. To do this, you will need to insert page breaks in your 
survey. See “Inserting Page Breaks” on page 2 - 189.

• If a survey field is on the first page, use the uniform resource locator 
(URL) that has the web survey script start your survey. The Readme.txt 
file that Survey Crafter Professional generates when you publish your 
survey's web files lists this URL.
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Editing Survey Questions

You can make changes to your survey at any time. For example, you can 
rewrite and rearrange the questions that make up your survey. The 
sections below cover the following:

• Editing Survey Questions and Text

• Editing and Rearranging Prompts 

• Editing Variables Associated with Question Blocks

• Copying and Cutting Survey Questions and Text

• Pasting Survey Questions and Text

• Dragging and Dropping Survey Questions and Text

• Deleting Survey Questions and Text

• Checking Spelling in Surveys

• Requiring Answers to your Survey’s Questions

Editing Survey Questions and Text 

You can change anything that is either outside a survey block or inside an 
instructions-only block directly in the Survey Designer window. You can 
also change some components of a survey question block directly in the 
Survey Designer window. To change most components of a survey 
question block, however, you will need to use the Question Block Wizard.

Follow the procedure below to make changes to a survey question block.
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• To make changes to a survey question block

1 In the Survey Designer window, move the cursor inside the block you 
want to change.

Figure 2 - 81: The Survey Designer window.

2 Try to make your changes directly in the cells of the block.

Survey Crafter Professional may prevent you from typing over some 
areas in the block. For example, if you chose to have a list supply the 
prompts, Survey Crafter Professional will prevent you from typing 
over the prompts in the Survey Designer window. You can, however, 
change the prompts' formatting using the formatting toolbar and the 
Format menu.

You may be 
able to make 
your changes 
directly in the 
cells of the 
block
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3 If Survey Crafter Professional prevents you from making your 
changes to the block in the Survey Designer window or you want to 
change the configuration or layout options of the block, click the right 
mouse button and choose Edit Block from the pop-up menu or click 
on the Edit Block button on the toolbar.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 82: The Type tab of the Question Block Wizard dialog box.

4 If you want to add or remove the block number to or from the block, 
do one of the following:

• Select the Number check box to include an area in the block for the 
block number.

• Clear the Number check box to remove the area for the block 
number.

5 If you want to but cannot change the block number in the Survey 
Designer window, do one of the following:

• Clear the Automatic check box. Survey Crafter Professional will no 
longer automatically number the block for you, leaving you to 
change the block number yourself in the Survey Designer window.

Edit Block button

If you want, click on a 
picture to change the 
selected layout for the 
block.

If you want, click on the 
check boxes to change the 
optional components 
included in the block.

If you want, click on the 
drop down to change the 
block’s type.
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• Select the Restart at check box and enter a number in the following 
field.

6 If you want to but cannot change the questions or you want to change 
the number of questions in the question block, click on the Questions 
tab and do one of the following:
 

Figure 2 - 83: The Questions tab of the Question Block Wizard dialog box.

• If you want to type the questions directly in the Survey Designer 
window, choose I will type the questions in the Survey Designer 
window and enter the number of questions you want to include in 
the block. Enter a number between 1 and 255.

• If you want a list to supply the questions, choose A list will supply 
the questions and select a list from the drop down. If you cannot 
find the list you want or you want to make a change to the list, click 
on the button to the right of the drop down.

Choose this option to type 
your questions directly in 
the Survey Designer 
window.

Choose this option to use a 
list to supply the questions.

Click on 
this 
button to 
make 
changes 
to the 
selected 
list or 
any 
other list 
in the 
library.
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7 If you want to but cannot change the prompts or you want to change 
the number of prompts in the question block, click on the Prompts tab 
and do one of the following:
 

Figure 2 - 84: The Prompts tab of the Question Block Wizard dialog box.

• If you want to type the prompts directly in the Survey Designer 
window, choose I will type the prompts in the Survey Designer 
window and enter the number of prompts you want. Enter a number 
between 1 and 255.

• If you want a list to supply the prompts, choose A list will supply 
the prompts and select a list from the drop down. If you cannot find 
the list you want or you want to make a change to the list, click on 
the button to the right of the drop down.

8 Click on the Finish button.

Survey Crafter Professional updates the block in the Survey Designer 
window.

Choose this option to 
type your prompts 
directly in the Survey 
Designer window.

Choose this option to 
use a list to supply the 
prompts.

Click on 
this 
button to 
make 
changes 
to the 
selected 
list or 
any 
other list 
in the 
library.
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Editing and Rearranging Prompts

Closed-end, all-that-apply, rating, quantity, ranking and constant sum 
questions use prompts.

For example, the question in Figure 2 - 85 has five prompts.

Figure 2 - 85: An all-that-apply question’s prompts.

You can change, delete, and reorder a question’s prompts at any time.

Changing a Prompt
Change a prompt if, for example, you want the prompt “Broilin’ Bill’s” in 
Figure 2 - 85 to read “Broilin’ Bill’s Steak House.”

• To change a prompt

1 In the Survey Designer window, move the cursor inside the question 
block that contains the prompts you want to change.

2 If you chose to type the prompts in the Survey Designer window, type 
over the prompts. Otherwise, proceed with the next steps.

Which of the following fast food restaurants have you visited? 
(Check all that apply.)

o  Burger World

o  King Taco

o  Broilin’ Bill’s

o  The Chicken Coop

o  Marsha’s Mex

This question has 
five prompts.
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3 Choose Edit from the Block menu, click the right mouse button and 
choose Edit Block from the pop-up menu or click on the Edit Block 
button on the toolbar.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 86: The Type tab of the Question Block Wizard dialog box.

Edit Block button

If you want, click on a 
picture to change the 
selected layout for the 
block.

If you want, click on the 
check boxes to change the 
optional components 
included in the block.

If you want, click on the 
drop down to change the 
block’s type.
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4 Click on the Prompts tab of the Question Block Wizard dialog box.
 

Figure 2 - 87: The Prompts tab of the Question Block Wizard dialog box.

5 Do one of the following:

• If you want to type the prompts directly in the Survey Designer 
window, choose I will type the prompts in the Survey Designer 
window and enter the number of prompts you want. Enter a number 
between 1 and 255.

• If you want a list to supply the prompts, choose A list will supply 
the prompts and select a list from the drop down. If you cannot find 
the list you want or you want to make a change to the list, click on 
the button to the right of the drop down.

6 Click on the Finish button.

Survey Crafter Professional updates the block in the Survey Designer 
window.

7 If you chose I will type the prompts in the Survey Designer window in 
step 5, type over the prompts in the Survey Designer window.

Choose this option to 
type your prompts 
directly in the Survey 
Designer window.

Choose this option to 
use a list to supply the 
prompts.

Click on 
this 
button to 
make 
changes 
to the 
selected 
list or 
any 
other list 
in the 
library.



2 - 158 Surveys
Editing Survey Questions  
Deleting a Prompt
You can delete a prompt if you do not want the question to include the 
prompt anymore. For example, if you do not want the question in Figure 
2 - 85 to include the prompt “Marsha’s Mex.”

• To delete a prompt

1 In the Survey Designer window, move the cursor inside the question 
block that contains the prompt you want to delete.

2 If you chose to type the prompts in the Survey Designer window, 
copy and paste the prompts below the one you are going to delete. In 
a later step, you will change the number of prompts to include in the 
question block.

3 Choose Edit from the Block menu, click the right mouse button and 
choose Edit Block from the pop-up menu or click on the Edit Block 
button on the toolbar.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 88: The Type tab of the Question Block Wizard dialog box.

Edit Block button

If you want, click on a 
picture to change the 
selected layout for the 
block.

If you want, click on the 
check boxes to change the 
optional components 
included in the block.

If you want, click on the 
drop down to change the 
block’s type.
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4 Click on the Prompts tab of the Question Block Wizard dialog box.
 

Figure 2 - 89: The Prompts tab of the Question Block Wizard dialog box.

5 Do one of the following:

• If you want to type the prompts directly in the Survey Designer 
window, choose I will type the prompts in the Survey Designer 
window and enter the number of prompts you want. Enter a number 
between 1 and 255.

• If you want a list to supply the prompts, choose A list will supply 
the prompts and select a list from the drop down. If you cannot find 
the list you want or you want to make a change to the list, click on 
the button to the right of the drop down.

6 Click on the Finish button

Survey Crafter Professional updates the block in the Survey Designer 
window.

Choose this option to 
type your prompts 
directly in the Survey 
Designer window.

Choose this option to 
use a list to supply the 
prompts.

Click on 
this 
button to 
make 
changes 
to the 
selected 
list or 
any 
other list 
in the 
library.
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Rearranging Prompts
You can arrange a question’s prompt’s in any order.

Figure 2 - 90: Rearranging a question’s prompts.

• To rearrange the prompts in a question block

1 In the Survey Designer window, move the cursor inside the question 
block that contains the prompts you want to rearrange.

2 If you chose to type the prompts in the Survey Designer window, 
rearrange the prompts by copying and pasting the prompts. 
Otherwise, proceed with the next steps.

Which of the following fast food restaurants have you visited? 
(Check all that apply.)

o  Burger World

o  King Taco

o  Broilin’ Bill’s

o  The Chicken Coop

o  Marsha’s Mex

For example, you 
can move “The 
Chicken Coop” to the 
top of the list.
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3 Choose Edit from the Block menu, click the right mouse button and 
choose Edit Block from the pop-up menu or click on the Edit Block 
toolbar button.

Survey Crafter Professional displays the Type tab of the Question 
Block Wizard dialog box.
 

Figure 2 - 91: The Type tab of the Question Block Wizard dialog box.

Edit Block button

If you want, click on a 
picture to change the 
selected layout for the 
block.

If you want, click on the 
check boxes to change the 
optional components 
included in the block.

If you want, click on the 
drop down to change the 
block’s type.
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4 Click on the Prompts tab of the Question Block Wizard dialog box.
 

Figure 2 - 92: The Prompts tab of the Question Block Wizard dialog box.

5 Do one of the following:

• If you want to type the prompts directly in the Survey Designer 
window, choose I will type the prompts in the Survey Designer 
window and enter the number of prompts you want. Enter a number 
between 1 and 255.

• If you want a list to supply the prompts, choose A list will supply 
the prompts and select a list from the drop down. If you cannot find 
the list you want or you want to make a change to the list, click on 
the button to the right of the drop down. See List Library dialog 
box.

6 Click on the Finish button.

Survey Crafter Professional updates the question block in the Survey 
Designer window.

7 If you chose I will type the prompts in the Survey Designer window in 
step 5, rearrange the prompts by copying and pasting the prompts.

Choose this option to 
type your prompts 
directly in the Survey 
Designer window.

Choose this option to 
use a list to supply the 
prompts.

Click on 
this 
button to 
make 
changes 
to the 
selected 
list or 
any 
other list 
in the 
library.
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Editing Variables Associated with Question 
Blocks

You can change the settings of an imported variable associated with a 
question block. 

Survey Crafter Professional automatically updates the settings of the 
imported variables associated with a question block. If you want to 
override some of the variables’ settings, follow the steps below.

• To change the settings of an imported variable associated with a 
question block

1 In the Survey Designer window, move the cursor inside the block that 
contains the variable you want to edit.

Note The changes you can make to the imported variables associated 
with a question block are limited. For example, you can change the 
names, and descriptions of the variables. For more information, see the 
sections “Renaming a Variable” on page 6 - 50, and “Changing a 
Variable’s Description” on page 6 - 51.
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2 Choose Edit Survey/Block Variables from the Block menu or click 
the right mouse button and choose Edit Survey/Block Variables from 
the pop-up menu.

Survey Crafter Professional displays the Survey/Block Variables 
dialog box.
 

Figure 2 - 93: The Survey/Block Variables dialog box.

3 In the Survey/Block Variables dialog box, highlight the variable you 
want to edit.

4 To change the variable's name, code, description, question or prompt, 
do the following:

• Click on the Info button.

• Clear the Automatically Generate Variable Information check box.

• Change the Name, Code, Description, Question or Prompt.

By default, Survey 
Crafter 
Professional 
automatically 
assigns a name, 
code and 
description to each 
variable associated 
with the question 
block.
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• Click on the OK button.

Survey Crafter Professional may prevent you from changing the 
name of the variable. For example, Survey Crafter Professional 
prevents you from changing the name of a variable if the variable is 
used in an expression in an analysis table.

If you clear the Automatically Generate Variable Information check 
box, Survey Crafter Professional no longer automatically updates the 
variable's name, code, description, question or prompt.

5 To change other variable settings, do the following:

• Click on the Edit button.

• Edit the variable’s settings in the Variable dialog box.

• Click on the OK button.

Survey Crafter Professional may prevent you from making changes to 
the definition of the variable. For example, Survey Crafter 
Professional prevents you from adding or removing categories from 
an imported category variable used by a question block.

6 Click on the Close button.

Copying and Cutting Survey Questions and Text

To rearrange your survey's questions and stand-alone text, you may need 
to copy or move entire blocks.
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You can copy one or more blocks to the clipboard and then paste copies of 
the blocks elsewhere in your survey. You can also cut one or more blocks 
to the clipboard and then move the blocks by pasting them elsewhere in 
your survey.

You can also paste blocks into a word processor. For more, see the section 
“Exporting a Survey to a Word Processor” on page 2 - 190.

• To cut a block (method 1)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the block you want to 
cut and choose Cut Block from the pop-up menu.

Survey Crafter Professional removes the block from the survey and 
places it on the clipboard.

• To cut a block (method 2)

1 In the Survey Designer window, move the cursor inside the block you 
want to cut.

Survey Crafter Professional draws a border around the block.

Note When you cut a block to the clipboard, Survey Crafter Professional 
removes the block and places it on the clipboard. When it removes a 
question block, Survey Crafter Professional also removes the block's 
associated imported variables unless an analysis table or chart references 
the variables. When it removes a variable, Survey Crafter Professional 
also removes the custom rules and expressions in the Expression Library 
that reference the variable.

Because Survey Crafter Professional removes blocks that you cut to the 
clipboard, consider dragging and dropping instead of cutting blocks. To 
learn more about dragging and dropping blocks in the Survey Designer 
window, see the section “Dragging and Dropping Survey Questions and 
Text” on page 2 - 169.
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2 Right-click inside the block and choose Cut Block from the popup 
menu.

You can also choose Cut Block from the Block menu or right-click 
inside the block and choose Select Block and then click on the Cut 
button on the toolbar.

Survey Crafter Professional removes the block from the survey and 
places it on the clipboard.

• To copy a block (method 1)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the block you want to 
cut and choose Copy Block from the pop-up menu.

Survey Crafter Professional places a copy of the block on the 
clipboard.

• To copy a block (method 2)

1 In the Survey Designer window, move the cursor inside the block you 
want to copy.

Survey Crafter Professional draws a border around the block.

2 Right-click inside the block and choose Copy Block from the pop-up 
menu.

You can also choose Copy Block from the Block menu or right-click 
inside the block and choose Select Block and then click on the Copy 
button on the toolbar.

Survey Crafter Professional places a copy of the block on the 
clipboard.

• To copy all of the survey’s blocks

1 Select the Surveys tab of the Study window

2 Select the survey you want to copy and then click on the Edit button.

Survey Crafter Professional displays the Survey Designer window.

Cut button

Copy button
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3 From the Edit menu, choose Select All.

4 From the Edit menu, choose Copy or click the Copy button on the 
toolbar.

Survey Crafter Professional copies all information appearing in the 
Survey Designer window to the clipboard. Now you can paste the 
survey into a word processor for custom formatting and page layout. 
See the section “Exporting a Survey to a Word Processor” on page 
2 - 190.

Pasting Survey Questions and Text

Suppose you paste a question block whose variables are not associated 
with any other question block in the Survey Designer window. Not only 
does the newly pasted question block appear in the Survey Designer 
window exactly as when you copied or cut it, the block also uses exactly 
the same variables.

Suppose you copy a question block and then paste the question block 
back in the same Survey Designer window without deleting the original 
question block. The newly pasted question block appears in the Survey 
Designer window exactly as when you copied it. However, the new block 
uses new variables, since the original variables are still associated with 
the original question block.

Survey Crafter Professional creates new variables because a variable can 
be associated with at most one question block in the Survey Designer 
window.

• To paste a block (method 1)

1 In the Survey Designer window, move the cursor to a location where 
you want to insert the block on the clipboard.

Note  You can paste more than one block at a time in the Survey 
Designer window. You can also copy and paste blocks from one Survey 
Designer window to another. You can also copy and paste blocks from 
one study to another.

Copy button
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2 From the Edit menu, choose Paste or click on the Paste button on the 
toolbar.

• To paste a block (method 2)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the block before which 
you want to insert the block on the clipboard and choose Paste Block 
from the pop-up menu.

Survey Crafter Professional inserts the block at the position in the 
Survey Designer window immediately before the block that is under 
the mouse pointer.

Dragging and Dropping Survey Questions and 
Text

In addition to being able to copy and paste, you can also drag and drop 
blocks and text in the Survey Designer window. 

You can drag and drop blocks and text from one Survey Designer window 
into another Survey Designer window. You can also drag and drop blocks 
and text from the Survey Designer window into another application.

• To move or copy one block by dragging and dropping (method 1)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, click on the block you want to move 
or copy and hold the left mouse button down.

3 Drag the mouse pointer over another the block in the Survey Explorer 
toolbar.

Note Because Survey Crafter Professional deletes blocks that you cut to 
the clipboard, consider dragging and dropping instead of cutting blocks.

Paste button
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4 If you want to insert a copy of the block, press and hold down the 
[CTRL] key.

A plus sign below the mouse pointer indicates the block will be 
copied. If you do not see a plus sign below the mouse pointer, the 
block will be moved.

5 Release the left mouse button.

Survey Crafter Professional will move the block to or insert a copy of 
the block at the position in the Survey Designer window immediately 
before the block that is under the mouse pointer.

If you release the left mouse button when the mouse pointer is over 
another application, Survey Crafter Professional will insert the block 
as formatted text.

If you release the left mouse button when the mouse pointer is over a 
block in another Survey Designer window, Survey Crafter 
Professional will produce a copy of the block, even when you are not 
pressing the [CTRL] key.

6 If you are holding it down, release the [CTRL] key.

• To move or copy one block by dragging and dropping (method 2)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, click on the block you want to move 
or copy and hold the left mouse button down.

3 Drag the mouse pointer to the location in the Survey Designer 
window where you want to move the block or insert a copy of the 
block.

4 If you want to insert a copy of the block, press and hold down the 
[CTRL] key.

A plus sign below the mouse pointer indicates the block will be 
copied. If you do not see a plus sign below the mouse pointer, the 
block will be moved.
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5 Release the left mouse button.

Survey Crafter Professional will move the block to or insert a copy of 
the block where the mouse is pointing in the Survey Designer 
window. If the mouse is over another block, Survey Crafter 
Professional will move the block to or insert a copy of the block at the 
position immediately before the block.

If you release the left mouse button when the mouse pointer is over 
another application, Survey Crafter Professional will insert the block 
as formatted text.

If you release the left mouse button when the mouse pointer is over 
another Survey Designer window, Survey Crafter Professional will 
produce a copy of the block, even when you are not pressing the 
[CTRL] key.

6 If you are holding it down, release the [CTRL] key.

• To move or copy one block by dragging and dropping (method 3)

1 In the Survey Designer window, move the cursor inside the block you 
want to move or copy.

Survey Crafter Professional draws a border around the block.

2 Choose Select from the Block menu or click the right mouse button 
and choose Select Block from the pop-up menu.

You can also press and hold the [ALT] key and click the left mouse 
button inside the block you want to move or copy. Release both the 
[ALT] key and the left mouse button once the block has been 
highlighted.

3 If you want to move the block, press and hold the [ALT] key and click 
the left mouse button inside the highlighted block. If you want to 
copy the block, press and hold the [CTRL] key and click the left 
mouse button inside the highlighted block.
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4 Holding the left mouse button down, drag the mouse pointer to the 
location where you want to move or copy the block.

A plus sign below the mouse pointer indicates the block will be 
copied. If you do not see a plus sign below the mouse pointer, the 
block will be moved.

If you decide you want to copy instead of move the block, release the 
[ALT] key and press the [CTRL] key while continuing to hold the left 
mouse button down. If you decide to move instead of copy the block, 
release the [CTRL] key while continuing to hold the left mouse 
button down.

5 Release the left mouse button when the mouse pointer is over the 
location where you want to move or copy the block.

Survey Crafter Professional moves or copies the block.

If you release the left mouse button when the mouse pointer is over 
another application, Survey Crafter Professional will insert the block 
as formatted text.

If you release the left mouse button when the mouse pointer is over 
another Survey Designer window, Survey Crafter Professional will 
produce a copy of the block, even when you release the [CTRL] key.

• To move or copy highlighted areas by dragging and dropping

1 In the Survey Designer window, use the mouse to highlight the blocks 
and/or text you want to move or copy.

If you want to copy all of the blocks and text in the Survey Designer 
window, choose Select All from the Edit menu or press [CTRL-A].

If only a portion of a block is highlighted, Survey Crafter Professional 
will only move or copy the block's highlighted text. You must 
highlight a block in its entirety to move or copy the block.

2 If you want to move the highlighted area, press and hold the [ALT] 
key and click the left mouse button inside the highlighted area. If you 
want to copy the highlighted area, press and hold the [CTRL] key 
down and click the left mouse button inside the highlighted area.
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3 Holding the left mouse button down, drag the mouse pointer to the 
location where you want to move or copy the highlighted blocks and/
or text.

A plus sign below the mouse pointer indicates the highlighted area 
will be copied. If you do not see a plus sign below the mouse pointer, 
the highlighted area will be moved.

If you decide you want to copy instead of move the highlighted area, 
release the [ALT] key and press the [CTRL] key while continuing to 
hold the left mouse button down. If you decide to move instead of 
copy the highlighted area, release the [CTRL] key while continuing to 
hold the left mouse button down.

4 Release the left mouse button when the mouse pointer is over the 
location where you want to move or copy the highlighted area.

Survey Crafter Professional moves or copies the highlighted area.

If you release the left mouse button when the mouse pointer is over 
another application, Survey Crafter Professional will insert the 
highlighted area as formatted text.

If you release the left mouse button when the mouse pointer is over 
another Survey Designer window, Survey Crafter Professional will 
produce a copy of the highlighted area, even when you release the 
[CTRL] key.

Deleting Survey Questions and Text

To delete stand-alone text like a title or introduction, highlight the text in 
the Survey Designer window and choose Clear from the Edit menu or 
press the [Del] key.

To delete a question or text inside a question or instructions-only block, 
you may need to delete the block containing it. When you delete a 
question block, Survey Crafter Professional automatically removes the 
block's associated imported variable(s) from the study if no other part of 
the study references the variables. When it removes a variable, Survey 
Crafter Professional also removes the custom rules and expressions in the 
Expression Library that reference the variable.
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• To delete a question or instructions-only block (method 1)

1 In the Survey Designer window, move the cursor inside the block you 
want to delete.

2 Right-click inside the block and choose Delete Block from the pop-up 
menu.

Survey Crafter Professional removes the block from the Survey 
Designer window. If no other part of the study references the block's 
associated imported variable(s), Survey Crafter Professional 
automatically removes the variables. When it removes a variable, 
Survey Crafter Professional also removes the custom rules and 
expressions in the Expression Library that reference the variable.

• To delete a question or instructions-only block (method 2)

1 Click on the Blocks tab of the Survey Explorer toolbar.

If the Survey Explorer toolbar is not visible, click on the View menu, 
Toolbars and then on Survey Explorer.

2 In the Survey Explorer toolbar, right-click on the block you want to 
remove and choose Delete Block from the pop-up menu.

Survey Crafter Professional removes the block from the Survey 
Designer window. If no other part of the study references the block's 
associated imported variable(s), Survey Crafter Professional 
automatically removes the variables. When it removes a variable, 
Survey Crafter Professional also removes the custom rules and 
expressions in the Expression Library that reference the variable.

Checking Spelling in Surveys

To check a survey's spelling, click on the Check Spelling button on the 
toolbar or choose Spelling from the Edit menu.

You can also export the entire survey to a word processor. For help on 
exporting surveys, see the section “Exporting Surveys to Word 
Processors” on page 2 - 190.

• To check spelling in a survey

1 Select the Surveys tab of the Study window.
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2 Select the survey you want to check and then click on the Edit button 
on the tab.

3 From the Edit menu, choose Spelling or click on the Check Spelling 
button on the toolbar.

Follow the instructions on the screen.

Requiring Answers to your Survey’s Questions

You can require answers to your survey's questions. If an answer to a 
question is required, Survey Crafter Professional notifies the respondent 
when he or she has not answered the question. You can also instruct 
Survey Crafter Professional to not allow the respondent to continue until 
the question has been answered.

• To require an anwer to a question

1 In the Survey Designer window, move the cursor inside the question 
block you want to make required.

2 Choose Edit from the Block menu or click the right mouse button and 
choose Edit Block from the pop-up menu.

You can also click the Edit Block button on the toolbar.

3 Click on the tab that corresponds to the type of question an answer to 
which you want to require.

For example, if you want to require answers to the closed-end 
question(s) in the block, click on the Closed-End tab.

Check Spelling button

Edit Block button
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4 Follow the instructions on the screen.
 

Figure 2 - 94: The Closed-End tab of the Question Block Wizard dialog box.

5 Click on the Finish button.

Select this option to 
force respondents to 
answer the question.

Select this option to 
allow respondents to 
continue even if the 
questions are not 
answered.
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Changing a Survey’s Language Settings

You can at any time change the spelling dictionary used in the Survey 
Designer window as well as the language package assigned to your 
survey. The sections below cover the following:

• Changing a Survey’s Spelling Dictionary

• Changing a Survey’s Language Package

Changing a Survey’s Spelling Dictionary

You can at any time change the spelling dictionary used in the Survey 
Designer window.

• To change a survey’s spelling dictionary

1 Select the Surveys tab of the Study window.

2 Double-click on the survey you are working on or click on the survey 
and then on the Edit button on the tab.

3 From the View menu, choose Survey Options.
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4 Click on the Language tab of the Survey Options dialog box.

5 Click on the drop down under Spelling Dictionary and choose the 
dictionary you want to use.

To add a new spelling dictionary or to remove or edit an existing 
spelling dictionary, click on the button to the right of the drop down.

If the spelling dictionary you want to use is not installed, use the 
Modify feature of the Survey Crafter Professional installation 
program, available from the Add/Remove Programs application of 
the Control Panel, to install the dictionary.

6 Select the check box Spell-checking as you type to have Survey 
Crafter Professional check the spelling as you type in the Survey 
Designer window.

7 Click on the Finish button.

Click on the drop 
down and choose the 
dictionary you want 
to use.

Select this check box 
to have Survey 
Crafter Professional 
check the spelling as 
you type in the 
Survey Designer 
window.

Click on this button 
to visit the Spell 
Dictionaries dialog 
box.
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Changing a Survey’s Language Package

A language package is a named collection of translations of built-in 
messages, headings and labels. Every Survey Crafter Professional survey 
is assigned a language package. The language package provides the 
words on the survey’s navigation buttons as well as in the survey’s 
informational headings and built-in error messages and warning 
messages.

You can at any time change the language package assigned to your 
survey.

• To change a survey’s language package

1 Select the Surveys tab of the Study window.

2 Double-click on the survey you are working on or click on the survey 
and then on the Edit button on the tab.

3 From the View menu, choose Survey Options.

4 Click on the Language tab of the Survey Options dialog box.

Click on the drop 
down and choose the 
language package 
you want your survey 
to use.

Select this check box 
to have Survey 
Crafter Professional 
replace messages, 
headings and labels 
that you modified 
with the defaults from 
the new language 
package.

Click on this button 
to visit the Language 
Package Library 
dialog box.
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5 Click on the drop down under Language Package and choose the 
language package you want your survey to use.

To add a new language package or to remove or edit an existing one, 
click on the button to the right of the drop down.

6 If you changed the selected language package, select the check box 
Apply the language package to messages, headings and labels that 
you modified to have Survey Crafter Professional replace messages, 
headings and labels that you modified with the defaults from the new 
language package.

7 Click on the Finish button.

Example Suppose your survey has a closed-end question with a box for 
respondents to enter a description for a prompt you labeled "other". Let's 
say you configured the question to require respondents to enter a 
description when "other" is selected and you modified the default error 
message. If you change the language package and select this check box, 
Survey Crafter Professional will replace your modified error message 
with the default error message from the new language package. If you 
change the language package but do not select this check box, your error 
message will remain unchanged.
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Changing How a Survey Looks

You can apply block styles to question blocks in the Survey Designer 
window. You can also change the font, point size, and style of the text in a 
survey question block or instructions-only block. The sections below 
cover the following: 

• Applying Block Styles to Survey Questions

• Changing the Survey Designer Window Display

• Formatting Survey Text

• Changing Web Survey Input Fields

• Inserting Page Breaks

Applying Block Styles to Survey Questions

You can all at once change the borders, shading and background colors of 
the cells in a block in the Survey Designer window by applying a block 
style to the block.

You can also create your own block styles and apply them to any number 
of blocks in the Survey Designer window.

Even after you have applied a block style to a block, you can still change 
the border, shading and background color settings of the cells in the block. 
You can always reapply the block style if you want to restore the settings.

You can also reapply all block styles to all subscribing blocks by clicking 
on the Reapply All button on the Block Style Library dialog box.

• To apply your block style to one or more blocks

1 In the Survey Designer window, highlight the blocks to which you 
want to apply your block style.

To highlight all blocks in the Survey Designer window, choose Select 
All from the Edit menu or press [Ctrl-A].
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2 If your block style has already been defined, choose your block style 
from the drop down list on the Survey Designer window's formatting 
toolbar.

Choose "None" to unsubscribe the highlighted blocks from all block 
styles.

3 If your block style has not yet been defined or you want to change the 
settings of your block style, choose Style from the Block menu.

Survey Crafter Professional displays the Block Style Library dialog 
box.

Figure 2 - 95: The Block Style Library dialog box.

Lists all of the block 
styles in the current 
study.
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4 If you want to add a new block style to the library, click on the New 
button below the list of block styles.

Survey Crafter Professional displays the Block Style dialog box.

Figure 2 - 96: The Block Style dialog box.

To read about your new block style's settings, click on the Help button 
or press the F1 key.

Click on the OK button when you are done.

5 If you want to change the settings of an existing block style, double-
click on the block style.

Survey Crafter Professional displays the Block Style dialog box.

To read about the block style's settings, click on the Help button or 
press the F1 key.

Click on the OK button when you are done.

Specify the formatting 
options for the block 
style.
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6 Click on the block style you want to apply to the highlighted blocks 
and click on the Select button.

Survey Crafter Professional changes the appearance of the 
highlighted blocks in the Survey Designer window according to the 
settings of the selected block style.

Changing the Survey Designer Window Display

You can show and hide several block components in the Survey Designer 
window. For example, you can show or hide variable names and variable 
codes in the Survey Designer window.

Changes you make to the Survey Designer window apply to all of the 
blocks in the currently displayed survey. Figure 2 - 97 shows the block 
components you can hide.

Figure 2 - 97: Block components you can hide by using the Survey Options command.

Variable 
name and 
code

Variable 
notes
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The procedure below does not cover how to format survey text. For 
instructions on formatting, see the section “Formatting Survey Text” on 
page 2 - 186.

• To change the Survey Designer window display

1 Select the Surveys tab of the Study window.

2 Select the survey you want to display and then click on the Edit 
button on the tab.

3 From the View menu, choose Survey Options.

4 In the General tab of the Survey Options dialog box, select or clear 
the check boxes corresponding to the information you want to show 
or hide.

Each check box applies to the entire survey. For a description of the 
check boxes, click on the Help button.

Figure 2 - 98: The General tab of the Survey Options dialog box.

To display the block 
component, select its 
check box.
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5 Click on the Finish button.

Survey Crafter Professional changes the Survey Designer window 
display. Note that the survey prints exactly as it appears in the Survey 
Designer window.

Formatting Survey Text

You can change the font, point size, style, spacing, foreground color and 
background color of text in the Survey Designer window. For example, 
use bold to set off important instructions or a large point size for the 
survey's title.

• To format survey text

1 In the Survey Designer window, highlight the text you want to format.

2 Choose Character from the Format menu.

Tip  You can also set the font, size, and style for text you have not yet 
typed. Select the options you want on the Formatting toolbar and start 
typing.
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3 Select the options you want for the highlighted text.

Figure 2 - 99: The Format Character dialog box.

4 Click on the Finish button.

Changing Web Survey Input Fields

You can change the input fields Survey Crafter Professional uses when it 
generates web survey files. For example, you can choose to have Survey 
Crafter Professional use a drop down list instead of radio buttons for a 
closed-end question block.

• To change web survey input fields

1 Select the Surveys tab of the Study window.

2 Select the survey you want to change and then click on the Edit 
button on the tab.

3 Choose Web Layout from the View menu.

Choose the font, font 
style and size for the 
highlighted text.

Displays sample text 
with the currently 
selected options.

Choose the foreground 
and background color of 
the highlighted text.

Choose the effects you 
want for the highlighted 
text.
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4 Move the cursor inside the block you want to change and choose Edit 
from the Block menu or click the right mouse button and choose Edit 
Block from the pop-up menu.

5 In the Type tab, choose the layout that uses the input fields you want 
for the block.
.

Figure 2 - 100: The Type tab of the Question Block Wizard dialog box.

6 If Survey Crafter Professional displays the Prompts tab, click on the 
Prompts tab and select the options you want for the prompts.

7 Click on the Finish button.

Edit Block button

This block layout 
features a single 
selection list. Choose a 
size of 1 in the Prompts 
tab to display the list as 
a drop down.

We are editing a block 
for 1 closed-end 
question.
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Inserting Page Breaks

You can insert page breaks to override Survey Crafter Professional's 
automatic page break calculations when printing. You can also use page 
breaks to define the pages Survey Crafter Professional creates when it 
generates web survey HTML pages or when it displays the survey in the 
built-in Interviewer.

• To insert a page break

1 In the Survey Designer window, move the cursor to the location 
where you want to insert the page break.

2 Choose Page Break from the Insert menu.
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Exporting a Survey

To enhance a survey’s format, you can export a survey to a word 
processor or to a file. The exported survey contains only the information 
appearing in the Survey Designer window.

Exporting a Survey to a Word Processor

You can export an entire survey or individual survey blocks.

• To export an entire survey to a word processor

1 Select the Surveys tab of the Study window.

2 Select the survey you want to copy and then click on the Edit button 
on the tab.

3 From the Edit menu, choose Select All to highlight the entire survey.

4 From the Edit menu, choose Copy to transfer the entire survey to the 
clipboard.

5 Open the word processor and the document you want to paste the 
survey into.

6 Paste the survey into the document.

• To export one block to a word processor

1 Select the Surveys tab of the Study window.

2 Select the survey from which you want to copy and then click on the 
Edit button on the tab.

3 In the Survey Designer window, move the cursor inside the block you 
want to transfer to a word processor.

Note You can also copy text from a word processor and paste it into the 
Survey Designer window.
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4 Choose Copy Block from the Block menu or click the right mouse 
button and choose Copy Block from the pop-up menu.

You can also choose Select from the Block menu or click the right 
mouse button and choose Select Block from the pop-up menu and 
then click the Copy button on the toolbar.

5 Open the word processor document you want to paste the block into.

6 Paste the block into the document.

Exporting a Survey to a File

To enhance a survey's format or to publish the survey in another format, 
you can export a survey to a file. The exported survey contains only the 
information that appears in the Survey Designer window. 

You can export a survey to the following types of files:

• HyperText Markup Language (HTML) file

• Rich Text Format (RTF) file

• Text file

• To export a survey to a file

1 Select the Surveys tab of the Study window.

2 Select the survey you want to export and then click on the Edit button.

3 From the File menu, choose Export.

Survey Crafter Professional displays the Save Survey File As dialog 
box. 

4 From the Files of Type drop-down list, select the type of file you want 
to save.

Note  If you want to export a survey to an HTML file, you may want 
to review the web survey HTML option settings in the Web Survey 
Setup dialog box. Survey Crafter Professional uses these settings 
when it exports a survey to an HTML file.

Copy button
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5 From the Locations (Save in) drop-down list, choose the location to 
save the file.

6 In the Folders list, select the folder in which you want to save the file.

7 In the File name field, type the name of the file to save.

8 Click on the Save button.
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After creating your survey in Survey Crafter Professional, you can 
publish the survey on the World Wide Web, interview respondents 
yourself, have respondents complete the survey on their own, or contract 
a market research supplier to conduct interviews for you. 

Before you can analyze a set of survey responses, you need to add the 
data to the Survey Crafter Professional study. If you are interviewing 
respondents yourself, you can add their responses using Survey Crafter 
Professional’s built-in Interviewer. If you published your survey on the 
World Wide Web, you can import the web survey’s data into the study. If a 
market research supplier interviewed respondents, you can import the 
data the supplier returns into the study. Once the data is in the study, you 
can edit it to prepare it for analysis. 

This chapter explains how to enter, import, edit, and export data sets. It 
also explains how to customize the Data window display. Read the section 
“Data Basics” first to learn key concepts about working with a study’s 
data set.

Chapter Contents

• Data Basics  3 - 3

• Opening a Study’s Data Set  3 - 10

• Entering Respondents’ Replies  3 - 11

• Importing Data Sets  3 - 21

• Isolating Errors in Data Sets  3 - 30

• Editing Data Sets  3 - 33

• Weighting Data  3 - 48

• Exporting Data Sets  3 - 51
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Data Basics

The study’s data set is comprised of values stored in variables. It includes 
variables with values you enter or import into the study (imported 
variables) and variables with values you calculate in Survey Crafter 
Professional (computed variables). 

This section describes features of the Data window.

About the Data Window

Figure 3 - 1 shows a data set in the Data window.

Figure 3 - 1: A data set in the Data window.

Row 
selectors

Column 
selectors

Each row is 
called a 
record. 
Each record 
contains 
data from a 
different 
respondent.

There are 
779 records 
in this data 
set.
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Each row in a data set is called a record. Each record contains data from a 
different respondent. Select an entire record by clicking on a row selector. 
Each column in a data set contains the values in one of the study’s 
variables. The variable’s name and code appears at the top of the column. 
Select an entire variable by clicking on a column selector.

When the Data window is active, you can use commands on the Edit, 
View and Interviewer menus to modify the window’s display and edit 
variables’ values 

Records Appearing in the Data Window

You can display all or a portion of the data set’s records. For example, you 
could choose to view only those records for respondents who heard about 
your company on the radio.

Figure 3 - 2: A filtered data set in the Data window.

The filter 
expression 
is 
gen_publicit
y=’radio’

Only those 
respondents 
for whom the 
filter 
expression 
evaluates to 
TRUE 
appear in 
the Data 
window.
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To filter the records appearing in the Data window, choose the Edit Filter 
command from the Edit menu. Then use the Expression Builder to write 
an expression that evaluates to TRUE or FALSE for each respondent in 
the data set. For example, gen_publicity=’radio’.

Records of respondents for whom the expression evaluates to TRUE 
appear in the Data window. The Data window’s Filter field shows the 
expression applied to the data set’s records. When no expression appears 
in this field, all records are displayed. 

For instructions on showing selected records in the Data window, see 
“Changing the Number of Records Displayed in the Data Window” on 
page 3 - 54.

Values Appearing in the Data Window

Each variable’s column may contain one of three types of values:  
categories, quantities, or literals (text). Category, quantity, and literal 
variables’ cells may also contain the value NV. NV (No Value) indicates 
that the record contains no value for the variable. For example, if the 
respondent was not asked a particular question, the question’s variable 
would contain NV. In addition, category and quantity variables’ cells may 
contain the value NR. NR (No Reply) indicates that the respondent was 
asked the question with which the variable is associated but refused to 
answer.

A computed variable’s values may all appear as NV. If this is the case, it is 
likely that Survey Crafter Professional has not yet calculated the 
variable’s values. To calculate the variable’s values, make the Data 
window the active window and then choose the Update command from 
the Edit menu.
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Color Coding in the Data Window

Survey Crafter Professional uses color coding to indicate the status of 
values in the Data window. Imported variables’ values appear in black, 
blue and red. Computed variables’ values appear in gray. See Table 3 - 1 
for more information on the color codes shown in the Data window’s Key.

Table 3 - 1: Color coding applied to values in the Data window. 

Color Meaning Description

Black Acceptable The value is acceptable because:

• its type matches the type of the imported variable that stores the 
value. For example, the value is a number and is stored in a quantity 
variable.

• it meets the specifications of the imported variable that stores the 
value. For example, the number is within the range of values 
specified in the definition of the quantity variable.

• it passes all of the custom data cleaning rules you assigned to the 
imported variable that stores the value. To add or modify your own 
data cleaning rules, see Chapter 2, “Adding custom data cleaning 
rules,” page 2 - 127.

Survey Crafter Professional can perform analyses with this value.
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Blue Unexpected The value is unexpected because:

• it does not meet the specifications of the imported variable that stores 
the value.

• it failed to pass one or more custom data cleaning rules you assigned 
to the imported variable that stores the value.To add or modify your 
own data cleaning rules, see Chapter 2, “Adding custom data 
cleaning rules,” page 2 - 127.

If the column corresponds to a quantity variable, the number is less than 
the minimum or greater than the maximum value defined for the 
quantity variable or the number does not follow the rules of its 
associated ranking or constant sum question.

For example, if a quantity variable is associated with a ranking question 
and if it and none of the other variables associated with the ranking 
question have a value of 1 and at least one of the variables has a value 
such as 2, all quantity variables associated with the ranking question are 
marked unexpected. This is because one of the rules of a ranking 
question is that if a respondent answers the question, there must be 
exactly one 1 value -- a ranking may not start with a 2.

If the column corresponds to a category variable, the choice does not 
follow rules of its associated all-that-apply question.

For example, if a category variable is associated with an all-that-apply 
question and if at least one of the variables associated with the all-that-
apply question has a value of 'yes' or 'no' and the other variables have a 
value of 'NV' or 'NR', all category variables associated with the all-that-
apply question are marked unexpected.

Survey Crafter Professional can perform analyses with this value. The 
IS_UNEXPECTED( ) function returns TRUE for unexpected values.

Red Unreadable Survey Crafter Professional cannot interpret unreadable values. There 
are two cases in which values can be unreadable:

• A quantity variable receives a non-numeric value

• A category variable receives a code outside the range of acceptable 
codes

Survey Crafter Professional displays unreadable values in the Data 
window but interprets and displays these values as NV in expressions. 
The IS_UNREADABLE( ) function returns TRUE for unreadable 
values. The IS_MISSING( ) function returns TRUE for missing and 
unreadable values.

Table 3 - 1: Color coding applied to values in the Data window.  (Continued)

Color Meaning Description
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Often, not all of the responses in a data set match values you expected. 
Some responses may lie outside an acceptable range, or they might not 
match the kind of information the question was designed to capture. For 
example, a question might require a ‘yes’ or ‘no’ answer but one record 
shows the value 35 for that question. Survey Crafter Professional features 
a Data Error Log that flags erroneous values. You can edit these values or 
delete the record from the data set.

Figure 3 - 3: Using the Data Error Log to isolate unreadable values in the data set.

After editing data, you can have Survey Crafter Professional scan the data 
set again to check whether the values resulting from your changes meet 
the variables' specifications as well as pass your own custom data 

Gray Computed 
value

The value belongs to a computed variable. 

Table 3 - 1: Color coding applied to values in the Data window.  (Continued)

Color Meaning Description

Clicking on 
the Show 
button 
automatically 
sets the Data 
window’s filter 
to isolate the 
unreadable 
value.

The Data Error 
Log window 
shows there’s 
1 unreadable 
value in the 
gen_company
size column.
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cleaning rules. To have Survey Crafter Professional scan the data set 
again, choose Update from the Edit menu. For more instructions, see 
“Flagging Errors in Data Sets” on page 3 - 41.

You can add your own custom data cleaning rules to your study from 
either the Survey Designer window or the Data window. For step-by-step 
instructions, see Chapter 2, “Adding custom data cleaning rules,” page 
2 - 127.
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Opening a Study’s Data Set

View the study’s data set in the Data window.

• To open a study’s data set

1 Select the Data tab of the Study window.

Figure 3 - 4: The Data tab of the Study window. 

2 Click on the Edit button on the tab.

If the study contains data, the matrix of variables and values appears 
in the Data window. If the study contains no data, the empty Data 
window appears.

Click on the 
Edit button to 
open the 
study’s data 
set.
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Entering Respondents’ Replies

Particularly for smaller samples, you can keep costs lower by 
interviewing respondents yourself rather than contracting a market 
research supplier. There are several ways to interview respondents. For 
example, you can interview respondents over the telephone or mail 
surveys and have them return the completed forms to you. Whatever 
means you choose for gathering data from respondents, you can use the 
Interviewer to build the study’s data set.

This section provides an overview of the Interviewer and explains how to 
navigate the Interviewer and use it to enter respondents’ replies. 

About the Interviewer

You can use the Interviewer in different ways. For example, if you are 
interviewing respondents over the telephone, you can enter each 
respondent’s answers question by question while talking to him or her. If 
respondents fill out and return surveys, you can collect a stack of 
completed surveys and enter the responses all at once.

Note If you published your survey on the World Wide Web, you need to 
import the web survey’s data file into the study. If you contracted a 
market research supplier, you need to import the data file the supplier 
returns into the study. See the section “Importing Data Sets” on page 
3 - 21.
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Figure 3 - 5 shows the Interviewer for entering the responses to a series of 
closed-end questions.

Figure 3 - 5: The Interviewer for adding a new record to the study’s data set.

If the Interviewer is configured to display question blocks "one at a time", 
the Interviewer displays one block at a time. In this case, the Interviewer 
never displays text and graphics that live outside the survey's question 
blocks.

If the Interviewer is configured to display question blocks "in groups 
defined by hard page breaks", the Interviewer displays one page at a time 
where the pages are defined by your survey's hard page breaks. If your 
survey has no hard page breaks, the entire survey appears in the 
Interviewer in one page.

Enter the responses 
here.
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Resizing the Interviewer Window

You can resize the Interviewer window by clicking on and dragging any 
of the window's borders. You can also double-click on the Interviewer 
window's caption to have the window occupy the entire screen. Double-
clicking on the Interviewer window's caption again returns the window to 
its previous size.

For your convenience, Survey Crafter Professional remembers the size 
and position of the Interviewer window so you should not need to resize 
the window again when you start a new session.

Navigating the Interviewer

You can use the mouse to navigate and answer the survey questions in the 
Interviewer. For example, to answer a closed-end, rating, or all-that-apply 
question, click on the radio button, drop down item, selection list item or 
checkbox that corresponds to the prompt you want to select.

You can also use the keyboard to navigate and answer the survey 
questions in the Interviewer. For example, use the Enter, Tab and Shift-
Tab keys to move from one question to another and the Up Arrow, Down 
Arrow, Left Arrow and Right Arrow keys to move from one prompt or 
question to another.

You can also use the Spacebar and the numbers on the numeric keypad to 
select answers for closed-end, rating, and all-that-apply questions. For a 
closed-end, rating or all-that-apply question, press a number on the 
numeric keypad to select the corresponding prompt. For an all-that-apply 
question, press the number again to unselect the prompt. For example, for 
an all-that-apply question, press 1 to select the first prompt and then press 
1 again to unselect the prompt. Press 0 to unselect all of the question’s 
prompts.

There are two ways to move from page to page in the Interviewer:

• By clicking on the slider control at the bottom of the Interviewer

• By clicking on the Next and Back buttons at the bottom of the 
Interviewer
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Use the first method when you need to skip several pages at once. Use the 
second method when you want to move to the page immediately before or 
after the currently selected page.

Entering Responses by Using the Interviewer

Each set of replies you enter for a respondent becomes a record in the 
study’s data set. Survey Crafter Professional adds the record to the bottom 
of the data set.

The Interviewer checks that the response you enter for a question meets 
the specifications for the values the question’s variable is designed to 
store. If you enter a value outside a variable’s specifications, Survey 
Crafter Professional displays an error message. A value may lie outside a 
variable’s specifications in two cases: the value is unexpected or it is 
unreadable. Both of these conditions are described in Table 3 - 1. 
Unexpected values are allowed, but unreadable values must be changed 
before you can proceed.

If a respondent is asked a question but refuses to answer it, use the No 
Reply (NR) value. If a response is missing for any other reason, use the 
No Value (NV) value. 

• To enter responses by using the Interviewer

1 Select the Data tab of the Study window and then click on the Edit 
button on the tab.

2 From the Interviewer menu, choose New Respondent or click on the 
New Respondent button on the toolbar.

New Respondent 
button
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3 If the Interviewer Options dialog box displays, do the following:

Figure 3 - 6: The Surveys tab of the Interviewer Options dialog box.

• In the Surveys tab, choose the order of the surveys you want to 
include in the Interviewer.

Choose the surveys 
to display in the 
Interviewer.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.
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• In the Operation tab, choose how you want Survey Crafter 
Professional to display your survey's blocks in the Interviewer.

Figure 3 - 7: The Operation tab of the Interviewer Options dialog box.

• In the Operation tab, if you want, click to select the Automatically 
move new records from the Interviewer to the study check box. If 
you select this check box, enter the number of new records you 
want to add before Survey Crafter Professional moves them to the 
Data window. Survey Crafter Professional moves records when you 
click on the Interviewer's Finish & New Respondent, New 
Respondent or Close button.

• In the Operation tab, if you want, click to select the Automatically 
save the study when new records are moved check box. If you select 
this check box, Survey Crafter Professional will save the study file 
each time it moves new records from the Interviewer to the Data 
window.

Choose how the 
Interviewer displays 
the survey blocks.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.
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• In the Operation tab, if you want, click to select the Cache the 
Interviewer's pages for faster display check box and enter the 
maximum number of pages to store in memory. If you select this 
check box, Survey Crafter Professional will store up to the number 
of pages you specify in memory, allowing the Interviewer to 
display your survey more quickly.

• To prevent the Interviewer Options dialog box from displaying 
every time you start the Interviewer, clear the Show whenever the 
interviewer is launched check box at the bottom of the dialog box.

• Click on the Done button.

Survey Crafter Professional displays the Interviewer window.

Figure 3 - 8: The Interviewer for adding new records to the study’s data set.

4 If you want, choose the magnification level you want to apply to the 
elements in the Interviewer.

Enter the responses 
here.
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When you choose 100%, Survey Crafter Professional displays each 
element normally. When you choose 50%, Survey Crafter 
Professional reduces the size of each element by one-half. When you 
choose 200%, Survey Crafter Professional doubles the size of each 
element.

5 If you want, resize the Interviewer window to better display your 
survey's questions.

To resize the Interviewer window, click on and drag any of the 
window's borders. You can also double-click on the Interviewer 
window's caption to have the window occupy the entire screen. 
Double-clicking on the Interviewer window's caption again returns 
the window to its previous size.

6 Using the slider control or the Next and Back buttons, go to the page 
containing the questions for which you want to enter responses.
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7 Use the mouse or the Enter, Up Arrow, Down Arrow, Left Arrow, 
Right Arrow, Tab and Shift-Tab keys to move from one question or 
prompt to another. Enter the responses to the questions by following 
the directions in Table 3 - 2.

Table 3 - 2: Entering responses using the Interviewer.

For this type of 
question

Enter the response by Notes/tips

Closed-end Selecting the prompt that 
corresponds to the category 
the respondent picked

Use the left mouse button to choose a prompt. 
Alternatively, press a number on the numeric 
keypad to select the corresponding prompt. For 
example, pressing 1 selects the first prompt, 
pressing 2 selects the second prompt, and so on.

To unselect a prompt, right-click on it or press 0. 
To clear all answers on the current page, click on 
the Clear Page button.

A No Reply prompt may be available in the list.

All-that-apply Selecting the prompts that 
correspond to the prompts 
the respondent picked

Use the left mouse button to choose one or more 
prompts. Alternatively, press a number on the 
numeric keypad to select the corresponding 
prompt. Press the number again to unselect the 
prompt. For example, pressing 1 selects the first 
prompt and pressing 1 again unselects the 
prompt. 

You can also unselect a prompt by right-clicking 
on it. To unselect all of a question’s prompts, 
press 0.  To clear all answers on the current page, 
click on the Clear Page button.

No Reply and No Value prompts are not 
available.

Rating Selecting the prompt that 
corresponds to the scale 
value the respondent picked

Use the left mouse button to choose a prompt. 
Alternatively, press a number on the numeric 
keypad to select the corresponding prompt. for 
example, pressing 2 selects the second prompt, 
pressing 3 selects the third prompt, and so on.

To unselect a prompt, right-click on it or press 0.

To clear all answers on the current page, click on 
the Clear Page button.

A No Reply prompt may be available in the list.
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8 Go to another page by using the slider control or the Next and Back 
buttons. Then repeat step 7.

9 When you finish entering the respondent's replies, click on either the 
Finish & New Respondent button or the Close button.

If you click on the Finish & New Respondent button, Survey Crafter 
Professional creates a new respondent record and displays the first 
page of the survey. Repeat steps 6 - 9.

If you click on the Close button, Survey Crafter Professional adds the 
new respondent records to the Data window. Variables associated 
with questions you skipped while entering the responses show NV 
(No Value) in the Data window.

10 If you want, calculate values for the new record's computed variables 
by choosing the Update command from the Edit menu.

Quantity Typing the response in the 
field

You can type NR for No Reply and NV for No 
Value.

Open-end Typing the response in the 
field

You can type NV for No Value. If the respondent 
was asked but did not reply to the question, enter 
text like “Did not answer in the field”. (Do not 
enter NR for "No Reply" since Survey Crafter 
Professional treats it as the characters “NR” not 
as the value NR.

Ranking Type the ranking for each 
prompt

You can type NR for No Reply and NV for No 
Value.

Constant sum Type the points the 
respondents assigns to each 
prompt

You can type NR for No Reply and NV for No 
Value.

Table 3 - 2: Entering responses using the Interviewer. (Continued)

For this type of 
question

Enter the response by Notes/tips
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Importing Data Sets

If you published your survey on the World Wide Web, you need to import 
the set of responses the web survey collected. If a market research 
supplier conducted interviews for you, you need to import the set of 
responses the supplier collected.

Importing data involves transferring data from the file the web survey or 
supplier provides (the import file) to the Survey Crafter Professional 
study. After importing the data into the study, you can analyze it and 
create charts and tables showing the analyses’ results.

Import Process Overview

Survey Crafter Professional reads the import file and matches the file’s 
data with imported variables created to store the data. Commonly, you 
create these variables when writing survey questions as discussed in 
Chapter 2. You can also create imported variables not associated with 
survey questions to store data from a source other than a Survey Crafter 
Professional survey. See the section “Creating Imported Variables” in 
Chapter 6. 

Except for CSV (comma separated value) format files, each import file 
must have a corresponding data dictionary file. Market research suppliers 
should provide the data dictionary file with the import file they return.

However, you need to create a data dictionary file if you are importing 
data from another statistical analysis program or from an import file you 
created and the file is not in CSV (comma separated value) format. For 
more on creating import files and data dictionary files, refer to Appendix 
A, “About Import Files and Data Dictionary Files.”

Note It is not necessary to create a data dictionary file if you are 
importing data from a file used by a Survey Crafter Professional web 
survey. This is because data files used by Survey Crafter Professional 
web surveys are in CSV (comma separated value) format.

Note You can only import data into an open study.
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The flowchart in Figure 3 - 9 illustrates the data import process. 

Figure 3 - 9: The data import process.

Selecting a Data File to Import (Task 1 of 3)

By default, Survey Crafter Professional looks for the data dictionary file 
in the same folder as the import file. If it does not find it there, Survey 
Crafter Professional assumes the import file is in the default CSV (comma 
separated value) format.

If you want Survey Crafter Professional to ask you if the import file is in 
the default CSV format, clear the Assume CSV Text File Format check 
box on the Data tab of the Preferences dialog box.

• To select a data file to import

1 Select the Study window’s Data tab. 

2 In the Name and Description fields, enter a name and description of 
the data set. 
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3 Click on the Edit button on the tab.

The Data window appears.

4 From the File menu, choose Import.

5 From the List Files of Type drop-down list, select ASCII Text Files 
(*.dat;*.txt;*.csv).

6 Use the Locations (Look in) drop-down list and Folders list to find 
the folder containing the import file.

7 Select the import file from the Folders list.

8 Click on the OK button.

9 Follow the instructions in Table 3 - 3.

• To select a data dictionary file

1 In the Survey Crafter Professional message box, click on the No 
button.

Table 3 - 3: Next step in the data import process.

If this dialog box appears Do this

Survey Crafter Professional cannot find... Click on the Yes button if the file is in 
CSV (comma separated value) 
format. 

Click on the No button if the file is not 
in CSV format and then complete the 
task “To select a data dictionary file” 
below.

Click on the cancel button if you do 
not want to continue.

Import Summary Go to the section “Finding Matches 
for Unmatched Dictionary Variables 
(Task 2 of 3)” on page 3 - 24.
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The Open Dictionary File dialog box appears.

Figure 3 - 10: The Open Dictionary File dialog box.

2 From the Files of Type drop-down list, select Dictionary Files 
(*.DCT).

3 Use the Locations (Look in) drop-down list and Folders list to find 
the folder containing the data dictionary file.

4 Select the data dictionary file from the Folders list.

5 Click on the OK button.

The Import Summary dialog box appears.

6 Go to the section “Finding Matches for Unmatched Dictionary 
Variables (Task 2 of 3)” below.

Finding Matches for Unmatched Dictionary 
Variables (Task 2 of 3)

Survey Crafter Professional attempts to pair each variable in the import 
file (these variables are called dictionary variables) with one of the 
study’s imported variables. It performs this matching by comparing 
imported variables’ codes with the dictionary variables’ names as defined 
in the data dictionary file. If the code and name are the same, Survey 
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Crafter Professional copies the values in the dictionary variable to the 
imported variable. Survey Crafter Professional reports any unmatched 
variables in the Import Summary dialog box shown in Figure 3 - 11.

A variable can go unmatched for two reasons: one, a dictionary variable  
might not match an imported variable (the import file contains a variable 
that does not pair with a variable in the study); or two, an imported 
variable might not match a dictionary variable (the study contains a 
variable that does not pair with a variable in the import file). Survey 
Crafter Professional does not import unmatched dictionary variables and 
assigns the value NV to all unmatched imported variables.

Figure 3 - 11: The Import Summary dialog box.

Table 3 - 4 explains the information under Statistics in the Import 
Summary dialog box.

Table 3 - 4: Information in the Import Summary dialog box.

Statistic Description

...records to be imported The number of records in the import file.

...matched variable(s) Shows the number of dictionary variables in the import file 
with names that match the codes of the imported variables in 
the study.

...unmatched dictionary variable(s) The number of variables in the import file with names that 
do not match any of the codes of the imported variables in 
the study.

...unmatched study variable(s) The number of imported variables in the study with codes 
that do not match any of the names of the dictionary 
variables in the import file. Note that this number is not 
necessarily the same as the number of unmatched dictionary 
variables.
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If Survey Crafter Professional reports any unmatched dictionary 
variables, you can pair them with imported variables using the Import 
Summary dialog box. Survey Crafter Professional may not match a 
dictionary variable and an imported variable if, for example, an imported 
variable has the code name and the corresponding dictionary variable’s 
name is mistyped incorrectly as names in the data dictionary file. To 
correct this problem, map the dictionary variable names to the imported 
variable with the code name.

You can also break the match between a dictionary variable and an 
imported variable. Break this match if you recognize an incorrect 
dictionary variable-to-imported variable match or if you do not want to 
import the values in a particular dictionary variable. See “Breaking the 
Mapping between a Field and an Imported Variable” on page 3 - 29.

• To find matches for unmatched dictionary variables

1 In the Import Summary dialog box, click on the More button.

If there are no unmatched dictionary variables and you do not want to 
change any matches, go to step 6.
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2 In the Dictionary Variables list, select an unmatched variable. 
(Unmatched variables appear in red on screen.)

Figure 3 - 12: The Import Summary dialog box (expanded).

3 Click on the Select button.

The Select Variable dialog box appears.

4 In the Select Variable dialog box, select the imported variable you 
want to store the data from the unmatched dictionary variable.

5 Click on the OK button.

Survey Crafter Professional displays the dictionary variable in black 
to indicate that the variable is now matched with an imported 
variable.

6 Repeat steps 2 through 5 for each unmatched dictionary variable you 
want to match with an imported variable.

7 Click on the OK button.

8 Do one of the following:

Here the unmatched 
dictionary variable is 
gen_addr.
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• If a message box appears stating that Survey Crafter Professional is 
importing the data, wait until the import is complete.

When the import is complete, the records appear in the Data 
window. If any values in a variable are erroneous, the Data Error 
Log appears. See the section “Isolating Errors in Data Sets” on page 
3 - 30.

• If the Import Options dialog box (shown below) appears, go to the 
section “Combining New and Existing Data (Task 3 of 3)” below.

The study already contains records and you need to tell Survey 
Crafter Professional whether to add the records in the import file to 
the records in the study or to overwrite the existing records with 
those in the import file.

Figure 3 - 13: The Import Options dialog box.

Combining New and Existing Data (Task 3 of 3)

If the study already contains survey responses, Survey Crafter 
Professional displays the Import Options dialog box. Use this dialog box 
to specify how to combine the data from the import file with the data 
already in the study.

• To combine new and existing data

1 In the Import Options dialog box, select one of the following options 
for combining new and existing data:

• Append to Existing Records to add all records in the current import 
file to the end of the study’s data set
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• Replace All Existing Records to overwrite the study’s data set with 
the data in the current import file

2 Click on the OK button to close the Import Options dialog box.

The Import Data dialog box appears, indicating the status of the 
import.

Survey Crafter Professional imports the data and displays the records 
in the Data window. If any variable contains unexpected or 
unreadable values, Survey Crafter Professional displays the Data 
Error Log. See “Isolating Errors in Data Sets” on page 3 - 30.

Breaking the Match between a Dictionary 
Variable and an Imported Variable

Break this match if you recognize an incorrect dictionary 
variable-to-imported variable match or if you do not want to import the 
values in a particular dictionary variable.

• To break the match between a field and a variable

1 In the Import Summary dialog box, click on the More button.

2 In the Dictionary Variables list, select the dictionary variable whose 
match you want to break. (Matched variables appear in black.)

The Corresponding Study Variable box shows the study’s imported 
variable to which the field is currently matched.

3 Click on the Deselect button.

The variable now appears in red in the Dictionary Variables list, 
indicating that it is no longer matched with an imported variable. You 
can now match the dictionary variable with a new imported variable. 
See “Finding Matches for Unmatched Dictionary Variables (Task 2 of 
3)” on page 3 - 24.
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Isolating Errors in Data Sets

After importing data, Survey Crafter Professional checks whether each 
variable’s values meet the specifications you defined when creating the 
imported variable. A value outside specifications is either unreadable or 
unexpected. See Table 3 - 1 for an explanation of these errors. 

If a value is outside the specifications, Survey Crafter Professional reports 
the erroneous value in the Data Error Log, a window that appears on top 
of the Data window. Survey Crafter Professional also color codes the 
error in the Data window. Use the Data Error Log to find records 
containing errors and make the process of editing variables’ values faster.

For background information on correcting errors in data sets, see the 
section “Handling Errors in Survey Data” in Chapter 5 of Understanding 
Survey Research:  A Primer for Success.

• To isolate errors in data sets

1 If the Data Error Log is not open, choose the Data Error Log 
command from the View menu.

In the Primer
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Figure 3 - 14: The Data Error Log.

2 View errors for variables listed in the Data Error Log as follows:

• To list the errors in one variable, double click on a variable.

• To list the errors in all variables, click on the Expand All button.

3 Select an error.

4 Click on the Show button.

An expression appears in the Data window’s Filter field. This 
expression limits the records in the Data window to only those 
containing the error you selected.

Note  To hide the list of errors in a variable, double click on the 
variable. To hide the lists of errors in all variables, click on the 
Collapse All button. 

The Data 
Error Log lists 
the number of 
unexpected 
and 
unreadable 
values in the 
data set by 
variable. 

For example, 
the variable 
gen_company
size contains 
one 
unreadable 
value.
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You can now edit the erroneous values in the records. See “Editing 
Data Sets” on page 3 - 33.

Figure 3 - 15: Records containing the selected error displayed in the Data window.

Only the 
records 
containing 
the selected 
error appear. 
In this case, 
the 
Unreadable 
error for the 
variable 
gen_compan
ysize.

The variable 
you selected 
in the Data 
Error Log 
appears in 
the Data 
window.
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Editing Data Sets

There are several reasons for editing a study’s data set. Probably the most 
common reason is to correct erroneous values before analyzing the data. 
For example, respondents may have answered a question that the survey’s 
skip logic dictates they should not have answered or a respondent’s 
answer may lie outside the range of values you expect for the question. 
Records sometimes contain so many errors that they are best deleted from 
the data set.

You may also need to edit a data set to add more responses to records. For 
example, suppose you are interviewing a respondent and entering his 
replies using the Interviewer and have to stop the interview. You can call 
back later to complete the interview and add the rest of his replies to the 
record. 

The following are various ways you can review and edit a data set.

•  Using the Interviewer to Edit Values

•  Calculating New Values

•  Selecting New Values from Cells’ Drop-down Lists

•  Finding and Replacing Values in the Data

•  Flagging Errors in Data Sets

•  Checking Spelling in the Data

•  Using the Interviewer to Check Spelling in the Data

•  Deleting a Record

•  Purging All Deleted Records

Using the Interviewer to Edit Values

You can use the Interviewer to edit records or you can type directly in 
cells in the Data window.

• To edit a record by using the Interviewer

1 In the Data window, select the respondent records you want to edit.
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To select more than one respondent record, click on the row selector 
of the first record you want to edit and then either hold down the 
[SHIFT] key to highlight adjacent records or hold down the [CTRL] 
key to highlight nonadjacent records and then click on the row 
selectors of the other records you want to edit.

To select all of the respondent records in the Data window, click on 
the top left corner of the spreadsheet.

2 From the Interviewer menu, choose Edit Respondent or click on the 
Edit Respondent button on the toolbar.

You can also double click on the row selector to access the 
Interviewer or click the right mouse button and choose Edit 
Respondent from the pop-up menu.

3 If Survey Crafter Professional displays the Interviewer Options dialog 
box, do the following:

Figure 3 - 16: The Surveys tab of the Interviewer Options dialog box.

• In the Surveys tab, choose the order of the surveys you want to 
include in the Interviewer.

Edit Respondent 
button

Choose the surveys 
to display in the 
Interviewer.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.
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• In the Operation tab, choose how you want Survey Crafter 
Professional to display your survey's blocks in the Interviewer.

Figure 3 - 17: The Operation tab of the Interviewer Options dialog box.

• In the Operation tab, if you want, click to select the Cache the 
Interviewer's pages for faster display check box and enter the 
number of pages to store in memory. If you select this check box, 
Survey Crafter Professional will store up to the number of pages 
you specify in memory, making the Interviewer display the pages 
faster.

• To prevent the Interviewer Options dialog box from displaying 
every time you start the Interviewer, clear the Show whenever the 
interviewer is launched check box at the bottom of the dialog box.

• Click on the Done button.

Choose how the 
Interviewer displays 
the survey blocks.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.



Survey Crafter Professional displays the Interviewer window.

Figure 3 - 18: The Interviewer for editing existing records in the study’s data set.

4 If you want, choose the magnification level you want to apply to the 
elements in the Interviewer.

When you choose 100%, Survey Crafter Professional displays each 
element normally. When you choose 50%, Survey Crafter 
Professional reduces the size of each element by one-half. When you 
choose 200%, Survey Crafter Professional doubles the size of each 
element.

5 If you want, resize the Interviewer window to better display your 
survey's questions.

Edit the responses 
here.
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To resize the Interviewer window, click on and drag any of the 
window's borders. You can also double-click on the Interviewer 
window's caption to have the window occupy the entire screen. 
Double-clicking on the Interviewer window's caption again returns 
the window to its previous size.

6 Using the slider control or the Next and Back buttons, go to the page 
that contains the questions for which you want to edit the responses.

For instructions on navigating the Interviewer and entering responses, 
see the section “Entering Respondents’ Replies” on page 3 - 11.

7 Use the mouse or the Enter, Up Arrow, Down Arrow, Left Arrow, 
Right Arrow, Tab and Shift-Tab keys to move from one question or 
prompt to another. Enter the new responses to the questions.

8 If you want, go to another page by using the slider control or the Next 
and Back buttons. Then repeat step 7.

9 When you are done editing the record, click on either the Finish & 
Next Respondent button or the Close button.

If you click on the Finish & Next Respondent button, Survey Crafter 
Professional displays the first page of the survey with the answers 
from the next respondent record. Repeat steps 6 - 9.

If you click on the Close button, Survey Crafter Professional 
dismisses the Interviewer and makes the changes in the Data window.

10 If you want to recalculate values for the record’s computed variables, 
choose the Update command from the Edit menu.

• To edit a cell value by typing in a cell

1 In the Data window, double click in the cell with the value you want 
to change.

2 Type the new value following the directions in Table 3 - 5. 

Table 3 - 5:Typing values in cells in the Data window.

When entering this type of 
value

Type

Quantity A number or NR for No Reply or NV 
for No Value
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3 Press the [ENTER] key.

4 To update the study’s data set, choose Update from the Edit menu or 
click on the Update button on the toolbar.

Blanks appear as NV (No Value).

Calculating New Values

You can write an expression to calculate a value for a cell in the Data 
window. For example, if a record is missing a value for the variable age, 
you can write an expression to assign the record the mean of the values in 
age.

• To calculate new values in data sets

1 In the Data window, select the cell or range of cells containing the 
values you want to change.

The cells must all be in the same column. 

2 From the Edit menu, choose Edit Values.

3 In the New Value Expression field, type the expression for calculating 
the value for the cell or range. 

Literal Any character(s) or NV for No 
Value

Category A name of one of the variable’s 
categories or NR for No Reply or 
NV for No Value

Note  To select a range of adjacent cells, click on the first cell you 
want, and then hold down the [SHIFT] key while clicking on the last 
cell you want. To select nonadjacent cells, hold down the [CTRL] 
key while clicking on each cell you want. 

Table 3 - 5:Typing values in cells in the Data window. (Continued)

When entering this type of 
value

Type

Update button

Expression Builder 
button
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For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

Figure 3 - 19: The Edit Values dialog box.

4 To include the values in the selected cells in the calculation, select the 
Include Current Selection in Calculation check box.

You probably want to leave this check box cleared especially if the 
selected cells contain erroneous values. Including erroneous values in 
the calculation could skew the results.

5 Click on the OK button.

6 To update the study’s data set, choose Update from the Edit menu or 
click on the Update button on the toolbar.

Selecting New Values from Cells’ Drop-down 
Lists

Each cell that belongs to an imported category or quantity variable in the 
Data window includes a drop-down list of values that you access by 
double clicking in the cell. The values in the drop-down list vary with the 
type of variable the cell belongs to as follows:

Update button
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• for an imported category variable, the drop-down list contains the 
variable’s categories plus NR and NV.

• for an imported quantity variable, the drop-down list contains NR and 
NV.

• To select a cell value from the cell’s drop-down list

1 In the Data window, double click in the cell whose value you want to 
change.

2 From the cell’s drop-down list, select the value you want.

Figure 3 - 20: A cell’s drop-down list in the Data window. 

3 To update the study’s data set, choose Update from the Edit menu or 
click on the Update button on the toolbar.

The variable 
gen_company
size is an 
imported 
category 
variable. 
Therefore the 
cell’s drop-
down list 
features the 
categories the 
variable 
accepts.

Update button
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Finding and Replacing Values in the Data

To search the Data window for any combination of characters, numbers, 
words or phrases, choose Find/Replace from the Edit menu when the Data 
window is active.

You can also use the command to make changes but only to the data 
stored by the imported variables in the window. To wit: although you can 
use the Find/Replace command to search the data stored by a computed 
variable, you cannot use the command to make any changes to that data. 
In this case, you would modify the variable's definition instead.

• To find or to find and replace values in the data

1 Select the Data tab of the Study window.

2 Click on the Edit button on the tab.

3 If you do not want to search all of the data in the Data window, 
highlight the columns, rows or values you want to search or change.

4 From the Edit menu, choose Find/Replace.

5 Follow the instructions on the screen.

Flagging Errors in Data Sets

Survey Crafter Professional uses color coding in the Data window to flag 
erroneous values in a study’s data set. Red indicates an unreadable value 
and blue indicates an unexpected value. Black indicates an acceptable 
value for an imported variable. Gray indicates a value in a computed 
variable.

See Table 3 - 1 for more information on erroneous values and color 
coding in the Data window.

After you edit any values in the Data window or edit any variable’s 
settings, have Survey Crafter Professional scan the data set again to check 
whether an edit results in an unexpected or unreadable value. 

• To flag errors in data sets

1 To display the study’s data set, select the Study window’s Data tab. 
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Then click on the Edit button on the tab.

2 To scan the data set for errors, choose Update from the Edit menu or 
click on the Update button on the toolbar.

Survey Crafter Professional applies color coding to variables’ values. 
You can now edit any remaining erroneous values.

Checking Spelling in the Data

To check and correct the spelling of the responses to your surveys' open-
end questions as well as the values contained in the study's other imported 
literal variables, choose Spelling from the Edit menu or click on the 
Check Spelling button on the toolbar when the Data window is active.

• To check spelling in the data

1 Select the Data tab of the Study window.

2 Click on the Edit button on the tab.

3 If you do not want to check all of the literal values in the Data 
window, highlight the columns, rows or values you want to check.

4 From the Edit menu, choose Spelling or click on the Check Spelling 
button on the toolbar.

Follow the instructions on the screen.

Using the Interviewer to Check Spelling in the 
Data

You can also use the Interviewer to check and correct the spelling of the 
responses to your surveys' open-end questions.

• To use the interviewer to check spelling in the data

1 In the Data window, select the records that contain the responses you 
want to check.

Update button

Check Spelling button
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To select more than one respondent record, click on the row selector 
of the first record you want to check and then either hold down the 
[SHIFT] key to highlight adjacent records or hold down the [CTRL] 
key to highlight nonadjacent records and then click on the row 
selectors of the other records you want to check.

To select all of the respondent records in the Data window, click on 
the top left corner of the spreadsheet.

2 Click on the Edit Respondent button on the toolbar.

Alternatively, you can click the right mouse button and choose Edit 
Respondent from the pop-up menu.

3 If Survey Crafter Professional displays the Interviewer Options dialog 
box, do the following:

Figure 3 - 21: The Surveys tab of the Interviewer Options dialog box.

• In the Surveys tab, choose the order of the surveys you want to 
include in the Interviewer.

Edit Respondent 
button

Choose the surveys 
to display in the 
Interviewer.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.
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• In the Operation tab, choose how you want Survey Crafter 
Professional to display your survey's blocks in the Interviewer.

Figure 3 - 22: The Operation tab of the Interviewer Options dialog box.

• In the Operation tab, if you want, click to select the Cache the 
Interviewer's pages for faster display check box and enter the 
number of pages to store in memory. If you select this check box, 
Survey Crafter Professional will store up to the number of pages 
you specify in memory, making the Interviewer display the pages 
faster.

• To prevent the Interviewer Options dialog box from displaying 
every time you start the Interviewer, clear the Show whenever the 
interviewer is launched check box at the bottom of the dialog box.

• Click on the Done button.

Choose how the 
Interviewer displays 
the survey blocks.

Clear this check box 
to prevent this dialog 
box from appearing 
each time you start 
the Interivewer.
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Survey Crafter Professional displays the Interviewer window.

Figure 3 - 23: The Interviewer for editing existing records in the study’s data set.

4 If you want, choose the magnification level you want to apply to the 
elements in the Interviewer.

When you choose 100%, Survey Crafter Professional displays each 
element normally. When you choose 50%, Survey Crafter 
Professional reduces the size of each element by one-half. When you 
choose 200%, Survey Crafter Professional doubles the size of each 
element.

5 If you want, resize the Interviewer window to better display your 
survey's questions.

Edit the responses 
here.
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To resize the Interviewer window, click on and drag any of the 
window's borders. You can also double-click on the Interviewer 
window's caption to have the window occupy the entire screen. 
Double-clicking on the Interviewer window's caption again returns 
the window to its previous size.

6 Click on the Check Spelling button above and to the left of the survey 
in the Interviewer window. 

The check begins with the current record on the current page and goes 
on until each of the remaining records on the page has been checked. 
It then goes on to the next page, beginning with the first record that 
has been loaded into the Interviewer and proceeding until each of the 
remaining records on the page has been checked. It continues in this 
way until all of the records on the remaining pages have been 
checked.

When Survey Crafter Professional encounters an unknown or 
misspelled word, it displays the Spelling Check dialog box. Follow 
the instructions on the screen.

You may press any key at any time or click on the Stop button on the 
Spelling Check dialog box to stop the operation.

Deleting a Record

Delete a record if, for example, its values are unreadable or you believe it 
contains many invalid or unreliable responses. 

If you delete a record, you may need to update one or more of the study’s 
analyses. See the section “Updating Tables” on page 4 - 78.

• To delete a record

1 At the Data tab of the Study window, click on the Edit button on the 
tab.

2 Select the record to delete.

3 From the Edit menu, choose Delete or press the [DELETE] key.

Survey Crafter Professional deletes the record from the study’s data 
set.

Check Spelling button
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4 To recalculate values in the study’s computed variables, do one of the 
following:

• From the Edit menu, choose Update.

• Click on the Update button on the toolbar.

Purging All Deleted Records

Purge all deleted records if, for example, you want to reduce the overall 
size of the study file.

If you purge all deleted records, you may need to update one or more of 
the study’s analyses. See the section “Updating Tables” on page 4 - 78.

• To purge all deleted records

1 At the Data tab of the Study window, click on the Edit button on the 
tab.

2 From the Edit menu, choose Purge All Deleted Records.

Survey Crafter Professional permanently removes all deleted records 
from the study’s data set.

Survey Crafter Professional also automatically recalculates the values 
in the study’s computed variables.

Update button
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Weighting Data

The best way to work with weighted data in Survey Crafter Professional 
is to import a weighted data set. However, you can weight values in 
individual variables by creating a computed variable with the IF( ) 
function. 

You can also have Survey Crafter Professional create a computed 
quantity variable for you by using the Category to Weights Variable 
Wizard.

Below are two examples of expressions for weighting data with the IF( 
) function.

• Example 1:  Using the IF( ) function to assign two weighting factors

Suppose you want to weight males’ income (stored in the variable 
income) by three-quarters of the actual amounts and females’ incomes 
by one-and-a-half times the actual amounts.

Use an expression like this:  IF(gender = 'male', income*0.75, 
income*1.5).

This expression tests whether the value for a respondent in gender is 
equal to ‘male’. If it is, the respondent’s value in income is multiplied 
by 0.75. If the value in gender is not equal to ‘male’, the value in 
income is multiplied by 1.5.

• Example 2:   Using the IF( ) function to assign more than two 
weighting factors

Suppose you want to weight incomes (stored in the variable income) 
based on three age groups. For respondents under age 25, you want to 
weight their incomes by half of the actual values. For respondents ages 
25 to 50, you want to weight their incomes by one-and-a-half times the 
actual values. For respondents over 50, you want to weight their 
incomes by two times the actual values.

Use an expression like this:  IF(age<25, income*0.5, 
IF(age>=25 AND age <=50, income*1.5, income*2)).
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This expression tells Survey Crafter Professional to test first whether 
the respondent’s value in the variable age is less than 25. If it is, the 
value in income is multiplied by 0.5. If the value in age is 25 or greater, 
Survey Crafter Professional next tests whether the value in age is 
between 25 and 50 inclusive. If it is, the value in income is multiplied 
by 1.5. If the value in age is greater than 50, the value in income is 
multiplied by 2. 

To add a fourth weighting factor, replace the income*2 argument with 
another IF( ) function.

For more information on weighting data, see the section “Weighting 
Data for Analysis” in Chapter 5 of Understanding Survey Research:  A 
Primer for Success.

• To weight data

1 Select the variables tab of the Study dialog box, and then click on the 
New button.

2 In the New Variable dialog box, choose Computed Variable under 
Custom Variable.

3 In the Variable Information dialog box, do the following:

• In the Name field, enter the name of the variable. 

For example, if you are weighting values in the variable income, 
call the computed variable weighted_income.

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a description of the values the 
variable stores.

• Click on the OK button.

In the Primer
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4 In the Variable dialog box, choose Quantity under Variable Type.

5 In the Quantity Expression field, write the expression using the IF( 
) function to weight the data.

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

6 Click on the OK button to close the Variable dialog box.

7 To calculate the weighted values, see the section “Updating 
Variables’ Values” on page 6 - 68.
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Exporting Data Sets

Sometimes you might want to mail a study’s data set to a coworker or use 
a data set outside of Survey Crafter Professional. You can export a study's 
data set to a CSV (comma separated value) text file, a Micorosft® Excel® 
97 workbook file or a HTML web page file.

Exporting a data set to a CSV text file involves selecting the file to write 
the data set to and confirming the variables to export. By default, Survey 
Crafter Professional exports only those variables that appear in the Data 
window. In addition, for category variables, you can export either 
category codes or category names.

When exporting a data set to a CSV text file, Survey Crafter Professional 
creates a CSV (comma separated value) text file and a data dictionary file. 
It stores both of these files in the same folder. The export file and the data 
dictionary file have the same name but the export file uses the .DAT 
extension and the data dictionary file uses the .DCT extension. For more 
on comma delimited files and data dictionary files, see Appendix A, 
“About Import Files and Data Dictionary Files.”

Exporting a data set to a Microsoft® Excel® 97 workbook or to a HTML 
web page file only involves selecting the file to write the data set to.

• To export data

1 Select the Data tab of the Study window. Then click on the Edit 
button on the tab.

2 From the File menu, choose Export.

3 In the Save Data File As dialog box, choose one of the following from 
the Save as type drop down:

• ASCII Text File

• Microsoft Excel 97 workbook

• Web Page

Note  Microsoft® Excel® 97 worksheets do not support more than 
255 columns.
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4 Enter a name and location for the file you want to write the data set to.

If you chose ASCII Text File in step 3, use the .DAT, .TXT or .CSV 
extension with the filename.

If you chose Microsoft Excel 97 workbook in step 3, use the .XLS 
extension with the filename.

If you chose Web Page in step 3, use the .HTM or HTML extension 
with the filename.

5 Click on the OK button.

If you chose Microsoft Excel 97 workbook or Web Page in step 3, 
Survey Crafter Professional creates the export file.

If you chose ASCII Text File in step 3, continue with step 6.

6 In the Export Summary dialog box, click on the More button.

7 If you do not want to export one or more variables, select the 
variables in the Variables list and then click on the Deselect button.
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The variables Survey Crafter Professional will not export appear in 
red.

Figure 3 - 24: The Export Summary dialog box.

8 Under Category Variable Options, select an option for exporting data 
in category variables.

9 Click on the OK button.

Survey Crafter Professional creates the export file and its 
corresponding data dictionary file. The export file features one line 
for each record in the study’s data set with values in each record 
separated by commas.
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Changing the Data Window Display

You can customize the Data window display in the following ways:

• Changing the Number of Records Displayed in the Data Window 

• Hiding and Showing Columns in the Data Window

• Rearranging Columns in the Data Window

• Changing Column Widths in the Data Window

• Sorting Respondent Records in the Data Window

Changing the Number of Records Displayed in 
the Data Window

To make the Data window display more manageable, you can view a 
subset of the records in a study’s data set. You can also view all of the data 
set’s records. By default, the Data window displays all of the records in a 
data set.

• To display a subset of records in a study’s data set

1 At the Data tab of the Study window, click on the Edit button on the 
tab.

2 From the Edit menu, choose Edit Filter.

3 In the Filter Expression field, write the expression for selecting 
records to display.

The expression must evaluate to TRUE or FALSE for each 
respondent in the data set. Records of respondents for whom the 
expression is TRUE appear in the Data window.

Expression Builder 
button
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For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.” 

Figure 3 - 25: The Edit Filter dialog box.

4 Click on the OK button.

The expression appears in the Data window’s Filter field.

5 To update the Data window display, choose Update from the Edit 
menu or click on the Update button on the toolbar.

• To display all of the records in a study’s data set

1 Make the Data window active by clicking in it or choosing Data from 
the Window menu. 

2 From the Edit menu, choose Clear Filter.

Survey Crafter Professional deletes the expression in the Filter field 
and displays all of the data set’s records.

Records of respondents for 
whom the variable Age 
stores a value greater than 
45 will appear in the Data 
window.

Update button
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Hiding and Showing Columns in the Data 
Window

You can hide and show the columns in the Data window. If you hide a 
column in the Data window, you can still use the corresponding variable 
in expressions. Hiding a column does not remove the corresponding 
variable from the study.

• To hide columns in the Data window

1 Select the Data tab of the Study window, and then click on the Edit 
button on the tab.

2 From the View menu, choose Show/Hide Variables. 

Alternatively, select one or more variables in the Data window (by 
clicking on one or more column selectors) and then choose Hide 
Selected Variables from the Edit menu.

Figure 3 - 26: The Show/Hide Variables dialog box.

A check mark indicates 
that the variable currently 
appears in the Data 
window.
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3 In the Show/Hide Variables dialog box, select the variables you want 
to remove from the Data window display.

4 Click on the Hide button.

The check mark next to each variable you selected disappears.

5 Click on the OK button.

Survey Crafter Professional removes the variables from the Data 
window.

• To show columns in the Data window

1 Select the Data tab of the Study window, and then click on the Edit 
button on the tab.

2 From the View menu, choose Show/Hide Variables.

3 In the Show/Hide Variables dialog box, select the variables you want 
to return to the Data window display.

Check marks indicate variables currently appearing in the Data 
window.

4 Click on the Show button.

A check mark appears next to each variable you selected.

5 Click on the OK button.

Survey Crafter Professional returns the variables to the Data window.

Note  To select a range of adjacent variables, click on the first 
variable you want and then hold down the [SHIFT] key while 
clicking on the last variable you want. To select a range of 
nonadjacent variables, hold down the [CTRL] key while clicking on 
each variable you want.

Note  To select a range of adjacent variables, click on the first 
variable you want and then hold down the [SHIFT] key while 
clicking on the last variable you want. To select a range of 
nonadjacent variables, hold down the [CTRL] key while clicking on 
each variable you want. 
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Rearranging Columns in the Data Window

Rearrange columns in the Data window to change the order in which 
variables appear.

• To rearrange columns in Data window

1 Select the Data tab of the Study window, and then click on the Edit 
button on the tab.

2 From the View menu, choose Show/Hide Variables.

Figure 3 - 27: The Show/Hide Variables dialog box.

3 In the Show/Hide Variables dialog box, do any of the following:

• Select Always list the variables in the order they appear in the 
survey(s) to have Survey Crafter Professional position the variables 
for you. Clear the check box to position the variables yourself.

Top-to-bottom order in this 
list matches left-to-right 
order in the Data window.
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• Highlight the variables you want to reposition in the Data window 
and click on the Up, Down, Top or Bottom buttons to move the 
highlighted variables. These buttons are not available if you have 
selected Always list the variables in the order they appear in the 
survey(s).

• Click on the Alpha button to have Survey Crafter Professional 
change the order to show the variables in alphabetical order by 
variable name. This button is not available if you have selected 
Always list the variables in the order they appear in the survey(s).

• Click on the Survey button to have Survey Crafter Professional 
change the order to show the variables in the order that they appear 
in your surveys. This button is not available if you have selected 
Always list the variables in the order they appear in the survey(s).

Top-to-bottom order in the list corresponds to left-to-right order in the 
Data window.

4 Click on the OK button.

Survey Crafter Professional changes the order of columns in the Data 
window.

Changing Column Widths in the Data Window

Change column widths to show less or more of the variables’ values in the 
Data window. Cell heights can also be changed in the Data window.

• To change column widths in the Data window

1 At the Data tab of the Study window, click on the Edit button on the 
tab.

2 Position the pointer on a column selector’s border.

Note  To select a range of adjacent variables, click on the first 
variable you want and then hold down the [SHIFT] key while 
clicking on the last variable you want. To select a range of 
nonadjacent variables, hold down the [CTRL] key while clicking on 
each variable you want. 
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The pointer turns into the border symbol (a two-sided arrow).

3 Click and drag the border until the column has the width you want.

Sorting Respondent Records in the Data Window

You can sort respondent records in the Data window to show the records 
in a different order.

• To sort respondent records in the Data window

1 At the Data tab of the Study window, click on the Edit button on the 
tab.

2 Click on the column selector that corresponds to the primary variable 
you want to use to sort the respondent records.

Survey Crafter Professional highlights the selected column.

3 If you want, press and hold the [CTRL] key and then click on the 
column selector that corresponds to the secondary variable you want 
to use to sort the respondent records.

Survey Crafter Professional highlights the selected column.

4 Choose Sort Respondents from the Edit menu.

Figure 3 - 28: The Sort Respondents dialog box.

Type the name of or select 
the primary variable used 
to sort the respondent 
records in the Data 
window.
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5 Choose the Ascending Order or Descending Order options for the 
primary and, if applicable, secondary variables.

6 Click on the OK button.

Survey Crafter Professional sorts the respondent records in the Data 
window.
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4 Analyses:  Tables

This chapter explains how to use wizards to build common types of 
analysis tables as well as how to build analysis tables yourself. It also 
explains how to format tabulated data for printing or using in a report or 
presentation and how to display a table’s data as a chart. Chapter 5, 
“Analyses: Charts,” explains how to format charts.

Read the section “Table Basics” first to learn key concepts about 
performing analyses and working with tables in Survey Crafter 
Professional.

Chapter Contents

• Table Basics  4 - 3

• Survey Crafter Professional’s Table Wizards  4 - 7

• Creating Tables by Using Wizards  4 - 22

• Creating Custom Tables  4 - 28

• Opening Existing Tables  4 - 37

• Copying Existing Tables  4 - 39

• Specifying Row, Column and Table Filters  4 - 41

• Copying Cell Properties to Other Table Cells  4 - 51

• Formatting Tables  4 - 53

• Repositioning and Resizing Rows, Columns, and Table Cells  4 - 64

• Updating Tables  4 - 78

• Displaying a Table’s Data as a Chart  4 - 79

• Sorting Table Cells  4 - 80

• Exporting Tables  4 - 82
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• Charts and Drawing Objects on Tables  4 - 84
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Table Basics

Read the sections below to learn basic concepts about working with tables 
in Survey Crafter Professional. The sections include an overview of 
Survey Crafter Professional tables and instructions on selecting cells in 
tables.

• What is a Table?

• Selecting Cells in the Analysis Window

• Values in Table Cells

What is a Table?

A table shows the results of an analysis you perform on the study’s data 
set. Figure 4 - 1 shows a table in an Analysis window.

Figure 4 - 1: A sample table in an Analysis window.

Cick on the 
row selector 
to select the 
entire row.

Cick on the 
column 
selector to 
select the 
entire 
column.

Text in a table 
cell

Cick on the 
table 
selector to 
select the 
entire table.

Table title

Column heading

Calculated values
Row heading
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As the figure shows, table cells contain either numbers or text. The 
number or text in a cell is defined by an expression.

For a description of analyses common to market research studies, see the 
section “Analyzing Data” in Chapter 5 of Understanding Survey 
Research:  A Primer for Success.

A table cell may contain a number, text or the value #Error, #Update, or 
#####.

#Error
#Error appears in a cell if Survey Crafter Professional could not evaluate 
the expression that defines the cell’s value. Usually #Error appears if the 
cell’s expression contains an error. #Error can also appear if your 
computer runs out of memory while evaluating the expression. 

#Update
#Update appears in a cell if the cell’s value needs to be recalculated. It 
appears if you have done any of the following:

• Entered a new expression for a cell

• Changed a cell’s expression

• Changed a row, column or table filter used by a cell’s expression

• Changed the expression for a computed variable used by a cell’s 
expression

• Copied and pasted an expression to a cell having a different row, 
column or table filter

• Changed the portion of the study’s data set a cell’s expression uses

• Added or deleted a record in the study’s data set

For instructions on recalculating a cell’s value, see the section “Updating 
Tables” on page 4 - 78.

In the Primer
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#####
This value appears when the table cell is not wide enough to display the 
value. If you resize the cell’s column, the value will appear. See 
“Changing Dimensions of Table Cells” on page 4 - 72.

Selecting Cells in the Analysis Window

You need to select a cell before you can edit its value or format it. You can 
select one cell, ranges of cells, entire rows or columns, or an entire table.  

• To select a single cell

Click in the cell. 

• To select a range of adjacent cells

Do one of the following:

• Click in a cell and drag the pointer across the range.

• Click in the cell in the range’s upper left corner. Then hold down the 
[SHIFT] key and click in the cell in the range’s lower right corner.

• To select multiple nonadjacent cells, rows, or columns

Select the first cell, row, or column you want. Then hold down the 
[CRTL] key while selecting each additional cell, row, or column you 
want.

• To select an entire row or column

Do one of the following:

• To select one row or column, click on its row selector or column 
selector. 

• To select multiple rows or columns, click and drag the pointer over 
several row or column selectors. Alternatively, click on the selector of 
the first row or column you want and then hold down the [SHIFT] key 
while clicking the selector for the last row or column you want.

• To select an entire table

Cick on the table selector.
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Values in Table Cells

Each cell in a table contains an expression that defines the value 
appearing in the cell. In the case of headings, notes, or table titles, the 
expression is only text like “Males” or  “Mean age by preferred brand.”  
In the case of calculated values, the expression involves one or more 
functions and variables. For example, the expression MEAN(age) 
displays the average value in the variable age in a table cell.

To enter or change a cell’s expression, use the Edit Value dialog box 
shown in Figure 4 - 2. Access the Edit Value dialog box by doing any of 
the following:

• Double-clicking in a table cell 

• Selecting a cell and then pressing the [ENTER] key

• Selecting a cell and then choosing the Edit Value command from the 
Edit menu 

Figure 4 - 2: The Edit Value dialog box.

A calculation in a table cell need not include all the respondents in the 
study’s data set. You can specify which respondents are included in a 
cell’s calculation. For example, a cell could show the mean age for only 
respondents who said they prefer the restaurant Marsha’s Mex.

Enter the 
expression for a 
cell’s value here.
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Survey Crafter Professional’s Table Wizards

Survey Crafter Professional includes the following wizards to help you 
build tables common to survey research studies:

• Banner Table Wizard

• Counts and Frequencies Table Wizard

• Cross Tabulation Table Wizard

• Correlation Matrix Table Wizard

• Descriptive Statistics Table Wizard

• Individual Responses Table Wizard

• All-That-Apply Question Table Wizard

• Ranking Question Table Wizard

Each of these wizards is described below with an example. You can also 
create custom tables. For more on custom tables, see the section “Creating 
Custom Tables” on page 4 - 28. 
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Banner Table Wizard

Use the Banner table wizard to build an analysis table that shows counts 
and percentages for selected category variables and counts, percentages, 
means and standard deviations for selected quantity variables.

The answers to your survey's closed-end and all-that-apply questions are 
stored in imported category variables. The answers to your survey's 
rating, quantity, ranking and constant sum questions are stored in 
imported quantity variables. For more information, see the section 
“Survey Blocks” on page 2 - 6.

For example, suppose your survey asks the respondent to rate your 
customer service on a scale from 1 to 5. You could use the Banner table 
wizard to build an analysis table that shows the number and percentage of 
times each of the points on the 5-point scale were chosen. Since the 
answers to the rating question are stored in an imported quantity variable, 
you could also have the table show the average rating.

In addition to selecting the category and quantity variables to include in 
the table, you can also choose a variable to cross tabulate against the 
selected variables.
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The analysis table in Figure 4 - 3 below was built by the Banner table 
wizard.

Figure 4 - 3: An analysis table built by the Banner table wizard.

The table shows counts and percentages for the category variable 
associated with the question "5. Which of the following best describes the 
reason you most often use a print shop?" followed by counts, percentages, 
means and standard deviations for the quantity variables associated with 
the questions "Our turnaround time?" and "The quality of our finished 
print jobs?". 

Although the picture shows only one of the values, the table repeats these 
calculations for each value in the category variable associated with the 
question "5. Which of the following best describes the reason you most 
often use a print shop?".

Variables 
included in 
the banner

Question text and prompts (some text 
may be cropped)

Category 
variable

Values for the whole 
sample

Quantity 
variable

Values for different segments of 
the sample (values for school 
and personal not shown)
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Counts and Frequencies Table Wizard

Use the Counts and Frequencies table wizard to build an analysis table 
that shows counts and percentages for any set of variables.

For example, suppose your survey asks the respondent to choose his or 
her favorite restaurant from a list of fast food restaurants. You could use 
the Counts and Frequencies table wizard to build an analysis table that 
shows the number and percentage of times each restaurant was chosen as 
the favorite.

Another example, suppose your survey asks the respondent to enter a 
comma-separated list of words or phrases that describe how he or she 
feels about the food in your restaurant. You could have the Counts and 
Frequencies table wizard build an analysis table that shows the number 
and percentage of times each of up to 250 different words or phrases were 
mentioned.

You can also have the Counts and Frequencies table wizard build an 
analysis table that shows weighted counts and weighted percentages. To 
do this, you must select a quantity variable that will provide a weight 
value for each respondent in the data set. If you have not yet created a 
quantity variable to provide the weights, see “Creating a Quantity 
Variable for Weighting Respondents” on page 6 - 35.

In addition to selecting the variables to include in the table, you can also 
cross tabulate the selected variables against other variables and show the 
statistical significance of the relationship between the values of the other 
variables.
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The analysis table in Figure 4 - 4 below was built by the Counts and 
Frequencies table wizard.

Figure 4 - 4: An analysis table built by the Counts and Frequencies table wizard.

The table shows counts and percentages for the category variable 
associated with the question "5. Which of the following best describes the 
reason you most often use a print shop?". The table repeats these 
calculations for each value in the category variable associated with the 
question "4. How did you hear about us?".

Totals for the 
category

Variable 
Categories 

Category 
variable

Category variable to subdivide the results
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Cross Tabulation Table Wizard

Use the Cross Tabulation table wizard to build an analysis table that 
shows all combinations of the values of two or more variables and the 
number and/or percentage of times each combination was chosen.

For example, suppose your survey asks for the respondent's marital status 
and favorite color. A cross tabulation could show all combinations of the 
answers to the two questions and the number and percentage of times 
each combination was chosen. You could use the table to find out how 
many respondents were both married and chose red.

If you want, you can have the wizard build a cross tabulation table with 
more than two variables. For example, suppose your survey asks for the 
respondent's age, gender and favorite restaurant. You could have the 
wizard build a cross tabulation that shows all combinations of age and 
gender against all of the restaurant choices.

If you have this wizard build a cross tabulation table with two variables 
and both are category variables, you can instruct the wizard to also show 
the statistical significance of the relationship between the two variables.
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The analysis table in Figure 4 - 5 below was built by the Cross Tabulation 
table wizard.

Figure 4 - 5: An analysis table built by the Cross Tabulation table wizard.

The table shows all of the combinations of the answers to the questions 
"4. How did you hear about us?", "6. Which of the following best 
describes the kind of print job that you most often need?" and "3. How 
large is your company?" and the number and percentage of times each 
combination was chosen.

Totals for the 
variable’s 
values.

The row variable’s 
values

Row variable

Column variable
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Correlation Matrix Table Wizard

Use the Correlation Matrix table wizard to build an analysis table that 
shows the correlation coefficients for any set of quantity variables.

You can also have the analysis table show the statistical significance of 
the correlations between the selected quantity variables.

The analysis table in Figure 4 - 6 below was built by the Correlation 
Matrix table wizard.

Figure 4 - 6: An analysis table built by the Correlation Matrix table wizard.

The table shows the correlation coefficients for the quantity variables 
associated with the questions "Our turnaround time?", "The quality of our 
finished print jobs?", "Our business hours?", and "The courtesy of our 
staff members?".

Quantity 
variables in 
the correlation 
matrix.

Correlation coefficients
Coefficients on this 
diagonal of the matrix 
are 1 because they 
represent variables 
correlated with 
themselves.
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Descriptive Statistics Table Wizard

Use the Descriptive Statistics table wizard to build an analysis table that 
shows statistics such as means, mean confidence intervals, medians, 
modes, minimums, maximums, standard deviations and variances for any 
set of quantity variables.

For example, suppose your survey asks the respondent to rate your 
customer service on a scale from 1 to 5 and to also indicate the reason 
why he or she visits your store. You could use the Descriptive Statistics 
table wizard to build an analysis table that shows the overall average 
customer service rating as well as the average customer service rating 
associated with each reason for visiting your store.

In addition to selecting the quantity variables to include in the table, you 
can also cross tabulate the selected variables against up to two other 
variables.
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The analysis table in Figure 4 - 7 below was built by the Descriptive 
Statistics table wizard.

Figure 4 - 7: An analysis table built by the Descriptive Statistics table wizard.

The table shows counts, means, medians, modes, maximums and 
minimums for the quantity variables associated with the questions "Our 
turnaround time?", "The quality of our finished print jobs?", "Our pick-up 
and delivery service?", "Our business hours?", "The courtesy of our staff 
members?", and "The experience and expertise of our staff members?". 

Although the picture only shows one of the values, the table repeats these 
calculations for each value in the computed category variable having the 
description "Respondent also uses our competitors".

Quantity 
variables 
selected for 
the 
calculation

Questions 
with which 
the variables 
are 
associated

Statistics for the 
entire sample

Statistics for different 
segments of the sample 
(No not shown)
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Individual Responses Table Wizard

Use the Individual Responses table wizard to build an analysis table that 
shows the actual responses stored by any set of variables. 

For example, suppose your survey asks the respondent to rate your 
customer service and also to provide a comment to explain his or her 
rating. You could use the Individual Responses table wizard to build an 
analysis table that shows the comments of those respondents who gave 
your customer service a low rating.

The analysis table in Figure 4 - 8 below was built by the Individual 
Responses table wizard.

Figure 4 - 8: An analysis table built by the Individual Responses table wizard.

The table shows the actual responses stored by the variables associated 
with the questions "The courtesy of our staff members" and "11. Do you 
have any other comments or suggestions?".

Record 
numbers

Questions 
with which 
the variables 
are 
associated

Individual 
responses
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All-That-Apply Question Table Wizard

Use the All-That-Apply Question table wizard to build an analysis table 
that shows counts and percentages for the category variables associated 
with your survey's all-that-apply questions.

In addition to selecting the category variables to include in the table, you 
can also cross tabulate the selected variables against another variable.

For example, suppose your survey asks the respondent to select all of the 
brands of hand soap he or she has purchased in the past six months. 
Suppose also your survey asks for the respondent's gender. You could use 
the All-That-Apply Question table wizard to build an analysis table that 
shows the number and percentage of times each brand was selected. You 
could also have the table show the number and percentage of times each 
brand was selected for men and for women.
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The analysis table in Figure 4 - 9 below was built by the All-That-Apply 
Question table wizard.

Figure 4 - 9: An analysis table built by the All-That-Apply Question table wizard.

The table shows counts and percentages for the category variables 
associated with the question "9. Do you use any of the following print 
shops? (Check all that apply) ". The table repeats these calculations for 
each value of the variable associated with the question "6. Which of the 
following best describes the kind of print job that you most often need?".

Counts and 
percentages 
for the entire 
sample

Questions 
with which the 
variables are 
associated

Values for 
different 
segments of the 
sample
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Ranking Question Table Wizard

Use the Ranking Question table wizard to build an analysis table that 
shows counts and percentages for the quantity variables associated with 
your survey's ranking questions.

In addition to selecting the quantity variables to include in the table, you 
can also cross tabulate the selected variables against another variable.

For example, suppose your survey asks the respondent to rank in order of 
preference a list of fast food restaurants. Suppose also your survey asks 
the respondent to indicate to which age group he or she belongs. You 
could use the Ranking Question table wizard to build an analysis table 
that shows the number and percentage of times each restaurant was 
ranked first, second, and so on. You could also have the table show these 
calculations for each age group.
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The analysis table in Figure 4 - 10 below was built by the Ranking 
Question table wizard.

Figure 4 - 10: An analysis table built by the Ranking Question table wizard.

The table shows counts and percentages for the quantity variables 
associated with the question "12. Please indicate your order of preference 
of the following print shops". The table repeats these calculations for each 
value in the category variable associated with the question "3. How large 
is your company?".

Counts and 
percentages for 
the entire sample

Questions 
with which the 
variables are 
associated

Values for 
different 
segments 
of the 
sample
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Creating Tables by Using Wizards

Use the following instructions to have a wizard build an analysis table for 
you.

• To create an analysis table by using a wizard

1 Select the Analyses tab of the Study window.

Figure 4 - 11: The Analyses tab of the Study window.

2 Click on the New button on the tab.

Click on the New button 
to create a new 
analysis table.
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Survey Crafter Professional displays step 1 of the New Analysis 
dialog box.

Figure 4 - 12: Step 1 of the New Analysis dialog box.

3 Select Have a wizard build an analysis table or chart for you.

4 Click on the Next button.

Select this option to 
have a wizard build an 
analysis table for you.
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Survey Crafter Professional displays step 2 of the New Analysis 
dialog box.

Figure 4 - 13: Step 2 of the New Analysis dialog box.

5 Under Table Wizards, click to select the wizard you want to use.

A brief description of the selected wizard appears in the window on 
the right.

6 Click on the Next button.

Click on the table 
wizard you want to use.
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Survey Crafter Professional displays step 3 of the New Analysis 
dialog box.

Figure 4 - 14: Step 3 of the New Analysis dialog box.

7 Enter a name and description for the analysis.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

8 Click on the Finish button.

Enter a name and 
description for the 
analysis.
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Survey Crafter Professional displays the wizard you selected in step 
5.

Figure 4 - 15: Step 1 of the Counts and Frequencies table wizard.

9 Follow the instructions on the screen to complete the wizard.

For help on any of the wizard’s options, click on the Help button on 
the wizard’s dialog box.

10 Click on the Finish button.

Choose the variables 
you want to analyze.

Click on the Help button 
for descriptions of the 
wizards’ options.
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Survey Crafter Professional builds a new analysis table according to 
the options you selected and displays the table in an Analysis 
window.

Figure 4 - 16: An analysis table built by the Counts and Frequencies table wizard.

If you want, you can now format the table.  See the section 
“Formatting Tables” on page 4 - 53.

Tip  You can revisit the wizard at any time to change your selections 
or to just have the wizard build the analysis table again. To revisit 
the wizard, choose Analysis Wizard from the Edit menu when the 
Analysis window is active.
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Creating Custom Tables

To create a custom table, you need to define the information to appear in 
each cell in the table. Table cells may contain expressions for calculating 
the cell’s values or they may contain text such as column headings.

Creating a custom table involves creating the table, defining a table title 
and headings, and defining table cell values.

Creating the Table

Follow the instructions below to create a new empty table.

• To create the table

1 Select the Analyses tab of the Study window.

Figure 4 - 17: The Analyses tab of the Study window.

2 Click on the New button on the tab.

Tip You can also create tables common to survey research studies  by 
using wizards. For more information, see the section “Creating Tables 
by Using Wizards” on page 4 - 22.

Click on the New button 
to create a new 
analysis table.
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Survey Crafter Professional displays step 1 of the New Analysis 
dialog box.

Figure 4 - 18: Step 1 of the New Analysis dialog box.

3 Select Build an analysis table or chart yourself.

4 Click on the Next button.

Select this option to 
build an analysis table 
yourself.
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Survey Crafter Professional displays step 2 of the New Analysis 
dialog box.

Figure 4 - 19: Step 2 of the New Analysis dialog box.

5 Enter a name and description for the table.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

6 Click on the Finish button.

Enter a name and 
description for the 
analysis.
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Survey Crafter Professional displays a new empty analysis table in an 
Analysis window.

Figure 4 - 20: A new empty analysis table.

7 Go to the section “Defining a Table Title and Headings” below.

Defining a Table Title and Headings 

A title and headings help viewers quickly understand the information a 
table shows. You can define both row and column headings for a table. 
Row headings fill the table’s leftmost columns. Titles and column 
headings fill the table’s topmost rows. You can reserve multiple columns 
and rows for row and column headings. 

Defining a title and headings involves first specifying the region of the 
table in which they will appear and then entering their text. You need to 
define the region of the table in which they appear so that if you view the 
table as a chart, Survey Crafter Professional knows which cells to use as 
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chart labels and which cells to plot as data. Figure 4 - 21 illustrates these 
different regions of a table.

Figure 4 - 21: Title and headings regions of a table.

Values to plot on 
the chart

Two levels of 
row headings

Title and two levels 
of column headings
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• To define a table title and headings

1 From the View menu, choose Analysis Options.

2 In the Number Of Columns field under Table Headings, type the 
number of columns to reserve for row headings.

3 In the Number Of Rows field, type the number of rows to reserve for 
column headings. Include a row for the table title.

For example, if you plan to have one row of column headings and a 
table title, enter 2.

Figure 4 - 22: The Analysis Options dialog box.

4 If you want to keep row or column headings visible regardless of the 
table region in view, select one or both Nonscrolling check boxes.

5 Click on the OK button to close the Analysis Options dialog box.

6 To type title and heading text, do the following in the Analysis 
window for the title and each heading:

• Select a cell to contain the title or heading text.

• From the Edit menu, choose Edit Value.

These heading settings for 
the table in Figure 4 - 21 
indicate that the table has 
two columns of row 
headings and three rows of 
column headings including 
the table title.
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• In the Value Expression field, type the title or heading text enclosed 
in double quotes. Then click on the OK button.

Figure 4 - 23: Title or heading text in the Edit Value dialog box.

7 Go to the section “Defining Table Cell Values” below.

Defining Table Cell Values 

Once you have set up the table’s framework of headings, you are ready to 
define the values that appear in the cells in the table’s body. To define 
these values, write an expression in each table cell that evaluates to a 
single value or to multiple values.

For example, MEAN(age) is a valid expression for a table cell because it 
returns one number. STANDARDIZE(age) is also a valid expression 
because it returns a different number for each respondent.

Many of Survey Crafter Professional’s functions let you specify a subset 
of respondents to include in the calculation. A short cut for defining 
subsets of respondents is to use row filters, column filters and table filters. 
For instructions on defining row, column and table filters, see the section 
“Specifying Row, Column and Table Filters” on page 4 - 41.  
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• To define values to appear in table cells

1 Select the cell for which you want to define an expression.

2 From the Edit menu, choose Edit Value or double-click in the cell.

3 In the Value Expression field, enter the expression for calculating the 
cell’s value. 

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

Figure 4 - 24: An expression for a table cell’s value in the Edit Value dialog box.

To include row, column and table filters in an expression, follow the 
syntax in Table 4 - 1 .

Table 4 - 1: Syntax for row, column and table filters.

Filter type Syntax in expression Example

Row filter $ROW MEAN(age, $ROW)

Column filter $COL MEAN(age, $COL)

Table filter $TABLE MEAN(age, $TABLE)

All filters Add the operator AND 
between the filters

MEAN(age, $ROW AND $COL AND 
$TABLE)

Expression Builder 
button
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4 Click on the OK button.

5 Repeat steps 1 through 4 for each cell that will display a calculated 
value.

For instructions on copying a cell’s expression to other cells, see the 
section “Copying Cell Properties to Other Table Cells” on page 
4 - 51.

6 When each cell’s expression is defined, do one of the following to 
calculate the cells’ values:

• From the Edit menu, choose Update.

• Click on the Update button on the toolbar.

Update button
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Opening Existing Tables

Open an existing table to view or edit its contents.

• To open an existing table

1 Select the Analyses tab of the Study window.

2 Select the table you want to view.

Figure 4 - 25: The Analyses tab of the Study window.

3 Click on the Edit button on the tab.

At the Analyses 
tab, select the 
table you want 
to view.
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Survey Crafter Professional displays the table in an Analysis window.

Note  If a cell contains the message #Update, its value needs to be 
recalculated. Choose the Update command from the Edit menu. 

If a cell contains the message #Error, Survey Crafter Professional 
could not evaluate the cell’s expression. To correct the error, 
double-click in the cell and edit the expression in the Value 
Expression field.
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Copying Existing Tables

Copy an existing table to edit its contents without modifying the original 
table.

• To copy an existing table

1 Select the Analyses tab of the Study window.

2 Select the table you want to copy.

Figure 4 - 26: The Analyses tab of the Study window.

3 Click on the Copy button on the tab.

The Analysis Information dialog box appears. 

4 In the Name field, enter a new name for the table.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

5 In the Description field, enter a new description of the table. 

At the Analyses 
tab, select the 
table you want 
to copy.
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Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

6 Click on the OK button.

Survey Crafter Professional displays the table in the Analysis 
window.

Note  If a cell contains the message #Update, its value needs to be 
recalculated. Choose the Update command from the Edit menu. 

If a cell contains the message #Error, Survey Crafter Professional 
could not evaluate the cell’s expression. To correct the error, 
double-click in the cell and edit the expression in the Value 
Expression field.
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Specifying Row, Column and Table Filters

The calculations in a table may include all respondents in the data set or 
only a subset. Row, column and table filters are short cuts for selecting 
subsets of respondents for calculations. 

Row, colum and table filters are expressions that evaluate to TRUE or 
FALSE for each respondent in the data set. Respondents for whom the 
expression is TRUE are included in the calculation. For example, if 
“Females” is the label for a table’s column, you could create a column 
filter such that the column’s calculations included only female 
respondents. 

Please read the section “About Row, Column and Table Filters” below to 
learn about how these filters can help you create tables.

About Row, Column and Table Filters

A row filter is an expression that determines those respondents to be 
included in the calculations in the row’s cells—for example, respondents 
who own homes. A column filter is an expression that determines those 
respondents to be included in the calculations in the column’s cells—for 
example, respondents under age 30.  A table filter is an expression that 
determines those respondents to be included in the calculation in all 
cells—for example, respondents who made purchases in the last year.

After you define the filters by using the Edit Filters command, you can 
use the row, column and table filter syntax ($ROW, $COL and $TABLE, 
respectively) as the condition argument in functions. Using this syntax 
tells Survey Crafter Professional to apply the filters to the data set and to 
include in the calculation only those respondents passing through the 
filters.

The example below illustrates how using row, column and table filters 
simplifies the process of defining values to appear in table cells.
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Using Row, Column and Table Filters:  An Example
Chris collected data on respondents’ preferred fast food restaurants by 
using a list of five choices:  Burger World, King Taco, Broilin’ Bill’s, The 
Chicken Coop, and Marsha’s Mex. Now Chris wants to create a table that 
shows the mean age of males and females who preferred each of the five 
restaurants. The empty table is shown in Figure 4 - 27.

Figure 4 - 27: Row and column headings in a table that will show mean ages by favorite 
restaurant and gender.

Chris defined the two column filters as follows. The Males column should 
show information on only the males in the data set. Since the study data 
set stores information on respondents’ genders in the category variable 
gender, the Males column should include all respondents for whom the 
variable gender contains the value ‘male’. 

 Mean age by preferred restaurant

Favorite restaurant Males Females

Burger World

King Taco

Broilin’ Bill’s

The Chicken Coop

Marsha’s Mex
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To define this column filter, Chris selected the Males column in the 
Analysis window and then chose Edit Filters from the Edit menu. In the 
Column Filter field, Chris entered the expression shown in Figure 4 - 28.

Figure 4 - 28: A column filter entered in the Edit Filters dialog box.

Similarly, the Females column filter is gender = ‘female’ or all 
respondents for whom gender contains the value ‘female’.

Chris then defined the five row filters as follows. The row labeled The 
Chicken Coop should show information only on respondents who said 
The Chicken Coop is their favorite restaurant. Since the study data set 
stores information on respondents’ favorite fast food restaurants in the 
category variable fave_rest, the row should include all respondents for 
whom the variable fave_rest contains the value ‘chickencoop’. 
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(‘chickencoop’ is the category name Chris assigned to The Chicken 
Coop.) Figure 4 - 29 shows the row filter in the Edit Filters dialog box.

Figure 4 - 29: A row filter entered in the Edit Filters dialog box.

 Figure 4 - 30 shows these filters in the table. The filters for the other rows 
and columns are analogous.
 

Figure 4 - 30: Filters for the column Males and the row The Chicken Coop.

The row filter is 
fave_rest = 
‘chickencoop’, that is, 
all respondents who said 
The Chicken Coop is 
their favorite restaurant.

 Mean age by preferred restaurant

Favorite restaurant Males Females

Burger World

King Taco

Broilin’ Bill’s

The Chicken Coop

Marsha’s Mex

The column filter is gender = ‘male’, that 
is, all respondents in the data set who said 
they were male.
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To calculate the mean age in the table cell Males:The Chicken Coop, 
Chris assigned the cell the expression MEAN(age, $ROW AND $COL) 
where $ROW and $COL are the syntax for the row filter and column filter.

Since Chris already defined the row and column filters, Survey Crafter 
Professional knows exactly which respondents to include in the mean 
calculation. Using the row and column filter syntax $ROW and $COL  is 
equivalent to writing the expression as MEAN(age, gender = ‘male’ 
AND fave_rest = ‘chickencoop’). This expression tells Survey 
Crafter Professional to calculate the average value in age for male 
respondents who said that The Chicken Coop is their favorite restaurant. 
Figure 4 - 31 shows the cell’s expression.

Figure 4 - 31: The expression for the value to appear in the cell in the “Males” column and the “The Chicken Coop” 

row.

Three Ways Using Row, Column and Table Filters Save 
Time
Using row, column and table filters saves time in three ways:

• They let you avoid writing an expression for selecting respondents to 
include in every cell’s calculation. 

 Mean age by preferred restaurant

Favorite restaurant Males Females

Burger World

King Taco

Broilin’ Bill’s

The Chicken Coop 32.5

Marsha’s Mex

The expression for this cell is MEAN(age, $ROW AND $COL). Its 
equivalent is MEAN(age, gender = ‘male’ AND fave_rest = 
‘chickencoop’). The former takes advantage of the defined row and 
column filters. 
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If you define a table filter or a filter for each row and column, you can 
then include the $TABLE, $ROW and $COL syntax in cells’ expressions 
rather than writing a unique expression to select respondents for each 
cell. The larger the table, the more time using row, column and table 
filters saves. Furthermore, entering a unique expression to select 
respondents for each cell’s calculation is both tedious and error-prone.

• If you decide you want to change the respondents included in a row or 
column’s calculations, you only need to edit one expression. 

Suppose Chris decided to calculate the mean age of male and female 
respondents according to data collected on their favorite types of 
vehicles instead of favorite fast food restaurants. Rather than editing the 
expression in all ten of the table’s cells, Chris could just edit the table’s 
five row filter expressions. For example, for the fourth row, Chris could 
change the row filter from fave_rest = ‘chickencoop’ to 
fave_vehicle = ‘convertible’.  

• Using row, column and table filters allows you to use the Paste and 
Paste Special commands to copy one cell’s expression to other cells in 
the table.

In the example above, the expression for the cell Males:The Chicken 
Coop cell uses the generic syntax $ROW and $COL for row and column 
filters you defined. Chris can enter the expression as MEAN(age, $ROW 
AND $COL) for one cell and then copy and paste the expression to the 
other nine cells in the table. Survey Crafter Professional will calculate 
the same MEAN (age, $ROW AND $COL) expression for each cell, but 
because the cells all have different row and column filters, the value in 
each cell is different. 

Row, Column and Table Filters are not Automatically 
Included in Calculations
Even if you define a row, column or table filter, Survey Crafter 
Professional does not automatically apply it to select respondents for a 
cell’s calculation. You must enter the $ROW, $COL or $TABLE syntax in 
the expression. In addition, if you enter $ROW, $COL or $TABLE in an 
expression but did not define filters in the Edit Filters dialog box, Survey 
Crafter Professional includes all respondents in the calculation.
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Because row, column and table filters are optional, you can override them 
and choose an entirely different set of respondents for a cell’s expression. 
For example, Chris could show the mean age for the entire sample in a 
note below the body of the table by using the expression MEAN(age), 
which does not use the column’s filter. See Figure 4 - 32.

Figure 4 - 32: Note text in a cell below the body of the table.

Defining Row, Column and Table Filters

The procedures below explain how to write expressions for row filters, 
column filters and table filters. Note that Survey Crafter Professional does 
not automatically limit its calculations to respondents that pass through a 
filter. You must include the filter syntax in the cell’s expression. For 
information on including the filter syntax in a cell’s expression, see the 
procedure in the section “Defining Table Cell Values” on page 4 - 34. 

• To specify a row filter

1 In the table in the Analysis window, select the row for which you 

 Mean age by preferred restaurant

Favorite restaurant Males Females

Burger World

King Taco

Broilin’ Bill’s

The Chicken Coop

Marsha’s Mex

Mean age of sample

This column’s filter is 
gender = ‘male’.

This cell is in a 
column with the filter 
gender = ‘male’, 
but you can ignore 
the column’s filter to 
show a value for a 
different set of 
respondents such as 
the entire sample.
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want to define a filter.

2 From the Edit menu, choose Edit Filters or click on the Edit Filters 
button on the toolbar.

3 In the Row Filter Expression field, type the expression that 
determines the subset of respondents to include in the row’s 
calculations.

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

Figure 4 - 33: Defining a row filter in the Edit Filters dialog box.

4 Click on the OK button.

• To specify a column filter

1 In the table in the Analysis window, select the column for which you 
want to define a filter.

2 From the Edit menu, choose Edit Filters.

3 In the Column Filter Expression field, type the expression that 
determines the subset of respondents to include in the column’s 
calculations. 

Edit Filters button

Respondents who said 
Burger World is their 
favorite restaurant pass 
through this row filter. 
(Information on favorite 
restaurants is stored in the 
variable fave_rest.)
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For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

Figure 4 - 34: Defining a column filter in the Edit Filters dialog box.

4 Click on the OK button.

• To specify a table filter

1 In the table in the Analysis window, select any cell.

2 From the Edit menu, choose Edit Filters.

3 In the Table Filter Expression field, type the expression that 
determines the subset of respondents to include in the table’s 
calculations.

Male respondents pass 
through this column filter. 
(Information on genders is 
stored in the variable 
gender.)
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For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

Figure 4 - 35: Defining a column filter in the Edit Filters dialog box.

4 Click on the OK button.

Respondents over 18 and 
under 21 pass through this 
table filter. (Information on 
age is stored in the variable 
age.)
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Copying Cell Properties to Other Table Cells

If several cells in a table use the same expression, save time by copying 
and pasting the expression into the other cells that use it. Besides the 
expression, you can copy and paste the cell’s formatting, row filter, and 
column filter. 

If you paste a row or column filter, Survey Crafter Professional 
overwrites the host cells’ row and column filters with the copied cells’ 
filters. If you did not define row or column filters for the copied cells, the 
copied cells use the filters of the host cells.

• To copy cell properties to other table cells

1 Select the cell or range with the properties you want to copy. 

2 From the Edit menu, choose Copy. 

3 Select the cell or range into which you want to paste the properties. 

4 From the Edit menu, choose Paste Special.

5 In the Paste Special dialog box, select check boxes corresponding to 
the copied cell’s properties that you want into paste to the selected 
cell or range.

Figure 4 - 36: The Paste Special dialog box.

6 Click on the OK button.

7 Do one of the following to calculate the values in the table’s cells:

• From the Edit menu, choose Update.Update button
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• Cick on the Update button on the toolbar.

Note  If the value #Error appears in the cell, Survey Crafter 
Professional could not evaluate the cell’s expression. Double-
click on the cell and edit the expression in the Value Expression 
field.
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Formatting Tables

You can enhance the format of Survey Crafter Professional tables for use 
in a report or presentation. This section covers the following formatting 
procedures:

• Aligning Table Cell Values

• Centering a Cell’s Contents across Other Cells

• Changing Fonts in Table Cells

• Applying and Removing Borders on Table Cells

• Applying and Removing Patterns on Table Cells

• Specifying Number Formats

• Making Row and Column Headings Nonscrolling

• Typing and Editing Text in Table Cells

Aligning Table Cell Values

You can control the horizontal and vertical position of text and values in 
table cells.

• To align cell values

1 In the Analysis window, select the cells with the values to align.

2 From the Format menu, choose Cells, and then select the Alignment 
tab.
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3 In the Alignment tab, specify the horizontal and vertical positioning 
of cell values.

Figure 4 - 37: The Alignment tab of the Format Cells dialog box.

4 To allow text to wrap to a new line if it exceeds the cell’s width, select 
the Wrap Text check box.

5 Click on the OK button.

The General option left 
justifies text and right 
justifies numbers.
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Centering a Cell’s Contents across Other Cells

By centering a cell's contents across other cells, you can make a cell 
straddle other cells. For example, Figure 4 - 38 shows the table title 
centered over column headings.

Figure 4 - 38: One cell’s contents centered across several cells.

• To center a cell’s contents across other cells

1 In the Analysis window, select the range of cells containing:

• The text you want to center

The table 
title is 
centered 
across the 
cells A1 
through F1.
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• The cells within which you want to center the text

Figure 4 - 39: Selecting the cells across which you want to center text.

2 From the Format menu, choose Cells, and then click on the 
Alignment tab.

3 In the Alignment tab, select Center Across Cells from the Horizontal 
drop-down list.

4 Click on the OK button.

Survey Crafter Professional centers the text across the selected cells.

Changing Fonts in Table Cells

You can use the formatting toolbar buttons to control the font, font style 
and size of text and values in table cells. You can also use the Format 
Cells dialog box to control additional formatting options including the 
line effects and color of text and values in table cells.

Cell A1 
contains the 
text to center. 
Cells B1 
through F1 
are also 
selected 
because the 
text will be 
centered 
across the 
range of cells 
A1:F1.
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• To change fonts in table cells using the Format Cells dialog box

1 In the Analysis window, select the cells in which you want to change 
the font.

2 From the Format menu, choose Cells, and then select the Font tab.

3 Change any settings in the Font tab.

Figure 4 - 40: The Font tab of the Format Cells dialog box.

4 Click on the OK button.

Applying and Removing Borders on Table Cells

You can apply borders in a variety of styles and colors to table cells. You 
can remove borders from one or more sides of a table cell or range.

• To apply borders to table cells

1 In the Analysis window, select the cell or cells to which you want 

The Sample field shows the 
typography applied to 
selected characters.
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borders applied.

2 From the Format menu, choose Cells, and then select the Border tab.

3 From the Line Style palette, select a line style.
 

Figure 4 - 41: The Border tab of the Format Cells dialog box.

4 From the Color palette, select a line color.

5 Select the buttons corresponding to the sides of the cells you want 
borders applied to.

6 Click on the OK button.

• To remove borders from table cells

1 In the Analysis window, select the cell or cells from which you want 
borders removed.

2 From the Format menu, choose Cells, and then select the Border tab.

3 Unselect the buttons corresponding to the sides of the cells you want 
borders removed from.

4 Click on the OK button.

To apply a border to only 
the perimeter of the entire 
selection, click on the 
outline button.
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Applying and Removing Patterns on Table Cells

You can apply patterns in a variety of colors and styles to table cells. You 
can also remove patterns from table cells.

• To apply a pattern to table cells

1 In the Analysis window, select the cell or cells to which you want a 
pattern applied.

2 From the Format menu, choose Cells, and then select the Patterns tab.

3 From the Fill Color palette, select a color for the pattern’s fill color. 

4 From the Pattern Color palette, select a color for the pattern’s color. 

5 From the Fill Pattern pallete, select a pattern style.

Figure 4 - 42: The Patterns tab of the Format Cells dialog box.

6 Click on the OK button.

• To remove a pattern from table cells

1 Select the table cell or cells from which you want the pattern 
removed.

2 From the Format menu, choose Cells, and then select the Patterns tab.

From the Fill Pattern 
palette, select a pattern for 
combining the foreground 
and background colors you 
chose.
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3 From the Fill Pattern palette, select None.

4 Click on the OK button.

Specifying Number Formats

By applying number formats to table cells, you can control how numbers 
appear in the cells. For example, you can display percent symbols after 
numbers or show numbers in scientific notation. Number formats do not 
affect cells containing text.

You can apply number formats to cells even if they do not currently 
contain numbers. When Survey Crafter Professional calculates and 
displays numbers in the cells, it will use the number format you specified 
for the cells.

• To specify number formats

1 In the Analysis window, select the cells to which you want number 
formats applied.

2 From the Format menu, choose Cells, and then select the Number tab.

3 From the Category list, select a category of formats.

4 From the Type list, select a format to apply to the selected cells.

5 To customize the format, edit it in the field above the Type list.
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Survey Crafter Professional saves the edited format as a new format 
in the selected category without overwriting the original.

Figure 4 - 43: The Number tab of the Format Cells dialog box.

6 Click on the OK button.

Survey Crafter Professional applies the formatting to numbers in the 
selected cells.

Making Row and Column Headings Nonscrolling

Making row and column headings nonscrolling keeps them visible 
regardless of the table portion in view.

• To make row and column headings nonscrolling

1 With the table visible in the Analysis window, choose Analysis 
Options from the View menu.

2 Do one or both of the following in the Analysis Options dialog box:

• To make row headings nonscrolling, select the Nonscrolling check 
box to the right of Number of Columns.

For example, to display 
three decimal places 
instead of two, select the 
0.00 format and then add 
a third zero.
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• To make column headings nonscrolling, select the Nonscrolling 
check box to the right of Number of Rows.

3 Click on the OK button.

Typing and Editing Text in Table Cells

You can add or edit text in table cells. For example, you can enter a 
comment on a value appearing in the table as Figure 4 - 44 shows.

Figure 4 - 44: Tables in the Analysis window may include cells showing text.

• To type text in a table cell

1 In the Analysis window, select the cell in which you want to type text. 

2 From the Edit menu, choose Edit Value. 

3 In the Value Expression field, type the text you want to appear in the 
cell.

Note text in 
a table cell
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 Enclose the text in double quotes.

Figure 4 - 45: Text for a table cell entered in the Edit Value dialog box.

4 Click on the OK button.

• To edit text in a table cell

1 In the Analysis window, select the cell in which you want to type text. 

2 From the Edit menu, choose Edit Value. 

3 In the Value Expression field, edit the text.

Enclose the text in double quotes.

4 Click on the OK button.
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Repositioning and Resizing Rows, Columns, 
and Table Cells

Survey Crafter Professional provides numerous ways to manipulate rows, 
columns, one cell, or a range of cells. This section covers the following 
procedures:

• Inserting Rows and Columns in a Table

• Inserting a Variable in a Table

• Inserting Cells in a Table

• Hiding and Showing a Table’s Rows and Columns

• Changing Dimensions of Table Cells

• Copying, Cutting, and Pasting Table Cells

• Clearing and Deleting Table Cells

Inserting Rows and Columns in a Table

You can insert one or more rows and columns in a table. Survey Crafter 
Professional inserts rows above the selected row and inserts columns to 
the left of the selected column.

• To insert a row in a table

1 In the Analysis window, select the row immediately below where you 
want to insert a row.
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To insert multiple rows, click in a row and drag the pointer across the 
number of rows you want to insert.

Figure 4 - 46: Selecting a row before inserting a row.

2 From the Insert menu, choose Rows.

The inserted row has the default height. 

Note  To change the default row height, from the Format menu, 
choose Row and then choose Height. Click on the Change Default 
button. Select the Custom option and enter a new height. Then click 
on the OK button. Then click on the OK button again. The new 
default height applies to subsequent rows you insert.

For example, 
to insert a row 
between rows 
1 and 2, select 
row 2.
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• To insert a column in a table

1 In the Analysis window, select the column immediately to the right of 
where you want to insert a column.

To insert multiple columns, click in a column and drag the pointer 
across the number of columns you want to insert.

Figure 4 - 47: Selecting a column before inserting a column.

2 From the Insert menu, choose Columns.

The inserted column has the default width.

Note  To change the default column width, from the Format menu, 
choose Column and then choose Width. Click on the Change 
Default button. In the Width field, enter a new width as the number 
of characters (from 0 and 120) you want to appear in the column. 
Then click on the OK button. Then click on the OK button again. 
The new default width applies to subsequent columns you insert.

For example, 
to insert a 
column 
between 
columns B 
and C, select 
column C.
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Inserting a Variable in a Table

You can insert a category variable into a table’s rows or columns by using 
the Variable command. When you insert a category variable, Survey 
Crafter Professional inserts a row or column for each category, sets up the 
row or column filter, and uses the variable’s name and prompts as row or 
column headings.

When you insert a category variable, any NV and NR values in the 
variable are grouped in a category called “Missing.”

• To insert a variable in a table by using the Variable command

1 Open the table in which you want to insert a category variable.

2 Select one of the following:

• The row you want to insert the variable above

• The column you want to insert the variable to the left of

3 From the Insert menu, choose Variable or click on the Insert Variable 
button on the toolbar.

4 Do one of the following:

• In the Insert Variable dialog box’s Name field, type the name of the 
category variable you want to insert. 

Insert Variable button
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• Scroll through the list of variables and select the variable to insert.

Figure 4 - 48: The Insert Variable dialog box.
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5 Click on the OK button.

To accommodate the inserted variable, Survey Crafter Professional 
shifts rows down or columns to the right. In Figure 4 - 49, the 
variable cmp_readysetgo was inserted in column C and the variable 
gen_companysize in row 3.

Figure 4 - 49: “Missing” categories for inserted category variables.

Survey 
Crafter 
Professional 
includes 
Missing 
categories in 
inserted 
variables to 
accommodate 
NR and NV 
values in the 
variables.
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Inserting Cells in a Table

You can insert a cell or range of cells in a table.

• To insert cells in a table

1 In the Analysis window, select a cell or range of cells matching the 
size of the range to insert.

2 From the Insert menu, choose Cells.

3 In the Insert Cells dialog box, select the option for repositioning 
surrounding cells. 

Note  When you insert a category variable in a table, Survey Crafter 
Professional expects to display two levels of headings, one for the variable 
name and one for the variable’s prompts. 

If you defined more than two levels of headings, Survey Crafter Professional 
populates only the bottom two levels (when inserting a variable in a column) or 
two rightmost levels (when inserting a variable in a row) with the variable’s 
name and prompts. If you defined only one level of heading, Survey Crafter 
Professional displays only the variable’s prompts. If you defined no levels of 
heading, Survey Crafter Professional does not display the variable’s name or 
prompts.

For instructions on defining levels of headings, see “Defining a Table Title and 
Headings” on page 4 - 31.
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To insert as many rows or columns as you selected in step 1, select 
Entire Row or Entire Column.

Figure 4 - 50: The Insert Cells dialog box.

4 Click on the OK button. 

Hiding and Showing a Table’s Rows and 
Columns

You can customize the Analysis window display by hiding and showing a 
table’s rows and columns. Hide a row or column to remove it from the 
Analysis window display. Hiding rows or columns does not delete their 
data. Show a row or column to return it to the Analysis window display.

• To hide a table’s rows or columns

1 In the Analysis window, select the rows or columns you want to hide.

2 To hide rows, from the Format menu, choose Row and then choose 
Hide. To hide columns, from the Format menu, choose Column and 
then choose Hide.

Survey Crafter Professional removes the rows or columns from the 
Analysis window display.

• To show a table’s rows or columns

1 In the Analysis window, click and drag the pointer over the rows or 
columns bordering the rows or columns you want to show. 

If you selected a 2x3 
region in step 1, selecting 
Entire Row inserts two 
rows and selecting Entire 
Column inserts three 
columns.
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Figure 4 - 51: Selecting the rows bordering a hidden row.

2 To show rows, from the Format menu, choose Row and then choose 
Unhide. To show columns, from the Format menu, choose Column 
and then choose Unhide.

Survey Crafter Professional returns the rows or columns to the 
Analysis window display.

Changing Dimensions of Table Cells

You can define a column’s width or a row’s height or have Survey Crafter 
Professional automatically size the row or column to fit the largest value 
it contains.

For 
example, to 
show row 6, 
select rows 
5 and 7.
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Setting Cell Dimensions Yourself
You can change cell dimensions by dragging row or column borders or, 
for more precision, by using the Row Height and Column Width dialog 
boxes.

• To change cell dimensions by dragging borders

1 In the Analysis window, position the pointer on the border between 
the selectors for the column or row you want to adjust.

2 Resize the entire row or column by clicking and dragging the border.

• To change row height by using a dialog box

1 In the Analysis window, select one or more rows.

2 From the Format menu, choose Row and then choose Height.

3 In the Format Row Height dialog box, do one of the following:

• Select Custom and type the rows' new height in inches.

• Select the Default Height check box to use the default row height.

Figure 4 - 52: The Format Row Height dialog box.

4 Click on the OK button.

• To change column width by using a dialog box

1 In the Analysis window, select one or more columns.

2 From the Format menu, choose Column and then choose Width.

3 In the Format Column Width dialog box, do one of the following:

If you want to enter a 
decimal value, type a 0 
first.
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• In the Width field, type the columns’ new width. Enter the width as 
the number of characters (from 0 to 120) to appear in the column’s 
cells.

• Select the Default Width check box to use the default column 
width.

Figure 4 - 53: The Format Column Width dialog box.

4 Click on the OK button.

Sizing Table Cells to Fit Values Automatically
Survey Crafter Professional can set a column's width to fit the column's 
widest value and a row's height to fit the row's tallest value.

• To size table cells to fit values automatically

1 In the Analysis window, select a column or row.

2 From the Format menu, choose Row and then choose Auto Size 
Selection or choose Column and then choose Auto Size Selection.

Survey Crafter Professional resizes the column or row to 
accommodate the widest or tallest value.

Copying, Cutting, and Pasting Table Cells

Use the Copy and Cut commands from the Edit menu to transfer table 
cells to the clipboard. Survey Crafter Professional features several options 
for pasting cells in tables.

If you want to enter a 
decimal value in either 
field, type a 0 first.
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Copying and Cutting Table Cells
Follow the steps below to copy or cut table cells.

• To copy table cells

1 In the Analysis window, select the cells you want to copy.

2 From the Edit menu, choose Copy or click on the Copy button on the 
toolbar.

• To cut table cells

1 In the Analysis window, select the cells you want to cut.

2 From the Edit menu, choose Cut or click on the Cut button on the 
toolbar.

Pasting Table Cells
Use the Edit menu’s Paste or Paste Special commands to transfer cells 
from the clipboard to a table. 

The Paste command automatically pastes cells’ formatting and 
expressions. The Paste Special command gives you the option of pasting 
one or both of these cell properties plus the selected cells’ row filters and 
column filters.

• To paste table cells

1 In the Analysis window, select the range of cells into which you want 
to paste the cells currently on the clipboard.

The size of the range you select should be the same as or a multiple of 
the range of cells on the clipboard. For example, you can paste a 2x2 
cell range into a 4x4 range but not into a 2x3 range.

2 From the Edit menu, choose Paste or click on the Paste button on the 
toolbar.

3 To recalculate the cells’ values, click on the Update button on the 
toolbar or choose the Edit menu’s Update command.

Note  If the value #Error appears in the cell, Survey Crafter 
Professional could not evaluate the cell’s expression. Double-click 
on the cell and edit the expression in the Value Expression field.

Copy button

Cut button

Paste button
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• To paste cells using the Paste Special command

1 In the Analysis window, select the range of cells into which you want 
to paste the cells currently on the clipboard.

The size of the range you select should be the same as or a multiple of 
the range of cells on the clipboard. For example, you can paste a 2x2 
cell range into a 4x4 range but not into a 2x3 range.

2 From the Edit menu, choose Paste Special.

3 In the Paste Special dialog box, select the check boxes corresponding 
to the cell attributes you want to paste into the selected range.

Figure 4 - 54: The Paste Special dialog box.

4 Click on the OK button.

5 Cick on the Update button on the toolbar to recalculate the cells’ 
values.

Clearing and Deleting Table Cells

Clear a cell if you want to remove selected cell properties but keep the 
cell in the table. Delete a cell if you want to remove the cell and all its 
properties.

• To clear table cells

1 In the Analysis window, select the cells you want to clear.

Note  If the value #Error appears in the cell, Survey Crafter 
Professional could not evaluate the cell’s expression. Double-click 
on the cell and edit the expression in the Value Expression field.

If you select the Row Filter 
or Column Filter check 
boxes, Survey Crafter 
Professional overwrites the 
host cells’ filters with those 
of the cells on the clipboard.
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2 From the Edit menu, choose Clear.

3 In the Clear dialog box, select the check boxes corresponding to the 
properties you want to remove from the selected cells.

Figure 4 - 55: The Clear dialog box.

4 Click on the OK button.

• To delete table cells

1 In the Analysis window, select the cells you want to delete.

2 From the Edit menu, choose Delete.

3 In the Delete dialog box, select an option for rearranging neighboring 
cells after the selected cells are deleted.

Figure 4 - 56: The Delete dialog box.

4 Click on the OK button.

Choose Entire Row to delete 
the rows containing the 
selected cells. Choose 
Entire Column to delete the 
columns containing the 
selected cells.
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Updating Tables

Update a table to calculate or recalculate the values in the table’s cells. 
After you have done any of the following, #Update may appear in one or 
more of a table’s cells, indicating that you need to update the table: 

• Entered a new expression for a cell

• Changed a cell’s expression

• Changed a row, column or table filter used by a cell’s expression

• Changed the expression for a computed variable used by a cell’s 
expression

• Copied and pasted an expression to a cell having a different row or 
column filter

• Changed the portion of the study’s data set a cell’s expression uses

• Added or deleted a record in the study’s data set

• To update a table

With the table open in the Analysis window, do one of the following:

• From the Edit menu, choose Update.

• Click on the Update button on the toolbar.

Survey Crafter Professional recalculates the cells’ values.Update button
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Displaying a Table’s Data as a Chart

You can display an entire table or a portion of a table as a chart. You can 
then customize the chart’s format.

• To view the entire table as a chart

1 Open the table you want to view as a chart.

2 From the View menu, choose Chart, or click on the Chart button on 
the toolbar.

The chart appears in the Analysis window. For instructions on 
formatting the chart, see Chapter 5, “Analyses: Charts.”

• To view a portion of the table as a chart

1 Open the table you want to view as a chart.

2 From the View menu, choose Analysis Options.

3 In the Chart Region field, enter the range of cells to chart. Separate 
the range’s upper left and lower right cells with a colon.

For example, entering B2:D5 plots data in columns B, C, and D and 
in rows 2, 3, 4, and 5.

To view the entire table as a chart, delete the range appearing in the 
Chart Region field.

4 Click on the OK button.

5 From the View menu, choose Chart or click on the Chart button on 
the toolbar.

The plotted data appears in the Analysis window. 

Note  The range in the Chart Region field stays the same even if the 
charted values change position in the table. Suppose you enter a 
range in the Chart Region field and then change the position of the 
charted data (for example, you insert rows or cut and paste the 
charted data). To see the same chart as before, you need to enter the 
charted data’s new range in the Chart Region field.

Chart button
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Sorting Table Cells

You can sort a selected range of cells in an analysis table. You can have 
the cells sorted vertically or horizontally, using up to 3 columns or rows to 
determine the sort order.

Sorting a Selected Range of Cells

• To sort a selected range of cells

1 At the Study window’s Analyses tab, open the table you want to work 
on.

2 Using your mouse or the keyboard, select the range of cells you want 
to sort.

Your selection must include cells from the columns or rows you want 
to use to determine the sort order.

3 From the Edit menu, choose Sort Cells or click on the Sort Cells 
button on the toolbar.

Survey Crafter Professional displays the Sort Cells dialog box.

4 Click on Top to bottom to sort the cells vertically or Left to right to 
sort the cells horizontally.

5 Click on the drop down under Sort by to choose the primary column 
or row to use to determine the sort order.

If you have chosen Top to bottom, the drop down will list all of the 
columns that are contained in the selected range. If you have chosen 
Left to right, the drop down will list all of the rows that are contained 
in the selected range.

6 Choose either ascending or descending for the column or row.

7 If you want, click on the drop down under Then by to choose the next 
column or row to use to determine the sort order. Also choose either 
ascending or descending for the column or row.

The selected column or row will be used when the values of the 
primary column or row are equal.

Sort Cells button
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8 If you want, click on the drop down under the second Then by to 
choose the final column or row to use to determine the sort order. 
Also choose either ascending or descending for the column or row.

The selected column or row will be used when the values of both the 
primary and secondary columns or rows are equal.

9 Click on the OK button.

Survey Crafter Professional will sort the selected range of cells 
according to the selections you made in the Sort Cells dialog box.
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Exporting Tables

You can export an entire table or a selected range of cells to use in a 
report, presentation, or spreadsheet. You can export a table to other 
applications using the clipboard or you can export a table to a file.

Exporting a Table using the Clipboard

• To export an entire table using the clipboard

1 At the Study window’s Analyses tab, open the table you want to 
export.

2 From the Edit menu, choose Copy All.

Survey Crafter Professional copies the table’s title, headings, and data 
to the clipboard in text, HTML, bitmap and metafile formats.

3 Open the file you want to paste the table into.

4 Paste the table into the file.

If this file’s application has a Paste Special command, you can use it 
to specify whether you want to paste the table as a metafile, which 
you can resize, unformatted text or HTML, which you can edit, or as 
a bitmap, which you cannot edit. If the application only has a Paste 
command, the table will appear in the file as unformatted text.

• To export a range of cells using the clipboard

1 Open the table with the cells you want to export.

2 Select the range of cells.

3 From the Edit menu, choose Copy or click on the Copy button on the 
toolbar.

Survey Crafter Professional copies the region to the clipboard in text, 
HTML, bitmap and metafile formats.

4 Open the file you want to paste the cells into.

5 Paste the cells into the file.

Copy button
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If this file’s application has a Paste Special command, you can use it 
to specify whether you want to paste the table as a metafile, which 
you can resize, unformatted text or HTML, which you can edit, or as 
a bitmap, which you cannot edit. If the application only has a Paste 
command, the table will appear in the file as unformatted text.

Exporting a Table to a File

To enhance a table's format or to publish the table in another format, you 
can also export a table to a file. You can export a table to the following 
types of files:

• Microsoft Excel 97 workbook (XLS) file

• HyperText Markup Language (HTM) file

• Text (Tab Delimited) file

• To export an entire table to a file

1 At the Study window’s Analyses tab, open the table you want to 
export.

2 From the File menu, choose Export.

Survey Crafter Professional displays the Save Analysis Table File As 
dialog box. 

3 From the files of Type drop-down list, select the type of file you want 
to save.

4 From the Locations (Save in) drop-down list, choose the location to 
save the file.

5 In the Folders list, select the folder in which you want to save the file.

6 In the File name field, type the name of the file to save.

7 Click on the Save button.

Tip  If you want to export a table to an HTML file, you may want to 
review the web analysis HTML option settings in the Web Analysis 
Setup dialog box. Survey Crafter Professional uses these settings 
when it exports a table to an HTML file.
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Charts and Drawing Objects on Tables

In addition to viewing a table as a chart, you can also insert charts and 
other drawing objects on a table. For example, you can use rectangles to 
highlight regions of your table and charts to further illustrate parts of your 
table. The following sections describe how to insert, format and remove 
charts and drawing objects on tables.

• Inserting Charts and Drawing Objects on Tables

• Formatting Charts and Drawing Objects on Tables

• Removing Charts and Drawing Objects on Tables

Inserting Charts and Drawing Objects on Tables

You can insert multiple charts and drawing objects on tables. The 
following sections describe how to insert charts and drawing objects on 
tables. 

• Inserting Charts on Tables

• Inserting Arcs on Tables

• Inserting Lines on Tables

• Inserting Ovals on Tables

• Inserting Polygons on Tables

• Inserting Rectangles on Tables

Inserting Charts on Tables
You can insert multiple charts on a table.

Note  Chapter 5, “Analyses: Charts,” explains how to format charts.

Note  Charts and drawing objects on tables appear on printed tables 
but not on exported tables.
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• To insert a chart on a table

1 Select a range of cells on the table to serve as the data source for the 
new chart.

If you select a range of cells that contain heading rows and columns, 
Survey Crafter Professional automatically detects the heading rows 
and columns and makes them the default series and axes labels. You 
can override these labels later in the Chart wizard.

If you select a range of cells that do not contain any heading rows or 
columns, you can still set the chart series and axes labels later in the 
Chart wizard.

2 Choose the Chart command from the Insert menu.

You can cancel this operation by choosing the Chart command again 
from the Insert menu.

3 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

4 Release the left mouse button.

Survey Crafter Professional displays the Chart wizard dialog box.

5 Follow the instructions on the Chart wizard dialog boxes, choosing 
the Next button at the end of each step and then the Finish button to 
insert the new chart on the table.

You can resize the chart by dragging its borders. You can also move 
the chart by clicking on and dragging it. You can also change the chart 
by right clicking on it and choosing the Chart Designer or Chart 
Wizard commands from the pop-up menu.
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Figure 4 - 57 shows a table with an inserted horizontal bar chart.

Figure 4 - 57: Table with an inserted horizontal bar chart.

Inserting Arcs on Tables
Use arc drawing objects to help illustrate your tables.

• To insert an arc drawing object on a table

1 Choose the Arc Drawing command from the Insert menu.

You can cancel this operation by choosing the Arc Drawing command 
again from the Insert menu.

2 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

3 Release the left mouse button.

Survey Crafter Professional draws an arc on the table.

Inserted bar 
chart 
illustrates the 
numbers in 
the table.
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You can resize the object by dragging its borders. You can also move 
the object by clicking on and dragging it. You can also change the 
object by clicking on it and choosing the Object command from the 
Format menu.

Inserting Lines on Tables
Use line drawing objects to help illustrate your tables.

• To insert a line drawing object on a table

1 Choose the Line Drawing command from the Insert menu.

You can cancel this operation by choosing the Line Drawing 
command again from the Insert menu.

2 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

3 Release the left mouse button.

Survey Crafter Professional draws a line on the table.

You can resize the object by dragging its points. You can also move 
the object by clicking on and dragging it. You can also change the 
object by clicking on it and choosing the Object command from the 
Format menu.

Inserting Ovals on Tables
Use oval drawing objects to help illustrate your tables.

• To insert an oval drawing object on a table

1 Choose the Oval Drawing command from the Insert menu.

You can cancel this operation by choosing the Oval Drawing 
command again from the Insert menu.

2 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

3 Release the left mouse button.

Survey Crafter Professional draws an oval on the table.
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You can resize the object by dragging its borders. You can also move 
the object by clicking on and dragging it. You can also change the 
object by clicking on it and choosing the Object command from the 
Format menu.

Inserting Polygons on Tables
Use polygon drawing objects to help illustrate your tables.

• To insert a polygon drawing object on a table

1 Choose the Polygon Drawing command from the Insert menu.

You can cancel this operation by choosing the Polygon Drawing 
command again from the Insert menu.

2 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

3 Release the left mouse button.

Survey Crafter Professional draws a polygon on the table.

You can resize the object by dragging its borders. You can also move 
the object by clicking on and dragging it. You can also change the 
object by clicking on it and choosing the Object command from the 
Format menu.

Inserting Rectangles on Tables
Use rectangle drawing objects to help illustrate your tables.

• To insert a rectangle drawing object on a table

1 Choose the Rectangle Drawing command from the Insert menu.

You can cancel this operation by choosing the Rectangle Drawing 
command again from the Insert menu.

2 Click on an open area on the table, hold the left mouse button down 
and drag the mouse down and to the right to create a rectangle.

3 Release the left mouse button.

Survey Crafter Professional draws a rectangle on the table.
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You can resize the object by dragging its borders. You can also move 
the object by clicking on and dragging it. You can also change the 
object by clicking on it and choosing the Object command from the 
Format menu.

Formatting Charts and Drawing Objects on 
Tables

You can format the charts and drawing objects on tables. The following 
sections describe how to format charts and drawing objects on tables.

• Formatting Charts on Tables

• Formatting Drawing Objects on Tables

Formatting Charts on Tables
You can use the Chart Designer and Chart Wizard dialog boxes to format 
a chart in a table.

• To format a chart on a table using the Chart Designer or the Chart 
Wizard dialog boxes

1 Select the chart.

2 Right click on the chart.

Survey Crafter Professional displays the chart pop up menu.

3 Choose the Chart Designer or the Chart Wizard command from the 
chart pop up menu.

4 Survey Crafter Professional displays the Chart Designer or the Chart 
Wizard dialog box.

For help on any of the Chart Designer or Chart Wizard dialog box 
options, click on the Help button.

Formatting Drawing Objects on Tables
You can format drawing objects on a table.

Note  Chapter 5, “Analyses: Charts,” explains how to format charts.
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• To format a drawing object on a table using the Format Object dialog 
box

1 Select the drawing object you want to format.

2 Choose the Object command from the Format menu.

Survey Crafter Professional displays the Format Object dialog box.

For help on the Format Object dialog box options, click on the Help 
button.

Figure 4 - 58: The Patterns tab of the Format Object dialog box.

3 Click on the OK button when you are finished changing formatting 
options.

Removing Charts and Drawing Objects on Tables

The following sections describe how to select all charts and drawing 
objects on tables and how to delete charts and drawing objects on tables.

• Selecting All Charts and Drawing Objects on Tables
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• Removing Charts and Drawing Objects on Tables

Selecting All Charts and Drawing Objects on Tables
You can select all charts and drawing objects on a table.

• To select all charts and drawing objects on a table

1 From the Edit menu, choose the Select All Objects command.

Survey Crafter selects all objects in the table. If you want to remove 
all objects in a table, choose the Clear command from Edit menu.

Removing Charts and Drawing Objects on Tables
You can remove one or more charts or drawing objects in a table.

• To remove a chart or drawing object in a table

1 Select the object by clicking on it.

You can select more than one object by holding the [SHIFT] key 
down and clicking on the next object in the table.

2 From the Edit menu, choose the Clear command.

Survey Crafter removes the selected object(s).

WARNING! This operation cannot be undone.
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5 Analyses:  Charts

In addition to presenting the results of analyses in a table, you can show 
results in a chart. Survey Crafter Professional supports a wide range of 
chart types including bar, line, area, and pie charts. It also gives you 
extensive control over charts’ formats. You can, for example, stack data 
series in bar charts, add axis titles, and apply solid or patterned backdrops 
to charts.

This chapter explains how to create a chart from a table and how to format 
chart elements. Read the section “Chart Basics” first to learn about chart 
elements and different chart types.

Chapter Contents

• Chart Basics  5 - 2

• Creating and Opening Charts  5 - 21

• Changing the Chart Type  5 - 33

• Displaying a Chart’s Data as a Table  5 - 32 

• Changing the Chart Type  5 - 33

• Selecting a Chart’s Series  5 - 38

• Reordering and Stacking Series  5 - 40

• Formatting Common Chart Elements  5 - 44

• Formatting 3D Charts  5 - 61

• Formatting Axes  5 - 67

• Formatting Plots  5 - 83

• Formatting Series and Data Points  5 - 94

• Formatting Labels  5 - 113
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• The Chart Wizard  5 - 122

• Exporting Charts  5 - 122

• Updating Charts  5 - 124

Chart Basics

Before working with charts, read this section to learn about series and 
categories, the relationship between a chart and its table, terms for chart 
elements, and different ways to access the dialog boxes for formatting 
chart elements. 
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Charts’ Series and Categories

The most basic components of a chart are series and categories, illustrated 
in Figure 5 - 1.

Figure 5 - 1: Series and categories in a chart.

A series is a group of related data points (for example, all the points on a 
line in a line chart or all the bars of one color in a bar chart). A category is 
a collection of one data point from each series in a chart (for example, the 
data point representing the percentage of males who said The Chicken 
Coop is their favorite restaurant.)

Less than 25 
employees is 
a series.

Business 
cards is a 
category.
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The Relationship between an Analysis’ Table and 
its Chart

A chart is a graphical representation of tabulated data, and every Survey 
Crafter Professional chart has a table associated with it. You can switch 
between viewing the data as either a chart or a table. Survey Crafter 
Professional uses a table’s row headings as category labels and its column 
headings as series labels on the chart as Figure 5 - 2 shows.

Figure 5 - 2: The relationship between a table and a chart.

You can display values or data points using formats like lines, bars, 
markers, filled areas, bubbles, or pie sections. Data points are grouped 
into series that are identified by unique colors or patterns. In many chart 
types, one data point from each series is grouped together in a category 
along an axis.
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Terms for Chart Elements

Figure 5 - 3 illustrates common 2D chart elements.

Figure 5 - 3: Common 2D chart elements.
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Figure 5 - 4 illustrates common 3D chart elements.

Figure 5 - 4: Common 3D chart elements.

Chart Types and Required Table Configurations

Survey Crafter Professional supports the 14 types of charts listed below. 
Many of these charts can be displayed in two or three dimensions. Each 
chart type requires the data in its table to be configured a certain way, as 
this section explains. In most chart types, one column of data in the table 
corresponds to one series and one row corresponds to one category.

If the data is not properly configured for a given chart type and you try to 
view that chart type, Survey Crafter Professional displays the message 
“Not Enough Data” in the Analysis window. 
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Area Charts
Area charts emphasize the relative importance of values over a period of 
time. An area chart focuses on the magnitude of change rather than the 
rate of change. 

Figure 5 - 5: A two-dimensional area chart (left) and a three-dimensional area chart.

Each filled area on the chart represents a series and is identified by a 
different color or pattern. Values are plotted on the vertical (Y) axis and 
categories are plotted on the horizontal (X) axis. You can also chart one or 
more series against the secondary Y axis instead of the primary axis.

An area chart’s table requires at least one column containing two or more 
values.

Bar Charts
Bar charts compare one item to another or a number of items over a 
period of time. They are particularly effective at showing large changes 
from one category to another. Each 2D or 3D bar represents a value in the 
table. Bars representing a series are located at the same position in each 
category and have the same color and pattern.
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In 2D charts, the vertical (Y) axis shows values and the horizontal (X) 
axis groups bars by category. On 3D charts, the vertical (Y) axis shows 
values, the horizontal (X) axis shows categories, and the depth (Z) axis 
shows series.

Figure 5 - 6: A two-dimensional bar chart (left) and a three-dimensional bar chart.

A bar chart’s table requires at least one column containing one or more 
values.

Clustered Bar Charts
Like 2D bar charts, clustered bar charts show categories on the X axis and 
values on the Y axis. However, clustered bar charts display all series, data 
points, and other chart elements in 3D.

Figure 5 - 7: A clustered bar chart.

A clustered bar chart’s table requires at least one column containing one 
or more values.
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Horizontal Bar Charts
Horizontal bar charts are similar to standard bar charts except that the 
categories are organized on a vertical (X) axis and the values are plotted 
on a horizontal (Y) axis.

Figure 5 - 8: A two-dimensional horizontal bar chart (left) and a three-dimensional horizontal bar chart.

A horizontal bar chart’s table requires at least one column containing one 
or more values.

Bubble Charts
Use bubble charts to show a visual comparison using three coordinates.

All the coordinates in a bubble chart measure values. Therefore, the 
vertical (Y) axis and the horizontal (X) axis both show values. The 
column heading on the first column in each series identifies the series in 
the legend.

Figure 5 - 9: A bubble chart.
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A bubble chart’s table requires three columns, with each row describing 
one bubble: 

• The first column contains the X coordinate of the data point (or bubble).

• The second column contains the Y coordinate of the data point.

• The third column contains the diameter of the bubble.

Combination Charts
Use combination charts to highlight the differences between multiple 
series of data. You can use a different method to draw each data series. 
For example, show one series as a line and another as bars and a third as 
an area chart.

Figure 5 - 10: Combination charts in which series appear as a line, a set of bars, and an area.

A combination chart’s table requires at least two columns containing one 
or more values.
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Gantt Charts
Gantt charts display a range of bars that indicate the relative time required 
for a project’s activities. The horizontal axis (Y) shows dates and the 
vertical axis (X) shows categories (activities).

Figure 5 - 11: A gantt chart.

Each series in a gantt chart requires two columns of data in the chart’s 
table:

• The first column contains the activity’s start date.

Dates must be entered as Julian dates (the number of days) counted 
from 1 January 1900. You can then apply a date format to the cells’ 
values so that they appear as dates using a more conventional format 
like MM/DD/YY. For example, enter the Julian date 39295 for 1 
August 2007. The Julian date 39300 corresponds to 6 August 2007.

• The second column contains the activity’s duration.

Hi-lo Charts
Hi-lo charts are most commonly used to indicate changes in values like 
stock prices over a period of time. The vertical (Y) axis shows values and 
the horizontal (X) axis shows categories or dates.

Survey Crafter Professional supports a number of variations of the hi-lo 
chart. These variations include hi-lo-close, which indicates the highest, 
lowest, and last measurements on a given date; and open-hi-lo-close, 
which also shows the first value measurement on a given date.
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The column heading on the first column in each series identifies the series 
in the legend.

Figure 5 - 12: A hi-lo-close chart with close markers crossing data points and dates 
appearing on the horizontal (X) axis.

The table for a hi-lo chart requires two columns for each series:

• The first column contains the series’ high point.

• The second column contains the series’ low point.

The table for a hi-lo-close chart requires three columns for each series:

• The first column contains the series’ high point.

• The second column contains the series’ low point.

• The third column contains the series’ close point.

The table for an open-hi-lo-close chart requires four columns for each 
series:

• The first column contains the series’ open point.

• The second column contains the series’ high point.

• The third column contains the series’ low point.
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• The fourth column contains the series’ close point.

Line Charts
Line charts show trends or changes in data over a period of time. These 
charts emphasize the rate of change rather than the amount of change. 

In 2D line charts, the vertical (Y) axis shows values and the horizontal 
(X) axis shows categories. In 3D charts, the vertical (Y) axis shows 
values, the horizontal (X) axis shows categories, and the depth (Z) axis 
shows series.

Figure 5 - 13: A two-dimensional line chart (left) and a three-dimensional line chart.

A line chart’s table requires at least one column containing two or more 
values. 

Pie and Doughnut Charts
Pie charts and doughnut charts show the relationship of parts to the 
whole. Each pie or doughnut represents a category. Each section of the pie 
or doughnut represents a different series’ value in that category. You can 

Note  To include dates on the chart’s horizontal (X) axis, enter the 
dates as the right column of the table. Dates must be entered as Julian 
dates (the number of days) counted from 1 January 1900. You can then 
apply a date format to the cells’ values so that they appear as dates in 
a more conventional format like MM/DD/YY. For example, enter the 
Julian date 39295 for 1 August 2007. The Julian date 39300 
corresponds to 6 August 2007.
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separate or explode a section in a chart by clicking a section and dragging 
it away from the rest of the pie or doughnut. 

Figure 5 - 14: A pie chart (left) and a doughnut chart.

Pie and doughnut charts’ tables require at least one row containing two or 
more values.

Polar Charts
Polar charts show cyclical trends.

The column heading on the first column in each series identifies the series 
in the legend.

Figure 5 - 15: A polar chart.

A polar chart’s table requires two columns in the table for each series: 

• The first column holds the angle on the perimeter of the chart. 

• The second column contains the distance from the center of the chart.
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Radar Charts
Radar charts show changes or frequencies of each series relative to a 
center point and to one another. Lines connect all the data markers in the 
same series. You can also fill the lines to create a radar area chart.

Figure 5 - 16: A radar chart.

A radar chart’s table requires one column containing at least one value.

Survey Crafter Professional divides the chart into as many equally spaced 
axes as there are data points. Each value represents the distance from the 
center of the radar chart on a different equally spaced axis.

Step Charts
Use step charts to compare items that do not show trends. Step charts 
display distinct points along the value (Y) axis, with vertical lines 
showing the difference between each point. The horizontal (X) axis shows 
categories.

Figure 5 - 17: A two-dimensional step chart (left) and a three-dimensional step chart.
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A step chart’s table requires at least one column with two or more values.

XY Charts
Use XY charts to plot two groups of numbers as one series of XY 
coordinates. An XY chart allows some series to have several data points 
with the same value (Y) axis coordinate.

Figure 5 - 18: An XY chart.

An XY chart’s table requires two columns for each series:

• The first column holds the X coordinate. 

• The second column the Y coordinate. 

The column heading on the first column in each series is used to identify 
the series in the legend. You can use markers or lines or both to draw the 
XY points.

Accessing Format Tabs for Formatting Chart 
Elements

To control the appearance of a chart element, change settings in the chart 
element’s format tabs in the Chart Designer dialog box. For example, use 
the Title element’s format tabs of the Chart Designer dialog box to change 
the look of a chart's title.

There are two methods for accessing a chart element’s format tabs in the 
Chart Designer dialog box:
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• Select the Chart Designer command from the Format menu and then 
select the chart element. For example, when you choose the Chart 
Designer command from the Format menu and then Title, the Title 
format tabs appear in the Chart Designer dialog box.

• Double-click on the chart element.

 Both methods are explained below.

Accessing Format Tabs by Using the Chart Designer 
Dialog box
Table 5 - 1 lists the format tabs that appear in the Chart Designer dialog 
box for each chart element type.

Table 5 - 1: Format tabs in the Chart Designer dialog box.

Chart element Format tabs Purpose

Chart Type, Backdrop, Picture Changes the chart type and formats the fill, 
frame, and shadow displayed in the chart 
backdrop.

Title Location, Backdrop, Picture, 
Layout, Text, Font

Formats the title backdrop and font, edits the 
title text, and controls the display of the title 
and its location.

Footnote Location, Backdrop, Picture, 
Layout, Text, Font

Formats the footnote backdrop and font, edits 
the footnote text, controls the display of the 
footnote and its location.

Legend Location, Backdrop, Picture, 
Font

Formats the legend backdrop, changes the font 
used to display the legend text, and controls the 
legend location.

Plot Position, 3D View, 3D 
Lighting, Base, Walls, Pie, 
Bubble, Contour, Elevation,  
Backdrop, Picture, Other

Controls the location of the plot, formats the 
plot backdrop, and sets chart type-specific 
options.

X Axis, Y Axis, 2nd 
Y Axis, Z Axis

Value Scale, Category 
Scale, Scale Type, Date 
Scale, Extra Intervals, Date 
Formats, Pens

Controls options for the X, Y, 2nd Y or Z axis. 
The selection of format tabs depends on the 
chart type. For example, for bar charts, formats 
the width and color of the axis, axis grid, and 
axis tick marks; and changes the axis scale.
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Axis Title Backdrop, Picture, Layout, 
Text, Font

Controls the appearance of the axis’ title.

Axis Labels Display, Format, Value 
Format, Percent Format, 
Backdrop, Picture, Layout, 
Font

Controls the appearance of the axis’ labels.

Series Series Type, Order Controls the display of series; formats series 
appearance such as bar shape, line style, 
markers, and fill colors; sets series smoothing; 
and formats statistics lines and guidelines.

Individual Series Options, Lines, Guidelines, 
Statistics

Controls the appearance of a series.

Datapoint Fill, Markers, Picture Controls the appearance of the data points of a 
series.

Individual Datapoint Defaults, Fill, Markers, 
Picture

Controls the appearance of a data point of a 
series.

Datapoint Labels Appearance, Format, Value 
Format, Percent Format, 
Backdrop, Picture, Layout, 
Font

Controls the appearance of the data point labels 
of a series.

Individual Datapoint 
Label

Defaults, Appearance, 
Format, Value Format, 
Percent Format, Backdrop, 
Picture, Layout, Text, Font

Controls the appearance of a data point label of 
a series.

Series Labels Controls the series label locations and line 
styles, edits the label text, formats the label text 
and position, and formats the label backdrop.

Individual Series 
Labels

Style, Backdrop, Picture, 
Layout, Text, Font

Controls the appearance of a series label.

Table 5 - 1: Format tabs in the Chart Designer dialog box. (Continued)

Chart element Format tabs Purpose
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Accessing Format Tabs by Double-Clicking on Chart 
Elements
Table 5 - 2 provides information on accessing format tabs by double-
clicking.

Table 5 - 2: Format tabs appearing when you double-click on chart elements.

To format Double-click Format tabs 
displayed

Format tab selected

Chart 
backdrop

The chart but not on a 
specific chart element

Type, Backdrop, Picture Type

Chart title Anywhere in the title area Location, Backdrop, 
Picture, Layout, Text, 
Font

Location

Footnote Anywhere in the footnote 
area

Location, Backdrop, 
Picture, Layout, Text, 
Font

Location

Legend 
backdrop

The legend but not the 
legend text or keys

Location, Backdrop, 
Picture, Font

Location

Legend text The legend text Location, Backdrop, 
Picture, Font

Location

Series A chart element in an 
unselected series or on the 
legend key identifying the 
series

Options, Lines, 
Guidelines, Statistics

Options

Series Label The series label Style, Backdrop, 
Picture, Layout, Text, 
Font

Style

Plot The plot but not on a 
specific chart element

Position, 3D View, 3D 
Lighting, Base, Walls, 
Pie, Bubble, Contour, 
Elevation,  Backdrop, 
Picture, Other

Position

Axis label An axis label Display, Format, Value 
Format, Percent Format, 
Backdrop, Picture, 
Layout, Font

Display
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Axis line or 
tick marks

The line or tick marks on 
an axis

Value Scale, Category 
Scale, Scale Type, Date 
Scale, Extra Intervals, 
Date Formats, Pens

Value Scale or Category Scale

Axis title The axis title text Backdrop, Picture, 
Layout, Text, Font

Backdrop

Grid Any grid line Value Scale, Category 
Scale, Scale Type, Date 
Scale, Extra Intervals, 
Date Formats, Pens

Value Scale or Category Scale

2D wall and 
3D wall or 
base

Any part of the base or 
wall other than a grid line

Position, 3D View, 3D 
Lighting, Base, Walls, 
Pie, Bubble, Contour, 
Elevation,  Backdrop, 
Picture, Other

Position

Data point A data point in a selected 
series or a data point in the 
same series as another 
selected data point

Defaults, Fill, Markers, 
Picture

Defaults

Data point 
label

The data point label Defaults, Appearance, 
Format, Value Format, 
Percent Format, 
Backdrop, Picture, 
Layout, Text, Font

Defaults

Table 5 - 2: Format tabs appearing when you double-click on chart elements. (Continued)

To format Double-click Format tabs 
displayed

Format tab selected
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Creating and Opening Charts

This section explains how to create new charts and open and copy 
existing charts.

Creating a Chart from a Table

Every chart starts as a table in the Analysis window. Once you create a 
table, you can chart the entire table or a portion of it, but different chart 
types require different table configurations. See the section “Chart Types 
and Required Table Configurations” on page 5 - 6.

When you chart a table’s data, Survey Crafter Professional displays the 
table’s column and row headings as series labels and category labels, 
respectively.

• To chart an entire table

1 At the Analyses tab of the Study window, select the table to chart. 
Then click on the Edit button on the tab. 

2 From the View menu, choose Analysis Options.

3 In the Number Of Columns field under Table Headings, enter the 
number of columns to reserve for row headings.

Survey Crafter Professional plots the row headings as category labels 
on the chart.

4 In the Number Of Rows field, enter the number of rows to reserve for 
column headings.
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Survey Crafter Professional plots the column headings as series labels 
on the chart.

Figure 5 - 19: The Analysis Options dialog box.

5 Click on the OK button.

6 From the View menu, choose Chart or click on the Chart View button 
on the toolbar.

The chart appears in the Analysis window. 

You can now change the chart type and format the chart. See the 
sections “Selecting Basic Chart Types” on page 5 - 33 and 
“Formatting Common Chart Elements” on page 5 - 44.

• To chart a portion of a table

1 At the Analyses tab of the Study window, select the table to chart. 
Then click on the Edit button on the tab.

2 From the View menu, choose Analysis Options.

3 In the Chart Region field, type the range of cells you want to chart. 

Separate the range’s upper left and lower right cells with a colon. For 
example, to chart the values in cells A3 to E7, enter A3:E7.

For example, if the table is 
like the one in Figure 4 - 1 
and has two levels of row 
headings and two levels of 
column headings, enter 
values in the Analysis 
Options dialog box as 
shown.

Chart View button
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4 Click on the OK button.

5 From the View menu, choose Chart or click on the Chart View button 
on the toolbar.

The chart appears in the Analysis window. 

You can now change the chart type and format the chart. See the 
section “Selecting Basic Chart Types” on page 5 - 33 and “Formatting 
Common Chart Elements” on page 5 - 44.

Using Wizards to Create Charts

Survey Crafter Professional includes two analysis wizards to help you 
build popular types of charts. The Count or Percentage Chart Wizard 
builds a pie or bar chart from a variable. You can use this wizard to build 
charts like the pie chart in Figure 5 - 20. The chart shows counts for the 
values in the category variable seg_jobtype, which stores answers to the 
question “Which of the following best describes the kind of print job that 
you most often need?”

The Quantity Variable Chart Wizard builds a chart that shows one 
statistic for one or more quantity variables. You can use this wizard to 
build charts like the one in Figure 5 - 20. The bar chart shows means for 

Chart View button
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the quantity variables sat_turnaround, sat_quality, sat_delivery, 
sat_hours, sat_courtesy, and sat_experience.

Figure 5 - 20:Charts built by the Count or Percentage Chart Wizard and the Quantity Variable Chart Wizard.

• To use a wizard to create a chart

1 Select the Analyses tab of the Study window.
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Figure 5 - 21: The Analyses tab of the Study window.

2 Click on the New button on the tab.

Survey Crafter Professional displays step 1 of the New Analysis 
dialog box.

Figure 5 - 22: Step 1 of the New Analysis dialog box.

Click on the New button 
to create a new 
analysis chart.

Select this option to 
have a wizard build an 
analysis chart for you.
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3 Select Have a wizard build an analysis table or chart for you.

4 Click on the Next button.

Survey Crafter Professional displays step 2 of the New Analysis 
dialog box.

Figure 5 - 23: Step 2 of the New Analysis dialog box.

5 Under Chart Wizards, click to select the wizard you want to use.

A brief description of the selected wizard appears in the window on 
the right.

6 Click on the Next button.

Click on the chart 
wizard you want to use.
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Survey Crafter Professional displays step 3 of the New Analysis 
dialog box.

Figure 5 - 24: Step 3 of the New Analysis dialog box.

7 Enter a name and description for the analysis.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

8 Click on the Finish button.

Enter a name and 
description for the 
analysis.



5 - 28 Analyses: Charts
Creating and Opening Charts  
Survey Crafter Professional displays the wizard you selected in step 
5.

Figure 5 - 25: Step 1 of the Count or Precentage chart wizard.

9 Follow the instructions on the screen to complete the wizard.

For help on any of the wizard’s options, click on the Help button on 
the wizard’s dialog box.

10 Click on the Finish button.

Enter or choose the 
variable you want to 
analyze.

Click on the Help button 
for descriptions of the 
wizards’ options.
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Survey Crafter Professional builds a new analysis chart according to 
the options you selected and displays the chart in an Analysis 
window.

Figure 5 - 26: An analysis chart built by the Count or Percentage chart wizard.

You can now format the chart.

Opening a Chart

Follow the steps below to view an existing chart.

Tip  You can revisit the wizard at any time to change your selections 
or to just have the wizard build the analysis chart again. To revisit 
the wizard, choose Analysis Wizard from the Edit menu when the 
Analysis window is active.
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• To open a chart

1 Select the Analyses tab of the Study window.

2 Scroll through the list at the Analyses tab and select the chart you 
want to view.

3 Click on the Edit button on the tab.

Survey Crafter Professional displays the chart in an Analysis window.

Copying an Existing Chart

Follow the steps below to copy an existing chart.

• To copy an existing chart

1 Select the Analyses tab of the Study window.

2 Select the chart you want to copy.

3 Click on the Copy button on the tab.

The Analysis Information dialog box appears.

4 In the Name field, enter a new name for the chart.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

5 In the Description field, enter a new description of the chart.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

6 Click on the OK button.

Note  If the message “The analysis must be updated” appears in the 
Analysis window, the table on which the chart is based has changed 
and its values need to be recalculated. To recalculate the table and 
update the chart, choose the Update command from the Edit menu.
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Survey Crafter Professional displays the chart in an Analysis window.

Note  If the message “The analysis must be updated” appears in the 
Analysis window, the table on which the chart is based has changed 
and its values need to be recalculated. To recalculate the table and 
update the chart, choose the Update command from the Edit menu.
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Displaying a Chart’s Data as a Table

You can quickly display the data in a chart as a table.

• To display a chart’s data as a table

1 At the Analyses tab of the Study window, select a chart. Then click on 
the Edit button on the tab.

Survey Crafter Professional displays the chart in an Analysis window.

2 From the View menu, choose Table or click on the Table View button 
on the toolbar.

Survey Crafter Professional displays the data as a table in the 
Analysis window.

Table View button
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Changing the Chart Type

You can try different chart types to determine which type best presents the 
data. For example, you can redraw a bar chart as a line chart to better 
illustrate a trend in the data. 

The section explains how to switch between chart types. The more 
complex chart types (combination, radar, and hi-lo-close charts) require 
more involved procedures. These complex chart types are dealt with 
individually in this section.

Selecting Basic Chart Types

Follow the steps below to switch to any chart type except combination, 
radar, or hi-lo-close charts. Instructions for switching to these three chart 
types appear later in the section.

• To select the chart type

1 Double-click on the chart or choose Chart Designer from the Format 
menu and then select Chart from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab. 

3 Select the 2D or 3D option to display 2D or 3D chart types in the 
Chart list.

4 In the Chart list, select a chart type.

Note  You can also use the Chart Wizard to quickly change the chart 
type. See the section “The Chart Wizard” on page 5 - 120 for 
instructions on how to start the Chart Wizard.
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5 Click on the OK or Apply button to redraw the chart.

Selecting Complex Chart Types

Chart types requiring more involved procedures are combination charts, 
radar charts, and hi-lo charts.

Selecting Combination Charts
Combination charts use a different type for each series. For example, you 
can show one series with bars and a second series with a line.

• To select a combination chart

1 Double-click on the chart or choose Chart Designer from the Format 
menu and then select Chart from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab.

3 Select the 2D or 3D option to display a list of 2D or 3D chart types in 
the Chart list.

4 In the Chart list, select Combination.

5 Select the Series element. In the Series Type tab, in the Series list, 
select one of the chart's series.

The Display As list shows the valid types for the selected series.

6 In the Display As list, select the type you want to use for the selected 
series.

7 Repeat steps 5 and 6 for each series in the combination chart.

8 Click on the OK or Apply button to redraw the chart.

Note  The data in the chart’s table may not be configured correctly 
for all chart types. If the chart type you requires more data than the 
table contains, Survey Crafter Professional displays the message 
“Not enough data” in the Analysis window when you click on the 
OK or Apply button. For information on chart types’ table 
configurations, see the section “Chart Types and Required Table 
Configurations” on page 5 - 6. 
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Selecting Radar Charts
If you select Radar as the chart type, indicate whether you want each 
series displayed as a line or filled area. 

• To change the variation of series in a radar chart

1 Double-click on the chart or choose Chart Designer from the Format 
menu and then select Chart from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab. 

3 Select the 2D option to display a list of 2D chart types.

4 In the Chart list, select Radar.

5 Select the Series element. In the Series Type tab, in the Series list, 
select a series.

6 In the Display As list, select Area or Line.

7 Repeat steps 5 and 6 for each series in the radar chart.

8 Click on the OK or Apply button to redraw the chart.

Selecting Hi-lo-close Charts 
Besides high, low, and close data, hi-lo-close charts can also show dates. 
If you want the chart to show dates, enter the information in a column 
immediately to the right of the close data as Figure 5 - 27 shows.

Dates must be entered as Julian dates (the number of days) counted from 
1 January 1900. You can then apply a date format to the cells’ values so 
that they appear in more conventional date formats like MM/DD/YY. For 
example, enter the Julian date 39295 for 1 August 2007. The Julian date 
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39300 corresponds to 6 August 2007. See the sections “Scaling a Date 
Axis” on page 5 - 77 and “Specifying Number Formats” on page 4 - 60.

Figure 5 - 27: A table configured for a hi-lo-close chart with dates.

• To select a hi-lo-close chart

1 Double-click on the chart or choose Chart Designer from the Format 
menu and then select Chart from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab. 

3 Select the 2D option to display a list of 2D chart types.

4 In the Chart list, select Hi Lo.

5 Select the Series element. Select the Series Type tab.

6 In the Series Type tab, in the Series list, select the first series that 
holds hi-lo-close information.

7 In the Display As list, select one of the hi-lo-close variations.

Dates 
appearing at 
the right of the 
hi-lo-close 
columns.

To create this date, double-
click on the cell, enter 43652 
in the Value Expression field, 
and click on the OK button. 
Then choose a date format 
for the cell using the Number 
tab of the Format Cells 
dialog box.
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The second and third columns in every series are indented to show 
that the series requires three columns of data to chart a hi-lo-close 
chart. 

8 If the table contains a column of dates, select Series 4 and then choose 
Dates under Display As.

Survey Crafter Professional uses the values in this column to create a 
horizontal date axis for this chart.

Figure 5 - 28: The Series Type tab of the Chart Designer dialog box for a hi-lo-close 
chart with dates.

9 Click on the OK or Apply button to redraw the chart.

Note  If you are viewing the hi-lo-close chart’s table and then view 
the table’s data as a chart, the chart may not redraw correctly. If the 
chart does not redraw correctly, repeat steps 1 through 9.

To chart the table in 
Figure 5 - 27, indicate 
that Series 1, 2, and 3 
hold the hi-lo-close data 
and that Series 4 holds 
dates.
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Selecting a Chart’s Series

By default, Survey Crafter Professional uses a table’s columns as series in 
a chart. Because each column is a different series, each column’s data 
appears in a different color in the chart.

Figure 29: A table column and its corresponding series in a chart.

Sometimes you create a table in which the data you want to use as series 
appears in the table’s rows. Rather than switching the table’s rows and 
columns to get the chart you want, you can have Survey Crafter 
Professional use the table’s rows as series.

• To select a chart’s series

1 At the Analyses tab of the Study window, select the table or chart you 
want to change. Then click on the Edit button on the tab.

2 From the View menu, choose Analysis Options.

This column in the table 
corresponds to this series in 
the chart.
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3 Under Chart Data Series In, do one of the following:

• To use the data in the table’s rows as series, select the Rows option.

• To use the data in the table’s columns as series, select the Column 
option.

4 Click on the OK button.

If you are viewing the table, click on the Chart View button on the 
toolbar to see the chart.

Chart View button
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Reordering and Stacking Series

You can change the order in which series appear in a chart and stack a bar 
chart’s series.

Reordering Series in a Chart

Reordering series can be particularly useful if one series obscures the 
view of another series.

• To reorder series in a chart

1 From the Format menu, choose Chart Designer and then select Series 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Order tab.

3 Select a series in the Series Order list.

4 Click on the Up button to move the series up or click on the Down 
button to move the series down in the drawing order. 

The first series in the Series Order list appears in the front of the 
chart.

5 Click on the OK or Apply button to redraw the chart.
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Stacking and Unstacking Series

Use the Order tab of the Chart Designer dialog box to stack and unstack a 
bar chart's series. Figure 5 - 30 shows the same chart with stacked and 
unstacked series. You need not stack all series in a chart.

Figure 5 - 30: Unstacked and stacked series.

• To stack all series in a chart

1 From the Format menu, choose Chart Designer and then select Series 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Order tab.

3 Select a series in the Series Order list.

4 Click on the Stack button.

In the Series Order list, the selected series appears stacked with the 
preceding series.

5 Repeat steps 3 and 4 for each series in the chart.

6 Click on the OK or Apply button to redraw the chart.

• To stack selected series in a chart

1 From the Format menu, choose Chart Designer and then select Series 
from the list of chart elements.
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2 In the Chart Designer dialog box, select the Order tab.

3 In the Series Order list, select a series.

4 Click on the Stack button.

In the Series Order list, the selected series appears stacked with the 
preceding series.

5 To stack with the preceding series, select the text <Stack> and click 
on the Stack button again.

The two stacked columns are now stacked with the preceding series. 
Top-to-bottom order in the Series Order list corresponds to 
top-to-bottom order in the chart.

6 Click on the OK or Apply button to redraw the chart.

• To unstack series

1 From the Format menu, choose Chart Designer and then select Series 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Order tab.

3 Do one of the following in the Series Order list:

• To unstack one series, select the series.

• To unstack all series, select the text <Stack>.

Figure 5 - 31: The Order tab of the Chart Designer dialog box.

Select this text to 
unstack all series.
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4 Click on the Unstack button.

5 Click on the OK or Apply button to redraw the chart.



5 - 44 Analyses: Charts
Formatting Common Chart Elements  
Formatting Common Chart Elements

Besides plotted data, the most common chart elements are titles, legends, 
footnotes, and second Y axes as shown in Figure 5 - 32. 

Figure 5 - 32: Common chart elements.

This section contains the following procedures for formatting these 
common chart elements:

• Adding Titles, Legends, and Footnotes to a Chart

• Hiding and Showing a Title, Footnote, Legend, or Second Y Axis

• Positioning and Resizing Chart Titles, Legends, and Footnotes

• Editing and Formatting Chart Text

• Editing Chart Elements’ Backdrops

• Resetting a Chart to Default Formats

Adding Titles, Legends, and Footnotes to a 
Chart 

Follow the steps below to add a title, legend, or footnote to a chart.

Legend

Second Y axis
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• To add a title to a chart

1 From the Format menu, choose Chart Designer and then select Title 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Location tab.

3 Select the Visible check box to display the title.

4 Select an option to specify the location of the title.

5 Select the Text tab.

6 In the Text field, type the title.

Figure 5 - 33: The Text tab of the Chart Designer dialog box.

7 If you want the title text to appear on more than one line if necessary, 
select the Layout tab and then select the Word Wrap check box.

8 Click on the OK or Apply button to redraw the chart.

• To add a legend to a chart

1 From the Format menu, choose Chart Designer and then select 
Legend from the list of chart elements.

2 In the Chart Designer dialog box, select the Location tab.

3 Select the Visible check box to display the legend.

Type the chart title text in 
this field.
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By default, Survey Crafter Professional uses series labels to identify 
each series in the legend.

Figure 5 - 34: The Location tab of the Chart Designer dialog box.

4 Select an option to specify the location of the legend.

5 Click on the OK or Apply button to redraw the chart.

• To add a footnote to a chart

1 From the Format menu, choose Chart Designer and then select 
Footnote from the list of chart elements.

2 In the Chart Designer dialog box, select the Location tab.

3 Check the Visible check box to display the footnote.

4 Select an option to specify the location of the footnote.

5 Select the Text tab.

6 In the Text field, type the footnote text.

7 If you want the footnote text to appear on more than one line if 
necessary, select the Layout tab and then select the Word Wrap check 
box.

8 Click on the OK or Apply button to redraw the chart.

Selecting the Visible check 
box enables the Location 
tab’s other options.
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Hiding and Showing a Title, Footnote, Legend, or 
Second Y Axis

Survey Crafter Professional lets you turn off and on the display of the 
chart’s title, legend, footnote, and second Y axis. Hiding a chart element 
does not delete it; you can display it again at any time.

• To hide a title, footnote, legend, or second Y axis

1 From the Format menu, choose Chart Designer and then select Title, 
Footnote, Legend or Value (2nd Y) from the list of chart elements.

2 In the Title, Footnote or Legend format tabs, select the Location tab. 
In the Value (2nd Y) Axis format tabs, select the Value Scale tab.

3 To hide a Title, Footnote or Legend, clear the Visible check box. To 
hide the 2nd Y Axis, clear the Show check box.

4 Click on the OK or Apply button to redraw the chart.

• To show a title, footnote, legend, or second Y axis

1 From the Format menu, choose Chart Designer and then select Title, 
Footnote, Legend or Value (2nd Y) Axis from the list of chart 
elements.

2 In the Title, Footnote or Legend format tabs, select the Location tab. 
In the Value (2nd Y) Axis format tabs, select the Value Scale tab.

3 To show a Title, Footnote or Legend, select the Visible check box. To 
show the 2nd Y Axis, select the Show check box.

4 Click on the OK or Apply button to redraw the chart.

Positioning and Resizing Chart Titles, Legends, 
and Footnotes

You can position a chart title, legend, or footnote in a preset or custom 
location.

Note  If you have not created a title or footnote, checking the Visible 
check box displays default text.
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By default, Survey Crafter Professional operates in automatic layout 
mode. In this mode, Survey Crafter Professional resizes and repositions 
the existing chart elements to make room for the new chart elements you 
add.

In automatic layout, Survey Crafter Professional draws the chart plot, 
title, legend, and footnote within their individual areas of the chart. The 
size of text used for the title, legend, footnote, and the axis labels and 
titles determine the size of each of these areas. If you use very large fonts 
or long lines of text, Survey Crafter Professional may crop some chart 
elements and not display axis labels and titles. 

Placing a Chart Title, Legend, or Footnote in a Preset 
Location
By default, when you add a title, legend, or footnote, Survey Crafter 
Professional puts the object in one of eight preset locations illustrated in 
Figure 5 - 35. 

Figure 5 - 35: Preset locations for chart titles, legends, and footnotes.

• To place a chart title, legend, or footnote in a preset location

1 Double-click a chart element or choose Chart Designer from the 
Format menu and then select the chart element to format.

2 In the Chart Designer dialog box, select the Location tab.

3 Select one of the position options.

4 Click on the OK or Apply button to redraw the chart.
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Placing a Chart Title, Legend or Footnote in a Custom 
Location
You can override the automatic layout of chart elements by selecting and 
dragging chart elements on the screen or by changing settings in the Chart 
Designer dialog box.

Once you manually reposition a chart element, it is no longer in automatic 
layout mode. Therefore, Survey Crafter Professional no longer considers 
the chart element when allocating space for the remaining chart elements 
that still use automatic layout.

• To place a chart title, legend, or footnote in a custom location 
manually

1 Select the title, footnote, plot or legend.

Handles appear around the chart element.

2 Click on the chart element and drag it to a new location.

• To place a chart title, legend, or footnote in a custom location by 
using the Chart Designer dialog box

1 Double-click on the title, footnote, plot or legend.

The Chart Designer dialog box appears with the chart element 
selected.

2 In the Chart Designer dialog box, select the Location tab.

3 Select the Custom Location option.

4 Enter values in the Top and Left fields to describe the coordinates of 
the upper left corner of the chart element.

5 Click on the OK or Apply button to redraw the chart.

Resizing Chart Titles, Legends, and Footnotes
You can override the automatic sizing of chart titles, legends, and 
footnotes by selecting and dragging the chart elements on the screen or by 
changing settings in the Chart Designer dialog box.

• To resize chart titles, legends, or footnotes manually

1 Select the title, legend, or footnote.
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Handles appear around the chart element.

2 Drag the handles to resize the chart element.

• To resize chart titles, legends, or footnotes by using the Chart 
Designer dialog box

1 Double-click on the title, footnote, plot or legend.

The Chart Designer dialog box appears with the chart element 
selected.

2 In the Chart Designer dialog box, select the Location tab.

3 Select the Custom Location option.

4 Enter values in the Height and Width fields to describe the chart 
element’s height and width.

5 Click on the OK or Apply button to redraw the chart.

Editing and Formatting Chart Text

You can edit and delete chart text, change its font, and control its 
orientation and alignment within its text box.

Editing Chart Text
You can edit text in chart elements like chart titles, footnotes, axis titles, 
series labels and data point labels.

• To edit chart text

1 Double-click on the text you want to edit or choose Chart Designer 
from the Format menu and then select the chart element to format.

2 In the Chart Designer dialog box, select the Text tab.

3 Edit the text.

Note  You actually resize the bounding rectangle around the object, 
not the text itself. Based on the size you make the bounding 
rectangle, Survey Crafter Professional may have to resize or crop 
objects to fit the space.
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4 Click on the OK or Apply button to redraw the chart.

Deleting Chart Text
You can delete most chart text. For example, if a chart becomes cluttered 
with many data point labels, delete a few labels. 

Deleting chart text is different from hiding chart elements. If you delete 
chart text, you must recreate it to display it on the chart again. 

• To delete chart text

1 Double-click on the text you want to delete or choose Chart Designer 
from the Format menu and then select the chart element to format.

2 In the Chart Designer dialog box, select the Text tab.

3 Delete the text in the Text field.

4 Click on the OK or Apply button to redraw the chart.

Changing the Font of Chart Text
You can specify the font, style, size, color, and line effects used to display 
a text element on a chart. The tabs used to specify fonts options for chart 
titles, legends, footnotes, labels and axis titles are identical.

• To change the font of chart text

1 Double-click on the text you want to format or choose Chart Designer 
from the Format menu and then select the chart element to format.
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2 In the Chart Designer dialog box, select the Font tab.

Figure 5 - 36: The Font tab of the Chart Designer dialog box.

3 Change attributes of the text’s font.

For help on the Font tab’s options, click on the Help button.

4 Click on the OK or Apply button to redraw the chart.

Aligning and Orienting Chart Text
You can control the alignment and orientation of chart text like the axis 
title.

Alignment regulates the position of text within its text box on the chart. 
For example, you can center text at the top of its text box. You may need 
to enlarge the text box to view text using the horizontal and vertical 
alignment you select. 

Orientation regulates the rotation of the text’s characters. For example, 
you can display the text vertically instead of horizontally.

• To align chart text

1 Double-click on the chart text you want to align or choose Chart 
Designer from the Format menu and then select the chart element to 
format.

2 In the Chart Designer dialog box, select the Layout tab.

3 Select the horizontal alignment option you want.

The tabs for formatting 
fonts of legends, footnotes, 
labels, and axis titles are 
identical to this tab.
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4 Select the vertical alignment option you want.

5 Click on the OK or Apply button to redraw the chart.

• To orient chart text

1 Double-click on the chart text you want to orient or choose Chart 
Designer from the Format menu and then select the chart element to 
format.

2 In the Chart Designer dialog box, select the Layout tab.

3 Under Orientation, select the orientation option you want.

Figure 5 - 37: Orientation options for chart text.

4 Click on the OK or Apply button to redraw the chart.

Horizontal Vertical 

Up Down 
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Editing Chart Elements’ Backdrops

The following sections describe how you can use backdrops to enhance a 
chart element’s appearance.

• Drawing a Frame around a Chart Element

• Drawing a Solid or Patterned Backdrop for a Chart Element

• Drawing a Gradient Backdrop for a Chart Element

• Using a Graphic as a Backdrop for a Chart Element

To create any of these backdrop styles, use the Backdrop tab in the Chart 
Designer dialog box.

Figure 5 - 38: The Backdrop tab of the Chart Designer dialog box.

Backdrop tabs for other 
chart elements are 
identical to this one.
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Drawing a Frame around a Chart Element
You can draw a frame in a variety of styles and colors around any chart 
element except data points and series. 

Figure 5 - 39: A chart with a shadowed frame drawn around the legend.

• To draw a frame around a chart element

1 Double-click on the chart element you want to draw a frame around 
or choose Chart Designer from the Format menu and then select the 
chart element to format.

2 In the Chart Designer dialog box, select the Backdrop tab.

3 Under Frame, from the Style drop-down list, select a line style for the 
frame. 

4 From the Color drop-down list, select a color for the frame.

5 In the Width field, enter a frame width in points.

6 To apply a shadow to the frame, do the following:

• Under Shadow, from the Style drop-down list, select a shadow style 
for the frame.

• In the Offset field, enter the number of points the shadow should be 
offset from the frame's upper left corner.

7 Click on the OK or Apply button to redraw the chart.
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Drawing a Solid or Patterned Backdrop for a Chart 
Element
You can apply a solid or patterned backdrop to any chart element except a 
series or a data point. (Fills are applied to series and data points. See the 
sections “Filling and Outlining Series” on page 5 - 96 and “Formatting 
Data Points” on page 5 - 108.) 

Figure 5 - 40 shows a chart with a patterned backdrop applied to its 
legend.
 

Figure 5 - 40: A chart with a patterned backdrop applied to its legend.

• To draw a solid backdrop for a chart element

1 Double-click on the chart element to which you want to apply a 
backdrop or choose Chart Designer from the Format menu and then 
select the chart element to format.

2 In the Chart Designer dialog box, select the Backdrop tab.

3 Select the Gradient option.

4 From the Gradient drop-down list, select any design for blending the 
colors.

5 From the Fill/From Color drop-down list, select the color for the chart 
element’s backdrop.

6 From the Pattern/To Color drop-down list, select the same color for 
the chart element's backdrop.
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7 Click on the OK or Apply button to redraw the chart.

• To draw a patterned backdrop for a chart element

1 Double-click on the chart element to which you want to apply a 
backdrop or choose Chart Designer from the Format menu and then 
select the chart element to format.

2 In the Chart Designer dialog box, select the Backdrop tab.

3 Select the Brush option.

4 From the Brush drop-down list, select a pattern style.

5 From the Fill/From Color drop-down list, select the color for the chart 
element's backdrop.

6 From the Pattern/To Color drop-down list, select the color for the 
chart element's backdrop.

7 Click on the OK or Apply button to redraw the chart.

Note  To remove the backdrop, select the No Fill option and then 
click on the OK or Apply button.

Note  To remove the backdrop, select the No Fill option and then 
click on the OK or Apply button.
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Drawing a Gradient Backdrop for a Chart Element
A gradient backdrop blends two colors to fill a backdrop. You can apply a 
gradient backdrop to any chart element except a data point or series. 
Figure 5 - 41 shows a chart with an oval gradient applied to the plot 
region.

Figure 5 - 41: A chart with an oval gradient applied to its plot region.

• To draw a gradient backdrop for a chart element

1 Double-click on the chart element to which you want to apply a 
backdrop or choose Chart Designer from the Format menu and then 
select the chart element to format.

2 In the Chart Designer dialog box, select the Backdrop tab.

3 Select the Gradient option.

4 From the Gradient drop-down list, select the design for blending the 
colors.

5 From the Fill/From Color drop-down list, select the color to use as 
one of the following:

• The top color in a horizontal gradient

• The left color in a vertical gradient

• The center color in a rectangle or oval gradient
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6 From the Pattern/To Color drop-down list, select the color to use as 
one of the following:

• The bottom color in a horizontal gradient

• The right color in a vertical gradient 

• The outer color in a rectangle or oval gradient

7 Click on the OK or Apply button to redraw the chart.

Using a Graphic as a Backdrop for a Chart Element
You can use a bitmap, Windows metafile or JPEG bitmap as the backdrop 
for a chart element. Survey Crafter Professional provides three options for 
specifying the graphic and five options for fitting the graphic in the chart 
element. Figure 5 - 42 shows a graphic used as a plot’s backdrop.

Figure 5 - 42: A chart with a graphic of a map used as the plot’s backdrop.

• To use a graphic as a backdrop for a chart element

1 Double-click on the chart element to which you want to apply a 
backdrop or choose Chart Designer from the Format menu and then 
select the chart element to format.

2 In the Chart Designer dialog box, select the Picture tab.

3 Do one of the following to specify the backdrop graphic:

Note  To remove the backdrop, select the No Fill option and then 
click on the OK or Apply button.
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• Type the path to the graphic in the File field.

• Click on the Browse button and select the graphic in the Open 
dialog box.

• If the graphic is on the clipboard, click on the Paste button.

4 Select an option to control how the graphic fills the chart element. 

For example, select Stretch To Fit to scale the graphic to the size of 
the backdrop regardless of the graphic’s original proportions.

5 To save the graphic with the chart, select the Embed check box.

6 Click on the OK or Apply button to redraw the chart.

Resetting a Chart to Default Formats

If you reset a chart to its default formats, Survey Crafter Professional 
returns all chart options except the chart type to their default values.

• To reset the chart to its default formats

1 From the Format menu, choose Chart Designer and then select Chart 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab.

3 Click on the Reset Chart to Defaults button.

Survey Crafter Professional restores the chart’s default formats.

4 Click on the OK or Apply button to redraw the chart.

Tip To save disk space, it is recommended that you do not embed 
graphics unless they will not be available in the same location later.
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Formatting 3D Charts

3D charts have many unique formatting features. For example, you can 
rotate them and illuminate them from different directions.

Displaying a Chart in 3D

You can display most types of 2D charts as 3D charts.

• To display a chart in 3D

1 From the Format menu, choose Chart Designer and then select Chart 
from the list of chart elements.

2 In the Chart Designer dialog box, select the Type tab.

3 Under Chart, choose the 3D option.

4 Click on the OK or Apply button to redraw the chart.

Changing the 3D View

You can change the rotation, elevation, viewing distance, and proportions 
of a 3D chart by using the 3D View tab of the Chart Designer dialog box. 
You can also rotate and elevate a chart manually.

• To change the 3D view by using the Chart Designer dialog box

1 From the Format menu, choose Chart Designer and then select Plot 
from the list of chart elements.
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2 In the Chart Designer dialog box, select the 3D View tab.

Figure 5 - 43: The 3D View tab of the Chart Designer dialog box.

3 To change the relative height from which the chart is viewed, enter an 
angle from 0 to 90 degrees (or equivalents) in the Elevation field.

Entering 90 degrees means you look directly down on top of the 
chart. Entering 0 degrees means you look directly at the side of the 
chart.

4 To specify the angle the chart is turned to the viewer, enter an angle 
from 0 to 360 degrees (or the equivalent) in the Rotation field.

This field does not apply to doughnut charts or 3D pie charts.

5 To control how Survey Crafter Professional gives the chart its 3D 
look, select an option from the Projection drop-down list. Refer to 
Table 5 - 3 and Figure 5 - 44.

Table 5 - 3: Projection options for 3D charts.

Projection option Description

Oblique Gives the chart depth but prevents the XY plane 
from changing when the chart is rotated or 
elevated.

Orthogonal Does not apply perspective to the chart. 
Vertical lines remain vertical, making some 
charts easier to read.



      Analyses: Charts 5 - 63 
Formatting 3D Charts
Figure 5 - 44: Projections for three-dimensional charts.

6 To control the distance from which the chart is viewed, enter a 
positive value (between 50 and 1000) as a percentage of the chart’s 
depth in the Viewing Distance field.

The larger the percentage you enter, the farther away the chart 
appears.

7 To control the chart’s width and depth, enter a percentage (between 5 
and 2000) of the chart’s height in the Width To Height and Depth To 
Height fields.

The larger the percentages you enter, the wider and deeper the chart 
appears.

8 Click on the OK or Apply button to redraw the chart.

• To rotate and elevate a chart manually

1 Place the pointer anywhere in the chart region.

2 Press and hold the [CTRL] key.

Perspective Gives the most realistic 3D appearance. 
Objects farther away converge toward a 
vanishing point.

Table 5 - 3: Projection options for 3D charts. (Continued)

Projection option Description

Perspective projection Orthogonal projection Oblique projection
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The cursor changes to the rotation cursor.

3 Click and hold the left mouse button.

A dotted bounding box appears around the chart plot. Reference 
arrows appear at the corner where the first data point in the first series 
is drawn.

Figure 5 - 45: Bounding box around a chart being rotated manually. 

4 Move the rotation cursor (a four-sided arrow) up and down to change 
the chart elevation and right and left to change the chart rotation.

The bounding box shows the position of the chart plot as you move 
the mouse.

5 When the chart has the rotation and elevation you want, release the 
mouse button.

Survey Crafter Professional redraws the chart in the new position.

Lighting 3D Charts

Light falling on a 3D chart illuminates some areas brightly and places 
other areas in shadows. You can control how much and from what 
direction light strikes the chart.

• To light a 3D chart

1 From the Format menu, choose Chart Designer and then select Plot 

Bounding box
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from the list of chart elements.

2 In the Chart Designer dialog box, select the 3D Lighting tab.

3 Enter the percentage (from 0 to 100) of ambient light shining on the 
chart in the Ambient Light field.

Entering 100 illuminates all sides of the chart equally regardless of 
the single light sources you turn on. Entering 0 illuminates only the 
sides of the chart facing active light sources.

Figure 5 - 46: The effects of ambient light on a chart’s appearance.

4 To accent the edges of 3D objects, do the following:

• Select the Edge Intensity check box. To turn off edge accents, clear 
the check box.

• Enter a percentage (between 0 and 100) to specify the amount of 
lighting applied to objects' edges in the Edge Intensity field.

Ambient light 100%
No edge lights
No light sources

Ambient light 50%
No edge lights
No light sources
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Entering 0 draws the edges as black lines. Entering 100 fully 
illuminates the objects' edges using the edge pen's color.

Figure 5 - 47: The effects of edges lights on a chart’s appearance.

5 To specify any single, preset light sources, enter percentages in fields 
under Light Source Intensities.

For example, to illuminate the chart from the upper left corner, enter 
100 in the High Left field and 0 in the other eight fields. At 100 
percent, chart surfaces perpendicular to the light source are fully 
illuminated.

6 Click on the OK or Apply button to redraw the chart.

Ambient light 100%
Edge lights on at 0%
No light sources

Ambient light 100%
Edge lights on at 100%
No light sources
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Formatting Axes

Survey Crafter Professional provides several options for formatting a 
chart’s axes including:

• Changing an Axis’ Color and Thickness

• Adding and Removing Grid Lines

• Hiding and Showing an Axis’ Scale

• Changing Axes’ Intersection

• Scaling Axes

• Changing the Value (Y) Axis Type

• Adding and Removing Tick Marks on an Axis

• Creating an Axis Title

Before formatting a chart’s axes, read the following section “Axis 
Terminology” to learn names for axes featured in different chart types.
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Axis Terminology

There are three primary types of axes that can appear on a chart: a value 
axis, a category axis, and a date axis. Category axes have text labels 
identifying the category or series in the chart. Value axes display numbers 
as values or percentages. Date axes display a range of dates. Table 5 - 4 
lists the types of axes on different chart types.

Changing an Axis’ Color and Thickness

Changing an axis color and thickness also changes the color and thickness 
of any tick marks on the axis.

• To change an axis’ color and thickness

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

Table 5 - 4: Names of axes in different chart types.

Chart type X axis Y axis 2nd Y axis Z axis

2D Bar, 2D Line, 2D Area, 2D 
Step, 2D Combination

Category Value Value N/A

3D Bar, 3D Line, 3D Area, 3D 
Step, 3D Combination

Category Value Value Category

2D and 3D Horizontal Bar Category Value N/A N/A

2D and 3D Gantt Category Date N/A N/A

XY Value Value N/A N/A

Bubble Value Value N/A N/A

Hi-Lo Date or 
Category

Value Value N/A

Polar Angle Value N/A N/A

Radar Radar Value N/A N/A
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2 In the Chart Designer dialog box, select the Pens tab.

Figure 5 - 48: The Pens tab of the Chart Designer dialog box.

3 To specify the thickness of the axis line, select an option from the 
Width drop-down list.

4 To specify the axis' color, select an option from the Color drop-down 
list.

5 Click on the OK or Apply button to redraw the chart.
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Adding and Removing Grid Lines

You can use different formats to distinguish major and minor grid lines. 
You can remove major or minor grid lines at any time.

Figure 5 - 49: Major and minor grid lines on a chart.

• To add grid lines

1 Do one of the following:

• Double-click on the axis you want to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

Major grid 
line

Minor grid 
line
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2 In the Chart Designer dialog box, select the Pens tab.

Figure 5 - 50: The Pens tab of the Chart Designer dialog box.

3 To format the minor grid lines, do the following under Minor Grid 
Pen:

• From the Style drop-down list, select a grid line style.

• From the Width drop-down list, select a grid line width.

• From the Color drop-down list, select a grid line color.

4 To format the major grid lines, do the following under Major Grid 
Pen:

• From the Style drop-down list, select a grid line style.

• From the Width drop-down list, select a grid line width.

• From the Color drop-down list, select a grid line color.

5 Click on the OK or Apply button to redraw the chart.

• To remove grid lines 

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Pens tab.
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3 To remove minor grid lines, select NULL from the Style drop-down 
list under Minor Grid Pen.

4 To remove major grid lines, select NULL from the Style drop-down 
list under Major Grid Pen.

5 Click on the OK or Apply button to redraw the chart.

Hiding and Showing an Axis’ Scale

You can hide or show any axis’ scale (the numbers, dates, or categories 
appearing on an axis).

• To hide an axis scale

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value or Category Scale 
tab.

3 Under Scale, clear the Show check box.

4 Click on the OK or Apply button to redraw the chart.

• To show an axis scale

1 Do one of the following:

• Double-click on the axis to format.

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value or Category Scale 
tab.

3 Under Scale, select the Show check box.

4 Click on the OK or Apply button to redraw the chart.
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Changing Axes’ Intersection

An axis may cross another axis at a location you define.

Figure 5 - 51: One axis intersecting another in a non-standard position.

• To change an axis’ intersection

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value or Category Scale 
tab.

3 Under Intersection, clear the Automatic check box.

4 In the Cross At field, enter the position where you want the selected 
axis to cross its intersecting axis.

If the intersecting axis is a value axis (Y axis), enter the value where 
you want to place the selected axis. If the intersecting axis is a date or 
category axis (X or Z axis), enter the division number at which you 
want to place the selected axis.

5 To move the axis labels with the axis, check the Labels Inside Plot 
check box.

Here the Y axis intersects the 
X axis near the X axis’ center 
rather than its left edge.
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Moving labels with their axis may obscure other chart elements.

6 Click on the OK or Apply button to redraw the chart.

Scaling Axes

By default, Survey Crafter Professional automatically scales axes based 
on the data in the chart. You can, however, override the automatic scaling 
to set the number and range of labels appearing on an axis. For example, 
you can specify that a value (Y) axis has a minimum value of 0, a 
maximum value of 100, and shows divisions at 20, 40, 60, and 80.

Scaling a Category (X or Z) Axis
You can change the number of labels and tick marks appearing on 
category (X or Z) axes. Reducing the number of labels and tick marks can 
help a chart look less cluttered.

• To scale a category (X or Z) axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
X Axis or Z Axis element.

Note  To return the selected axis to its default position, select the 
Automatic check box and then click on the OK or Apply button.
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2 In the Chart Designer dialog box, select the Category Scale tab.

Figure 5 - 52: The Category Scale tab of the Chart Designer dialog box.

3 Under Scale, clear the Automatic check box.

4 Under Divisions, enter the number of divisions you want between 
labels in the Per Label field.

For example, a value of 1 labels every division. A value of 3 labels 
every third division.

5 Under Divisions, enter the number of tick marks to appear between 
labels in the Per Tick field. 

For example, a value of 1 places a tick at every division. A value of 3 
places a tick at every third division.

6 If you are working with a 2D chart and want to center each label at a 
tick mark, select the Label On Ticks check box.

7 Click on the OK or Apply button to redraw the chart.

Note  To have Survey Crafter Professional scale the axis based on 
the data being charted, select the Automatic check box and then 
click on the OK or Apply button.
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Scaling a Value (Y) Axis
You can scale the value axis (Y axis) based on the data being charted or 
you can customize the axis. When customizing the axis, define the axis’ 
minimum and maximum values and enter the number of major and minor 
divisions to appear on the axis. Axis labels appear at only major divisions.

• To scale a value (Y) axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
Y Axis element.

2 In the Chart Designer dialog box, select the Value Scale tab.

Figure 5 - 53: The Value Scale tab of the Chart Designer dialog box.

3 Under Scale, clear the Automatic check box.

4 To define the axis’ endpoints, enter the axis’ minimum value in the 
Minimum field and its maximum value in the Maximum field.

5 Under Divisions, enter the number of major divisions to appear on the 
axis in the Major field.

6 Enter the number of minor divisions to appear on the axis in the 
Minor field.
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7 Click on the OK or Apply button to redraw the chart.

Scaling a Date Axis
You can have Survey Crafter Professional scale the date axis based on the 
data being charted or you can customize the axis. When customizing the 
axis, define the axis’ minimum and maximum dates, its major and minor 
date divisions, and formats to indicate new months and new years. Axis 
labels appear at only major date divisions.

• To scale a date axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Date Scale tab.

3 Under Scale, clear the Automatic check box.

4 In the Minimum field, enter the start date for the chart. In the 
Maximum field, enter the end date for the chart. 

5 In both the Major Interval and Minor Interval fields, enter a number 
to specify how many intervals pass before a tick mark appears on the 
axis. Then select an interval type from each drop-down list.

6 To avoid displaying dates that fall on weekends, select the Skip 
Weekends check box. Leave the box cleared if you want to display all 
dates regardless of the day of the week.

7 Select the Date Formats tab.

8 Define formats for axis labels as follows:

• From the Major Format drop-down list, select a date format for the 
first level of axis labels.

Note  To have Survey Crafter Professional scale the axis based on 
the data being charted, select the Automatic check box and then 
click on the OK or Apply button.



5 - 78 Analyses: Charts
Formatting Axes  
• From the Extra Interval 1 drop-down list, select a format for the 
first extra interval.

• From the Extra Interval 2 drop-down list, select a format for the 
second extra interval.

9 Click on the OK or Apply button to redraw the chart.

Scaling a Polar Axis
You can format the radius axis on a polar chart just like any other value 
(Y) axis. Scaling the polar axis allows you to control the number of radial 
grid lines and labels that appear around the chart’s perimeter.

• To scale a polar axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value Scale tab.

3 Under Scale, clear the Automatic check box.

4 Under Divisions, enter the number of major divisions for the chart in 
the Major field.

For example, to divide the chart into quadrants, enter 4.

5 Enter the number of minor divisions to appear between each major 
division in the Minor field.

For example, to divide each quadrant into thirds, enter 3.

Note  To have Survey Crafter Professional scale the axis based on 
the data being charted, select the Automatic check box and then 
click on the OK or Apply button.
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6 Click on the OK or Apply button to redraw the chart.

Changing the Value (Y) Axis Type

A chart’s value (Y) axis may be one of three types:  linear, logarithmic, or 
percent.

When choosing the logarithmic axis type, specify a base for the scale.

When choosing the percent axis type, specify what basis Survey Crafter 
Professional calculates percentages on. Indicate, for example, whether 
Survey Crafter Professional should treat as 100% the largest value in the 
series or the sum of all values in the series.

• To change the value (Y) axis type

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Scale Type tab.

3 Under Scale Type, select the new axis type.

4 If you selected Logarithmic in step 3, enter the logarithm’s base in the 
Log Base field.

5 If you selected Percent in step 3, select the quantity Survey Crafter 
Professional should treat at 100% from the % Basis drop-down list.

Indicate, for example, whether Survey Crafter Professional should 
treat the largest value in the series or the sum of all values in the series 
as 100%.

Click on the Help button for a description of the % Basis options.

6 Click on the OK or Apply button to redraw the chart.

Note  To have Survey Crafter Professional scale the axis based on 
the data being charted, select the Automatic check box and then 
click on the OK or Apply button.
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Adding and Removing Tick Marks on an Axis

You can control the length and location of an axis’ tick marks. Tick 
marks’ color and thickness are the same as the axis’ color and thickness.

• To add tick marks to an axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value or Category Scale 
tab.

Figure 5 - 54: The Category Scale tab of the Chart Designer dialog box.

3 Under Ticks, select where you want tick marks to appear on the axis.

Select the Center option if you want tick marks to straddle the axis.

4 In the Length field, enter the length of the tick marks in points.

5 Click on the OK or Apply button to redraw the chart.
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• To remove tick marks from an axis

1 Do one of the following:

• Double-click on the axis to format. 

• From the Format menu, choose Chart Designer, and then select the 
axis element to format.

2 In the Chart Designer dialog box, select the Value or Category Scale 
tab.

3 Under Ticks, select the None option.

4 Click on the OK or Apply button to redraw the chart.

Creating an Axis Title

You can add a title to each axis. Axis titles provide additional information 
about the axis and help the viewer interpret the chart.

• To create an axis title

1 Do one of the following:

• Double-click on the axis you want to title.

• From the Format menu, choose Chart Designer, expand the axis 
element to format, and then select Axis Title.

2 In the Chart Designer dialog box, select the Text tab. 

3 Type the title text in the Text field.
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Figure 5 - 55: The Text tab of the Chart Designer dialog box.

4 Select the Layout tab.

5 Align and orient the title text as follows:

• Under Alignment, select a horizontal alignment option.

• Under Alignment, select a vertical alignment option.

• Under Orientation, select an orientation option.

6 If you want the title text to appear on more than one line if necessary, 
select the Word Wrap check box.

7 Click on the OK or Apply button to redraw the chart.

For instructions on formatting the title, see the sections below.

• “Changing the Font of Chart Text” on page 5 - 51

• “Aligning and Orienting Chart Text” on page 5 - 52

• “Drawing a Frame around a Chart Element” on page 5 - 55

• “Drawing a Solid or Patterned Backdrop for a Chart Element” on 
page 5 - 56

• “Drawing a Gradient Backdrop for a Chart Element” on page 5 - 58

• “Using a Graphic as a Backdrop for a Chart Element” on page 
5 - 59

Enter the axis title’s text 
here.



      Analyses: Charts 5 - 83 
Formatting Plots
Formatting Plots

A chart’s plot consists of all the chart features except the title, legend, and 
footnote. Formatting changes you can make to a plot include positioning 
and sizing the plot, formatting the plot’s base and walls, and adjusting 
spacing between bars in bar charts.

Positioning and Sizing a Plot

You can place a chart’s plot in a custom location and specify its 
dimensions manually or by using the Chart Designer dialog box.

• To place a plot in a custom position manually

1 Click on the chart plot to select it.

Handles appear around the plot.

2 Click and drag the plot to its new position.

• To place a plot in a custom position by using the Chart Designer 
dialog box

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Position tab.

3 Clear the Automatic Location check box.

4 Under Custom Location, enter positions in the Top and Left fields.

5 Click on the OK or Apply button to redraw the chart.

• To size a plot manually

1 Click on the chart plot to select it.

Handles appear around the plot.

2 Click and drag a handle to resize the plot.

Survey Crafter Professional redraws the plot when you release the 
mouse button.
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• To size a plot by using the Chart Designer dialog box

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Position tab.

3 Clear the Automatic Location check box.

4 Under Custom Location, enter the plot’s height in the Height field.

5 Enter the plot’s width in the Width field.

6 Click on the OK or Apply button to redraw the chart.

Formatting a Plot’s Base and Walls

You can draw lines around and apply solid or patterned fills to plots’ 
bases and walls. The figure below illustrates a plot’s base and walls. Both 
2D and 3D plots have walls but only 3D plots have bases.

Figure 5 - 56: A 3D plot’s base and walls.
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• To format a 2D or 3D plot’s walls

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Walls tab.

3 Enter the wall thickness in points in the Wall Width field.

Figure 5 - 57: The Walls tab of the Chart Designer dialog box.

4 To draw a line around the plot’s walls, do the following under Pen:

• From the Style drop-down list, select a line style. To remove the 
walls’ lines, select NULL.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

5 To apply a fill to the plot’s walls, do the following under Fill:

• From the Pattern drop-down list, select a pattern for the fill. To 
apply a single color, choose Solid.

• From the Fill Color drop-down list, select the solid fill’s color or the 
pattern’s background color.

• From the Pattern Color drop-down list, select the pattern’s 
foreground color.

6 Click on the OK or Apply button to redraw the chart.
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• To format a 3D plot’s base

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Base tab.

3 Enter the base thickness in points in the Base Height field.

4 To draw a line around the plot’s base, do the following under Pen:

• From the Style drop-down list, select a line style. To remove the 
base’s lines, select NULL.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

5 To apply a fill to the plot’s base, do the following under Fill:

• From the Pattern drop-down list, select a pattern for the fill. To 
apply a single color, choose Solid.

• From the Fill Color drop-down list, select the solid fill’s color or the 
pattern’s background color.

• From the Pattern Color drop-down list, select the pattern’s 
foreground color.

6 Click on the OK or Apply button to redraw the chart.

Adjusting Bar Spacing

For 2D bar charts, you can change the distance between bars within a 
category (the bar gap ratio) and the space between categories of bars (the 
X gap ratio).
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For 3D bar charts, you can control the space between series of bars on the 
Z axis (the Z gap ratio) and the space between individual bars on the X 
axis (also called the X gap ratio). 

Figure 5 - 58: Bar gap and X gap ratios in a 2D bar chart.

• To adjust bar spacing in 2D bar charts

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Other tab.

3 To adjust the space between bars within a category, under Bars, enter 
a value as a percentage of bar width in the Bar Gap Ratio field.

A bar gap ratio of 50 places a space that is half as wide as a bar 
between each bar.

4 To adjust the space between categories of bars, enter a value as a 
percentage of bar width in the X Gap Ratio field.

An X gap ratio of 500 places a space that is five times as wide as a bar 
between each bar.

5 Click on the OK or Apply button to redraw the chart.

Bar gap ratio of 200%

X gap ratio of 500%
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• To adjust bar spacing in 3D bar charts

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Other tab.

3 To adjust the space between series of bars on the Z axis, enter a value 
as a percentage of bar width in the Z Gap Ratio field. 

A Z gap ratio of 300 places a gap that is three times as wide as a bar 
between series’ bars.

4 To adjust the space between bars on the X axis, enter a value as a 
percentage of bar width in the X Gap Ratio field.

An X gap ratio of 500 places a space that is five times as wide as a bar 
between each bar.

5 Click on the OK or Apply button to redraw the chart.

Formatting Pie, Doughnut, Radar, and Polar 
Charts

Survey Crafter Professional provides several options for formatting pie, 
doughnut, radar, and polar charts including:

• Controlling the Direction of Pie, Doughnut, Radar, and Polar Charts

• Ordering and Weighting Pie and Doughnut Charts

• Controlling a Doughnut or 3D Pie Chart’s Height and Top Radius

• Changing a Doughnut Chart’s Center Diameter

• Adjusting the Number of Sides in a Doughnut Charts
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Controlling the Direction of Pie, Doughnut, Radar, and 
Polar Charts
You can draw these chart types in the clockwise or counterclockwise 
direction. You can also define the position at which Survey Crafter 
Professional begins plotting the chart’s data.

Figure 5 - 59: A pie chart drawn clockwise with a starting position of 0 degrees (left) and a 
pie chart drawn counterclockwise with a starting position of 0 degrees.

• To control the direction of pie, doughnut, radar, and polar charts

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Other tab.

3 To draw the chart in the clockwise direction, select the Clockwise 
check box. To draw the chart in the counterclockwise direction, clear 
the Clockwise check box.

4 Set the position at which Survey Crafter Professional begins plotting 
the chart’s data in the Starting Angle field. 

The value in the Starting Angle field appears in degrees, radians, or 
grads depending on the option selected from the Angle Units 
drop-down list.

90 degrees sets the start position to 12 o’clock and 0 degrees sets the 
start position to 3 o’clock.

5 If the chart is a radar or polar chart, enter the angle at which you want 
the scale to appear in the Scale Angle field.

6 Click on the OK or Apply button to redraw the chart.
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Ordering and Weighting Pie and Doughnut Charts
You can sort the sections of a pie or doughnut chart in ascending or 
descending order based on their size. If a chart shows more than one pie 
or doughnut, you can size each pie or doughnut relative to the others or to 
the first series in each pie or doughnut.

• To order and weight sections of a pie or doughnut chart

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and the select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Pie tab.

3 To define the basis for weighting pie or doughnut charts, choose one 
of the following:

• The Area option to weight pies or doughnuts by their areas

• The Diameter option to weight pies or doughnuts by their diameters

4 To control the relative size of the chart’s pies or doughnuts, select an 
option from the Basis drop-down list under Weighting. Refer to Table 
5 - 5. 

5 From the Sorting drop-down list, select an option for arranging the 
sections based on their sizes.

Table 5 - 5: Weighting options.

Select So that

None All pies and doughnuts appear the same size.

Total Survey Crafter Professional totals the slice 
values in each pie or doughnut and determines 
the size of each chart relative to the largest pie 
or doughnut.

Series Survey Crafter Professional determines the size 
of each pie or doughnut according to the size of 
the value in each chart’s first series. The larger 
the value in the first series, the larger the pie or 
doughnut.
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To draw the pie or doughnut in the order the data appears in the 
chart’s table, select None.

Figure 5 - 60: Pie charts sorted in ascending order (left) and descending order.

6 Click on the OK or Apply button to redraw the chart.

Controlling a Doughnut or 3D Pie Chart’s Height and Top 
Radius
You can define a 3D pie or doughnut chart’s height as a percentage of its 
bottom radius and its top radius as a percentage of its bottom radius.

Figure 5 - 61: A pie chart with a top 50% as wide as its base (left) and a doughnut chart 
with a height equal to 50% of its bottom radius.

• To control a 3D pie or doughnut chart’s height and top radius

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Pie tab.

3 To set a 3D pie or doughnut chart’s height, enter a value between 0 
and 100 in the Thickness Ratio field.

For example, entering 100 makes the chart as tall as its bottom radius. 
Entering 33 makes the chart one-third as tall as its bottom radius.
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4 To set a 3D pie or doughnut chart’s top radius, enter a percentage 
(from 0 to 100) of the chart’s bottom radius in the Top Radius Ratio 
field.

For example, entering 100 makes the chart’s top and bottom radius 
the same. Entering 0 draws the chart as a cone.

5 Click on the OK or Apply button to redraw the chart.

Changing a Doughnut Chart’s Center Diameter
You can define a doughnut chart’s center diameter as a percentage of the 
entire doughnut’s diameter.

• To change a doughnut chart’s center diameter

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Pie tab.

3 Under 3D, in the Interior Ratio field, enter the percentage (from 1 to 
100) of the entire doughnut diameter used to display its center.

Entering 50 sets the center diameter equal to half the doughnut’s 
diameter.

4 Click on the OK or Apply button to redraw the chart.

Adjusting the Number of Sides in a Doughnut Charts
The more sides you assign a doughnut chart, the rounder and smoother it 
appears. For example, assigning a doughnut chart 3 sides gives it a 
triangular cross section. Assigning it 360 sides gives it a circular cross 
section.

Figure 5 - 62: A three-sided doughnut chart.
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• To adjust the number of a doughnut’s sides

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and the select Plot from the list of chart elements.

2 In the Chart Designer dialog box, select the Pie tab.

3 Under 3D, in the Sides field, enter the number of sides (from 2 to 
360) for the doughnut chart.

Survey Crafter Professional assigns this number of sides to all 
doughnuts appearing in the chart.

4 Click on the OK or Apply button to redraw the chart.
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Formatting Series and Data Points

Survey Crafter Professional provides several options for formatting 
individual series and data points including:

• Hiding, Excluding, and Showing Series

• Filling and Outlining Series

• Setting Series Options

• Formatting Series Lines

• Formatting Series Markers

• Adding and Removing Guidelines on Series

• Displaying Series Statistics

• Formatting Data Points

Hiding, Excluding, and Showing Series

There are two ways to remove a series from a chart without editing the 
tabulated data appearing in the chart:

• Hiding a series (removes the series from the chart but still shows the 
space it occupied)
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• Excluding a series (removes the series and the space it occupied from 
the chart)

Figure 5 - 63: Shown, hidden, and excluded series.

• To hide or exclude a series

1 Do one of the following:

• Double-click on the series you want to hide or exclude.

• Choose Chart Designer from the Format menu and then select the 
series you want to hide or exclude.

2 In the Chart Designer dialog box, select the Options tab.

3 To hide the series, select the Hide Series check box. To exclude the 
series, select the Exclude Series check box.

4 Click on the OK or Apply button to redraw the chart.

• To show a series

1 Choose Chart Designer from the Format menu and then select the 
series you want to show.

2 In the Chart Designer dialog box, select the Options tab.

3 Clear the Hide Series or Exclude Series check box.

4 Click on the OK or Apply button to redraw the chart.

Both series shown One series hidden One series excluded
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Filling and Outlining Series

You can apply solid and patterned fills to series and, for 2D bars, display a 
graphic inside the bars. You can also draw outlines around series 
elements. Each procedure appears below.

Figure 5 - 64: Fills and outlines applied to series.

• To apply a solid fill to a series

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, expand the selected series and then 
select Datapoint.

3 Select the Fill tab.

4 From the Pattern drop-down list, select the solid pattern.

5 From the Fill Color drop-down list, select the fill color.

6 Click on the OK or Apply button to redraw the chart.

Note  To remove a fill from a series, select the None option from the 
Pattern drop-down list.

Patterned fill applied to 
series

Outlined series A stacked graphic in 
one series
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• To apply a patterned fill to a series

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, expand the selected series and then 
select Datapoint.

3 Select the Fill tab.

4 From the Pattern drop-down list, select the fill pattern.

5 From the Fill Color drop-down list, select the pattern’s background 
color.

6 From the Pattern Color drop-down list, select the pattern’s foreground 
color.

7 Click on the OK or Apply button to redraw the chart.

• To insert a graphic inside 2D bars

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, expand the selected series and then 
select Datapoint.

3 Select the Picture tab.

4 To select the graphic to insert, do one of the following:

• Type the graphic’s path in the File field.

• Click on the Browse button and select the graphic in the Open 
dialog box.

• If the graphic is on the clipboard, click on the Paste button.

Note  To remove a fill from a series, select the None option from the 
Pattern drop-down list.
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5 Select the Tiled option to duplicate the graphic repeatedly to fill the 
bars or select the Stretch To Fit option to scale the graphic to fit the 
bars regardless of its original proportions.

6 To save the graphic with the chart, select the Embed check box.

To limit file size, it is recommended that you embed graphics only if 
they will not be available in the same location later.

7 Click on the OK or Apply button to redraw the chart.

• To outline a series

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, expand the selected series and then 
select Datapoint.

3 Select the Fill tab.

4 Do the following under Edge:

• From the Style drop-down list, select the line style.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

5 Click on the OK or Apply button to redraw the chart.

Note  To remove a graphic from a series, click on the Clear button 
and then click on the OK or Apply button.

Note  To remove an outline from a series, select NULL from the 
Style drop-down list and then click on the OK or Apply button.
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Setting Series Options

Series options affect how Survey Crafter Professional represents data in a 
series. You can change 3D bar styles, smooth series on line and area 
charts, define bubble diameters, and set gain and loss colors for hi-lo 
charts.

Changing 3D Bar Styles
You can give 3D bars any number of sides from 3 to 360. For example, to 
give the bars a triangular cross section, assign them 3 sides. Assigning 
360 sides gives the bars circular cross sections. You can also make the 
bars’ tops broader or narrower than their bases. 

Figure 5 - 65: Triangular and conical bars in a three-dimensional bar chart.

• To change 3D bar styles

1 Do one of the following:

• Double-click on a bar in the series.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Options tab.

3 Under Bars, in the Sides field, enter the number of sides for the 
series’ bars.

4 In the Top Ratio field, enter a positive number to indicate the 
percentage of the bars’ bottom dimensions used to draw the bars’ top.
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For example, entering 100 gives the bar the same top and bottom 
dimensions. Entering values greater than 100 makes the tops of the 
bars broader than their bases and entering values less than 100 makes 
their tops narrower than their bases.

5 Click on the OK or Apply button to redraw the chart.

Smoothing Series in Line and Area Charts
Smoothing a series makes the curve through its data points look less 
jagged. Choose from two mathematical formulas Survey Crafter 
Professional uses to smooth series.

• To smooth a series in line and area charts

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Options tab.

3 Select a smoothing function from the Function drop-down list.

The CubicBSpline option results in a smoother curve than the 
QuadraticBSpline but the resulting curve tends to vary farther from 
the data points.

4 In the Factor field, enter the number of points Survey Crafter 
Professional samples between data points.

A higher number results in a smoother curve.

5 Click on the OK or Apply button to redraw the chart.

Defining Bubble Diameters
To control the appearance of bubbles in a bubble chart, define the largest 
bubble’s diameter.

• To define bubble diameters

1 Double-click on the chart plot or choose Chart Designer from the 
Format menu and then select Plot from the list of chart elements.
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2 In the Chart Designer dialog box, select the Bubble tab.

3 In the Largest Bubble Ratio field, enter the percentage (from 2 to 50) 
of the shortest chart axis to use as the largest bubble’s diameter.

Survey Crafter Professional sizes the chart’s other bubbles relative to 
the largest bubble.

4 Click on the OK or Apply button to redraw the chart.

Setting Gain and Loss Colors for Hi-lo-close Charts
You can use different colors to show gains and losses in hi-lo-close charts. 
For example, use red to indicate losses and black to indicate gains.

• To set gain and loss colors for hi-lo-close charts

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Options tab.

3 Under HiLo Close, from the Gain Color drop-down list, select the 
color to indicate gains.

4 From the Loss Color drop-down list, select the color to indicate 
losses.

5 Click on the OK or Apply button to redraw the chart.
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Formatting Series Lines

You can use lines to connect data points in series appearing as lines in 
line, XY, radar, polar, and hi-lo charts.

Figure 5 - 66: Different line styles for a charts’ series.

• To format series lines

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Lines tab.

3 If you want to show lines, select the Show Series Lines check box. To 
hide lines, clear the check box.

4 Format the series lines by doing the following:

• From the Style drop-down list, select a line style.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

• From the Join drop-down list, select a method for joining line 
segments in the series.



      Analyses: Charts 5 - 103 
Formatting Series and Data Points
• From the Caps drop-down list, select a method for displaying the 
ends of the lines.

5 Click on the OK or Apply button to redraw the chart.

Formatting Series Markers

Markers (for example, stars, hollow triangles, or filled circles) indicate 
the exact location of a data point in a series. You can show or hide 
markers and specify their format or have Survey Crafter Professional 
format them automatically.

All chart types except pies and doughnuts can display markers.

Figure 5 - 67: Markers displayed on a chart’s series.

• To format series markers

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Options tab.

3 To show markers on the series, select the Show Markers check box. 
To hide markers, clear the check box.
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4 To have Survey Crafter Professional format the series’ markers, select 
the Automatic Markers check box. Then go to step 8. To format the 
markers, clear the Automatic Markers check box and go to step 5.

5 Expand the selected series in the Chart Designer dialog box and then 
select Datapoint.

6 Select the Markers tab.

7 To format the marker, do the following:

• From the Style drop-down list, select a marker type.

• From the Color drop-down list, select a marker color.

• In the Size field, enter a marker size in points.

• From the Pen Width drop-down list, select the width of the 
marker’s lines.

8 Click on the OK or Apply button to redraw the chart.

Adding and Removing Guidelines on Series

Guidelines are lines connecting data points in a series to one or more 
axes. They help viewers identify data points.
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You can display guidelines only on area, step, bubble, and line charts.

Figure 5 - 68: Guidelines on a series.

• To add guidelines to series

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Guidelines tab.

Figure 5 - 69: The Guidelines tab of the Chart Designer dialog box.

Guidelines connecting a 
series’ data points to 
the X axis
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3 Select the Show Guidelines check box.

4 To format the guidelines, do the following:

• From the Style drop-down list, select a line style.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

• From the Caps drop-down list, select a style for the lines’ ends.

5 Click on the OK or Apply button to redraw the chart.

• To remove guidelines from a series

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Guidelines tab.

3 Clear the Show Guidelines check box.

4 Click on the OK or Apply button to redraw the chart.

Displaying Series Statistics

You can provide additional information about a series on the value (Y) 
axis by indicating its minimum, maximum, mean, standard deviation, and 
regression. Each statistic appears on the chart as a line intersecting a Y 
axis. You can use a different line style for each statistic.
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You can display series statistics only on 2D line and XY charts.

Figure 5 - 70: Selected statistics displayed for a series.

• To display series statistics

1 Do one of the following:

• Double-click on the series you want to format.

• Choose Chart Designer from the Format menu and then select the 
series you want to format.

2 In the Chart Designer dialog box, select the Statistics tab.

Figure 5 - 71: The Statistics tab of the Chart Designer dialog box.

The series’ 
maximum

The series’ 
minimum
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3 To show a statistic, do the following:

• Select the statistic’s check box.

• From its Line Styles drop-down list, select the statistic’s line style.

4 To format the statistics’ lines, do the following:

• From the Width drop-down list, select the lines’ width.

• From the Color drop-down list, select the lines’ color.

The same width and color applies to each of the chart’s statistics 
lines.

5 Click on the OK or Apply button to redraw the chart.

Formatting Data Points

To format individual data points, you can apply fills and display data 
point markers.

Applying Fills to Data Points
You can apply solid or patterned fills and outlines to individual data 
points unless the point is on a series drawn as a line. If a data point is a 2D 
bar, you can also display a graphic inside the bars.

• To apply a solid fill to a data point

1 Do one of the following:

• Double-click on the data point to format.

• From the Format menu, choose Chart Designer. Expand Series, the 
series that contains the data point and then Datapoint. Select the 
data point to format.

Note  To remove a statistic from the chart, clear the statistic’s check 
box and then click on the OK or Apply button.

Note  To discard any custom fill settings you enter for a data point, select 
the Defaults tab, click on the Reset to Default Datapoint button, and then 
click on the OK or Apply button.
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2 In the Chart Designer dialog box, select the Fill tab.

Figure 5 - 72: The Fill tab of the Chart Designer dialog box.

3 From the Pattern drop-down list, select a solid pattern.

4 From the Fill Color drop-down list, select the fill color.

5 Click on the OK or Apply button to redraw the chart.

• To apply a patterned fill to a data point

1 Do one of the following:

• Double-click on the data point to format.

• From the Format menu, choose Chart Designer. Expand Series, the 
series that contains the data point and then Datapoint. Select the 
data point to format.

2 In the Chart Designer dialog box, select the Fill tab.

3 From the Pattern drop-down list, select the fill pattern.

4 From the Fill Color drop-down list, select the pattern’s background 
color.

5 From the Pattern Color drop-down list, select the pattern’s foreground 
color.

Note  To remove a fill from a data point, select the None option from 
the Pattern drop-down list.
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6 Click on the OK or Apply button to redraw the chart.

• To outline a data point

1 Do one of the following:

• Double-click on the data point to format.

• From the Format menu, choose Chart Designer. Expand Series, the 
series that contains the data point and then Datapoint. Select the 
data point to format.

2 In the Chart Designer dialog box, select the Fill tab.

3 Do one of the following under Edge:

• From the Style drop-down list, select the line style. To remove an 
outline, select NULL.

• From the Width drop-down list, select a line width.

• From the Color drop-down list, select a line color.

4 Click on the OK or Apply button to redraw the chart.

• To insert a graphic inside a 2D bar

1 Do one of the following:

• Double-click on the data point to format.

• From the Format menu, choose Chart Designer. Expand Series, the 
series that contains the data point and then Datapoint. Select the 
data point to format.

2 In the Chart Designer dialog box, select the Picture tab.

3 To select the graphic to insert, do one of the following:

• Type the graphic’s path in the File field.

• Click on the Browse button and select the graphic in the Open 
dialog box.

• If the graphic is on the clipboard, click on the Paste button.

Note  To remove a fill from a data point, select the None option from 
the Pattern drop-down list.
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4 Select the Tiled option to duplicate the graphic repeatedly to fill the 
bar or select the Stretch To Fit option to scale the graphic to fit the bar 
regardless of the graphic’s original proportions.

5 To save the graphic with the chart, select the Embed check box.

To limit file size, it is recommended that you embed graphics only if 
they will not be available in the same location later.

6 Click on the OK or Apply button to redraw the chart.

Adding and Removing Data Point Markers
Markers indicate the location of a data point within a series. You can 
show or hide individual data point’s markers and format each marker 
differently.

• To add and format a data point marker

1 Do one of the following:

• Double-click on the data point to format.

• From the Format menu, choose Chart Designer. Expand Series, the 
series that contains the data point and then Datapoint. Select the 
data point to format.

Note  To remove a graphic from a data point, click on the Clear 
button and then click on the OK or Apply button.
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2 In the Chart Designer dialog box, select the Markers tab.

Figure 5 - 73: The Markers tab of the Chart Designer dialog box.

3 Select the Show Markers check box.

4 To format the marker, do the following:

• From the Style drop-down list, select a marker style.

• From the Color drop-down list, select a marker color.

• In the Size field, enter the marker size in points.

• From the Pen Width drop-down list, select the width of the 
marker’s lines.

5 Click on the OK or Apply button to redraw the chart.

• To remove a data point marker

1 Complete steps 1 and 2 above.

2 Clear the Show Markers check box.

3 Click on the OK or Apply button to redraw the chart.

Note  To discard any custom marker settings you entered, select the 
Defaults tab, click on the Reset to Default Datapoint button, and 
then click on the OK or Apply button.
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Formatting Labels

The sections below explain how to create and format series and data point 
labels and how to format axis labels.

Creating and Positioning Series Labels and Data 
Point Labels

By default, Survey Crafter Professional uses the column headings of the 
table you are plotting as series labels. However, if the table has no column 
headings, you can create series labels on the chart. Data point labels 
provide additional information about or draw attention to a data point. 

Creating Series Labels
An alternative to the legend, series labels identify some or all series on a 
line, area, step, XY, or radar chart. For example, if you charted monthly 
revenue for two companies, suitable series labels might be “Company 1” 
and “Company 2.”

Figure 5 - 74: A chart using series labels instead of a legend.

• To create series labels

1 From the Format menu, choose Chart Designer and then expand 
Series Labels.



2 Select the series for which you want to create a label.

3 Select the Style tab.

4 Do the following:

• Under Text Location, select where to place the series label.

• Under Label Line Style, select a line style to connect the label to its 
series.

5 Select the Text tab.

6 In the Text field, type the label’s text.

7 Click on the OK or Apply button to redraw the chart.

Creating Data Point Labels
Data point labels provide additional information about or draw attention 
to a data point. For example, suppose a chart shows monthly revenue for 
the year. To emphasize the month with the highest revenue, add a label 
like “Highest monthly revenue” to the data point.

Figure 5 - 75: A label applied one data point in a series.

You can use data point labels generated by Survey Crafter Professional or 
create your own labels.

• To create a data point label

1 From the Format menu, choose Chart Designer and then expand 
Series.

Data point label
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2 Expand the series that contains the data points for which you want to 
create a label and then select Datapoint Labels.

3 Select the Appearance tab.

4 Under Text Location, select an option for positioning the label around 
the data points.

5 Under Label Line Style, select a style for the line to connect the label 
and its data point.

6 If you want to use automatic labels, select the Automatic option under 
Datapoint Label and then select the check boxes corresponding to the 
labels you want.

For example, to use the data point's value as its label, select the Value 
check box.

7 If you want to create a custom label, expand Datapoint Labels in the 
Chart Designer dialog box and select the data point for which you 
want to create a custom label. Then select the Text tab and enter the 
label text in the Text field. Perform this step for each data point for 
which you want to create a custom label.

8 Click on the OK or Apply button to redraw the chart.

Positioning Data Point and Series Labels
Position data point and series labels by clicking and dragging.

• To position data point and series labels

Click on the label and drag it to its new location.

Formatting and Positioning Axis Labels

Axis labels mark values, categories, or dates on axes as Figure 5 - 76 
illustrates. 
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Formatting an Axis Label
Formatting an axis label is similar to formatting any other chart element. 
You can change the font, size, orientation, and alignment of axis label 
text, create a backdrop for the label, and assign a format code to the text. 

Figure 5 - 76: Y and X axis labels.

• To format axis labels

For help on formatting axis labels, see one of the sections below.

• “Changing the Font of Chart Text” on page 5 - 51

• “Aligning and Orienting Chart Text” on page 5 - 52

• “Drawing a Frame around a Chart Element” on page 5 - 55

• “Drawing a Solid or Patterned Backdrop for a Chart Element” on page 
5 - 56

• “Drawing a Gradient Backdrop for a Chart Element” on page 5 - 58

• “Using a Graphic as a Backdrop for a Chart Element” on page 5 - 59

• “Specifying Label Formats” on page 5 - 118

Positioning Axis Labels
You can align and orient axis labels or let Survey Crafter Professional 
position them automatically to optimize chart layout. 

Y axis label

X axis label
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If the chart is 3D, you can use the Standing option to position axis labels 
upright, making them more legible when the chart’s angle of elevation is 
low. The Standing option applies only to labels on an X or Z axis on most 
charts and the Y axis on horizontal bar charts.

Figure 5 - 77: Standing labels on a 3D bar chart.

• To position axis labels

1 Double-click on the axis labels to position, or choose Chart Designer 
from the Format menu, and then expand the axis that contains the 
labels to position.

2 Select Axis Labels.

3 Select the Display tab.

4 To stand axis labels up, select the Standing Labels check box (if 
available). To return labels to their default lying position, clear this 
check box.

5 To have Survey Crafter Professional automatically align and orient 
the labels, select the Automatic Rotation check box and go to step 9. 
To align and orient the labels, clear the Automatic Rotation check box 
and go to step 6.

6 Select the Layout tab.

7 To align the labels, do the following:

• Under Alignment, select a horizontal alignment option.

• Under Alignment, select a vertical alignment option.

Standing 
labels



5 - 118 Analyses: Charts
Formatting Labels  
8 To orient the labels, select an option under Orientation.

9 Click on the OK or Apply button to redraw the chart.

Specifying Label Formats

You can control the format of axis and data point labels. For example, you 
can show the data point label “-10,000” as “-10,000” in the color red or in 
scientific notation as “-1.00E+04”.

The label format you define for an axis applies to every other label on the 
axis. A label format you define for a data point applies only to that data 
point label rather than every label in the series.

Figure 5 - 78: Y axis labels shown in scientific notation format.

• To specify label formats

1 Double-click on the axis label or the data point label you want to 
format.

The Chart Designer dialog box appears.

2 Select a tab in the Chart Designer dialog box as follows:

• If you selected an axis label, select the Format tab.

• If you selected a data point label showing a percentage, select the 
Percent Format tab.

• If you selected any other data point label, select the Value Format 
tab.
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3 In the Category list, select a category of label formats.

For example, to show the value in scientific notation, select 
Scientific.

4 Select a label type in the Format Codes list.

For descriptions of the label types, click on the Help button.

5 To edit the code, make changes to the label type in the Code field. 

For example, if you chose the scientific code 0.00E+00, you could 
add another decimal place to the label by typing 0.000E+00.

Figure 5 - 79: The Format tab of the Chart Designer dialog box.

6 Click on the OK or Apply button to redraw the chart.

Edit the code in this field.

The Percent Format and 
Value Format tabs look 
similar to this one.
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The Chart Wizard

The Chart Wizard provides a fast and easy way to select the most 
frequently used chart formatting options. Use the Chart Wizard to quickly 
format a new or existing chart.

Starting the Chart Wizard

You can start the Chart Wizard from the Format menu or by right clicking 
on the chart.

• To start the Chart Wizard from the Format menu

1 At the Analyses tab of the Study window, select the chart you want to 
change. Then click on the Edit button on the tab.

2 If you are viewing the table, click on the Chart View button on the 
toolbar to see the chart.

3 From the Format menu, choose Chart Wizard.

Survey Crafter Professional displays the Chart Wizard dialog box.

Figure 5 - 80: The Gallery step of the Chart Wizard dialog box.

4 Follow the instructions on the Chart Wizard dialog box.

Choose Next to go to the 
next step of the Chart 
Wizard.

Select 2D to view a gallery 
of 2D charts. Select 3D to 
view a gallery of 3D charts.
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For help on the Chart Wizard dialog box, press the [F1] key.

• To start the Chart Wizard by right clicking on the chart

1 At the Analyses tab of the Study window, select the chart you want to 
change. Then click on the Edit button on the tab.

2 If you are viewing the table, click on the Chart View button on the 
toolbar to see the chart.

3 Right click on the chart.

Survey Crafter Professional displays the chart pop up menu.

4 Choose Wizard from the pop up menu.

Survey Crafter Professional displays the Chart Wizard dialog box

5 Follow the instructions on the Chart Wizard dialog box.

For help on the Chart Wizard dialog box, press the [F1] key.
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Exporting Charts

You can export a chart for use in a report or presentation. For example, 
export a chart and paste it into the word processor document containing 
the report you are writing. You can also export a chart to a file.

Exporting a Chart by using the Clipboard

You can export a chart to another program like a presentation software 
package or a word processor.

• To export a chart by using the clipboard

1 Select the Analyses tab of the Study window.

2 Select the chart you want to export. Then click on the Edit button on 
the tab.

The chart appears in an Analysis window.

3 From the Edit menu, choose Copy All.

Survey Crafter Professional copies the entire chart to the clipboard.

4 Open the document you want to paste the chart into.

5 Paste the chart into the document.

If you choose to paste the chart using the Windows metafile format, 
you can edit the chart’s format by using the host file’s application. For 
example, you can change the colors of bars in a chart or edit axis 
labels. 

Exporting a Chart to a File

To enhance a chart's format or to publish the chart in another format, you 
can also export a chart to a file. You can export a chart to the following 
types of files:

• HyperText Markup Language (HTML) file

• JPEG File Interchange Format (JPG) file
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• Windows Bitmap (BMP) file

• Windows Metafile Format (WMF) file

• To export a chart to a file

1 At the Study window’s Analyses tab, open the chart you want to 
export.

2 From the File menu, choose Export.

Survey Crafter Professional displays the Save Analysis Chart File As 
dialog box. 

3 From the files of Type drop-down list, select the type of file you want 
to save.

4 From the Locations (Save in) drop-down list, choose the location to 
save the file.

5 In the Folders list, select the folder in which you want to save the file.

6 In the File name field, type the name of the file to save.

7 Click on the Save button.

Survey Crafter Professional creates the file.

Note  If you want to export a chart to an HTML file, you may want 
to review the web analysis HTML option settings in the Web 
Analysis Setup dialog box. Survey Crafter Professional uses these 
settings when it exports a chart to an HTML file.
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Updating Charts

Every chart is based on a table. If the values in the table on which a chart 
is based need to be recalculated (for example, if you changed the 
expression defining a table cell’s value), Survey Crafter Professional 
displays a message “The analysis must be updated” when you attempt to 
view the chart.

• To update a chart

If the message “The analysis must be updated” appears in the Analysis 
window when you attempt to view a chart, do one of the following:

• From the Edit menu, choose Update.

• Click on the Update button on the toolbar.

Survey Crafter Professional recalculates the table’s values and redraws 
the chart using the new values.

Update button



6 Variables

A Survey Crafter Professional study may contain both imported or 
computed variables. Imported variables store data like survey responses 
that are collected outside of Survey Crafter Professional. You usually 
create most of a study’s imported variables when writing a survey, as 
Chapter 2, ”Surveys,” explains. However, you may need to create 
imported variables outside the survey to import data not associated with a 
survey question. Computed variables store the results of calculations 
performed in Survey Crafter Professional.

This chapter explains how to create imported variables, how to create 
computed variables, and how to edit variables. Read the section “Variable 
Basics” first to learn key concepts about Survey Crafter Professional 
variables.

Chapter Contents

• Variable Basics  6 - 2

• Creating Imported Variables  6 - 9

• Creating Computed Variables  6 - 22

• Editing Variables—All Types  6 - 50

• Editing Category Variables  6 - 56

• Editing Quantity Variables  6 - 63

• Editing Literal Variables  6 - 67

• Updating Variables’ Values  6 - 68
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Variable Basics

Variables store responses to survey questions and the results of 
calculations. A variable represents a group of related data. For example, 
you might use the variable age to store respondents’ ages. Variables also 
provide the means to tell Survey Crafter Professional which data to 
include in an analysis. For example, to calculate the average value in age, 
use the expression MEAN(age). 

Types of Variables

Survey Crafter Professional’s variables have two primary distinguishing 
characteristics. As Figure 6 - 1 shows, each variable either is an imported 
or computed variable and either a category, quantity, or literal variable. 
Thus, for example, a variable can be said to be an imported quantity 
variable or a computed category variable. Each of these characteristics is 
explained below.

Figure 6 - 1: Characteristics of Survey Crafter Professional variables.

Imported and Computed Variables
Imported variables usually store data collected by administering a survey 
created in Survey Crafter Professional or another program (for example, 
responses you entered into a study using the Interviewer, responses your 
web survey collected or responses a market research supplier collected). 
They can also store data calculated by other analysis software and 
imported into Survey Crafter Professional. You can analyze the responses 
stored in imported variables or use them to create computed variables.
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Computed variables store values calculated within Survey Crafter 
Professional. Survey Crafter Professional calculates computed variables’ 
values by performing one or more operations on imported variables or 
other computed variables. For example, you could subtract one imported 
variable from another and store the difference in a computed variable.

Category, Quantity, and Literal Variables
Each imported or computed variable may be one of three types:

• Category variable

A category variable stores the name matched with a prompt in a 
closed-end or all-that-apply question’s list of choices. For example, a 
category variable might store ‘yes’ or ‘no’. 

If you view an import file returned by your web survey or by a market 
research supplier, you will notice that the values in category variables 
are integers. These integers, called codes, are used by the market 
research supplier and correspond to category names. For example, the 
codes for the category names “yes” and “no” might be 1 and 0, 
respectively. Survey Crafter Professional automatically converts the 
codes to the category names so that when you view the data set in the 
Data window, you see more informative category names instead of 
codes. 

Category variables can also store names for groups you divide 
respondents into. For example, you might assign respondents to the 
High, Middle, or Low category based on values they reported for their 
income.

• Quantity variable

A quantity variable stores numbers. Quantity variables often store 
responses to questions like “What is your age?” or “Rate our customer 
service on a scale of 1 to 5.” They can also store numbers calculated by 
expressions you write.

• Literal variable

A literal variable stores text. Most often, literal variables store answers 
to open-end questions.
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For more background on variables, see the section “Understanding 
Variables and Scales” in Chapter 4 of Understanding Survey Research:  A 
Primer for Success.

Reasons for Creating Computed Variables

When writing a survey, you often cannot ask respondents directly for 
every piece of data you want. To do so would probably make the survey 
too complex or too long. However, given a well-designed survey, you can 
use data respondents supply to infer or calculate data you did not 
explicitly ask for. 

Computed variables store values Survey Crafter Professional calculates 
by evaluating  expressions you write involving one or more imported or 
computed variables. For information on expressions, see Chapter 7, 
“Expressions.”

To learn more about reasons to create a computed variable, read the 
examples below.

Example:  Creating a Category Variable from a Quantity 
Variable
Your survey asks each respondent his or her age and stores it in the 
imported quantity variable age. You hypothesize that respondents in three 
broad age brackets have different customer service needs. To test your 
hypothesis, you need to assign each respondent to one of the three age 
brackets. 

To divide the respondents among the three brackets, create a computed 
category variable called agegroup with three categories: Young, Middle 
Age, and Old. Then assign each respondent to one of the three categories 

In the Primer
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based on his or her age. You can then use this computed category variable 
for cross tabulations and other analyses category variables support.

Figure 6 - 2: Creating a computed category variable from an imported quantity variable.

Example:  Reducing the Number of Categories in a 
Category Variable
You ask respondents to choose the car they drive from a list of 25 cars 
manufactured in the US, Japan, and Germany. The responses are stored in 
an imported category variable with 25 categories called car_driv. You 
want to analyze the cars by manufacturing country and need to create 
these categories: US cars, Japanese cars, and German cars. 

To reduce the number of categories from 25 to 3, create a computed 
category variable that uses an expression to assign each of the 25 cars to 
the country that manufactures it.

Figure 6 - 3: Reducing the number of categories in a category variable.

Young
age <= 35

Quantity variable
age

Middle Age
35 < age < 65

Old
age >= 65

Categories of category variable agegroup

Japanese
car 1

American car
1

German car
1

Japanese
car 2

American car
2

German car
2

American car
3

American cars Japanese cars German cars

...
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Example:  Creating a Quantity Variable from a Category 
Variable
You ask respondents to specify their annual income by choosing from a 
list of ranges:  $0 - $20,000, $20,001 - $40,000, and so on. The result is 
stored in an imported category variable called income. You want to 
estimate the mean income for the sample but cannot use income to 
calculate the mean because it is a category variable. Calculating a mean 
requires a quantity variable.

To create a computed quantity variable from income, write an expression 
that assigns a quantity to each income category. The expression might 
assign the quantity $10,000 to the category $0 - $20,000 and $30,000 to 
the category $20,001 - $40,000. Using the computed quantity variable, 
you can estimate the average income for the sample.

Figure 6 - 4: Creating a quantity variable from a category variable.

Example:  Creating a Quantity Variable for Weighting 
Respondents
You ask respondents to rate a service you provide on a scale of 1 to 5. 
Survey Crafter Professional stores their responses in an imported quantity 
variable called RateService. You also ask respondents for their gender. 
You want to estimate the mean service rating for your target population. 
However, your target population consists of 40% males and 60% females 
and your sample has 60% males and 40% females. The mean calculation 
of RateService may not represent your target population.

Use the Category to Weights Variable Wizard to create a computed 
quantity variable called GenderWeights based on the definition of the 
Gender variable. In the wizard, assign 40% to the male category and 60% 
to the female category.

Under $25,000 $25,000 to $34,999

If the respondent is in this category . . .

$10,000 $30,000

Estimated income is . . .
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You can use the GenderWeights variable to calculate the weighted mean 
of the RateService variable. You can also use the GenderWeights variable 
in analysis wizards that support weighted calculations like the Descriptive 
Statistics wizard, the Counts and Frequencies wizard or the All-that-apply 
Question wizard.

Reasons for Creating Imported Variables

Imported variables store data coming into Survey Crafter Professional 
from outside sources. They primarily store data collected by 
administering a survey written with Survey Crafter Professional, but they 
can also store data calculated by other analysis software and imported into 
Survey Crafter Professional.

There are several other cases for which you might want to create imported 
variables:

• You want to capture additional information about a respondent in your 
web survey. For example, you want to capture a respondent’s user name 
or IP address or the date and time the survey was completed.

• While administering the survey, the market research supplier creates a 
variable you did not include in the survey.

• A survey was written without Survey Crafter Professional and you want 
to use Survey Crafter Professional to analyze the survey data set.

• You created and populated variables in another statistical analysis 
software package and want to import the variables into Survey Crafter 
Professional for further analysis.

Variable Templates

A variable template is a group of predefined settings for specifying the 
values imported variables accept. Survey Crafter Professional provides 
several standard templates available for all studies, and you can define 
new templates to use within a study. Survey Crafter Professional supplies 
a different default template for each variable type.
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Variable Names

Each Survey Crafter Professional variable has two names: the name you 
assign it (called the name) and the name Survey Crafter Professional 
generates for the variable (called the code).

You assign a name to a variable in the Variable Information dialog box, 
which appears when you click on the Info button on the Variables tab of 
the Study window. The name must begin with a letter and may contain up 
to 31 additional letter, digit, or underscore characters.

Figure 6 - 5: The Variable Information dialog box.

Web surveys and market research suppliers use variables’ codes. Because 
market reserarch suppliers’ computer systems can usually handle 
variables with only eight or fewer characters in their names, Survey 
Crafter Professional limits the code to eight characters. 

While web surveys and vendors use the code—that is, the name for the 
variable while it is being used outside Survey Crafter Professional—you 
use the potentially longer and more descriptive name while working in 
Survey Crafter Professional.

Survey Crafter 
Professional truncates 
the variable name to 
create the code.
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Creating Imported Variables

You will probably create most of a study’s imported variables when 
writing a survey. However, you may need to create additional imported 
variables to store data from other analysis packages or to store data in 
variables the market research supplier creates. For instructions on creating 
variables while writing survey questions, see the section “Inserting 
Survey Blocks” on page 2 - 67. 

Creating an Imported Category Variable

To create an imported category variable, define the variable’s categories 
in the Variable Definition dialog box. By default, Survey Crafter 
Professional assigns every imported category variable the category NR. 
The NR (No Reply) category is assigned to a respondent if he or she was 
asked a question but refused to answer it. 

When creating an imported variable, you can base it on a template. 
Templates store predefined settings for the values a variable accepts. See 
“Variable Templates” on page 6 - 7 for more information.

• To create an imported category variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 6: The New Variable dialog box.

2 In the New Variable dialog box, select Imported Variable under 
Custom Variable.

3 Click on the OK button.

Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 7: The Variable Information dialog box.
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4 In the Variable Information dialog box, enter the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a summary of the information the 
variable contains. 

• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 8: The Variable Definition dialog box for imported category variables.

5 In the Variable Definition dialog box, select Category under Variable 
Type.
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6 Accept the default template or select a new template from the Based 
on Template drop-down list.

If you want to add categories to the variable, go to step 7. If you want 
to use the variable’s current settings, go to step 11.

7 Click on the Insert button to add a category.

Survey Crafter Professional displays the Category Definition dialog 
box.

Figure 6 - 9: The Category Definition dialog box for imported category variables.

8 In the Category Definition dialog box, do the following:

• In the Prompt field, type the category's description.

The description appears as a choice in the survey if you associate 
the variable with a survey question. The description also appears in 
wizard-generated analyses.

• In the Name field, type the category's name. Accept the default or 
enter a new category name.

The name must begin with a letter and may contain up to 14 
additional letter, digit, or underscore characters. Use this name 
when referring to the category in expressions.

• In the Code field, type the category’s code. Accept the default or 
enter a new integer between -9996 and 9996.

• Click on the OK button to close the Category Definition dialog box.

9 To add another category, repeat steps 7 and 8.
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10 To save the variable’s settings as a different template, type the new 
name in the Based on Template field.

11 Click on the OK button to close the Variable Definition dialog box.

Creating an Imported Quantity Variable

Imported quantity variables store numbers. For example, they store 
responses to questions like “What is your age?” and “Rate our customer 
service in the following areas using a scale from 1 to 5.”

When creating an imported variable, you can base it on a variable 
template. Templates store predefined settings for values a variable 
accepts. See the section “Variable Templates” on page 6 - 7 for more 
information.

Optionally, you can define scale points for the imported quantity variable.

• To create an imported quantity variable 

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 10:The New Variable dialog box.

2 In the New Variable dialog box, select Imported Variable under 
Custom Variable.

3 Click on the OK button.

Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 11:The Variable Information dialog box.
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4 In the Variable Information dialog box, do the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a summary of the information the 
variable contains. 

• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 12: The Variable Definition dialog box for imported quantity variables.

5 Under Variable Type in the Variable Definition dialog box, select 
Quantity.
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6 Accept the default template or select another template from the Based 
on Template drop-down list.

If you want to change the variable’s settings, go to step 7. If not, go to 
step 12.

7 To define the range of acceptable values for the variable, type the 
minimum value in the Minimum field and the maximum value in the 
Maximum field.

For example, if you are surveying teenagers and asking them their 
age, enter a minimum of 13 and a maximum of 19. 

To associate scale points with the quantity variable, enter the scale’s 
low point (for example, 1) in the Minimum field and the scale’s high 
point (for example, 5) in the Maximum field. For help defining scale 
point labels, see the task “To add a scale point” below.

8 In the Decimal Places field, enter the number of decimal places 
(maximum of ten) the variable stores.

To limit the variable’s values to integers, use the default of 0.

9 In the Units field, type the units for the response.

For example, if the respondents report income in US dollars, type 
$US.

10 If you want, select the Only include values from ___ to ___ in 
statistical calculations check box to have Survey Crafter 
Professional's analysis wizards only include a range of values for the 
statistical calculations. Then enter numbers between the variable's 
minimum and maximum values.

11 To save the variable settings under as a different template, type the 
new template’s name in the Based on Template field.

12 Click on the OK button to close the Variable Definition dialog box.

• To add a scale point

1 In the Variable Definition dialog box, click on the Scale button.

Survey Crafter Professional displays the Scale dialog box.
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2 In the Scale dialog box, click on the Add button.

Survey Crafter Professional displays the Scale Definition dialog box.

Figure 6 - 13: The Scale Definition dialog box.

3 In the Value field, type the scale point’s number as an integer. 

4 In the Label field, type text explaining what the value means. 

For example, type Very Satisfied.

5 Click on the OK button to close the Scale Definition dialog box.

The scale point appears in the Scale dialog box.

6 To add another scale point, repeat steps 2 through 5.

Survey Crafter Professional sorts the scale points in ascending order 
when you close the Scale dialog box.

7 Click on the OK button to close the Scale dialog box.

• To delete a scale point

1 In the Variable Definition dialog box, click on the Scale button.

Survey Crafter Professional displays the Scale dialog box.

2 Select the scale point you want to delete. 

3 Click on the Delete button.

4 Click on the OK button to close the Scale dialog box.

Creating an Imported Literal Variable

Follow the steps below to create an imported literal variable. 
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• To create an imported literal variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 14:The New Variable dialog box.

2 In the New Variable dialog box, select Imported Variable under 
Custom Variable.

3 Click on the OK button.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 15:The Variable Information dialog box.

4 In the Variable Information dialog box, enter the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description, enter a summary of the information the variable 
contains. 
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• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 16: The Variable Definition dialog box for imported literal variables.

5 In the Variable Definition dialog box, select Literal under Variable 
Type.

6 To define the maximum acceptable length for the variable, type a 
number in the Maximum length field.

7 If you want, click on the Use a text substitution table check box and 
choose a text substitution table from the drop down.

To create a new text substitution table or modify an existing text 
substitution table, click on the button to the right of the drop down. 
Survey Crafter Professional displays the Text Substitution Table 
Library dialog box.

Note A text substitution table is a two-column table that contains one or 
more textual mappings. Each textual mapping consists of value to search 
for and the value’s replacement text. When you associate a text 
substitution table with a literal variable, Survey Crafter Professional's 
analysis wizards use the table's textual mappings to automatically 
substitute the literal variable’s values in the headings of the resulting 
analysis tables and charts.
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8 If you want, click on the Each literal value is a list, separated by the 
characters check box to have Survey Crafter Professional's analysis 
wizards analyze the the literal values as lists of items. If you select 
this check box, enter the characters you want to use to separate the 
items in the lists.

9 Click on the OK button.
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Creating Computed Variables

Create a computed variable by performing calculations on imported 
variables or other computed variables.

Using a Wizard to Create a Computed Variable

Survey Crafter Professional features four wizards to create computed 
variables by performing four common types of variable conversions:

• Converting a Category Variable to a Quantity Variable

• Converting a Quantity Variable to a Category Variable

• Converting a Literal Variable to a Category Variable

• Creating a Quantity Variable for Weighting Respondents

Converting a Category Variable to a Quantity Variable
Suppose you ask respondents to specify their annual income by choosing 
from a list of ranges:  Under $25,000; $25,000 - $34,999; and so on. Their 
responses are stored in an imported category variable called income. Later 
you want to estimate the mean income for the sample. However, you 
cannot calculate the mean of income because it is a category variable. 
Calculating a mean requires a quantity variable.

You can use the Category to Quantity Variable Wizard to convert the 
categories in income to quantities stored in a variable called 
computed_income. You might associate categories with quantities as 
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shown in Figure 6 - 17. Then by finding the mean of computed_income, 
you can estimate the average income for the sample.

Figure 6 - 17:Assigning a numeric value to each category in a category variable. 

• To use a wizard to convert a category variable to a quantity variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.

Under $25,000 $25,000 to $34,999

If the respondent is in this category . . .

$10,000 $30,000

Estimated income is . . .



6 - 24 Variables
Creating Computed Variables  
Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 18:The New Variable dialog box.

2 In the New Variable dialog box, select Category to Quantity Variable 
Wizard under Variable Wizards.

3 Click on the OK button.
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Survey Crafter Professional displays the Category to Quantity 
Variable Wizard dialog box.

Figure 6 - 19:Step 1 of the Category to Quantity Variable Wizard.

4 Follow the directions on the screen to complete the wizard and click 
on the Finish button to create the variable.

For information on any of the wizard’s options, click on the Help 
button on the wizard’s dialog box.
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After you click on the Finish button, the Variable Information dialog 
box appears.

Figure 6 - 20:The Variable Information dialog box.

5 In the Name field, enter a name for the variable.

The name of the variable must begin with a letter and may include up 
to 31 additional letters, digits, and underscore characters.

6 In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable code 
based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

7 In the Description field, enter a description for the variable.

8 Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

9 Review the definition of the variable and click on the OK button.

Survey Crafter Professional adds the variable to the Variables tab of 
the Study window.
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Converting a Quantity Variable to a Category Variable
Suppose you ask respondents to rate your customer service using a scale 
from 1 to 10. Their responses are stored in an imported quantity variable 
called RateCustomerService. Later you want to count the frequency of 
responses for groups of the numbers on the scale. One way of doing this is 
by writing expressions in cells of an analysis table (ex. 
COUNT(RateCustomerService>=1 AND RateCustomerService<=2), 
COUNT(RateCustomerService>=3 AND RateCustomerService<=4), 
etc.).

Alternatively, you can use the Quantity to Category Variable Wizard to 
convert the numbers in RateCustomerService to categories stored in a 
variable called RateCustomerService_Cats and then modify the category 
definitions. You can then use RateCustomerService_Cats in analysis 
wizards such as the Category Variable Chart Wizard or the Cross 
Tabulation Wizard to count the frequency of responses for each number 
on the scale.

• To use a wizard to convert a quantity variable to a category variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 21:The New Variable dialog box.

2 In the New Variable dialog box, select Quantity to Category Variable 
Wizard under Variable Wizards.

3 Click on the OK button.
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Survey Crafter Professional displays the Quantity to Category 
Variable Wizard dialog box.

Figure 6 - 22:Step 1 of the Quantity to Category Variable Wizard.

4 Follow the directions on the screen to complete the wizard and click 
on the Finish button to create the variable.

For information on any of the wizard’s options, click on the Help 
button on the wizard’s dialog box.
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After you click on the Finish button, the Variable Information dialog 
box appears.

Figure 6 - 23:The Variable Information dialog box.

5 In the Name field, enter a name for the variable.

The name of the variable must begin with a letter and may include up 
to 31 additional letters, digits, and underscore characters.

6 In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable code 
based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

7 In the Description field, enter a description for the variable.

8 Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

9 Review the definition of the variable and click on the OK button.

Survey Crafter Professional adds the variable to the Variables tab of 
the Study window.
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Converting a Literal Variable to a Category Variable
Literal variables store responses to open-end questions like “What is your 
zip code?” One of the most popular ways to analyze responses to 
open-end questions is to count the different responses to the question. For 
example, you might want to know how many respondents live in the zip 
code 14802.

Use the Literal to Category Variable Wizard to create a computed 
category variable zip_code_cats based on the responses stored in the 
literal variable zip_code. For example, the wizard creates the category 
‘14802’ from the literal response “14802”. Then you can use the variable 
zip_code_cats in cross tabulations and banners to count the number of 
respondents in different zip codes.

• To use a wizard to convert a literal variable to a category variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 24:The New Variable dialog box.

2 In the New Variable dialog box, select Literal to Category Variable 
Wizard under Variable Wizards.

3 Click on the OK button.
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Survey Crafter Professional displays the Literal to Category Variable 
Wizard dialog box.

Figure 6 - 25:Step 1 of the Literal to Category Variable Wizard.

4 Follow the directions on the screen to complete the wizard and click 
on the Finish button to create the variable.

For information on any of the wizard’s options, click on the Help 
button on the wizard’s dialog box.
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After you click on the Finish button, the Variable Information dialog 
box appears.

Figure 6 - 26:The Variable Information dialog box.

5 In the Name field, enter a name for the variable.

The name of the variable must begin with a letter and may include up 
to 31 additional letters, digits, and underscore characters.

6 In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable code 
based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

7 In the Description field, enter a description for the variable.

8 Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

9 Review the definition of the variable and click on the OK button.

Survey Crafter Professional adds the variable to the Variables tab of 
the Study window.
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Creating a Quantity Variable for Weighting Respondents
Suppose you ask respondents to rate a service you provide on a scale of 1 
to 5. Survey Crafter Professional stores their responses in an imported 
quantity variable called RateService. You also ask respondents for their 
gender. Later you want to estimate the mean service rating for your target 
population. However, your target population consists of 40% males and 
60% females and your sample has 60% males and 40% females. The 
mean calculation of RateService may not represent your target population.

Use the Category to Weights Variable Wizard to create a computed 
quantity variable called GenderWeights based on the definition of the 
Gender variable. In the wizard, assign 40% to the male category and 60% 
to the female category.

You can use the GenderWeights variable to calculate the weighted mean 
of the RateService variable. You can also use the GenderWeights variable 
in analysis wizards that support weighted calculations like the Descriptive 
Statistics wizard, the Counts and Frequencies wizard or the All-that-apply 
Question wizard.

• To use a wizard to create a quantity variable for weighting 
respondents

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 27:The New Variable dialog box.

2 In the New Variable dialog box, select Category to Weights Variable 
Wizard under Variable Wizards.

3 Click on the OK button.
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Survey Crafter Professional displays the Category to Weights 
Variable Wizard dialog box.

Figure 6 - 28:Step 1 of the Category to Weights Variable Wizard.

4 Follow the directions on the screen to complete the wizard and click 
on the Finish button to create the variable.

For information on any of the wizard’s options, click on the Help 
button on the wizard’s dialog box.
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After you click on the Finish button, the Variable Information dialog 
box appears.

Figure 6 - 29:The Variable Information dialog box.

5 In the Name field, enter a name for the variable.

The name of the variable must begin with a letter and may include up 
to 31 additional letters, digits, and underscore characters.

6 In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable code 
based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

7 In the Description field, enter a description for the variable.

8 Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

9 Review the definition of the variable and click on the OK button.

Survey Crafter Professional adds the variable to the Variables tab of 
the Study window.
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Creating a Custom Computed Category Variable

Use a computed category variable to group respondents based on values 
in another variable. For example, assign respondents to age categories 
based on the values in the quantity variable age.

• To create a custom computed category variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 30:The New Variable dialog box.

2 In the New Variable dialog box, select Computed Variable under 
Custom Variable.

3 Click on the OK button.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 31:The Variable Information dialog box.

4 In the Variable Information dialog box, do the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a summary of the information the 
variable contains. 
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• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 32: The Variable Definition dialog box for computed category variables.

5 In the Variable Definition dialog box, select Category under Variable 
Type.

6 Click on the Append button.

Survey Crafter Professional displays the Category Definition dialog 
box.

Figure 6 - 33: The Category Definition dialog box for computed category variables.
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7 In the Category Definition dialog box, do the following:

• In the Prompt field, type the category’s description. 

• In the Condition Expression field, enter the expression that 
determines which respondents belong to the category.

For help writing the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

• In the Name field, type the category’s name. Accept the default or 
enter a new category name.

The category name must begin with a letter and may contain up to 
14 additional letter, digit, or underscore characters. Use this name 
to include the category in expressions.

• In the Code field, type the category’s code. Accept the default or 
enter a new integer between -9996 and 9996.

• Click on the OK button.

8 Repeat steps 6 and 7 for each category you want to add.

9 Click on the OK button to close the Variable Definition dialog box.

Survey Crafter Professional adds the variable to the study but does 
not yet calculate its values. For help on calculating the variable’s 
values, see the section “Updating Variables’ Values” on page 6 - 68.

Creating a Custom Computed Quantity Variable

Computed quantity variables store numbers calculated by Survey Crafter 
Professional. Creating a computed quantity variable involves writing an 
expression that Survey Crafter Professional uses to calculate the 
variable’s values. 

Expression Builder 
button
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• To create a custom computed quantity variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 34:The New Variable dialog box.

2 In the New Variable dialog box, select Computed Variable under 
Custom Variable.

3 Click on the OK button.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 35:The Variable Information dialog box.

4 In the Variable Information dialog box, do the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a summary of the information the 
variable contains. 
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• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 36: The Variable Definition dialog box for computed quantity variables.

5 In the Variable Definition dialog box, select Quantity under Variable 
Type.

6 In the Quantity Expression field, type the expression that calculates 
the variable’s values. 

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

7 Click on the OK button to close the Variable Definition dialog box.

Survey Crafter Professional adds the variable to the study but does 
not yet calculate its values. For help on calculating the variable’s 
values, see the section “Updating Variables’ Values” on page 6 - 68.

Creating a Computed Literal Variable

Computed literal variables store text calculated by Survey Crafter 
Professional. Creating a computed literal variable involves writing an 
expression that Survey Crafter Professional uses to calculate the 
variable’s values.

This expression defines 
the values in the computed 
quantity variable 
family_income as the sum 
of the values in the 
variables income and 
spouse_income.

Expression Builder 
button
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Literal variables store values up to 32,767 characters long. If a value is 
longer than 32,767 characters, Survey Crafter Professional stores up to 
and including the 32,767th character.

• To create a computed literal variable

1 Select the Variables tab of the Study window. Then click on the New 
button on the tab.

Survey Crafter Professional displays the New Variable dialog box.

Figure 6 - 37:The New Variable dialog box.

2 In the New Variable dialog box, select Computed Variable under 
Custom Variable.

3 Click on the OK button.

Tip Alternatively, you can right-click anywhere inside the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on any column in the Data window and choose New Variable from the 
pop-up menu.
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Survey Crafter Professional displays the Variable Information dialog 
box.

Figure 6 - 38:The Variable Information dialog box.

4 In the Variable Information dialog box, do the following:

• In the Name field, enter a name for the variable. 

The name of the variable must begin with a letter and may include 
up to 31 additional letters, digits, and underscore characters.

• In the Code field, accept the default or enter a new code for the 
variable.

Survey Crafter Professional automatically generates the variable 
code based on the text in the Name field.

The variable code is used outside Survey Crafter Professional in 
exported data files. 

• In the Description field, enter a summary of the information the 
variable contains. 
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• Click on the OK button.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 39: The Variable Definition dialog box for computed literal variables.

5 In the Variable Definition dialog box, select Literal under Variable 
Type.

6 In the Literal Expression field, type the expression that calculates the 
variable’s values. 

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

This expression 
concatenates three 
variables to produce a 
respondent’s full name. 

Expression Builder 
button
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7 If you want, click on the Use a text substitution table check box and 
choose a text substitution table from the drop down.

To create a new text substitution table or modify an existing text 
substitution table, click on the button to the right of the drop down. 
Survey Crafter Professional displays the Text Substitution Table 
Library dialog box.

8 If you want, click on the Each literal value is a list, separated by the 
characters check box to have Survey Crafter Professional's analysis 
wizards analyze the the literal values as lists of items. If you select 
this check box, enter the characters you want to use to separate the 
items in the lists.

9 Click on the OK button to close the Variable Definition dialog box.

Survey Crafter Professional adds the variable to the study but does 
not yet calculate its values. For help on calculating the variable’s 
values, see the section “Updating Variables’ Values” on page 6 - 68.

Note A text substitution table is a two-column table that contains one or 
more textual mappings. Each textual mapping consists of value to search 
for and the value’s replacement text. When you associate a text 
substitution table with a literal variable, Survey Crafter Professional's 
analysis wizards use the table's textual mappings to automatically 
substitute the literal variable’s values in the headings of the resulting 
analysis tables and charts.
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Editing Variables—All Types

There are several changes you can make to variables of any type. These 
changes include: 

• Renaming a Variable

• Changing a Variable’s Description

• Deleting a Variable

• Changing a Variable’s Template (for imported variables only)

• Rewriting a Variable’s Expression (for computed variables only)

The next three sections of this chapter explain changes unique to category, 
quantity and literal variables.

Renaming a Variable

Survey Crafter Professional does not allow you to change a variable’s 
name if the variable is used in an expression for calculating a computed 
variable’s values or if the variable is used in an expression in an analysis 
table or chart. For example, if a computed variable’s expression is age + 
3, you cannot rename the variable age.

• To rename a variable

1 Select the Variables tab of the Study window.

2 Select the variable you want to rename.

3 Do one of the following:

• From the Edit menu, choose Variable Info.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Information from the pop-up menu.
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• Click on the Info button on the Variables tab.

Survey Crafter Professional displays the Variable Information dialog 
box.

4 In the Name field, type the new name for the variable.

Survey Crafter Professional generates a value in the Code field based 
on the name you enter.

5 Click on the OK button.

Changing a Variable’s Description

You can change a variable’s description at any time.

• To change a variable’s description

1 Select the Variables tab of the Study window.

2 Select the variable with the description you want to change.

3 Do one of the following:

• From the Edit menu, choose Variable Information.

• Click on the Info button on the Variables tab.

Survey Crafter Professional displays the Variable Information dialog 
box.

4 In the Description field, type the variable’s new description. 

5 Click on the OK button.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Information from the pop-up menu.
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Deleting a Variable

Survey Crafter Professional will not allow you to delete a variable if the 
variable is associated with a survey question, if the variable is used in an 
expression for calculating a computed variable’s values, or if the variable 
is used in an expression in an analysis table or chart. For example, if a 
computed variable’s expression is age + 3, you cannot delete the 
variable age.

• To delete a variable

1 Select the Variables tab of the Study window.

2 From the Variables list, select the variable you want to delete.

3 Do one of the following:

• From the Edit menu, choose Delete. 

• Press the [Delete] key.

4 Click on the Yes button in the system message that appears.

Survey Crafter Professional deletes the variable if it is not associated 
with a survey block, used in a computed variable’s expression or used 
in an expression in an analysis table or chart.

Changing a Variable’s Template (for imported 
variables only)

To redefine an imported variable’s settings quickly, choose a new 
template in the Variable Definition dialog box. After you choose a new 
template, you can edit its settings if necessary. 

Survey Crafter Professional does not allow you to change the template of 
a category variable that currently uses the All-that-apply template and is 
associated with an all-that-apply question in a survey. Survey Crafter 

Tip Alternatively, you can right-click on the variable’s column in the 
Data window and choose Delete Selected Variables from the pop-up 
menu.
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Professional also does not allow you to change the template of a quantity 
variable that currently uses the Ranking or Constant Sum template and is 
associated with a ranking or constant sum question in a survey.

• To change the variable’s template

1 Select the Variables tab of the Study window.

2 Select the variable with the template you want to change. Then click 
on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 In the Based on Template field, select the new template to apply to the 
variable.

4 Change the template’s settings if necessary.

For example, add a new category to a category variable or change the 
range of values a quantity variable stores.

5 If you want to save the template settings under a different name, type 
the new name in the Based on Template field.

6 Click on the OK button.

Rewriting a Variable’s Expression (for computed 
variables only)

You can edit the expressions used to calculate computed variables’ 
values. 

After rewriting a computed variable’s expression, you need to recalculate 
its values. For instructions on recalculating computed variables’ values, 
see the section “Updating Variables’ Values” on page 6 - 68.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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• To rewrite a category variable’s expression

1 Select the Variables tab of the Study window.

2 Select the variable with the expression you want to rewrite. Then 
click on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 In the Variable Definition dialog box, select the expression to edit.

4 Click on the Edit button.

Survey Crafter Professional displays the Category Definition dialog 
box.

5 In the Category Definition dialog box, edit the expression in the 
Condition Expression field. 

For help rewriting the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

6 Click on the OK button to close the Category Definition dialog box.

7 Click on the OK button to close the Variable Definition dialog box.

• To rewrite a quantity or literal variable’s expression  

1 Select the Variables tab of the Study window.

2 Select the variable with the expression you want to rewrite. Then 
click on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Tip Alternatively, you can double-click on the variable’s column 
heading in the Data window or right-click on the variable’s column in 
the Data window and choose Variable Definition from the pop-up menu.

Tip Alternatively, you can double-click on the variable’s column 
heading in the Data window or right-click on the variable’s column in 
the Data window and choose Variable Definition from the pop-up menu.

Expression Builder 
button
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3 Edit the expression in the Quantity Expression or Literal Expression 
field.

For help rewriting the expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

4 Click on the OK button to close the Variable Definition dialog box.
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Editing Category Variables

Changes you can make to category variables include the following:

• Adding a Category

• Editing a Category

• Deleting a Category

• Rearranging Categories

Adding a Category

You can add a category above or below any category in the Variable 
Definition dialog box except the NR category. You can only add 
categories above the NR category.

After adding a category to a computed category variable, you need to 
recalculate the variable’s values. See the section “Updating Variables’ 
Values” on page 6 - 68.

• To add a category

1 Select the Variables tab of the Study window.

Note Survey Crafter Professional does not allow you to edit a category 
variable that uses the All-that-apply template and is currently associated 
with an all-that-apply question in a survey.  

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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2 Select the variable to which you want to add a category. Then click on 
the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 40: Using the Append and Insert buttons to add categories.

3 From the list on the bottom of the Variable Definition dialog box, 
select a category.

4 Click on the Append or Insert button.

Survey Crafter Professional displays the Category Definition dialog 
box.

5 In the Category Definition dialog box, enter the following:

• In the Prompt field, type the category’s description.

The description appears as a choice on the survey if the variable is 
an imported variable and you associate it with a survey question.

• In the Condition Expression field (if the variable is a computed 
variable), type the category’s expression. 

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

• In the Name field, type the category’s name. Accept the default or 
enter a new category name.

Click on the Append 
button to add a category 
below or the Insert 
button to add a category 
above the selected 
category.

Expression Builder 
button
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The category name must begin with a letter and may contain up to 
14 additional letter, digit, or underscore characters. Use this name 
to refer to the category in expressions.

• In the Code field, type the category’s code. Accept the default or 
enter a new integer between -9996 and 9996.

6 Click on the OK button to close the Category Definition dialog box.

The category appears in the Variable Definition dialog box.
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7 If the variable is an imported variable and you want to save the 
settings as a different template, type the new name in the Based on 
Template field.

For more information on variable templates, see the section “Variable 
Templates” on page 6 - 7.

8 Click on the OK button.

Editing a Category

You can change a category’s name, prompt, and code. If the category 
belongs to a computed variable, you can also change its expression.

After editing a category in a computed category variable, you need to 
recalculate the variable’s values. See the section “Updating Variables’ 
Values” on page 6 - 68.

• To edit a category

1 Select the Variables tab of the Study window.

2 From the Variables list, select the variable containing the category 
you want to edit. Then click on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 From the list on the bottom of the Variable Definition dialog box, 
select the category you want to redefine.

4 Click on the Edit button.

Survey Crafter Professional displays the Category Definition dialog 
box.

5 In the Category Definition dialog box, enter the following:

• In the Prompt field, type the category’s description.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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If the variable is an imported variable and you associate it with a 
question block, the text in the Prompt field appears in the survey as 
a possible response.

• In the Condition Expression field (if the variable is a computed 
variable), type the category’s expression. 

For help writing an expression, click on the Expression Builder 
button. Also see Chapter 7, “Expressions.”

• In the Name field, type the category’s name.

The category name must begin with a letter and may contain up to 
14 additional letter, digit, or underscore characters. Use this name 
to refer to the category in expressions.

• In the Code field, type the category’s code. Accept the default or 
enter a new integer between -9996 and 9996.

6 Click on the OK button to close the Category Definition dialog box.

7 Select another category to redefine or click on the OK button.

Deleting a Category

Follow the steps below to delete a category from a category variable.

After deleting a category from a computed category variable, you need to 
recalculate its values. See the section “Updating Variables’ Values” on 
page 6 - 68.

• To delete a category from a variable

1 Select the Variables tab of the Study window.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.

Expression Builder 
button
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2 Select the variable from which you want to delete a category. Then 
click on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 From the list on the bottom of the Variable Definition dialog box, 
select the category you want to delete. 

4 Click on the Delete button.

5 Click on the OK button.

Rearranging Categories

You can sort a variable’s categories into any order. The only category you 
cannot move is the NR (No Reply) category.

For imported variables, the order of the categories in the Variable 
Definition dialog box matches how they appear on a survey. 

For computed variables, the order of the categories in the Variable 
Definition dialog box determines how Survey Crafter Professional 
assigns respondents using a fall-through approach. Using this approach, 
Survey Crafter Professional evaluates the list of expressions from top to 
bottom and assigns respondents to the category containing the first 
expression that evaluates to TRUE.

• To rearrange a variable’s categories

1 Select the Variables tab of the Study window.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.



6 - 62 Variables
Editing Category Variables  
2 Select the variable whose categories you want to rearrange. Then 
click on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Figure 6 - 41: Rearranging a category variable’s categories.

3 From the list on the bottom of the Variable Definition dialog box, 
select a category to move.

4 To move the category up one row, click on the Up button. To move 
the category down one row, click on the Down button.

5 Click on the OK button.

Use these 
buttons to 
rearrange 
categories.
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Editing Quantity Variables

The changes explained in this section apply only to imported quantity 
variables. All changes you can make to computed quantity variables are 
covered in the section “Editing Variables—All Types” on page 6 - 50.

Edits to imported quantity variables include the following:

• Redefining Units

• Editing Scale Points

• Redefining Ranges and Decimal Places

Redefining Units

Follow the steps below to change the units associated with an imported 
quantity variables’ values.

• To redefine units

1 Select the Variables tab of the Study window.

2 Select the quantity variable you want to edit. Then click on the Edit 
button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 In the Units field, type the new unit you want to associate with the 
variable’s values. Use up to 32 characters.

Note Survey Crafter Professional does not allow you to edit a quantity 
variable that uses the Ranking or Constant Sum template and is currently 
associated with a ranking or constant sum question in a survey.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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4 Click on the OK button.

Editing Scale Points

You can change the values and labels on an imported quantity variable’s 
scale.

• To edit scale points

1 Select the Variables tab of the Study window.

2 Select the quantity variable with the scale you want to edit. Then click 
on the Edit button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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3 Click on the Scale button.

Survey Crafter Professional displays the Scale dialog box.

Figure 6 - 42: The Scale dialog box.

4 In the Scale dialog box, select the scale point you want to edit. 

5 Click on the Edit button.

Survey Crafter Professional displays the Scale Definition dialog box.

6 In the Scale Definition dialog box, do one or both of the following:

• To reposition the point on the scale, type a new integer in the Value 
field.

• To change the point’s label, type new text in the Label field.

7 Click on the OK button to close the Scale Definition dialog box.

8 Click on the OK button to close the Scale dialog box.

9 Click on the OK button to close the Variable Definition dialog box.

Scale points associated 
with the selected 
quantity variable.
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Redefining Ranges and Decimal Places

You can change the maximum and minimum values and the number of 
decimal places an imported quantity variable accepts.

• To redefine ranges and decimal places

1 Select the Variables tab of the Study window.

2 Select the quantity variable you want to edit. Then click on the Edit 
button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 To change the range of values the variable accepts, edit the values in 
the Minimum and Maximum fields.

The variable's minimum must be greater than -2,100,000,000 and its 
maximum must be less than 2,100,000,000.

4 To change the number of decimal places the variable accepts, edit the 
value in the Decimal Places. Enter a maximum of ten.

Enter 0 if you want Survey Crafter Professional to accept only 
integers for the variable’s values.

5 Click on the OK button.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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Editing Literal Variables

The changes explained in this section apply only to imported literal 
variables. All changes you can make to computed literal variables are 
covered in the section “Editing Variables—All Types” on page 6 - 50.

Edits to imported literal variables include the following:

• Redefining the Maximum Length

Redefining the Maximum Length

Follow the steps below to change the maximum length associated with an 
imported literal variables’ values.

• To redefine the maximum length

1 Select the Variables tab of the Study window.

2 Select the literal variable you want to edit. Then click on the Edit 
button on the tab.

Survey Crafter Professional displays the Variable Definition dialog 
box.

3 In the Maximum length field, type the new maximum length you 
want to associate with the variable’s values.

4 Click on the OK button.

Tip Alternatively, you can right-click on the variable in the Variables tab 
of the Survey Designer window’s Survey Explorer toolbar or right-click 
on the variable’s column in the Data window and choose Variable 
Definition from the pop-up menu.
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Updating Variables’ Values

After you write or edit an expression for a computed variable and close 
the Variable Definition dialog box, Survey Crafter Professional fills the 
variable’s column in the Data window with the value NV (No Value). It 
does this because Survey Crafter Professional does not automatically 
calculate the variable’s values. 

Because Survey Crafter Professional does not calculate the values 
automatically, you can create several computed variables and then 
calculate their values all at once. The Study or Data window must be the 
active window for the recalculation to work.

Note Survey Crafter Professional automatically updates a variable’s 
values when other computed variables or analysis tables or charts that 
use the variable are updated. For example, if you create a new computed 
variable, use the new computed variable in an expression in an analysis 
table and then update the analysis table, Survey Crafter Professional will 
automatically updates the new computed variable before it updates the 
analysis table.
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• To update a variable’s values

1 If the Data window is open, click on it to make it the active window. 
If it is not open, select the Study window’s Data tab, and then click on 
the Edit button on the tab.

The study’s data set appears in the Data window. The Data window 
includes a column for the new computed variable.

Figure 6 - 43: An uncalculated computed variable’s values displayed in the Data window.

2 From the Edit menu, choose Update or click on the Update button on 
the toolbar.

Survey Crafter Professional calculates the values for the computed 
variable.

The computed 
variable’s 
column 
contains the 
value NV if 
you have not 
yet had 
Survey Crafter 
Professional 
calculate its 
values.

Update button
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7 Expressions

Expressions are formulae that you write for Survey Crafter Professional 
to perform calculations and tests. This chapter begins with an overview of 
expressions and their components. It then explains how to write 
expressions and lists the operators and functions Survey Crafter 
Professional supports. It concludes with examples of expressions.
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An expression is a combination of operators, functions, variables, and 
values used to represent a single value or a set of values, with one for each 
respondent in the data set. As Table 7 - 1 shows, expressions are 
fundamental to your work in many areas of Survey Crafter Professional.

Read the sections below for an overview of expressions and their parts. 
For instructions on writing expressions, see the section “Writing 
Expressions” on page 7 - 6.

Table 7 - 1: Using expressions in Survey Crafter Professional.

Use expressions in To

Custom Opening and Closing 
Web Survey Rules

Have your web surveys automatically open or 
close.

Custom Branching and 
Skipping Rules

Automatically take respondents from one question 
block or page to another question block or page

Custom Validation Rules Show respondents your own error and warning 
messages

Custom Assignment Rules Automatically assign values to imported variables 
as respondents take your survey.

Custom Web Cookie Rules Have Survey Crafter Professional send and receive 
cookies to and from a respondent's browser as the 
respondent takes your web survey.

Custom Data Cleaning Rules Mark values in the Data window unexpected

Computed value survey fields Display calculated values in your survey when 
your survey is on the Web or in the built-in 
Interviewer.

Computed variables Calculate a new variable’s values from existing 
variables

Values in the Data window Calculate new values for the selected cells in the 
study's data set

Data window filters Filter the records visible in the Data window

Analysis table cells Calculate the values appearing in the cells
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Parts of an Expression

An expression can include one or more values, variables, functions, and 
operators alone or in combination. You define the values and variables 
and select the functions and operators from those Survey Crafter 
Professional provides.

Row, column and table filters Limit the records included in an analysis table 
cell's calculation

Batch report filters Limit the records included in the analysis tables 
and charts in a batch report

Batch report condition 
expressions

Conditially include analysis tables and charts in a 
batch report

Table 7 - 1: Using expressions in Survey Crafter Professional. (Continued)

Use expressions in To
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Figure 7 - 1 shows an example of an expression and its parts.

Figure 7 - 1: An example expression and its parts.

The terms of an expression an operator acts on are called operands. In the 
expression above:

• 1.5 and (age - MEDIAN(age)) are operands of the 
* (multiplication) operator

• age and MEDIAN(age) are operands of the - (subtraction) operator

• 1.5 is a value (a number)

• age is a variable in the study’s data set

• MEDIAN( ) is a function that calculates the median of its argument, 
here the variable age

Table 7 - 2: Parts of a Survey Crafter Professional expression.

Element Examples Description

Value “Blue”, 32, -1.4e-5, TRUE Represents a constant that Survey Crafter 
Professional uses exactly as written

Variable age, height Refers to a variable in the study’s data set

Function MEAN(age), MODE(age) Returns a value by performing a calculation 
on its arguments

Operator <, >=, + Indicates an operation to be performed on 
one or more terms

1.5  *  (age  -  MEDIAN(age))

Value Variable

Operators

Function
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Types of Values Expressions Return

Some expressions return a single value while others return a different 
value for each respondent (or each record) in the data set. 

The expression MEAN(age) calculates a single value like 32.5, the 
average of the values in the quantity variable age. 

The expression age + 3 returns a different value for each respondent, 
adding 3 to the value in age for each. For example, if one respondent has 
the value 25 stored in age, the expression returns 28 for that respondent. If 
another respondent has the value 53 stored in age, the expression returns 
56 for that respondent.

If an expression returns a different value for each respondent, you can 
store that set of values in a variable unless the expression returns TRUE 
or FALSE. (TRUE and FALSE, logical values that result from testing 
conditions, cannot be stored in variables.) For example, you could write 
the expression age + 3 and store the resulting numbers in the quantity 
variable age_plus. You could then calculate the average value in age_plus 
by using the expression MEAN(age_plus).

Alternatively, you do not have to store the values an expression returns in 
a variable. For example, you could use the expression age + 3 as the 
argument in the MEAN( ) function by entering MEAN(age + 3). In this 
case, Survey Crafter Professional adds 3 to each value in age and then 
finds the mean of the sums, but the sums themselves are not stored in the 
variable.
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This section discusses rules for entering values, variables, functions, and 
operators in expressions. It also discuss nesting expressions and Survey 
Crafter Professional’s rules for matching the values expressions return. 
For an overview of expressions’ parts, see the section “About 
Expressions” on page 7 - 2.

Expression elements are not case sensitive. For example, Survey Crafter 
Professional considers the variables Age, AGE, and agE equivalent to 
age, the literal value “Applesauce” equivalent to “APPLESAUCE” and 
the function mean(age) equivalent to MEAN(age).

Entering Values

You can enter five types of values in an expression:  literals, numbers, 
categories, logical values, and missing values (NR and NV).

Literals
A literal value may be any string of characters. Enclose the string in 
double quotes. For example, "My name is Larry". 

If the string contains the double quote character, use back-to-back double 
quotes for each instance of the character. For example, to use the literal 
value Dick "Night Train" Lane in an expression, enter "Dick 
""Night Train"" Lane".

Survey Crafter Professional treats literal constants as text only. For 
example, Survey Crafter Professional considers "2" different from 2. You 
can use 2 in arithmetic but not "2".

Numbers
You can enter any real numbers including counting numbers (1, 2, 3), 
negative numbers (-1, -2, -3), decimal fractions (1.001, -3.1415), and 
numbers expressed in scientific notation (3.14e-3). Numbers do not 
require any punctuation to distinguish them from the expression’s other 
terms.
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Categories
Enclose the name of a category in single quotes. For example, 
‘student’ and ‘full_time’. Do not use the category’s code. A 
category name must begin with a letter and may be followed with up to 14 
letter, digit, or underscore characters.

Logical Values
Logical values indicate whether a condition has been met. For example, a 
logical value indicates whether a respondent is over the age of 35. The 
two possible logical values are TRUE and FALSE. Either the respondent 
is over the age of 35 or he is not. Enter the logical values as TRUE and 
FALSE.

Missing Values (NR and NV)
To enter either NR (No Reply) or NV (No Value) in an expression, enter 
the letters NR or NV. Do not use any quotes or other punctuation around 
the letters. For example, gender = NR is a valid expression.

Entering Variables

To enter a variable, type the variable’s name. Variable names must begin 
with a letter and may be followed with up to 31 letter, digit, or underscore 
characters. Examples of valid variable names are age and has_a_car.

The Expression Builder can help you enter variables. See “Using the 
Expression Builder” on page 7 - 10.

Entering Functions

Type the function name and enclose its arguments in parentheses. For 
example, MEAN(age). Separate the function’s arguments with commas. 
For example, MODE(age, gender = ’male’).

A function’s arguments may be expressions themselves. See the section 
“Nesting Expressions” below for more information.

The Expression Builder and Function Wizard can help you enter 
functions. See “Using the Expression Builder” on page 7 - 10.



7 - 8 Expressions
Writing Expressions  
Entering Operators

For unary operators (operators acting on one term), type the operator 
before its operand. For example, -age negates the values in the quantity 
variable age. For binary operators (operators acting on two terms), type 
the operator between its operands. For example, in the expression 1.5 * 
age, the * operator multiplies the number 1.5 by each of the values in the 
quantity variable age.

The Expression Builder can help you enter operators. See “Using the 
Expression Builder” on page 7 - 10.

Nesting Expressions

You can write (nest) an expression within an expression. For example, a 
function’s arguments may be expressions themselves. Enclose each 
nested expression in parentheses. 

In the expression MEAN(age + spouse_age), the nested expression is 
age + spouse_age. In the expression 
(4 + MEAN(age)) > spouse_age, the nested expression is 
4 + MEAN(age).

Matching Types

Although the syntax of the expression 1.5 * (’student’ + age) is 
correct, the expression is invalid because the + (addition) operator must 
add two numbers. (Here age is a variable storing numbers but 
’student’ is a category name.) To ensure that expressions are 
meaningful, Survey Crafter Professional checks each expression using a 
set of type rules. If the expression does not follow the type rules, Survey 
Crafter Professional displays an error message.

Several tasks in Survey Crafter Professional require you to write an 
expression that returns a specific type of value. For example, when 
editing the value in a Data window cell that belongs to a quantity variable, 
you must assign the cell an expression that returns a number (for example, 
MEAN(age) or 5). The cell will not accept a category name like 
‘Student’ or a literal value like "Reduce parking fees".
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To check whether the type of value or set of values returned matches the 
type required, Survey Crafter Professional uses the following rules:

• Exact matches are always allowed. 

For example, Survey Crafter Professional accepts a number where a 
number is required.

• Any type of value or variable may be tested for equivalence with the 
values NR (No Reply) and NV (No Value).

• An expression returning a single value of type x may be used where a 
value of type x is required for each respondent in the data set. In this 
case, Survey Crafter Professional assigns the same value to all 
respondents in the data set.

Suppose you are creating a computed variable by using an expression 
that returns the number 3. To populate the variable, Survey Crafter 
Professional needs a value for every respondent in the data set, so it 
assigns the number 3 to all respondents.

• An expression returning a value for each respondent in the data set is 
not allowed where a single value is required.

Suppose you are editing a cell belonging to the quantity variable age in 
the Data window. This cell stores one number. Therefore, you can use 
the expression MEAN(age) to calculate the cell’s value because it 
returns one number. However, you cannot use an expression like age + 
3 because it returns a number for each respondent in the data set.
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Using the Expression Builder

The Expression Builder helps you write expressions by providing 
resources that you can drag and drop into your expressions such as 
functions, your study's variables, values from your study's data set and 
expressions from the Expression Library.

The caption of the Expression Builder dialog box lists the return types 
expected of your expression. For example, the expression you are writing 
may be required to return either TRUE or FALSE.
 

Figure 7 - 2: The Expression Builder dialog box.

To write an expression, type in the box or click on a button or drag or 
double-click on an operator, function, variable or value in one of the lists 
to insert the item in the box. For more information about and examples for 
an operator or function, click on the operator or function in the list and 
then click on the Info button.

Build your 
expression in the 
box. When you 
double-click on a 
variable name or 
function in the box, 
Survey Crafter 
Professional 
automatically selects 
the variable or 
function in the lists.

Click on a button or 
drag or double-click 
on a function, 
operator, variable or 
value in one of the 
lists to insert the item 
in the box.
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For guidance on inserting a function, move the cursor to where you want 
to insert the function in the box and click on the Fn button to start the 
Function Wizard.

When you double-click on a variable name or function in the box, Survey 
Crafter Professional automatically selects the variable or function in the 
lists. 

Table 7 - 3 contains descriptions of the resources the Expression Builder 
provides.

Table 7 - 3: Expression Builder Resources

Resource Description

Function Wizard (Fn) Button Inserts an expression built by the Function Wizard 
in the box.

Expression Element Buttons 
(=, >, <, <>, +, -, *, /, AND, 
OR, NOT, (, ), TRUE, 
FALSE, NV, NR)

Inserts the expression element in the box.

Expression Group List Lists all of the available expression groups for the 
currently selected return type.

Functions, Operators or 
Variables List

Lists the functions, operators or variables that 
belong to the currently selected expression group.

Drag or double-click on an item in the list to insert 
the item in the box.

For examples, click on an item in the list and then 
click on the Info button.

Values List Lists the values that belong to the currently 
selected item in the Functions, Operators or 
Variables list. 

Drag or double-click on a value in the list to insert 
the value in the box.

Save Button Saves your expression to your study's Expression 
Library.

Library Button Inserts an expression from your study's Expression 
Library in the box.
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Test Button Has Survey Crafter Professional test your 
expression for syntax errors and then verify that 
your expression returns one of the types listed in 
the caption of the Expression Builder dialog box. 

Survey Crafter Professional displays an error 
message if your expression contains a syntax error 
or returns an unlisted type.

Info Button Displays information about the currently selected 
function, operator, variable or value.

Table 7 - 3: Expression Builder Resources

Resource Description
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Operators and Functions Supported by Variable 
Types

Some functions and operators may be used only by specific variable 
types. For example:

• You can calculate the mean of values stored in a quantity variable but 
not of values stored in a category variable.

• You can use the + (addition) operator to add two quantities or two 
literals but not two categories.

Table 7 - 4 lists the operators and functions supported by different 
variable types.

The “Condition” row lists operators and functions that involve testing a 
condition (a statement that evaluates to TRUE or FALSE) for any variable 
type. For example, you can use the COUNT( ) function to determine the 
number of respondents with the value ‘male’ in the category variable 
gender or the number of respondents with values less than 50,000 in the 
quantity variable income. 

Table 7 - 4: Operators and functions supported by different variable types.

Variable type Operators Functions

All variables =, <> CURRENT_VALUE, IF, IS_MISSING,,  
IS_UNEXPECTED, IS_UNREADABLE, 
IS_VALID, OCCURS, RECORDNUM, 
RECORDS, RECORD_VALUE, 
SORTED_RECORDNUM, 
SORTED_RECORDS, 
SORTED_UNIQUE_RECORDS, 
SORTORDER, SORTORDER2, 
UNIQUE_RECORDS

Category variables =, <> XTAB_SIGNIFICANCE
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For more on Survey Crafter Professional’s operators and functions, see 
the sections “About Survey Crafter Professional’s Operators” on page 
7 - 15 and “About Survey Crafter Professional’s Functions” on page 
7 - 18.

Quantity variables *, /, +, - (for subtraction), 
- (for negation), %, =, <>, 
<=, >=, <, >

ABS, CEIL, CONFIDENCE_MEAN, 
CORRELATION, 
CORRELATION_SIGNIFICANCE,  
FLOOR, MAX,  MEAN,   
MEANS_SIGNIFICANCE, MEDIAN,  
MIN,  MODE,  NORMALIZE, POWER, 
RAND, RANK,  RANK_PERCENT, 
ROUND, STANDARDIZE,   STDEV, SUM,  
TTEST, VARIANCE

Literal variables +, =, <>, <=, >=, <, > CONCAT, CONTAINS, CONTAINS_RE, 
FORMAT_LOCALTIME, FORMAT_TIME, 
FORMAT_UTCTIME, INDEX, 
INDEX_RE, LEFT, LENGTH, 
LIST_CONTAINS, LIST_ELEMENT, 
LIST_INDEX, LIST_RANDOMIZE, 
LIST_REMOVE, LIST_REVERSE, 
LIST_ROTATE, LIST_SIZE, 
LIT_TO_QTY, MIDSTR, 
QTY_TO_LIT, REPLACE, 
REPLACE_RE, RIGHT, STRIP, 
SUBSTR, SUBSTR_RE, TOLOWER, 
TOUPPER, WEB_COLUMN_VALUE, 
WEBSERVER_ENV

Condition AND, NOT,OR CONFIDENCE_PERCENTAGE, COUNT, 
IS_FALSE_OR_NV, 
IS_TRUE_NOT_NV, IS_TRUE_OR_NV, 
PERCENTAGE, 
PERCENTAGES_SIGNIFICANCE, 
RATIO

Table 7 - 4: Operators and functions supported by different variable types.

Variable type Operators Functions
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About Survey Crafter Professional’s Operators 

This section lists the operators Survey Crafter Professional includes and 
explains the order in which Survey Crafter Professional evaluates them.

You can read about each operator’s syntax and see examples of the 
operator in expressions in the Survey Crafter Professional Online Help 
System. From the Help menu, choose Search for Help on. In the Search 
dialog box, enter the operator as the keyword. In the help topics’ syntax 
descriptions, bold face type indicates a required operand and normal type 
indicates an optional operand.

Operator Reference

Survey Crafter Professional includes sets of arithmetic, comparison, and 
logical operators for use in expressions. Operators are either unary or 
binary.

Unary operators act on only one term in an expression. For example, the 
- (negation) operator negates one quantity. Binary operators act on two 
terms in an expression. For example, the + (addition) operator adds two 
quantities or two literals.

For information on the order in which Survey Crafter Professional 
evaluates operators, see the section “Operator Precedence” below.

Arithmetic Operators
Arithmetic operators are either unary or binary.

Table 7 - 5: Survey Crafter Professional’s arithmetic operators.

Operator Meaning Unary or binary?

* Multiplication Binary

/ Division Binary

+ Addition Binary

- Subtraction Binary

- Negation Unary
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Comparison Operators
All comparison operators are binary.

Logical Operators
Logical operators are either unary or binary.

Literal Operators
Literal operators are either unary or binary.

% Modulo Binary

Table 7 - 6: Survey Crafter Professional’s comparison operators.

Operator Meaning

= Equal to

<> Not equal to

<= Less than or equal to

>= Greater than or equal to

< Less than

> Greater than

Table 7 - 7: Survey Crafter Professional’s logical operators.

Operator Meaning Unary or binary?

AND Conjunction Binary

OR Union (inclusive “or”) Binary

NOT Logical negation Unary

Table 7 - 8: Survey Crafter Professional’s literal operators.

Operator Meaning Unary or binary?

+ Concatenation Binary

Table 7 - 5: Survey Crafter Professional’s arithmetic operators. (Continued)

Operator Meaning Unary or binary?
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Operator Precedence

When an expression includes several operators, Survey Crafter 
Professional evaluates the operators in a predetermined order. This order 
is called operator precedence. However, you can use parentheses to 
override the order of precedence and force Survey Crafter Professional to 
evaluate some parts of an expression before others. Survey Crafter 
Professional always performs operations within parentheses before those 
outside. Inside parentheses, Survey Crafter Professional follows normal 
operator precedence.

Table 7 - 9 lists operators in order of precedence from top to bottom. 
Operators in the same row of the table have equal precedence. Survey 
Crafter Professional evaluates operators having equal precedence in the 
order they occur from left to right in the expression. 

Table 7 - 9: Precedence of Survey Crafter Professional operators.

Operators in order of precedence (from top to bottom)

Logical negation (NOT),  arithmetic negation ( - )

Multiplication, division and modulo (* , /, %) 

Addition and subtraction ( + , - )

Less than, greater than, less than or equal to, greater than or equal to (< , > , <= 
, >= )

Equals, not equals (= , <> )

Logical conjunction, logical union (AND , OR)
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About Survey Crafter Professional’s Functions

This section describes the functions Survey Crafter Professional includes.

You can read about each function’s syntax and see examples of the 
function in expressions in the Survey Crafter Professional Online Help 
System. From the Help menu, choose Search for Help on. In the Search 
dialog box, enter the function as the keyword. In the help topics’ syntax 
descriptions, bold face type indicates a required argument and normal 
type indicates an optional argument. 

Arithmetic Functions
Survey Crafter Professional includes the arithmetic functions shown in 
Table 7 - 10.

Table 7 - 10: Survey Crafter Professional’s arithmetic functions.

Function Description

ABS Returns the absolute value of a quantity.

CEIL Returns the smallest whole number greater than 
or equal to the quantity value.

COUNT Returns the number of respondents meeting a 
condition.

FLOOR Returns the largest whole number less than or 
equal to the quantity value.

PERCENTAGE Returns the percentage of respondents meeting a 
condition.

POWER Returns one quantity value raised to the power of 
another quantity value.

RAND Returns a pseudorandom number between 0 and 
the quantity.

RATIO Returns the proportion of respondents meeting a 
condition.

ROUND Returns the quantity rounded according to the 
precision.
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Logical Functions
Survey Crafter Professional includes the logical functions shown in Table 
7 - 11.

SUM Returns the sum of quantity values for 
respondents meeting a condition.

Table 7 - 11: Survey Crafter Professional’s logical functions.

Function Description

IF Returns one value if a condition is TRUE and 
another if it is FALSE.

IS_FALSE_OR_NV Returns TRUE if the condition is either FALSE or 
NV.

IS_MISSING Returns TRUE if the value is missing (the value is 
NR or NV. Otherwise returns FALSE.

IS_TRUE_NOT_NV Returns TRUE if the condition is TRUE. Returns 
FALSE if the condition is either FALSE or NV.

IS_TRUE_OR_NV Returns TRUE if the condition is either TRUE or 
NV.

IS_UNEXPECTED Returns TRUE if the value is unexpected. 
Otherwise returns FALSE.

IS_UNREADABLE Returns TRUE if the value is unreadable. 
Otherwise returns FALSE.

IS_VALID Returns TRUE if the value is valid (the value is 
not NR or NV). Otherwise returns FALSE.

Table 7 - 10: Survey Crafter Professional’s arithmetic functions. (Continued)

Function Description
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Statistical Manipulations
Survey Crafter Professional includes the functions in Table 7 - 12 for 
normalizing and standardizing values in quantity variables.

Statistical Descriptions
Survey Crafter Professional includes the functions in Table 7 - 13 for 
calculating statistics on values in quantity variables.

Table 7 - 12: Survey Crafter Professional’s statistical manipulation functions.

Function Description

NORMALIZE Normalizes the values in a quantity variable about 
their mean.

STANDARDIZE Standardizes the values in a quantity variable 
about their mean.

Table 7 - 13: Survey Crafter Professional’s statistical description functions.

Function Description

CORRELATION Returns the Pearson correlation coefficient for 
two quantity variables.

MAX Returns the maximum value in a quantity 
variable.

MEAN Returns the arithmetic mean of a quantity 
variable.

MEDIAN Returns the median of a quantity variable.

MIN Returns the minimum value in a quantity variable.

MODE Returns the mode of a quantity variable.

RANK Returns the rank of a number against the values of 
a quantity variable.

RANK_PERCENT Returns the percentage of numbers in a quantity 
variable that are either less than or greater than a 
given number.

STDEV Returns the standard deviation of a quantity 
variable.
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Statistical Tests
Survey Crafter Professional includes the functions in Table 7 - 14 for 
calculating confidence intervals and testing for statistical significance.

VARIANCE Returns the variance of a quantity variable.

Table 7 - 14: Survey Crafter Professional’s statistical test functions.

Function Description

CONFIDENCE_MEAN Returns the confidence interval for the 
mean of a quantity variable.

CONFIDENCE_PERCENTAGE Returns the confidence interval for the 
percentage of records meeting a 
condition.

CORRELATION_SIGNIFICANCE Returns the results of a Pearson 
correlation t-test.

MEANS_SIGNIFICANCE Returns the results of a 2 mean, 2-
sample, unequal variance t-test.

PERCENTAGE_SIGNIFICANCE Returns the results of a 2 percentage, 2 
sample t-test.

TTEST Returns the results of a 2-mean, 2-
sample, equal variance t-test, a 2-
mean, 2-sample, unequal variance t-
test or a paired sample t-test.

XTAB_SIGNIFICANCE Returns the results from a chi-square 
test for two category variables.

Table 7 - 13: Survey Crafter Professional’s statistical description functions. (Continued)

Function Description
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Literal Functions
Survey Crafter Professional includes the literal functions shown in Table 
7 - 15.

Table 7 - 15: Survey Crafter Professional’s literal functions.

Function Description

CONCAT Returns the concatenation of two literal variables 
or values.

CONTAINS Returns TRUE if the pattern is contained in the 
literal variable or value.

CONTAINS_RE Returns TRUE if the regular expression pattern is 
contained in the literal variable or value.

INDEX Returns the one-based offset of the first 
occurrence of the pattern in the literal variable or 
value. If the pattern is not found, returns 0.

INDEX_RE Returns the one-based offset of the first 
occurrence of the regular expression pattern in the 
literal variable or value. If the pattern is not found, 
returns 0.

LEFT Returns a specified number of characters from the 
left side of a literal variable or value.

LENGTH Returns the length of the literal variable or value.

LIST_CONTAINS Returns TRUE when all of list1's elements are in 
list2. Otherwise, returns FALSE.

LIST_ELEMENT Returns the specified element from a list of 
elements.

LIST_INDEX Returns the one-based offset of the first 
occurrence of the element in the list. If the 
element is not found in the list, returns 0.

LIST_RANDOMIZE Returns the result of randomly reordering all or 
part of a list.

LIST_REMOVE Returns the result of removing the elements in 
list1 from list2.

LIST_REVERSE Returns the result of reversing all or part of a list.
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LIST_ROTATE Returns the result of rotating all or part of a list.

LIST_SIZE Returns the number of elements in a list.

LIT_TO_QTY Converts literal values to quantity values.

MIDSTR Returns a specified number of characters from the 
middle of a literal variable or value.

QTY_TO_LIT Converts quantity values to literal values.

REPLACE Returns the result of replacing all occurrences of 
the pattern in the literal.

REPLACE_RE Returns the result of replacing all occurrences of 
the regular expression pattern in the literal.

RIGHT Returns a specified number of characters from the 
right side of a literal variable or value.

STRIP Returns the literal variable or value with spaces 
removed from the beginning and the end.

SUBSTR Returns the first sub-string in the literal variable 
or value that matches the pattern.

SUBSTR_RE Returns the first sub-string in the literal variable 
or value that matches the pattern.

TOLOWER Returns the literal variable or value with all lower 
case letters.

TOUPPER Returns the literal variable or value with all upper 
case letters.

Table 7 - 15: Survey Crafter Professional’s literal functions. (Continued)

Function Description
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Respondent Functions
Survey Crafter Professional includes the respondent functions shown in 
Table 7 - 16.

Table 7 - 16: Survey Crafter Professional’s respondent functions.

Function Description

CURRENT_VALUE Returns a variable's value for the current 
respondent.

OCCURS Returns a number for each value of a given 
variable showing the number of times the 
value occurs.

RECORDNUM Returns the record numbers for all 
respondents in the dataset that meet a 
specified condition.

RECORDS Returns the response values of one variable 
for all respondents in the dataset that meet a 
specified condition.

RECORD_VALUE Returns a variable's value at a specified 
record.

SORTED_RECORDNUM Returns the record numbers for all 
respondents in the dataset that meet a 
specified condition. Uses a quantity variable 
to determine the order of the returned record 
numbers.

SORTED_RECORDS Returns the response values of one variable 
for all respondents in the dataset that meet a 
specified condition. Uses a quantity variable 
to determine the order of the returned 
response values.

SORTED_UNIQUE_RECORDS Returns the unique response values of one 
variable for all respondents in the dataset 
that meet a specified condition. Uses a 
quantity variable to determine the order of 
the returned response values.

SORTORDER Returns the sort order of each respondent in 
the dataset. Uses one variable to determine 
the sort order.
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Date / Time Functions
Survey Crafter Professional includes the date / time functions shown in 
Table 7 - 17.

SORTORDER2 Returns the sort order of each respondent in 
the dataset. Uses two variables to determine 
the sort order.

UNIQUE_RECORDS Returns the unique response values of one 
variable for all respondents in the dataset 
that meet a specified condition.

Table 7 - 17: Survey Crafter Professional’s date / time functions.

Function Description

FORMAT_LOCALTIME Returns the current local date and time 
formatted as a literal value.

FORMAT_TIME Returns the date and time formatted as a 
literal value.

FORMAT_UTCTIME Returns the current date and time in 
Coordinated Universal Time (UTC) as a 
literal value.

LOCALTIME_PART Returns the specified part from the current 
local date and time as a quantity value.

UTCTIME_PART Returns the specified part from the current 
date and time in Coordinated Universal 
Time (UTC) as a quantity value.

Table 7 - 16: Survey Crafter Professional’s respondent functions. (Continued)

Function Description
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Web Server Functions
Survey Crafter Professional includes the web server functions shown in 
Table 7 - 18.

Table 7 - 18: Survey Crafter Professional’s web server functions.

Function Description

WEB_COLUMN_VALUE Returns the current value of the specified 
column from the web survey's data file (web 
only).

WEBSERVER_ENV Returns the value of the web server 
environment variable (web only).
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Examples of Expressions

Expressions help you get your work done in many areas of a study. This 
section includes examples of expressions for each of the following areas 
of a study:

• Custom Opening and Closing Web Survey Rules

• Custom Branching and Skipping Rules

• Custom Validation Rules

• Custom Assignment Rules

• Custom Web Cookie Rules

• Custom Data Cleaning Rules

• Computed Value Survey Fields

• Computed Variables

• New Data Set Values

• Values in Table Cells

• Row, Column and Table Filters

• Filtering Records in the Data Window 

• Batch Report Filters 

• Batch Report Conditions 

Custom Opening and Closing Web Survey Rules

Custom opening and closing web survey rules allow you to configure 
your web surveys to open or close at specified dates and times or 
alternatively when the expressions you write for them evaluate to TRUE.

A condition expression for a custom opening or closing web survey rule 
must evaluate to either TRUE or FALSE. Depending upon the other 
settings of a closing web survey rule, for example, respondents for whom 
the rule's expression evaluates to TRUE are either shown a message or 
taken to a page on the Internet or your Intranet, or both.
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Table 7 - 19 shows examples of condition expressions for custom opening 
and closing web survey rules. Please note that the variables and their 
values referenced in the expressions below are not likely to exist in your 
studies.

Table 7 - 19: Examples of expressions for custom opening and closing web survey rules.

Expression Description

FORMAT_UTCTIME(1,1)>="202
1/03/30 08:00"

This condition expression evaluates to TRUE when the 
current date and time in Coordinated Universal Time (UTC) 
is on or after 8AM, March 30, 2021. Note that for opening 
and closing web survey rules, it is strongly recommended 
that you not use the function FORMAT_LOCALTIME. The 
reason is the date and time returned by 
FORMAT_LOCALTIME will be in the time zone of either 
the respondent's browser or the server that is hosting your 
web survey, each of which may be different from yours.

FORMAT_UTCTIME(1,1)>="202
1/03/30 15:00" AND 
FORMAT_UTCTIME(1,1)<="202
1/03/31 23:59"

This condition expression evaluates to TRUE when the 
current date and time in Coordinated Universal Time (UTC) 
is on or after 3PM, March 30 and on or before 11:59PM, 
March 31. If you were to use this expression in an open web 
survey rule, the survey would open at 3PM, March 30 UTC 
and then close at 12AM, March 31 UTC. If you were to use 
this expression in a close web survey rule, the survey would 
close at 3PM, March 30 UTC and then reopen at 12AM, 
March 31 UTC.

COUNT (A3_WhatIsYourAge = 
'20_29') >= 10

If you were to use an expression like this in a close web 
survey rule, the survey would close for all respondents when 
there are already 10 respondents in the survey's data file who 
said they are older than 19 and younger than 30. Note that 
even if you have a question in your survey that asks for the 
respondent's age, the variable and value referenced in your 
expression would be different.

COUNT 
(IS_VALID(A99_Last)) >= 
1000

If you were to replace A99_Last in the example with a 
variable from your survey that is associated with the last 
question that requires an answer and use the modified 
expression in a close web survey rule, the survey would close 
for all respondents when the survey's data file has 1000 
records that have valid answers to the question.
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Custom Branching and Skipping Rules

Custom branching and skipping rules allow you to configure your survey 
to automatically take respondents from one question block or page to 
another question block or page, when the expressions you write evaluate 
to TRUE.

A condition expression for a custom branching and skipping rule must 
evaluate to either TRUE or FALSE for every respondent in the study’s 
data set. Depending upon the rule, respondents for whom the expression 
evaluates to TRUE are taken from one question block or page to another 
question block or page.

Table 7 - 20 shows examples of condition expressions for custom 
branching and skipping rules. Please note that the variables referenced in 
the expressions below are not likely to exist in your studies.

Custom Validation Rules

Custom validation rules allow you to configure your survey to have 
Survey Crafter Professional show your own warning and error messages 
to respondents, when the expressions you write evaluate to TRUE.

Table 7 - 20: Examples of expressions for custom branching and skipping rules.

Expression Description

A1_WhatIsYourGender = 
’Male’

This condition expression returns TRUE when a respondent 
chooses Male when answering the question “What is your 
gender?”

A2_HowSatisfiedAreYouWith 
> 3

This condition expression returns TRUE when a respondent 
chooses 4 or greater to the rating question “How satisfied are 
you with our service? (Use a scale from 1 to 5)”.

COUNT (A3_WhatIsYourAge = 
’20_29’) >= 10

This condition expression returns TRUE when there are 
already 10 respondents who said they were older than 19 but 
younger than 30.

COUNT (A3_WhatIsYourAge = 
CURRENT_VALUE 
(A3_WhatIsYourAge)) >= 10

This condition expression returns TRUE when there are 
already 10 or more respondents who chose the age range the 
current respondent has chosen.
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A condition expression for a custom validation rule must evaluate to 
either TRUE or FALSE for every respondent in the study’s data set. 
Depending upon the rule, respondents for whom the expression evaluates 
to TRUE are either shown a warning or an error message.

Table 7 - 21 shows examples of condition expressions for custom 
validation rules. Please note that the variables referenced in the 
expressions below are not likely to exist in your studies.

Table 7 - 21: Examples of expressions for custom validation rules.

Expression Description

A1_WhatCityAreYouFrom = 
’Other’ AND NOT 
VALID(A1_OtherSpecify)

This condition expression returns TRUE when a respondent 
chooses Other when answering the closed-end question 
“What city are you from” but does not specify what Other 
means.

(A2_WhatColorsDoYouSee_Re
d = ‘Yes’ OR 
A2_WhatColorsDoYouSee_Blu
e = ‘Yes’ OR 
A2_WhatColorsDoYouSee_Gre
en = ‘Yes’) AND 
A2_WhatColorsDoYouSee_Non
e = ‘Yes’

This condition expression returns TRUE when a respondent 
chooses None as well as Red, Blue, or Green when answering 
the all-that-apply question “What Colors do you see in the 
picture above?”

(IF(A3_WhatAreYour2Favori
te_Burger=’Yes’,1,0) + 
IF(A3_WhatAreYour2Favorit
e_KingTaco=’Yes’,1,0) + 
IF(A3_WhatAreYour2Favorit
e_Marshas=’Yes’,1,0) + 
IF(A3_WhatAreYour2Favorit
e_Broilin=’Yes’,1,0)) <> 2

This condition expression returns TRUE when a respondent 
does not choose 2 restaurants when answering the all-that-
apply question “What are your 2 favorite restaurants?”

NOT(CONTAINS_RE(A4_WhatIs
YourEmailAddress,"^[a-zA-
Z0-9._%-]+@[a-zA-Z0-9.-
]+\.[a-zA-Z][a-zA-Z][a-
zA-Z]?[a-zA-Z]?$"))

This condition expression returns TRUE when a respondent 
does not enter a valid email address to the open-end question 
"What is your email address?"
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Custom Assignment Rules

Custom assignment rules allow you to configure your surveys to have 
Survey Crafter Professional automatically assign values to imported 
variables as the respondent takes your survey.

An assignment expression for a custom assignment rule must evaluate to 
a value of the same type as the selected imported variable. A condition 
expression for a custom assignment rule must always evaluate to either 
TRUE or FALSE for every respondent in the study's data set.

NOT(CONTAINS_RE(A5_WhatIs
TodaysDate,"^[0-9][0-
9][0-9][0-9]/(0?[1-
9]|1[0-2])/(0?[1-9]|[1-
2][0-9]|3[0-1])$"))

This condition expression returns TRUE when a respondent 
does not enter a date in YYYY/MM/DD format to the open-
end question "What is today's date?"

NOT(CONTAINS_RE(A6_WhatIs
TodaysDate,"^(0?[1-
9]|1[0-2])/(0?[1-9]|[1-
2][0-9]|3[0-1])/([0-9][0-
9]|[0-9][0-9][0-9][0-
9])$"))

This condition expression returns TRUE when a respondent 
does not enter a date in MM/DD/YY or MM/DD/YYYY 
format to the open-end question "What is today's date?"

NOT(CONTAINS_RE(A6_WhatIs
TodaysDate,"^(0?[1-9]|[1-
2][0-9]|3[0-1])/(0?[1-
9]|1[0-2])/([0-9][0-
9]|[0-9][0-9][0-9][0-
9])$"))

This condition expression returns TRUE when a respondent 
does not enter a date in DD/MM/YY or DD/MM/YYYY 
format to the open-end question "What is today's date?"

NOT(CONTAINS_RE(A7_WhatIs
TheCurrentTime,"^([1-
9]|1[0-2]):[0-5][0-9][ 
]?(am|AM|pm|PM)$"))

This condition expression returns TRUE when a respondent 
does not enter a time in HH:MM am/pm format to the open-
end question "What is the current time?"

NOT(CONTAINS_RE(A8_WhatIs
TheCurrentTime,"^([0-
9]|1[0-9]|2[0-3]):[0-
5][0-9]$"))

This condition expression returns TRUE when a respondent 
does not enter a time in HH:MM military time format to the 
open-end question "What is the current time?"

Table 7 - 21: Examples of expressions for custom validation rules. (Continued)

Expression Description
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Table 7 - 24 shows examples of both assignment and condition 
expressions for custom assignment rules. Please note that the variables 
referenced in the expressions below are not likely to exist in your studies.

Table 7 - 22: Examples of expressions for custom assignment rules.

Expression Description

FORMAT_LOCALTIME(1,3) This assignment expression returns the current date and time 
as a literal value in YYYY/MM/DD HH:MM:SS format.

The custom assignment rule's variable must be an imported 
literal variable.

LOCALTIME_PART(0) This assignment expression returns the current year as a 
quantity value.

The custom assignment rule's variable must be an imported 
quantity variable.

StartTime=NV This condition expression returns TRUE when the variable 
StartTime has no value.

If the custom assignment rule's variable is StartTime, this 
condition expression has Survey Crafter Professional assign 
StartTime only once.

WEBSERVER_ENV("REMOTE_ADD
R")

This assignment expression returns the IP address of the 
respondent as a literal value in AAA.BBB.CCC.DDD format 
when your survey is on the Web.

The custom assignment rule's variable must be an imported 
literal variable.

This expression always returns NV when evaluated by the 
Survey Crafter Professional desktop application.

WEBSERVER_ENV("REMOTE_USE
R")

This assignment expression returns the respondent's logged 
in user name as a literal value when your survey is on the 
Web. 

The respondent's logged in user name is usually available 
only when both the respondent and web server are on the 
same Intranet.

The custom assignment rule's variable must be an imported 
literal variable.

This expression always returns NV when evaluated by the 
Survey Crafter Professional desktop application.
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WEBSERVER_ENV("HTTP_USER_
AGENT")

This assignment expression returns information about the 
respondent's browser as a literal value when your survey is 
on the Web.

The custom assignment rule's variable must be an imported 
literal variable.

This expression always returns NV when evaluated by the 
Survey Crafter Professional desktop application.

WEB_COLUMN_VALUE("_#") This assignment expression returns the current respondent's 
unique identification number in your survey's data file when 
the survey is on the Web.

The custom assignment rule's variable must be an imported 
literal variable.

This expression always returns NV when evaluated by the 
Survey Crafter Professional desktop application.

WEB_COLUMN_VALUE("_$") This assignment expression returns the number of times the 
current respondent has completed your survey when the 
survey is on the Web.

If your survey has been configured to save the respondent's 
answers as the respondent proceeds from one page to the 
next, until the respondent has completed the survey, the 
column will contain a floating point number (ex. 0.2) with 
the number to the right of the decimal point indicating the last 
page saved. Otherwise, the column will contain 0.

The custom assignment rule's variable must be an imported 
literal variable.

This expression always returns NV when evaluated by the 
Survey Crafter Professional desktop application.

A1_WhatIsYourGender = 
'Male'

This condition expression returns TRUE when a respondent 
chooses Male when answering the question "What is your 
gender?"

A1_WhatIsYourGender <> 
'Female' AND 
A3_WhatIsYourAge = '20_29'

This condition expression returns TRUE when a respondent 
does not choose Female when answering the question "What 
is your gender" but does choose 20-29 when answering the 
question "What is your age?"

Table 7 - 22: Examples of expressions for custom assignment rules. (Continued)

Expression Description
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Custom Web Cookie Rules

Custom web cookie rules have Survey Crafter Professional send and 
receive cookies to and from a respondent's browser as the respondent 
takes your web survey. These rules make use of expressions to calculate a 
cookie's value and if the option is selected, to also determine when the 
calculation should be done and the cookie sent.

Expressions used by these rules to calculate a cookie's value must 
evaluate to a literal or quantiy value. Expressions used to determine when 
to calculate and send the cookie must evaluate to either TRUE or FALSE.

Table 7 - 24 shows examples of expressions that could be used in a 
custom web cookie rule.

Table 7 - 23: Examples of expressions for custom assignment rules.

Expression Description

QTY_TO_LIT(RAND(9999))+".
"+QTY_TO_LIT(UTCTIME_PART
(7))+"."+WEBSERVER_ENV("R
EMOTE_ADDR")+"."+QTY_TO_L
IT(RAND(9999))

This expression evaluates to a literal value composed of a 
series of digits separated by periods. The periods separate a 
randomly generated number, the number of seconds and 
microseconds since January 1, 1970, the respondent’s IP 
address and another randomly generated number.

You can use this expression in a Set/Get Web Cookie rule to 
assign the resulting unique value to a cookie before it’s sent 
to the respondent's browser. Sending a cookie with a unique 
value to a respondent's browser makes it possible for Survey 
Crafter Professional to identify the respondent if the 
respondent were to return to the survey.

QTY_TO_LIT(RAND(9999))+".
"+REPLACE_RE(FORMAT_UTCTI
ME(1,3),"[ /
:]","")+"."+WEBSERVER_ENV
("REMOTE_ADDR")+"."+QTY_T
O_LIT(RAND(9999))

This expression evaluates to a literal value composed of a 
series of digits separated by periods. The periods separate a 
randomly generated number, only the digits of the current 
date and time in Universal Coordinated Time (UTC), the 
respondent’s IP address and another randomly generated 
number.

You can use this expression in a Set/Get Web Cookie rule to 
assign the resulting unique value to a cookie before it’s sent 
to the respondent's browser. Sending a cookie with a unique 
value to a respondent's browser makes it possible for Survey 
Crafter Professional to identify the respondent if the 
respondent were to return to the survey.
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Custom Data Cleaning Rules

Custom data cleaning rules allow you to have Survey Crafter Professional 
color response values in the Data window when the expressions you write 
for the rules evaluate to TRUE.

A condition expression for a custom data cleaning rule must evaluate to 
either TRUE or FALSE for every respondent in the study’s data set. 
Response values in the Data window are colored blue when the 
expression evaluates to TRUE.

Table 7 - 24 shows examples of condition expressions for custom data 
cleaning rules. Please note that the variables referenced in the expressions 
below are not likely to exist in your studies.

LIT_TO_QTY(QTY_TO_LIT(ROU
ND(RAND(10))+10)+IF(LENGT
H(QTY_TO_LIT(ROUND(UTCTIM
E_PART(7))))>8,RIGHT(QTY_
TO_LIT(ROUND(UTCTIME_PART
(7))),8),QTY_TO_LIT(ROUND
(UTCTIME_PART(7))))+"."+Q
TY_TO_LIT(ROUND(RAND(8999
99))+100000))

This expression evaluates to a large quantity value with a 
precision of 6 digits. The number is composed of 2 randomly 
generated digits, followed by the number of seconds since 
January 1, 1970 in Universal Coordinated Time (UTC), the 
decimal point, and 6 randomly generated digits.

You can use this expression in a Set/Get Web Cookie rule to 
assign the resulting unique value to a cookie before it’s sent 
to the respondent's browser. Sending a cookie with a unique 
value to a respondent's browser makes it possible for Survey 
Crafter Professional to identify the respondent if the 
respondent were to return to the survey.

Table 7 - 24: Examples of expressions for custom data cleaning rules.

Expression Description

OCCURS(A1_RecordNumber) > 
1

This condition expression returns TRUE when the same 
answer to the “Record Number” question appears more than 
once in the study’s data set. If the rule’s associated imported 
variable is A1_RecordNumber, all instances of the duplicate 
answer are colored blue in the Data window.

Table 7 - 23: Examples of expressions for custom assignment rules. (Continued)

Expression Description
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Computed Value Survey Fields

Computed value survey fields allow you to have Survey Crafter 
Professional display calculated values in your survey when your survey is 
on the Web or in the built-in Interviewer.

An expression for a computed value survey field must evaluate to a 
category, quantity or literal value.

Table 7 - 24 shows examples of expressions for computed value survey 
fields. Please note that the variables referenced in the expressions below 
are not likely to exist in your studies. 

A2_HowSatisfiedAreYouWith 
= 5 AND 
A3_OverallSatisfaction = 1

This condition expression returns TRUE when a respondent 
chooses a 5 when answering the rating question “How 
satisfied are you with our service” and 1 when answering the 
rating question “Overall Satisfaction”.

A3_Divide1150By30 <> 35 This condition expression returns TRUE when a respondent 
does not enter 35 when answering the quantity question 
“Divide 1150 by 30”. If the rule’s associated imported 
variable is A3_Divide1150By30, all instances of the incorrect 
answer are colored blue in the Data window.

Table 7 - 25: Examples of expressions for computed value survey fields.

Expression Description

FORMAT_LOCALTIME(1,3) This expression returns the current date and time as a literal 
value in YYYY/MM/DD HH:MM:SS format.

LOCALTIME_PART(0) This assignment expression returns the current year as a 
quantity value.

Table 7 - 24: Examples of expressions for custom data cleaning rules. (Continued)

Expression Description
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RANK (CURRENT_VALUE 
(A1_Score), A1_Score)

When your survey is on the Web, this expression returns the 
ranking of the current respondent's score, stored in the 
variable A1_Score, against the scores already entered by 
other respondents.

Here, the lower the score, the higher the ranking. For 
example, this expression would return a ranking of 2 for a 
score of 10, compared against other scores of 5, 15, 25 and 
50.

RANK (CURRENT_VALUE 
(A1_Score), A1_Score, 
TRUE, 1)

When your survey is on the Web, this expression returns the 
ranking of the current respondent's score, stored in the 
variable A1_Score, against the scores already entered by 
other respondents.

Here, the higher the score, the higher the ranking. For 
example, this expression would return a ranking of 2 for a 
score of 30, compared against other scores of 5, 15, 25 and 
50.

RANK_PERCENT 
(CURRENT_VALUE 
(A1_Score), A1_Score)

When your survey is on the Web, this expression returns the 
percentage of numbers in A1_Score already entered by other 
respondents that are less than the current respondent's 
number.

Here, the higher the score, the higher the percentage. For 
example, this expression would return 60% for a score of 30 
compared against other scores of 5, 15, 25 and 50.

WEBSERVER_ENV("REMOTE_ADD
R")

This expression returns the IP address of the respondent as a 
literal value in AAA.BBB.CCC.DDD format when your 
survey is on the Web.

This expression always returns NV when evaluated by 
Survey Crafter Professional's built-in Interviewer.

WEBSERVER_ENV("REMOTE_USE
R")

This expression returns the respondent's logged in user name 
as a literal value when your survey is on the Web. 

The respondent's logged in user name is usually available 
only when both the respondent and web server are on the 
same Intranet.

This expression always returns NV when evaluated by 
Survey Crafter Professional's built-in Interviewer.

Table 7 - 25: Examples of expressions for computed value survey fields. (Continued)

Expression Description
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Computed Variables

Survey Crafter Professional automatically calculates the values stored in 
computed variables using the expressions you write. Expressions for 
computed variables return a value for each respondent in the study’s data 
set.

LEFT(A1_WhatIsYourName,30
)

This expression returns as a literal value at most 30 
characters of the respondent's name as it was entered for the 
question What is your name?

A1_YourIncome + 
A2_SpouseIncome

This expression returns as a quantity value the sum of the 
answers to two income questions.

If either of the two questions has not been answered, this 
expression returns NV.

IF (IS_VALID 
(A1_YourIncome), 
A1_YourIncome, 0) + IF 
(IS_VALID 
(A2_SpouseIncome), 
A2_SpouseIncome, 0)

This expression returns as a quantity value the sum of the 
answers to two income questions.

This expression never returns NV. Instead, it assumes an 
income of 0 when a question has not been answered.

Table 7 - 25: Examples of expressions for computed value survey fields. (Continued)

Expression Description
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Computed Category Variables
Table 7 - 26 shows several examples of expressions used to calculate the 
values stored in computed category variables. Please note that the 
variables referenced in the expressions below are not likely to exist in 
your studies.

Table 7 - 26: Examples of expressions for computed category variables.  

Expressions Description

• age < 25

• age >= 25 AND age <= 50

• age > 50

These three expressions assign each respondent to one of 
three categories based on the value in the quantity variable 
age:

• Respondents who are under age 25

• Respondents who are between the ages of 25 and 50 
inclusive

• Respondents who are over age 50

• sport = ‘tennis’ OR sport 
= ‘squash’

• sport = ‘sailing’ OR 
sport = ‘rowing’ OR sport 
= ‘swimming’

• sport = ‘running’ OR 
sport = ‘biking’

These three expressions create three categories of 
respondents based on their favorite sport:

• Respondents who prefer sports played with rackets

• Respondents who prefer water sports 

• Respondents who prefer road sports

• gender = ‘male’ AND 
OwnCar = ‘yes’

• gender = ‘male’ AND 
OwnCar = ‘no’

• gender = ‘female’ AND 
OwnCar = ‘yes’

• gender = ‘female’ AND 
OwnCar = ‘no’

These four expressions group respondents into four 
categories:

• Male respondents who own cars

• Male respondents who do not own cars

• Female respondents who own cars

• Female respondents who do not own cars
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Computed Quantity Variables
Table 7 - 27 shows several examples of expressions used to calculate the 
values stored in computed quantity variables. Please note that the 
variables referenced in the expressions below are not likely to exist in 
your studies.

Computed Literal Variables
Table 7 - 28 shows several examples of expressions used to calculate the 
values stored in computed literal variables.

Table 7 - 27: Example expressions for computed quantity variables.

Expression Description

OwnInc + SpouseInc This expression adds each respondent’s income and his or her 
spouse’s income. The computed quantity variable stores these 
sums.

NORMALIZE(age) This expression normalizes the values in the quantity variable 
age. The computed quantity variable stores the normalized 
values.

OCCURS(age) This expression returns a number for each value in the quantity 
variable age showing the number of times the value occurs. The 
computed quantity variable stores these counts. If you want, you 
can use the computed quantity variable to sort records in the 
dataset by age popularity.

LIT_TO_QTY 
(LIST_ELEMENT (date, 3, 
“/”)+2000

This expression extracts the 3rd element of each value of the 
date literal variable, converts the extracted values to quantities 
and then adds 2000. Suppose the study’s dataset contains three 
respondents with the values “12/15/03”, “1/1/04” and “1/12/04” 
in the literal variable date. The computed quantity variable 
stores the values 2003, 2004 and 2004.

Table 7 - 28: Example expressions for computed literal variables.

Expression Description

STRIP(FirstName + 
IF(LENGTH(MiddleName)>0
, “ “ + MiddleName, ““) 
+ “ “ + LastName)

This expression concatenates each respondent’s first, middle 
and last name. The computed literal variable stores the full 
names.
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New Data Set Values

Table 7 - 29 shows several examples of expressions used to calculate new 
values for a study’s data set. The type of the expression’s result must 
match the variable type to which you want to assign the result. For 
example, a number can be assigned only to a quantity variable.

REPLACE_RE(USState, 
"[Mm][Aa][Ss]+[a-z,A-
Z]* ", "MA")

This expression replaces all occurrences of “Massachusetts”, 
“Mass”, and other spellings of the state with “MA”. The 
computed literal variable stores the new values.

Table 7 - 29: Example expressions for values in Data window cells.

Expression Variable type selected in
the Data window

Description

0 Quantity This expression assigns the value 0 to 
all cells selected in the variable’s 
column.

NV Any This expression assigns the value NV 
(No Value) to all cells selected in the 
variable’s column.

MEAN(age) Quantity This expression assigns the mean of the 
quantity variable age to all cells 
selected in the variable’s column.

Table 7 - 28: Example expressions for computed literal variables.

Expression Description
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Values in Table Cells

Table 7 - 30 shows several examples of expressions used to calculate 
values appearing in a table’s cells. Please note that the variables 
referenced in the expressions below are not likely to exist in your studies.

Row, Column and Table Filters

Row, column and table filters are powerful short cuts for defining 
respondents to include in table cells’ calculations. A row filter is an 
expression that determines those respondents to be included in the 
calculations in the row’s cells. A column filter is an expression that 
determines those respondents to be included in the calculations in the 
column’s cells. A table filter is an expression that determines those 
respondents to be included in the calculations in all cells. For a detailed 
example of using row and column filters, see the section “About Row, 
Column and Table Filters” on page 4 - 41.

Row, column and table filter expressions must evaluate to either TRUE or 
FALSE for every respondent in the study’s data set. Respondents for 
whom the expression is TRUE pass through the row, column or table 
filter and are included in the calculation.

Table 7 - 30: Examples expressions for table cell values.

Expression Description

MODE(age) This expression calculates the mode of the values in the quantity 
variable age for all respondents in the study’s data set.

MEAN(age, $ROW AND $COL 
AND $TABLE)

This expression calculates the mean of the quantity variable age 
for those respondents passing through the cell’s row filter, 
column filter and table filter.

COUNT(age = 35) This expression calculates the number of respondents for whom 
the quantity variable age stores the value 35.

RECORDS(comments, age = 
35, 100)

This expression returns the first 100 responses stored in the 
comments literal variable for those respondents for whom the age 
variable equals 35.
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Table 7 - 31 shows examples of expressions for row, column and table 
filters. Please note that the variables referenced in the expressions below 
are not likely to exist in your studies.

Filtering Records in the Data Window

Because study data sets can contain large numbers of records, you may 
want to view only a subset of the records in the Data window. You can 
write an expression to limit or filter the records appearing in the Data 
window. This expression is called a filter expression because it filters the 
records to display.

The filter expression must evaluate to either TRUE or FALSE for every 
respondent in the study’s data set. Records of respondents for whom the 
expression is TRUE appear in the Data window.

Table 7 - 32 shows several examples of filter expressions for limiting 
records appearing in the Data window. Please note that the variables 
referenced in the expressions below are not likely to exist in your studies.

Table 7 - 31: Examples of expressions for row, column and table filters.

Expression Description

For a row filter, 

income < 40000

This expression includes in the row only those respondents 
who reported their income to be under $40,000.

For a column filter,

married = ‘Yes’

This expression includes in the column only those 
respondents who are married.

For a table filter,

income < 40000 AND married 
= ‘Yes’

This expression includes in all cells only respondents whose 
income is less than $40,000 and who are married.

Table 7 - 32: Examples of expressions for limiting records appearing in the Data window.

Expression Description

age > 50 This expression displays only records of respondents who are over 
age 50.

gender = ‘female’ This expression displays only records of female respondents.
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Batch Report Filters

Survey Crafter Professional supports three types of batch report filters: 
Simple Condition Expression, Repeat Condition Expressions, and Repeat 
Variable Values.

Creating a batch report filter of type Simple Condition Expression 
requires that you write an expression that evaluates to either TRUE or 
FALSE for each respondent in your study's data set. When you add a 
batch report filter of this type to a batch report, when printing or exporting 
the report, Survey Crafter Professional uses your expression to limit the 
report's calculations to a subset of the respondent records in your study's 
data set.

Creating a batch report filter of type Repeat Condition Expressions 
requires that you write one or more expressions that evaluate to either 
TRUE or FALSE for each respondent in your study's data set. When you 
add a batch report filter of this type to a batch report, when printing or 
exporting the report, Survey Crafter Professional uses the expressions one 
at a time to limit the report's calculations to a subset of the respondent 
records in your study's data set.

The table below shows several examples of expressions for batch report 
filters. Please note that the variables referenced in the expressions below 
are not likely to exist in your studies.

age > 50 AND gender = 
‘female’

This expression displays only records of female respondents who 
are over age 50.

Table 7 - 33: Examples of expressions for batch report filters.

Expression Description

age = '18to20' OR age = 
'21-30'

This expression has Survey Crafter Professional limit the records 
used in the report's calculations to respondents who said their ages 
are between 18 and 30.

Table 7 - 32: Examples of expressions for limiting records appearing in the Data window. (Continued)

Expression Description
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Batch Report Conditions

You can configure a batch report design item to have Survey Crafter 
Professional include the item's analysis tables and charts only when the 
result of evaluating an expression is TRUE.

The table below shows several examples of condition expressions for 
batch report design item. Please note that the variables referenced in the 
expressions below are not likely to exist in your studies.

gender = 'male' This expression has Survey Crafter Professional limit the records 
used in the report's calculations to respondents who said they are 
male.

(age = '18to20' OR age 
= '21-30') AND gender = 
'male'

This expression has Survey Crafter Professional limit the 
records used in the report's calculations to respondents who 
said their ages are between 18 and 30 and that they are male.

Table 7 - 34: Examples of expressions for batch report conditions.

Expression Description

COUNT (age = '18to20' 
OR age = '21-30') > 0

This expression has Survey Crafter Professional include the batch 
report design item's analysis tables and charts only when there are 
respondents in your study's data set who said their ages are 
between 18 and 30.

COUNT (gender = 
'male') > 0

This expression has Survey Crafter Professional include the batch 
report design item's analysis tables and charts only when there are 
respondents in your study's data set who said they are male.

COUNT (children >= 1) > 
0

This expression has Survey Crafter Professional include the batch 
report design item's analysis tables and charts only when there are 
respondents in your study's data set who said they have one or 
more children.

COUNT ($FILTER) > 0 This expression has Survey Crafter Professional include a batch 
report design item’s analysis table or chart when there are one or 
more respondents in your study’s data set who pass through the 
table or chart’s filter.

Table 7 - 33: Examples of expressions for batch report filters. (Continued)

Expression Description
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COUNT (($FILTER) AND 
children >= 1) > 0

This expression has Survey Crafter Professional include a batch 
report design item’s analysis table or chart when there are one or 
more respondents in your study’s data set who both pass through 
the table or chart’s filter and said they have one or more children.

Table 7 - 34: Examples of expressions for batch report conditions. (Continued)

Expression Description



8 Batch Reports

A batch report is a series of analysis tables and charts that you print or 
export together as one report. You can very quickly design a batch report 
that includes analysis tables and charts for every question in your survey.

This chapter explains how to create and use batch reports. Read the 
section “Batch Report Basics” first to learn how to work with batch 
reports in Survey Crafter Professional.

Chapter Contents

• Batch Report Basics  8 - 2

• Creating and Opening Batch Reports  8 - 15

• Designing Batch Reports  8 - 24

• Printing and Exporting Batch Reports  8 - 61

• Deleting Batch Reports  8 - 71
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Batch Report Basics

The following sections introduce features and concepts that will help you 
as you design batch reports in Survey Crafter Professional.

• About Batch Reports

• The Batch Report Designer Window

About Batch Reports

A batch report allows you to print and export in one report groups of 
Survey Crafter Professional tables and charts that analyze the responses to 
your survey. In addition to including temporary tables that Survey Crafter 
Professional automatically builds when the report is printed or exported, a 
batch report can also include tables and charts that are already in your 
study.

Note For information about building and adding analysis tables and 
charts in your study, see “Analyses: Tables” on page 4 - 1 and 
“Analyses: Charts” on page 5 - 1.
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What is a Batch Report?
A batch report is a specification for printing and exporting Survey Crafter 
Professional analysis tables and charts.

Figure 8 - 1: A batch report in a Batch Report Designer window.

A batch report consists of a list of design items, each of which specifies a 
group of tables and charts to print and export. Batch reports are stored in 
your study and listed in the Analyses tab of the Study window.

List of 
design 
items.

Use these 
buttons to 
manage the 
list of 
design 
items.

Number of 
tables/
charts 
specified by 
each design 
item.

Type of 
each design 
item.

Description 
of each 
design item.
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What is a Batch Report Design Item?
A batch report design item is a component of a batch report. Each 
batch report design item specifies a group of Survey Crafter 
Professional analysis tables and charts to print and export.

Figure 8 - 2: The Type tab of the Batch Report Design Item dialog box.

There are five types of batch report design items:

1)Basic Analysis - Survey

Basic Analysis - Survey design items are useful for quickly analyzing 
the responses to all of the questions in your survey.

A Basic Analysis - Survey item can have Survey Crafter Professional 
automatically build, print and export temporary tables that analyze all 
of the questions in one or more selected surveys from your study. You 

Choose the type of 
design item you want to 
add to the batch report.
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choose which surveys as well as which types of questions you want to 
analyze.

Figure 8 - 3: Configuring a Basic Analysis - Survey batch report design item.

You can configure a Basic Analysis - Survey design item to include 
count and percentage calculations for all-that-apply, closed-end and 
open-end questions and count, percentage, mean, mean confidence 
interval, median, mode, minimum, maximum, standard deviation, 
variance and valid number calculations for constant sum, quantity, 
ranking and rating questions.

2)Basic Analysis - Question Block

A Basic Analysis - Question Block design item has Survey Crafter 
Professional automatically build, print and export temporary tables that 
analyze the responses to one or more selected question blocks from 

On this tab, choose which 
surveys you want to 
analyze.

On this tab, choose which 
types of questions you 
want to analyze.

Follow the instructions on 
the remaining tabs to 
configure the design item.
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your study’s surveys. You choose which question blocks you want to 
analyze.

Figure 8 - 4: Configuring a Basic Analysis - Question Block batch report design item.

You can configure a Basic Analysis - Question Block design item to 
include count and percentage calculations for all-that-apply, closed-end 
and open-end questions and count, percentage, mean, mean confidence 
interval, median, mode, minimum, maximum, standard deviation, 
variance and valid number calculations for constant sum, quantity, 
ranking and rating questions.

Follow the instructions on 
the remaining tabs to 
configure the design item.

On this tab, choose which 
question blocks you want 
to analyze.
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3)Basic Analysis - Variable

A Basic Analysis - Variable design item has Survey Crafter Professional 
automatically build, print and export temporary tables that analyze the 
values in one or more selected variables from your study. You choose 
which variables you want to analyze.

Figure 8 - 5: Configuring a Basic Analysis - Variable batch report design item.

You can configure a Basic Analysis - Variable design item to include 
count and percentage calculations for category and literal variables and 
count, percentage, mean, mean confidence interval, median, mode, 
minimum, maximum, standard deviation, variance and valid number 
calculations for quantity variables.

Follow the instructions on 
the remaining tabs to 
configure the design item.

On this tab, choose which 
variables you want to 
analyze.
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4)Analysis Table/Chart

An Analysis Table/Chart design item allows you to have Survey Crafter 
Professional print and export analysis tables and charts that are already 
in your study. 

Figure 8 - 6: Configuring an Analysis Table/Chart batch report design item.

If you want, you can add a batch report filter to the item to have Survey 
Crafter Professional apply a series of table filters to the analysis tables 
and charts and automatically print and export the different results. 

Note For information about building and adding analysis tables and 
charts in your study, see “Analyses: Tables” on page 4 - 1 and 
“Analyses: Charts” on page 5 - 1.

Note For more information on batch report filters, see “What is a Batch 
Report Filter?” on page 8 - 10.

Follow the instructions on 
the remaining tabs to 
configure the design item.

On this tab, choose which 
analysis tables and charts 
you want to include.
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5)Custom Script

A Custom Script design item allows you to use an automation 
procedures file to build, print and export analysis tables and charts.

Figure 8 - 7: Configuring a Custom Script batch report design item.

Automation procedure files are provided by Survey Crafter technical 
support. 

If Survey Crafter 
technical support has 
provided you with an 
automation procedures 
script file, click on this 
button to load the file 
into the design item.
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What is a Batch Report Filter?
Batch report filters are useful for limiting a batch report's calculations to a 
subset of the respondent records in your study's data set. They are also 
useful for automatically repeating a batch report's calculations, each time 
limiting the calculations to a different subset of the respondent records.

Figure 8 - 8: The Filters tab of the Batch Report Design Item dialog box.

There are three types of batch report filters:

Click on the Add button 
to add a batch report 
filter to the design item.
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1)Simple Condition Expression

Simple Condition Expression filters contain one expression that evaluates 
to either TRUE or FALSE for each respondent in your study's data set.

Figure 8 - 9: Configuring a Simple Condition Expression batch report filter.

Let's say you create a batch report filter of this type, enter an expression 
and add the filter to a batch report design item. When it prints or exports 
the item's analysis tables and charts, Survey Crafter Professional uses 
the filter's expression to limit the calculations to a subset of the 
respondent records in your study's data set.

Choose Simple Condition 
Expression for a filter that 
uses one expression.

Enter an expression that 
evaluates to either TRUE 
or FALSE for each 
respondent in your study’s 
data set.

If you want, enter text to  
add to the end of the title of 
the table or chart the filter 
is being applied to.

Enter a name and 
description for the filter.



8 - 12 Batch Reports
Batch Report Basics  
2)Repeat Condition Expressions

Repeat Condition Expressions filters contain one or more expressions that 
each evaluate to either TRUE or FALSE for each respondent in your 
study's data set.

Figure 8 - 10: Configuring a Repeat Condition Expressions batch report filter.

Let's say you create a batch report filter of this type, enter a few 
expressions and add the filter to a batch report design item. When it 
prints or exports the item's analysis tables and charts, Survey Crafter 
Professional automatically repeats the calculations using each of the 
filter's expressions to limit the calculations to a different subset of the 
respondent records in your study's data set.

Choose Repeat Condition 
Expressions for a filter that 
uses one or more 
expressions.

Click on the Add button to 
add a new expression to 
the list.

Enter a name and 
description for the filter.
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3)Repeat Variable Values

Repeat Variable Values filters contain a list of one or more variables that 
are used to build expressions that each evaluate to either TRUE or FALSE 
for each respondent in your study's data set.

Figure 8 - 11: Configuring a Repeat Variable Values batch report filter.

Let's say you create a batch report filter of this type, choose one 
variable and add the filter to a batch report design item. When it prints 
or exports the item's analysis tables and charts, Survey Crafter 
Professional builds an expression for each of the variable's unique 
values and repeats the calculations using each of the expressions to 
limit the calculations to a different subset of the respondent records in 
your study's data set.

Choose Repeat Variable 
Values for a filter that uses 
one or more variables.

Click on the Add button to 
add a variable to the list.

Enter a name and 
description for the filter.
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The Batch Report Designer Window

Use the Batch Report Designer window to design, print and export a 
batch report.

Figure 8 - 12: A batch report in a Batch Report Designer window.

A batch report consists of a list of design items, each of which specifies a 
group of Survey Crafter Professional analysis tables and charts to print 
and export. The Batch Report Designer window displays the list, allowing 
you to make changes to as well as print and export the report.

Click on the 
Print button 
on the 
toolbar to 
print and/or 
export the 
batch 
report.

The list of 
batch report 
design 
items.

Click on the 
Add button 
to add 
another 
batch report 
design item 
to the list.
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Creating and Opening Batch Reports

There are two different ways of creating a batch report in Survey Crafter 
Professional.

This section provides step-by-step instructions for creating a batch report 
as well as for opening an existing batch report.

• Using the New Analysis Dialog Box to Create a Batch Report

• Creating a New Batch Report By Copying

• Opening a Batch Report

Using the New Analysis Dialog Box to Create a 
Batch Report

Follow the steps below to create a new batch report.

• To create a new batch report

1 Select the Analyses tab of the Study window.

Figure 8 - 13: The Analyses tab of the Study window.

2 Click on the New button on the tab.

Click on the New button 
to create a new batch 
report.
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Survey Crafter Professional displays step 1 of the New Analysis 
dialog box.

Figure 8 - 14: Step 1 of the New Analysis dialog box.

3 Select Design a Batch Report.

4 Click on the Next button.

Select this option to 
design a new batch 
report.
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Survey Crafter Professional displays step 2 of the New Analysis 
dialog box.

Figure 8 - 15: Step 2 of the New Analysis dialog box.

5 Enter a name and description for the batch report.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

6 Click on the Finish button.

Enter a name and 
description for the 
batch report.
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Survey Crafter Professional displays the Batch Report Design Item 
dialog box.

Figure 8 - 16: The Batch Report Design Item dialog box.

7 Follow the instructions on the screen to configure a new batch report 
design item for the batch report.

For help on any of the options, click on the Help button on the dialog 
box.

8 Click on the Finish button.

Choose the type of 
design item you want to 
add to the batch report.
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Survey Crafter Professional adds the design item to the new batch 
report in the Batch Report Designer window.

Figure 8 - 17: The Batch Report Designer window.

If you want, you can add more design items to the batch report.

Creating a New Batch Report By Copying

You can create a new batch report by copying an existing one.

Follow the steps below to copy an existing batch report.

Note For information about designing your batch report, see “Designing 
Batch Reports” on page 8 - 24. For information about printing and 
exporting your batch report, see “Printing and Exporting Batch Reports” 
on page 8 - 61.
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• To copy an existing batch report

1 Select the Analyses tab of the Study window.

Figure 8 - 18: The Analyses tab of the Study window.

2 Select the batch report you want to copy.

3 Click on the Copy button on the tab.

Survey Crafter Professional displays the Batch Report Information 
dialog box.

Figure 8 - 19: The Batch Report Information dialog box.

4 Enter a new name for the batch report.

Click on the Copy button to 
copy the highlighted batch 
report.

Enter a new name for 
the batch report.
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The name must not have already been given to any other batch report, 
analysis table or chart.

The name must begin with a letter and may contain up to 49 
additional letter, digit, or underscore characters.

5 Enter a new description for the batch report.

Both the name and description will appear in the list of analyses in the 
Analyses tab of the Study window.

6 Click on the OK button.

Survey Crafter Professional displays the new copy of the batch report 
in a Batch Report Designer window.

Figure 8 - 20: The Batch Report Designer window.
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If you want, you can make changes to the batch report.

Opening a Batch Report

Follow the steps below to open an existing batch report.

• To open an existing batch report

1 Select the Analyses tab of the Study window.

Figure 8 - 21: The Analyses tab of the Study window.

2 Select the batch report you want to open.

3 Click on the Edit button on the tab.

Alternatively, you can double-click on the batch report you want to 
open.

Note For information about designing your batch report, see “Designing 
Batch Reports” on page 8 - 24. For information about printing and 
exporting your batch report, see “Printing and Exporting Batch Reports” 
on page 8 - 61.

Click on the Edit button to 
open the highlighted batch 
report.
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Survey Crafter Professional displays the batch report in a new Batch 
Report Designer window.

Figure 8 - 22: The Batch Report Designer window.
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Designing Batch Reports

Designing a batch report consists of adding, modifying, moving and 
deleting batch report design items.

This section provides step-by-step instructions for doing the following.

• Adding Items to a Batch Report

• Modifying Items in a Batch Report

• Deleting Items From a Batch Report

• Copying and Pasting Items in a Batch Report

• Moving Items in a Batch Report

• Including and Excluding Items in a Batch Report

• Adding Filters to Items in a Batch Report

• Dragging and Dropping Items in a Batch Report

Adding Items to a Batch Report

Follow the steps below to add a batch report design item to a batch report.

• To add an item to a batch report

1 Open an existing batch report or create a new one.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22. To create a new batch report, see “Using the New Analysis 
Dialog Box to Create a Batch Report” on page 8 - 15 or “Creating a New 
Batch Report By Copying” on page 8 - 19.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 23: The Batch Report Designer window.

2 In the Batch Report Designer window, click on the Add button at the 
bottom left corner of the window.

Tip Alternatively, click on the Design menu and then on Add New Item 
or click on the Add New Item button on the toolbar. When there are one 
or more items in the batch report, you can also right-click on an item and 
choose Add New Item from the pop-up menu.

Click on the 
Add button 
to add 
another 
batch report 
design item 
to the list.
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Survey Crafter Professional displays the Batch Report Design Item 
dialog box.

Figure 8 - 24: The Type tab of the Batch Report Design Item dialog box.

3 Use the Batch Report Design Item dialog box to configure the new 
item.

For help on any of the options, click on the Help button on the dialog 
box.

4 Click on the Finish button on the dialog box.

Choose the type of 
batch report design 
item you want.
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Survey Crafter Professional adds the new item to the batch report in 
the Batch Report Designer window.

Figure 8 - 25: The Batch Report Designer window.

Modifying Items in a Batch Report

Follow the steps below to modify a batch report design item in a batch 
report.

• To modify an item in a batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 26: The Batch Report Designer window.

2 In the Batch Report Designer window, click to select the item you 
want to modify.

3 Click on the Edit button at the bottom of the window.

Tip Alternatively, double-click on the item, click on the Design menu 
and then on Edit Item, click on the Edit Item button on the toolbar or 
right-click on the item and choose Edit Item from the pop-up menu.

Click on the 
Edit button 
to modify 
the 
highlighted 
item.
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Survey Crafter Professional displays the Batch Report Design Item 
dialog box.

Figure 8 - 27: The Type tab of the Batch Report Design Item dialog box.

4 Use the Batch Report Design Item dialog box to modify the item.

For help on any of the options, click on the Help button on the dialog 
box.

5 Click on the Finish button on the dialog box.

Use the dialog box to 
modify the item.
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Survey Crafter Professional redisplays the item in the Batch Report 
Designer window.

Figure 8 - 28: The Batch Report Designer window.

Deleting Items From a Batch Report

You can delete any number of batch report design items at any time.

Follow the steps below to delete one or more batch report design items 
from a batch report.

• To delete one or more items from a batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 29: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items you want to 
delete.

3 Click on the Delete button at the bottom of the window.

4 Click on the Yes button.

Tip Alternatively, press the [DEL] key, click on the Edit menu and then 
on Delete, click on the Delete Item(s) button on the toolbar or right-click 
on the items and choose Delete Item(s) from the pop-up menu.

Click on the 
Delete 
button to 
delete the 
highlighted 
items.
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Survey Crafter Professional deletes the highlighted items from the 
batch report in the Batch Report Designer window.

Figure 8 - 30: The Batch Report Designer window.

Copying and Pasting Items in a Batch Report

You can copy and paste batch report design items within a batch report or 
from one batch report into another.

Follow the steps below to copy and paste batch report design items.

• To copy and paste items within a batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 31: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items you want to 
copy.

3 Click on the Edit menu and then on Copy.

Survey Crafter Professional copies the highlighted items to the 
clipboard.

4 In the Batch Report Designer window, click on the item after which 
you want to add the copies.

Tip Alternatively, press [CTRL-C] or right-click on the items and 
choose Copy Item(s) from the pop-up menu.

Highlight 
the items 
you want to 
copy.
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5 Click on the Edit menu and then on Paste.

Survey Crafter Professional adds the items from the clipboard to the 
batch report in the Batch Report Designer window.

Figure 8 - 32: The Batch Report Designer window.

• To copy and paste items from one batch report into another

1 Open the batch report from which you want to copy items.

Tip Alternatively, press [CTRL-V] or right-click on the item and choose 
Paste Item(s) from the pop-up menu.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 33: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items you want to 
copy.

3 Click on the Edit menu and then on Copy.

Survey Crafter Professional copies the highlighted items to the 
clipboard.

Tip Alternatively, press [CTRL-C] or right-click on the items and 
choose Copy Item(s) from the pop-up menu.

Highlight 
the items 
you want to 
copy.
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4 Open the batch report to which you want to add the items from the 
clipboard.

5 In the Batch Report Designer window, click on the item after which 
you want to add the copies.

6 Click on the Edit menu and then on Paste.

Survey Crafter Professional adds the items from the clipboard to the 
batch report in the Batch Report Designer window.

Figure 8 - 34: The Batch Report Designer window.

Tip If you cannot see the Study window, click on the Window menu and 
then on Study - <name of study file>. Then click on the Analyses tab and 
open an existing batch report or create a new one.

Tip Alternatively, press [CTRL-V] or right-click on the item and choose 
Paste Item(s) from the pop-up menu.
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Moving Items in a Batch Report

Survey Crafter Professional prints and exports batch report design items 
in the order the items are listed in the Batch Report Designer window.

Follow the steps below to move items within a batch report or from one 
batch report into another.

• To move items within a batch report (method 1)

1 Open the batch report you want to modify.

Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 35: The Batch Report Designer window.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

Highlight 
the items 
you want to 
move.

Use these 
buttons to 
move the 
highlighted 
items up, 
down, to the 
top or to the 
bottom of 
the list.
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2 In the Batch Report Designer window, highlight the items you want to 
move.

3 Click on the Up, Down, Top or Bottom buttons at the bottom of the 
window.

Survey Crafter Professional moves the highlighted items.

Figure 8 - 36: The Batch Report Designer window.

• To move items within a batch report (method 2)

1 Open the batch report you want to modify.

Tip Alternatively, right-click on the highlighted items and choose Move 
Item(s) Up, Move Item(s) Down, Move Item(s) to Top, or Move Item(s) 
to Bottom from the pop-up menu.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 37: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items you want to 
move.

3 Click on the Edit menu and then on Cut.

Survey Crafter Professional copies the highlighted items to the 
clipboard and then deletes the items.

4 In the Batch Report Designer window, click on the item after which 
you want to add the copies.

Tip Alternatively, press [CTRL-X] or right-click on the items and 
choose Cut Item(s) from the pop-up menu.

Highlight 
the items 
you want to 
move.
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5 Click on the Edit menu and then on Paste.

Survey Crafter Professional adds the items from the clipboard to the 
batch report in the Batch Report Designer window.

Figure 8 - 38: The Batch Report Designer window.

• To move items from one batch report into another

1 Open the batch report that has the items you want to move.

Tip Alternatively, press [CTRL-V] or right-click on the item and choose 
Paste Item(s) from the pop-up menu.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 39: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items you want to 
move.

3 Click on the Edit menu and then on Cut.

Survey Crafter Professional copies the highlighted items to the 
clipboard and then deletes the items.

Tip Alternatively, press [CTRL-X] or right-click on the items and 
choose Cut Item(s) from the pop-up menu.

Highlight 
the items 
you want to 
move.
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4 Open the batch report to which you want to add the items from the 
clipboard.

5 In the Batch Report Designer window, click on the item after which 
you want to add the items.

6 Click on the Edit menu and then on Paste.

Survey Crafter Professional adds the items from the clipboard to the 
batch report in the Batch Report Designer window.

Figure 8 - 40: The Batch Report Designer window.

Tip If you cannot see the Study window, click on the Window menu and 
then on Study - <name of study file>. Then click on the Analyses tab and 
open an existing batch report or create a new one.

Tip Alternatively, press [CTRL-V] or right-click on the item and choose 
Paste Item(s) from the pop-up menu.
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Including and Excluding Items in a Batch Report

Survey Crafter Professional prints and exports only those batch report 
design items that are marked included.

Follow the steps below to include and exclude items in a batch report.

• To include or exclude items in a batch report

1 Open the batch report you want to modify.

Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 41: The Batch Report Designer window.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

Highlight 
the items 
you want to 
include or 
exclude.

You can 
also use 
these 
buttons to 
include or 
exclude the 
highlighted 
items.

You can 
click on the 
check 
boxes in the 
Include 
column to 
include or 
exclude an 
item.
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2 In the Batch Report Designer window, highlight the items you want to 
include or exclude.

3 Click on the Include or Exclude button at the bottom of the window.

Survey Crafter Professional includes or excludes the highlighted 
items.

Figure 8 - 42: The Batch Report Designer window.

Tip Alternatively, right-click on the highlighted items and choose 
Include Item(s) or Exclude Item(s) from the pop-up menu.

You can also click on a check box in the Include column to include or 
exclude an item.
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Adding Filters to Items in a Batch Report

Follow the steps below to add one or more batch report filters to one or 
more batch report design items in a batch report.

• To add one or more batch report filters to one item in a batch report

1 Open the batch report you want to modify.

Tip If you would like to add one or more batch report filters to all of a 
batch report's items, consider adding the filters when you print and/or 
export the report. For step-by-step instructions on adding filters when 
you print and/or export a batch report, see “To add one or more batch 
report filters when printing and/or exporting the batch report” on page 
8 - 51.

For more information about printing and exporting batch reports, see 
“Printing and Exporting Batch Reports” on page 8 - 61

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.



8 - 46 Batch Reports
Designing Batch Reports  
Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 43: The Batch Report Designer window.

2 In the Batch Report Designer window, double-click on the item to 
which you want to add batch report filters.

Tip Alternatively, click on the item and then click on the Edit button at 
the bottom of the window, click on the item and then click on the Edit 
Item button on the toolbar or right-click on the item and choose Edit 
Item from the pop-up menu.

Double-
click on the 
item to 
which you 
want to add 
batch report 
filters.

You can 
also click on 
the Edit 
Item button 
on the 
toolbar.
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Survey Crafter Professional displays the Batch Report Design Item 
dialog box.

Figure 8 - 44: The Type tab of the Batch Report Design Item dialog box.

3 Click on the Filters tab of the Batch Report Design Item dialog box.

Survey Crafter Professional displays the Filters tab of the Batch 
Report Design Item dialog box.

Figure 8 - 45: The Filters tab of the Batch Report Design Item dialog box.

Click on the Filters tab.

List of batch report 
filters to apply to the 
calculations.

Click on the Add button 
to add one or more 
batch report filters to 
the list.
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4 Click on the Add button at the bottom left corner of the tab.

Survey Crafter Professional displays the Batch Report Filter Library 
dialog box.

Figure 8 - 46: The Batch Report Filter Library dialog box.

The only filters listed in the dialog box are those not already 
associated with the item.

5 Highlight the batch report filters you want to add to the item and click 
on the Select button.

Highlight the batch 
report filters you want 
to add to the design 
item.

Click on the New or 
Copy button to add a 
new batch report filter 
to the library.
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Survey Crafter Professional adds the filters to the item.

Figure 8 - 47: The Filters tab of the Batch Report Design Item dialog box.

6 Click on the Finish button.

• To add one or more batch report filters to more than one item in a 
batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

List of batch report 
filters to apply to the 
calculations.

Use these buttons to 
manage the list of 
filters.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 48: The Batch Report Designer window.

2 In the Batch Report Designer window, highlight the items to which 
you want to add batch report filters.

3 Right-click on the highlighted items and choose Add Filters to 
Item(s) from the pop-up menu.

Tip Alternatively, click on the Add Filters to Item(s) button on the 
toolbar.

Highlight 
the items to 
which you 
want to add 
batch report 
filters.

The Add 
Filters to 
Items 
button on 
the toolbar.
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Survey Crafter Professional displays the Batch Report Filter Library 
dialog box.

Figure 8 - 49: The Batch Report Filter Library dialog box.

The only filters listed in the dialog box are those not already 
associated with any of the highlighted items in the Batch Report 
Designer window.

4 Highlight the batch report filters you want to add to the items and 
click on the Select button.

Survey Crafter Professional adds the filters to the highlighted items in 
the Batch Report Designer window.

• To add one or more batch report filters when printing and/or 
exporting the batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

Highlight the batch 
report filters you want 
to add to the design 
items.

Click on the New or 
Copy button to add a 
new batch report filter 
to the library.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 50: The Batch Report Designer window.

2 In the Batch Report Designer window, click on the Print/Export 
button at the bottom of the window.

Tip Alternatively, click on the File menu and then on Print/Export, click 
on the Print button on the toolbar, or right-click on any item in the 
window and choose Print/Export from the pop-up menu.

Click on the 
Print button 
on the 
toolbar or 
the Print/
Export 
button at 
the bottom 
of the 
window to 
print and 
export the 
batch 
report.
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Survey Crafter Professional displays the Batch Report Print/Export 
dialog box.

Figure 8 - 51: The Print/Export tab of the Batch Report Print/Export dialog box.

3 Use the Batch Report Print/Export dialog box to configure the batch 
report for printing and/or exporting.

For help on any of the options, click on the Help button on the dialog 
box.

4 Click on the Filters tab of the dialog box.

Configure the batch 
report for printing and/
or exporting.
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Survey Crafter Professional displays the Filters tab of the Batch 
Report Print/Export dialog box.

Figure 8 - 52: The Filters tab of the Batch Report Print/Export dialog box.

5 Click on the Add button at the bottom left corner of the tab.

Survey Crafter Professional displays the Batch Report Filter Library 
dialog box.

Figure 8 - 53: The Batch Report Filter Library dialog box.

List of batch report 
filters to apply to all of 
the calculations.

Click on the Add button 
to add one or more 
batch report filters to 
the list.

Highlight the batch 
report filters you want 
to add to the batch 
report.

Click on the New or 
Copy button to add a 
new batch report filter 
to the library.
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6 Highlight the batch report filters you want to add to the batch report 
and click on the Select button.

Survey Crafter Professional adds the filters to the batch report.

Figure 8 - 54: The Filters tab of the Batch Report Print/Export dialog box.

7 When you are ready to print and/or export the batch report, click on 
the Finish button.

Survey Crafter Professional prints and/or exports the batch report.

Dragging and Dropping Items in a Batch Report

You can drag and drop batch report design items within a batch report or 
from one batch report into another.

Follow the steps below to drag and drop a batch report design item.

• To drag and drop an item within a batch report

1 Open the batch report you want to modify.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

List of batch report 
filters to apply to the 
calculations.

Use these buttons to 
manage the list of 
filters.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 55: The Batch Report Designer window.

2 In the Batch Report Designer window, move the mouse pointer over 
the item you want to move or copy.

3 Press and hold the [ALT] key down and then press and hold the left 
mouse button down.

4 While holding the left mouse button down, move the mouse pointer 
over the batch report design item after which you want to move or 
copy the original item.

5 Release the [ALT] key.

6 If you want to copy the item, while holding the left mouse button 
down, press and hold the [CTRL] key down.

7 Release the left mouse button.

Press and 
hold the 
[ALT] key 
down and 
then press 
and hold 
the left 
mouse 
button 
down.
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If you are holding the [CTRL] key down, Survey Crafter Professional 
adds a copy of the original item after the item the mouse pointer is 
over. Otherwise, Survey Crafter Professional moves the original item 
after the item the mouse pointer is over.

Figure 8 - 56: The Batch Report Designer window.

8 If you are holding it down, release the [CTRL] key.

• To drag and drop an item from one batch report into another

1 Open a first batch report.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.

The design 
item was 
moved to 
the end of 
the list.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 57: The Batch Report Designer window.

2 If the Batch Report Designer window is maximized, click on the 
middle button below the top right corner of Survey Crafter 
Professional’s main window.

3 Open a second batch report.

If the Batch 
Report 
Designer 
window is 
maximized, 
click on the 
middle 
button 
below the 
top right 
corner of 
the main 
window.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 58: Two Batch Report Designer windows.

4 Resize and arrange the two Batch Report Designer windows so you 
can see parts of both windows at the same time.

5 In the Batch Report Designer window for the first batch report, move 
the mouse pointer over the item you want to copy.

6 Press and hold the [ALT] key and then press and hold the left mouse 
button down.

Note You cannot move a batch report design item from one batch report 
to another by dragging and dropping. To move a design item from one 
batch report to another, use the cut and paste feature. For step-by-step 
instructions, see “Moving Items in a Batch Report” on page 8 - 37.

Resize and 
arrange the 
two Batch 
Report 
Designer 
windows so 
you can see 
parts of 
both 
windows at 
the same 
time.
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7 While holding the left mouse button down, move the mouse pointer 
over the list inside the second Batch Report Designer window.

8 Release the [ALT] key.

9 Release the left mouse button.

Survey Crafter Professional adds a copy of the item to the second 
batch report.

Figure 8 - 59: Two Batch Report Designer windows.

The design 
item was 
copied to 
the second 
batch 
report.
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Printing and Exporting Batch Reports

Once you have added at least one design item to your batch report, you 
can print and/or export the report.

This section provides step-by-step instructions for doing the following.

• Printing a Batch Report

• Exporting a Batch Report to MS Excel Workbook Files

• Exporting a Batch Report to HTML Files

Printing a Batch Report

Follow the steps below to print a batch report.

• To print a batch report

1 Open the batch report you want to print.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.



8 - 62 Batch Reports
Printing and Exporting Batch Reports  
Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 60: The Batch Report Designer window.

2 In the Batch Report Designer window, click on the Print/Export 
button on the bottom of the window.

Tip Alternatively, click on the Print button on the toolbar, click on the 
File menu and then on Print/Export, or right-click on a batch report 
design item and choose Print/Export from the pop-up menu.

Click on the 
Print button 
on the 
toolbar or 
the Print/
Export 
button at 
the bottom 
of the 
window to 
print the 
batch 
report.
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Survey Crafter Professional displays the Batch Report Print/Export 
dialog box.

Figure 8 - 61: The Print/Export tab of the Batch Report Print/Export dialog box.

3 In the Print/Export tab of the dialog box, select the Print the tables 
and charts check box.

4 To print the report's table of contents, select The table of contents. To 
print the report's analysis tables and charts, select The analysis tables 
and charts.

5 Enter a title for the report.

The title will appear at the top of the printed page, worksheet and 
HTML page.

6 Use the other tabs to configure the batch report for printing.

Tip You can print and export your batch report at the same time.

Tip If you do not want Survey Crafter Professional to print all of the 
analysis tables and charts specified by the report, select Tables/Charts. 
Then enter the numbers of the analysis tables and charts you want the 
program to print. For example, to have Survey Crafter Professional print 
analyses 1, 2 and 5 through 8, enter 1,2,5-8.

Select the Print the 
tables and charts check 
box.

Select the The table of 
contents and/or The 
analysis tables and 
charts check boxes.

Enter a title for the 
report.
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Click on the Help button at the bottom of the dialog box for 
information about the current tab.

7 When you are ready to print the batch report, click on the Finish 
button.

Survey Crafter Professional prints the batch report.

Exporting a Batch Report to MS Excel Workbook 
Files

Follow the steps below to export a batch report to MS Excel workbook 
files.

• To export a batch report to MS Excel workbook files

1 Open the batch report you want to export.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 62: The Batch Report Designer window.

2 In the Batch Report Designer window, click on the Print/Export 
button on the bottom of the window.

Tip Alternatively, click on the Print button on the toolbar, click on the 
File menu and then on Print/Export, or right-click on a batch report 
design item and choose Print/Export from the pop-up menu.

Click on the 
Print button 
on the 
toolbar or 
the Print/
Export 
button at 
the bottom 
of the 
window to 
export the 
batch 
report.
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Survey Crafter Professional displays the Batch Report Print/Export 
dialog box.

Figure 8 - 63: The Print/Export tab of the Batch Report Print/Export dialog box.

3 In the Print/Export tab of the dialog box, select the Export the tables 
to MS Excel 97 workbook files and the charts to JPEG picture files 
check box.

If you want, select the Export the Basic Analysis and Custom Script 
tables to one MS Excel 97 worksheet check box.

4 To export the report's table of contents, select The table of contents. 
To export the report's analysis tables and charts, select The analysis 
tables and charts.

5 Enter a title for the report.

Tip You can print and export your batch report at the same time.

Tip If you do not want Survey Crafter Professional to export all of the 
analysis tables and charts specified by the report, select Tables/Charts. 
Then enter the numbers of the analysis tables and charts you want the 
program to export. For example, to have Survey Crafter Professional 
export analyses 1, 2 and 5 through 8, enter 1,2,5-8.

Select the Export the 
tables to MS Excel 97 
workbook files and the 
charts to JPEG picture 
files check box.

Select the The table of 
contents and/or The 
analysis tables and 
charts check boxes.

Enter a title for the 
report.
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The title will appear at the top of the printed page, worksheet and 
HTML page.

6 Use the on other tabs to configure the batch report for exporting.

Click on the Help button at the bottom of the dialog box for 
information about the current tab.

7 When you are ready to export the batch report, click on the Finish 
button.

Survey Crafter Professional exports the batch report.

Exporting a Batch Report to HTML Files

Follow the steps below to export a batch report to HTML files.

• To export a batch report to HTML files

1 Open the batch report you want to export.

Note To open an existing batch report, see “Opening a Batch Report” on 
page 8 - 22.
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Survey Crafter Professional displays the batch report in the Batch 
Report Designer window.

Figure 8 - 64: The Batch Report Designer window.

2 In the Batch Report Designer window, click on the Print/Export 
button on the bottom of the window.

Tip Alternatively, click on the Print button on the toolbar, click on the 
File menu and then on Print/Export, or right-click on a batch report 
design item and choose Print/Export from the pop-up menu.

Click on the 
Print button 
on the 
toolbar or 
the Print/
Export 
button at 
the bottom 
of the 
window to 
export the 
batch 
report.
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Printing and Exporting Batch Reports
Survey Crafter Professional displays the Batch Report Print/Export 
dialog box.

Figure 8 - 65: The Print/Export tab of the Batch Report Print/Export dialog box.

3 In the Print/Export tab of the dialog box, select the Export the tables 
and charts to HTML files check box.

4 To export the report's table of contents, select The table of contents. 
To export the report's analysis tables and charts, select The analysis 
tables and charts.

5 Enter a title for the report.

The title will appear at the top of the printed page, worksheet and 
HTML page.

6 Use the other tabs to configure the batch report for exporting.

Tip You can print and export your batch report at the same time.

Tip If you do not want Survey Crafter Professional to export all of the 
analysis tables and charts specified by the report, select Tables/Charts. 
Then enter the numbers of the analysis tables and charts you want the 
program to export. For example, to have Survey Crafter Professional 
export analyses 1, 2 and 5 through 8, enter 1,2,5-8.

Select the Export the 
tables and charts to 
HTML files check box.

Select the The table of 
contents and/or The 
analysis tables and 
charts check boxes.

Enter a title for the 
report.
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Click on the Help button at the bottom of the dialog box for 
information about the current tab.

7 When you are ready to export the batch report, click on the Finish 
button.

Survey Crafter Professional exports the batch report.
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Deleting Batch Reports

Follow the steps below to delete a batch report.

• To delete a batch report

1 In the Analyses tab of the Study window, click on the batch report 
you want to delete.

Figure 8 - 66: The Analyses tab of the Study window.

2 Press the [DEL] key.

Survey Crafter Professional asks if you are sure you want to delete 
the batch report.

Figure 8 - 67: Are you sure you want to delete the batch report?

Note Alternatively, click on the Edit menu and then on Delete.

To delete a batch report, 
click on the report and 
then press the [DEL] key.
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3 Click on the Yes button.

Survey Crafter Professional removes the batch report from your 
study.



A Appendix
About Import Files and Data 
Dictionary Files

If you administer your survey on the Web or contract a market research 
supplier to interview respondents for you, you will download a file or the 
supplier will return a file containing responses to the survey. You need to 
import the data in this file into the Survey Crafter Professional study. In 
some cases, two files are required for importing data:  the import file (the 
data file containing the survey responses) and the data dictionary file (a 
file that Survey Crafter Professional uses to interpret the import file).

This appendix provides an overview of import files and data dictionary 
files and explains how they work together during the data import process 
outlined in the section “Importing Data Sets” on page 3 - 21. This 
appendix also explains how to create import files and data dictionary 
files.

Note You do not need to create a data dictionary file if you are importing 
data from a file used by a Survey Crafter Professional web survey. Data 
files used by Survey Crafter Professional web surveys are in the default 
CSV (comma separated value) format.
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The Relationship between Import Files and Data 
Dictionary Files

If you administered your survey on the Web or a market research supplier 
interviewed respondents for you (or if you collected the responses 
yourself and compiled them in a file rather than using the Interviewer to 
enter them directly into a study), you need to import the responses into the 
study. The file containing the responses is called the import file.

The import file is a matrix containing rows of responses to survey 
questions. Each respondent’s record accounts for one or more rows in the 
import file. Each record commonly occupies one line in the import file. 

Each record is divided into different values. Each value represents the 
respondent’s reply to a different question in the survey. Each value in a 
record is stored in a different imported variable created in the Survey 
Crafter Professional study. Figure A - 1 illustrates the relationship 
between an import file’s values and a study’s imported variables.

Figure A - 1: The relationship between an import file’s fields and a study’s imported variables.

Import file

. . .0, 2, 24, 8

. . .1, 3, 35, 2

. . .0, 1, 47, 3  This row is one record in 
the import file.

Imported variables in 
a Survey Crafter 
Professional study

. . . 
age
rating
. . . 

47, the respondent’s age, is one value in the 
record. This value matches with the study’s 
imported quantity variable age. The variable 
age stores this value from each record.
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Survey Crafter Professional uses a data dictionary file to understand how 
to read an import file and copy its values to the proper imported variables 
in the study. Unless the import file is in the default CSV (comma 
separated value) format, you cannot import data into Survey Crafter 
Professional without a data dictionary file.

If the data you import is returned by a Survey Crafter Professional web 
survey, you do not need to create the data dictionary file. Survey Crafter 
Professional web surveys use the default CSV (comma separated value) 
format.

If the data you import is returned by a market research supplier, the 
supplier should provide the data dictionary file. If you want, you can add 
a block called Notes to the Market Research Supplier from the 
Instructions group of Survey Crafter Professional’s Question Library to 
your survey. The block explains the data dictionary file’s parameters.

However, if you created the import file yourself or want to import data 
from a source other than a market research supplier and the import file is 
not in the default CSV (comma separated value) format, you need to 
create the data dictionary file. 

Overview of Import Files

Files you import into Survey Crafter Professional must be text (ASCII) 
files. ASCII (American Standard Code for Information Interchange) is an 
internationally accepted code for data files. ASCII files consist of 
numbers, letters, and other symbols. For example, numbers appear as 
characters like 1, 2, and 3 and letters appear as characters like A, 
B, and C.

Note The Survey Crafter Professional default CSV (comma separated 
value) format has a first line that lists variables’ codes, separated by the 
comma character, and one additional row for each respondent 
containing response values separated by the comma character.
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Although ASCII is a standard code, ASCII files have no standard 
structure. For example, ASCII files may have fixed or delimited formats. 
In fixed format files, a variable’s value starts in the same column in every 
record. In delimited files, a variable’s value may start in a different 
column in each record, and each value is separated (delimited) by a 
character such as a comma. Figure A - 2 shows a fixed format import file. 

Figure A - 2: A sample fixed format ASCII file.

Figure A - 3 shows a sample free format ASCII file that is in the default 
CSV (comma separated value) format.

Figure A - 3: A sample free format ASCII file that is in the the default CSV (comma separated value) format.

0 basketball 60 4
1 knitting 50 3
1 skateboarding 24 2
0 computer program 45 5
0 soccer 35 2
1 calligraphy 57 10
0 writing 42 4
1 painting 38 4

Each variable’s value (here, the 
respondent’s age) begins in the same 
column in each record.

The import file 
contains eight 
records with each 
record occupying 
one line in the import 
file.

gender, hobby, age, rating
0,basketball,60,4
1,knitting,50,3
1,skateboarding,24,2
0,computer program,45,5
0,soccer,35,2
1,calligraphy,57,10
0,writing,42,4
1,painting,38,4

Each value (here, the respondent’s 
age) may begin in a different column 
in each record.

The import file 
contains eight 
records with each 
record occupying 
one line in the import 
file. 

This file’s first line, 
which lists variables’ 
codes, is explained 
in the section 
“Creating an Import 
File” below.

Note that commas separate 
each value in a record.
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Because ASCII files have no standard structure, Survey Crafter 
Professional must learn the structure of the import file by reading the data 
dictionary file.

Creating an Import File

When you interview respondents yourself, you will probably want to 
enter their responses directly into the study by using Survey Crafter 
Professional’s Interviewer. For more information on using the 
Interviewer, see the section “Entering Respondents’ Replies” on page 
3 - 11. You can, however, compile the results of the interview in an import 
file.

If you interview respondents on the Web, you do not need to create an 
import file yourself because Survey Crafter Professional automatically 
generates an empty import file in the default CSV (comma separated 
value) format when you publish the survey.

Creating an import file involves creating a record for each respondent. 
Use a text editor like Microsoft Notepad or a spreadsheet program like 
Microsoft Excel to create the import file. 

You can create a fixed format or delimited import file. However, to keep 
the process of creating an import file simple, it is recommended that you 
create a comma delimited file with one record in each row like the one in 
Figure A - 3. 

Keep the following in mind when creating a comma delimited import file:

• If you asked a respondent a question but he or she refused to reply, enter 
the code for NR (No Reply) unless the variable is a literal variable. 
Because literal variables have no code for NR, enter text that indicates 
the respondent would not answer the question. For example, enter Did 
not answer.
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• If the response is simply missing (for example, the respondent was 
never asked the question), enter a period or a space surrounded by 
commas. Survey Crafter Professional converts the period or space to the 
value NV (No Value) when you import the data.

• For category variables, enter the category’s code and not the category’s 
name. For example, enter 1 not ‘Male’.

• If you need to enter a comma in a literal value, surround the response 
with a character (typically double quotes) unless you are using 
Microsoft Excel to create the import file. For example, to enter Smith, 
Nancy as a response, type “Smith, Nancy”. If you are using Excel, do 
not surround the response in quotes because Excel, by default, adds 
quotes around values that contain a comma.

In the corresponding data dictionary file, be sure to indicate the 
character you used to surround these literal values by defining the Text 
Qualifier parameter (see Table A - 3).

• To create a free format comma separated import file

1 Open a text editor or spreadsheet program.

2 In the first line of the import file, type the variable codes (which 
Survey Crafter Professional generates from the variable names you 
enter) across the top of the import file.

Survey Crafter Professional uses these codes to match values in the 
import file with imported variables in the study. For a list of variable 
codes, see the Variables tab of the Study window.

If you are using a text editor, separate each code with a comma as 
Figure A - 4 shows. If you are using a spreadsheet program, enter one 
code in each cell.

If records will occupy more than one row in the import file, enter 
codes for the variables in each row on different lines. For example, if  
age appears as the first variable of the second row in a record, enter it 
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as first variable on the second line of the import file, as shown in 
Figure A - 4.

Figure A - 4: Line(s) showing variable codes for variables in an import file.

3 On the line immediately below the list of variables, type the responses 
from the first person.

If you are using a text editor, separate responses to questions with a 
comma. If you are using a spreadsheet, enter each response in a 
different cell in the same row.

4 After entering all the person’s responses, press [RETURN] to start a 
new record for another respondent or click in the first cell in the next 
row.

5 Enter the responses for the next person.

Figure A - 5 shows examples of partially completed import files. 

Figure A - 5: Partially completed import files with one row per record (left) and two rows per record.

Two rows per record

gender,hobby
age,rating
(actual responses start here
with two rows for each record)

One row per record

gender,hobby,age,rating
(actual responses start here)

Two rows per record

gender,hobby
age,rating
0,basketball
60,4
1,knitting
50,3
1,skateboarding
24,2
0,computer program
45,5
....

One row per record

gender,hobby,age,rating
0,basketball,60,4
1,knitting,50,3
1,skateboarding,24,2
0,computer program,45,5
....
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6 Repeat steps 3 through 5 until you have created a record for each 
respondent.

7 To save the file, do one of the following:

• If you are using a text editor, save the file as text (ASCII).

• If you are using a spreadsheet program, save the file as comma 
delimited.

For example, if you are using Microsoft Excel, select CSV (comma 
separated value) from the Save File as Type drop-down list.

In either case, save the file using a .CSV filename extension. When 
you import data, Survey Crafter Professional displays files with 
.CSV, .TXT and .DAT extensions in the Open Import File dialog 
box.

Overview of Data Dictionary Files

Survey Crafter Professional uses data dictionary files to read values from 
an import file into a study. A data dictionary file may have up to two parts 
to it depending on whether the file is fixed format or delimited. 

The first part, called the Options section, describes general characteristics 
of the import file. The Options section is required for both fixed format 
and delimited import files. 

The second part, called the Variables section, describes the variables in 
the import file and matches them with imported variables in the study. 
The Variables section is required for fixed format files; delimited files, 
however, do not use the Variables section in the data dictionary file 
because the import files themselves contain this matching information in 
their first line(s) as shown in Figure A - 4.

The sections below describe parameters for the file’s two sections and 
compare examples of data dictionary files for fixed and delimited import 
files.
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Options Section

The data dictionary file’s first line must read [Options]. This line is 
then followed by the Options section’s parameters, which may appear in 
any order. The Options section in data dictionary files for fixed and 
delimited import files use different parameters. 

Table A - 1 lists Options section parameters in data dictionary files for 
fixed format import files. 
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Table A - 2 lists Options section parameters in data dictionary files for 
delimited import files.

Regardless of the import file type, you must specify the Format 
parameter. Other parameters are optional, however. If you do not define 
the other parameters, Survey Crafter Professional uses their defaults.

Table A - 1: Options section parameters in data dictionary files for fixed format import files.

Parameter Possible value(s) Required?

Format= fixed

Indicates that the import file is fixed format

Yes.

Cards= 1, 2, 3,...an integer

Indicates the number of rows (sometimes 
called cards) each record occupies

No. 

If you do not define this 
parameter, Survey Crafter 
Professional uses 1 by 
default.

Table A - 2: Options section parameters in data dictionary files for delimited import files.

Parameter Possible values Required?

Format= delimited

Indicates that the import file is delimited

Yes.

Cards= 1, 2, 3,...an integer

Indicates the number of rows (sometimes 
called cards) each record occupies

No. 

If you do not define this 
parameter, Survey Crafter 
Professional uses 1 by 
default.

Delimiter= The character that separates values in the 
import file’s records.

In most cases, you enter the actual character. 
However, if tabs separate characters, enter \t 
as the delimiter or if spaces separate characters 
enter \s.

No.

If you do not define this 
parameter, Survey Crafter 
Professional uses the , 
(comma) by default.

Text 
Qualifier=

The character that should surround values 
containing the delimiter character.

Typically the single quote or double quote 
character surround these values.

No.

If you do not define this 
parameter, Survey Crafter 
Professional uses “ (double 
quote) by default.
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Variables Section

The first line of the Variables section must read [Variables]. The 
required variable information follows this line. 

The Variables section contains one line for each variable in the import 
file. Each line has the format code = offset, length, card 
number. Table A - 3 describes these parameters. The parameters must 
appear in that order.

Note that only data dictionary files for fixed format import files require a 
Variables section; data dictionary files for delimited import files do not. 
(Because a delimited import file contains sufficient information about the 
file’s variables, Survey Crafter Professional does not use a Variables 
section in the file’s data dictionary.) Compare the sample data dictionary 
files in Figure A - 6 and Figure A - 7.

Table A - 3: Variables section parameters for fixed format import files.

Parameter Possible value(s) Required?

code The variable code Survey Crafter Professional 
assigned the variable. 

This code is a maximum of eight characters. You 
can see a variable’s code at the Variables tab of 
the Study window or by displaying the survey and 
then choosing the Survey Options command from 
the View menu and selecting the Show Variable 
Names / Codes check box.

Yes

offset 1, 2, 3,...an integer.

Indicates the column in which the variable’s 
values begin.

Yes

length 1, 2, 3,...an integer.

Indicates the number of columns the variable’s 
values occupy.

Yes

card number 1, 2, 3,...an integer.

Indicates the row of the record containing the 
variable.

Only if the Cards 
parameter in the Options 
section is greater than 1
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An equals sign (=) must appear between the code and offset 
parameters. Commas must separate the offset, length, and card 
number parameters. Any number of white spaces may come before or 
after the equals sign or commas. 

Examples of Data Dictionary Files

Figure A - 6 shows the data dictionary file for the fixed format import file 
in Figure A - 2. Note that in the data dictionary file on the right in Figure 
A - 6, the Cards and card number parameters have been omitted 
because they use the default values.

Figure A - 6: Data dictionary file for the fixed format import file in Table A - 2.

This data dictionary file indicates, for example, that the variable hobby 
starts in column 2 and occupies 16 columns.

Figure A - 7 shows the data dictionary file for the delimited import file in 
Figure A - 3. Because the data dictionary file is for a delimited import 
file, it does not include a Variables section. Note that in the data 
dictionary file on the right in Figure A - 7, the parameters Delimiter, 

All parameters listed

[Options]
Format=fixed
Cards=1

[Variables]
gender=1, 1, 1
hobby=2, 16, 1
age=18, 3, 1
rating=21, 2, 1

Options section

Variables section

Default parameters not listed

[Options]
Format=fixed

[Variables]
gender=1, 1
hobby=2, 16
age=18, 3
rating=21, 2
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Text Qualifier, and Cards have been omitted because they use 
default values.

Figure A - 7: Data dictionary file for the free format import file shown in Figure A - 3.

Suppose the fixed format import file in Figure A - 2 had records that 
occupied two rows. The resulting import and data dictionary files are 
shown in Figure A - 8.
 

Figure A - 8: A fixed format import file with two rows per record (left) and its corresponding data dictionary file. 

All parameters listed

[Options]
Format=delimited
Delimiter=,
Text Qualifier="
Cards=1

Default parameters not listed

[Options]
Format=delimited

Because this data 
dictionary file is for a 
delimited import file, it 
does not include a 
Variables section.

Import file

0 basketball
60 4
1 knitting
50 3
1 skateboarding
24 2
0 computer program
45 5
0 soccer
35 2
1 calligraphy
57 10
0 writing
42 4
1 painting
38 4

Data dictionary file

[Options]
Format=fixed
Cards=2

[Variables]
gender=1,1,1
hobby=2,16,1
age=1,3,2
rating=4,2,2

Each record 
occupies two 
rows.

This number 
indicates that the 
variable appears 
in the first row of 
a record.

This number 
indicates that 
the variable 
appears in the 
second row of 
a record.
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Creating a Data Dictionary File

If you are importing data from a Survey Crafter Professional web survey, 
you do not need to create a data dictionary file. If you are importing data 
from a market research supplier, the supplier should provide the data 
dictionary file for you. If you created the import file yourself and the 
import file is not in the default CSV (comma separated value) format, you 
need to create a data dictionary file to import the data into Survey Crafter 
Professional.

To create a dictionary file, use a Microsoft Windows text editor that lets 
you create a text (ASCII) file. For example, use Microsoft Notepad or 
Microsoft Word and save the file as text (ASCII).

It is recommended that the data dictionary file have the same name as the 
import file and use the .DCT extension. It is also recommended that you 
store the data dictionary file in the same directory as the import file 
because Survey Crafter Professional looks for the data dictionary file in 
that directory by default.  For example, if the import file is 
C:\CUSTPROJ\DATA\SURVRES.CSV, the data dictionary file should be 
C:\CUSTPROJ\DATA\SURVRES.DCT for the import process to operate 
most efficiently.

The information in the data dictionary file is case insensitive and you can 
include spaces before and after the equals signs in parameter definitions. 
For example, both text Qualifier=, and TEXT quaLIFIer = , are 
acceptable.

• To create a data dictionary file

1 Open the text editor you want to use to write the data dictionary file.

2 Type [Options] as the first line of the data dictionary file.

Include the brackets around the word “Options.”

3 Type the Options section.

See Table A - 1 or Table A - 2 for a description of the section’s 
parameters and their possible values. 

Each parameter must appear on a different line.

4 Is the data dictionary file for a fixed format or delimited import file?
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• If it is for a fixed format import file, go to step 5.

• If it is for a delimited import file, go to step 8.

5 Press [RETURN] to add a blank line after the Options section.

6 Type [Variables] on the next line.

Include the brackets around the word “Variables.”

7 Type the Variables section.

See Table A - 3 for a description of this section’s parameters.

8 Save the file as a text (ASCII) file and assign it the .DCT extension. 

Warning If you are using a text editor that does not 
automatically save a document as text (ASCII), make sure 
to choose Text Only or Text Files from the Save File As 
Type drop-down list in the Save As dialog box. Only 
typing the .DCT extension after the file name does not 
automatically save the file as text (ASCII).  
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B Appendix
Setting Startup Preferences

Survey Crafter Professional displays several dialog boxes when you start 
the application:

• The Welcome dialog box, which gives you a choice of creating a new 
study or opening an existing study

• The Tip of the Day dialog box, which displays a tip for using Survey 
Crafter Professional or performing survey research

By editing Survey Crafter Professional’s preferences, you can control 
which of these screens and dialog boxes appear when you start Survey 
Crafter Professional.

By default, Survey Crafter Professional displays all four tabs of the Study 
window, allowing the creation and modification of surveys, data, analyses 
and variables. However, you can instruct Survey Crafter Professional to 
hide up to three of these tabs to prevent access to some of these features.
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Setting Startup Preferences

Turning off the Welcome Screen and Tips

By default, the Welcome screen and the Tip of the Day dialog box 
automatically appear when you start Survey Crafter Professional. You can 
turn off both of these features.

• To turn off the Welcome screen and tips

1 Open any study.

2 From the Edit menu, choose Preferences.

3 To turn off the Welcome screen, clear the Show Welcome Dialog at 
Startup check box. 

If you want the Welcome screen to appear again, select this check 
box.

4 To turn off the Tip of the Day, clear the Show Tips at Startup check 
box.

If you want the Tip of the Day to appear again, select this check box.
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Figure B - 1: The General tab of the Preferences dialog box.

5 Click on the Finish button.

Showing and Hiding Study Window Tabs

By default, all four tabs of the Study window are displayed: Surveys, 
Data, Analyses and Variables. You can instruct Survey Crafter 
Professional to hide up to three of the Study window’s tabs to prevent 
access to the features the tabs provide.

• To show and hide Study window tabs

1 Open any study.

2 From the Edit menu, choose Preferences.

3 In the General tab of the Preferences dialog box, select or clear the 
check boxes that correspond to the Study window tabs you want to 
show or hide. 



If the check boxes are disabled, you must first type the password in 
the password box. Once the password has been entered, Survey 
Crafter Professional enables the check boxes.

4 To password-protect the Study window settings, select the Password 
Protect check box and type a password in the password box. 

Write down the password, noting the upper and lower case letters and 
digits.

Figure B - 2: The General tab of the Preferences dialog box.

5 Click on the Finish button.

6 You must close and restart Survey Crafter Professional to see the 
changes.
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ASCII The format Survey Crafter Professional requires for import files. 
ASCII stands for American Standard Code for Information 
Interchange. 

You can include notes to market research suppliers with your 
survey. These notes explain that the import files suppliers return 
must be in ASCII format. 

ASP (Active Server 
Pages)

Active Server Pages is a scripting environment principally for 
Microsoft Internet Information Server (IIS) in which you can 
combine HTML, scripts and reusable ActiveX server components 
to create dynamic web pages.

a priori segmentation Dividing respondents into mutually exclusive groups prior to 
analyzing the groups. Respondents are often divided based on a 
characteristic like age or a combination of characteristics like age 
and income.

absolute frequency The number of respondents meeting criteria you specify. For 
example, of the people surveyed, 549 said they read the Times 
every day. Also called counts.

all-that-apply question A question that asks the respondent to check one or more prompts 
from a predefined list of prompts. For example, “Which of the 
following restaurants have you visited? Burger World, King Taco, 
Broilin’ Bill’s, The Chicken Coop, Marsha’s Mex.”
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all-that-apply question 
block

In a survey, a question and two or more associated variables for 
storing replies to the question. All-that-apply questions (questions 
for which respondents select one or more answers) use 
all-that-apply question blocks.

all-that-apply question 
wizard

An analysis wizard especially tailored for all-that-apply question 
blocks. The All-that-Apply Question wizard shows statistics for 
each prompt in an all-that-apply question block.

analytical plan The document that outlines the analyses planned for a survey 
research project.

argument A term a function uses to perform a calculation. For example, the 
function POWER( ), which raises one number to the power of 
another, takes two arguments:  the number to use as the base and 
the number to use as the base's exponent. Some functions have 
one or more optional arguments.

banner A banner shows counts and percentages for selected category 
variables and counts, percentages, means and standard deviations 
for selected quantity variables. A banner can also show the cross 
tabulation of the selected variables against another variable.

For example, the banner below shows the number of responses, 
the mean, and the standard deviation for the quantity variables 
age, height, and weight.

batch report A batch report is a specification for printing and exporting Survey 
Crafter Professional analysis tables and charts. A batch report 
consists of a list of items, each of which specifies a group of 

Count Mean Std. Dev.

age 573 43.7 12.4

height 600 5.75 1.9

weight 550 146 40.7
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tables and charts to print and export. You can very quickly design 
a batch report that includes tables and charts that analyze the 
responses to every question in your survey. Batch reports are 
stored in your study and listed in the Analyses tab of the Study 
window.

batch report design 
item

A batch report design item is a component of a batch report. Each 
batch report design item specifies a group of Survey Crafter 
Professional analysis tables and charts to print and export. There 
are five types of batch report design items: Basic Analysis - 
Survey, Basic Analysis - Question Block, Basic Analysis - 
Variable, Analysis Table/Chart, and Custom Script. Basic 
Analysis items are useful for quickly analyzing the responses to 
your survey.

batch report designer 
window

A batch report consists of a list of items, each of which specifies a 
group of Survey Crafter Professional analysis tables and charts to 
print and export. The batch report Designer window displays the 
list, allowing you to make changes to as well as print and export 
the report.

batch report filter Add a batch report filter to a batch report when you want to limit 
the calculations to a subset of the respondent records in your 
study's data set. You can also configure a batch report filter to 
have Survey Crafter Professional repeat the calculations, each 
time using a different subset of the respondent records and 
automatically print and export the different results. There are 
three types of batch report filters: Simple Condition Expression, 
Repeat Condition Expressions, and Repeat Variable Values.

binary operator An operator that acts on two terms in an expression. For example, 
the + (addition) operator adds two quantities.

block A block in the Survey Designer window is a special table that can 
contain one or more survey questions, or just text or pictures. A 
block that contains one or more survey questions is called a 
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question block. A block that contains no questions is called an 
instructions-only block. Typically, instructions-only blocks 
contain instructions, pictures, section headings or other text.

block layout A block layout represents a particular organization and 
presentation of the components of a survey block. A block layout 
dictates how the text, question, prompt and other components of a 
block are arranged. For example, one block layout may display a 
closed-end question's prompts in a single column below the 
question whereas another may display the prompts in a single row 
to the right of the question.

A block layout can also dictate the type and location of the 
block's controls. For example, when the Survey Designer window 
is in Web Layout or Interviewer Layout mode, many of the block 
layouts designed for 1 closed-end question employ radio button 
controls while others employ a single-selection list box control.

Most block layouts are designed to work with one or more of just 
one type of question. However, there are several block layouts 
that are designed to work with more than one type of question. 
For example, there is a block layout that combines multiple 
closed-end questions with one ranking question.

block style A block style is a set of predefined formatting options that you 
can apply to a survey block. You can create your own block styles 
or edit existing ones. A block style controls the borders, shading 
and background colors of the cells of a survey block.

branching A technique used to direct interviewers or respondents to 
different places in a survey based on the response to a question. 
For example, you might want respondents to skip a question 
about a particular fast food restaurant if they have never been to 
that restaurant. 

browser A software application used to view websites. Common browsers 
include Firefox, Microsoft® Internet Explorer®, Safari, Google 
Chrome and Opera.
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category (on a chart) A collection of one data point from each series in a chart. For 
most chart types, a category corresponds to one row of numbers 
in the chart’s data table.

category variable A variable that stores a response selected from a predefined list of 
choices. The list of choices is a nominal scale. Each possible 
response is assigned an arbitrary code that market research 
suppliers use. For example, the response “Yes” could have the 
code 1 and “No” could have the code 0.

chart A graphical display of an analysis’ results. Survey Crafter 
Professional supports several chart types including line, bar, and 
pie charts.

chi-square test A test to determine whether the relationship between two 
category variables is statistically significant.

cleaning data The process of editing unreadable and unexpected values in a 
study’s data set before analyzing the data.

closed-end question A question that requires the respondent to pick at most one 
prompt from a list of predefined prompts. Also called a forced 
choice or multiple-choice question. For example, "Which of the 
following restaurants is your favorite?  Burger World, King Taco, 
Broilin' Bill's, The Chicken Coop, Marsha's Mex."

code (for a category) The arbitrary number associated with a response to a closed-end 
or all-that-apply question. For example, for the question “What is 
your gender?” the response “Male” may be assigned the code 0 
and “Female” the code 1. 

Although you do not use codes within Survey Crafter 
Professional, category variables include them and Survey Crafter 
Professional exports them for use by market research suppliers 
and other software programs.
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code (for a variable’s 
name)

A variable code is a shortened name (up to eight characters long) 
that is only used when referencing a variable outside Survey 
Crafter Professional.

For example, variable codes are used in web survey HTML and 
data files since these files exist outside Survey Crafter 
Professional. Variable codes are also used when importing and 
exporting respondent data.

The reason for the shortened name is to conserve space in 
external data files. Also, market research suppliers typically limit 
variable identifiers to eight characters..

column filter The expression you write to determine which respondents to 
include in a column’s calculations in the Analysis window. The 
expression must evaluate to TRUE or FALSE. Respondents for 
whom the expression is TRUE pass through the filter and are 
included in the column.

For example, the column filter gender = ‘female’ includes 
only respondents who have the value ‘female’ stored in the 
category variable gender.

column percentage In cross tabulations, the number of respondents in a table cell 
divided by the total number of respondents in that cell’s column. 
Also called column frequency.

computed variable A variable storing values Survey Crafter Professional calculates 
from values in imported variables or other computed variables. 
For example, if the imported variable income stores a 
respondent’s income and spouse_income stores the respondent’s 
spouse’s income, the computed variable family_income could 
store the sum of the values in these two variables.

computer aided 
personal interviewing 
(CAPI)

An in-person interviewing method in which the interviewer 
enters the answers to survey questions into a computer as the 
respondent says them. Because CAPI surveys are programmed 
into a computer, they can support complicated skip logic.
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computer aided 
telephone 
interviewing (CATI)

A telephone interviewing technique in which interviewers enter 
answers to survey questions into a computer as the respondent 
says them. Because CATI surveys are programmed into a 
computer, they can support complicated skip logic.

confidence interval The range within which the population’s mean or percentage is 
expected to lie. The upper and lower bounds of the interval are 
calculated from sample information and a confidence level. 

For example, if the 95% confidence interval for the mean of 
variable x  is 0.7 to 1.5, there is a 95% chance that the mean of x 
for the population should lie between 0.7 and 1.5.

confidence level A measure of how confident you can be in a test’s results. 
Confidence intervals are used when testing for statistical 
significance and when determining confidence intervals.

For example, suppose the confidence level for the mean of 
variable x is calculated from sample data as 0.7 to 1.5 at a 95% 
confidence level. Then, 95% of the time the mean of x for the 
population should lie between 0.7 and 1.5. In other words, you 
can be 95% confident that the population’s mean lies between 0.7 
and 1.5.

constant sum 
question

A question that respondents reply to by assigning points to a 
series of items. The points they assign across items add up to a 
total you decide. For example: "Divide 100 points among the 
following three fast food restaurants according to how likely you 
are to visit them (the more points, the more likely you are to 
visit): Burger World, Marsha's Mex, Broilin' Bill's."

constant sum 
question block

A survey block that contains one constant sum question and 
quantity variables for storing replies to the question.
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correlation A statistical technique for measuring the degree to which two 
quantity variables are related. For example, a correlation could 
measure whether units sold and the amount spent on marketing 
are related. 

A correlation results in a correlation coefficient between 1 and -1 
inclusive. 1 indicates a perfect positive correlation—an increase 
in one variable corresponds to an exact increase in the other 
variable. For example, when $x more is spent on marketing, y 
more units are sold. -1 indicates a perfect negative correlation—
an increase in one variable corresponds to an exact decrease in 
the other variable. For example, when the price is increased by 
$x, y fewer units are sold.

There is not necessarily a causal relationship between correlated 
variables, that is, an increase in one variable does not necessarily 
cause an increase or decrease in the other. The variables are just 
related.

correlation coefficient A statistic that describes the relationship between two quantity 
variables storing interval-scaled data (for example, ratings of 
satisfaction and durability) or ratio-scaled data (for example, 
age). 

Values can range from 1 to -1. 1 indicates a perfect positive 
correlation--an increase in one variable corresponds to an exact 
increase in the other variable. For example, when $x more is 
spent on marketing, y more units are sold.

-1 indicates a perfect negative correlation--an increase in one 
variable corresponds to an exact decrease in the other variable. 
For example, when price is increased by $x , y fewer units are 
sold.

The degree to which the variables are related is given by the 
magnitude of the coefficient. A coefficient of 0.8 indicates that 
the relationship is more prevalent than if the coefficient was 0.2.

There is not necessarily a causal relationship between correlated 
variables, that is, an increase in one variable does not necessarily 
cause an increase or decrease in the other. The variables are just 
related.
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correlation matrix A table showing the correlation coefficients for a set of quantity 
variables. In the correlation matrix below, note that each cell on 
the diagonal running from upper-left to lower-right contains the 
value 1 because it represents the variable correlated with itself.  

count The number of respondents meeting criteria you specify. For 
example, of the people surveyed, 549 said they read the Times 
everyday. Also called absolute frequencies.

counts and 
frequencies

A counts and frequencies table shows count and percentage 
calculations for each value of one or more selected variables. The 
variables you select for a counts and frequencies table can be of 
any type.

For example, suppose your survey has a question that asks the 
respondent to choose the newspaper he or she reads the most 
from a list of newspapers. A counts and frequencies table could 
show the number of people who mostly read the Gazette as well 
as the number of people who mostly read the Times.

cross tabulation A cross tabulation shows all combinations of the values of two or 
more variables and the number and/or percentage of times each 
combination was chosen.

income age num_childre
n

spouse_inco
me

income 1 0.62 -0.14 0.2

age 0.62 1 0.5 0.3

num_childre
n

-0.14 0.5 1 0.45

spouse_inco
me

0.2 0.3 0.45 1
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For example, suppose your survey contains a question that asks 
for the respondent’s gender and the newspaper that he or she 
reads the most. The cross tabulation below shows the number of 
respondents belonging to categories in the gender and newspaper 
variables. According to this cross tabulation, 250 males mostly 
read the Gazette.

data cleaning The process of editing unreadable and unexpected values in a 
study’s data set before analyzing the data.

data dictionary file An ASCII text file describing the structure of an import file. 
Survey Crafter Professional uses the data dictionary file to match 
variables in an import file to a study’s imported variables. In 
some cases, an import file needs a data dictionary file. An import 
file used by a Survey Crafter Professional web survey does not 
need a data dictionary file.

If a data dictionary file is needed, to make the import process 
most efficient, the data dictionary file should have the same name 
as its import file and be located in the same directory. Data 
dictionary files typically use the .DCT extension.

delimiter The character used to separate variables or records in an import or 
export file. Common delimiters are commas or tabs.

Gender

Newspaper Male Female Total

Daily World 700 respondents 465 respondents 1165 respondents

Gazette 250 100 350

Times 310 790 1100

Tribune 460 215 675

Total 1720 1570 3200
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descriptive statistics Statistics on the values in quantity variables including the 
following: counts, means, mean confidence intervals, medians, 
modes, maximums, minimums, standard deviations, and 
variances.

dictionary variable A variable in an import file. A dictionary variable’s name should 
be the same as the code of its corresponding imported variable in 
a study.

download To get a file from the Web by copying it from a web server to 
your computer.

exclusive prompt An exclusive prompt is a prompt that a respondent is allowed to 
choose only when she has chosen no other prompt.

Since a respondent may pick at most one prompt in a closed-end 
or rating question, all prompts in closed-end and rating questions 
are exclusive. Since by default a respondent may choose more 
than one prompt in an all-that-apply question, all prompts in an 
all-that-apply question are not exclusive.

However, you can mark the last one or more prompts in an all-
that-apply question exclusive. For example, if the prompts for 
your all-that-apply question include "None of the above" and 
"Refused", you could list the two prompts at the end and then 
mark them exclusive.

export file The file to which Survey Crafter Professional writes the study’s 
data set. Create an export file to use the study’s data set in another 
application or to transfer it to another user.

expression An expression is a combination of functions, operators, variables, 
and/or values that evaluates to one value or a different value for 
each respondent in a study's data set. For example, the expression

COUNT(gender='male' AND newspaper='BostonGlobe')
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evaluates to the number of males in the study's data set who read 
the Boston Globe.

You can also use an expression to include a subset of the 
respondents in the study's data set. For example, the expression 

(satisfaction='VerySatisfied' OR 
satisfaction='Satisfied')

evaluates to TRUE for each respondent who said she is either 
very satisfied or satisfied and FALSE for each respondent who 
said she is neither very satisfied nor satisfied.

Expression Builder A dialog box that helps you write expressions by providing 
resources that you can drag and drop into your expressions such 
as functions, your study's variables, values from your study's data 
set and expressions from the Expression Library.

Expression Library A place where you can store and retrieve your study's 
expressions. To copy an expression to another study, name the 
expression and save it to your study's Expression Library, export 
your study's Expression Library to a text file and then import the 
text file into the other study's Expression Library.

field Another name for a variable’s values in an import file. Survey 
Crafter Professional matches fields to a study’s imported 
variables when you import data from an import file into a study.

field delimiter A character used to separate values in an import file. Common 
field delimiters are tabs or commas.

field width The number of columns allotted to a variable’s value in an import 
file.
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forced choice 
question

A question that requires the respondent to choose a response from 
a list of pre-defined answers. Also called a closed-end question. 
For example, “Which of the following restaurants is your 
favorite?  Burger World, King Taco, Broilin’ Bill’s, The Chicken 
Coop, Marsha’s Mex.”

formatting of table 
cells

The number format, alignment, font, borders, and patterns 
specified for a table cell and its value.

frequency The number of people who respond a certain way to a survey 
question. Can be expressed as a count (543 respondents read the 
Times daily) or a percentage (59% of respondents read the Times 
daily).

Counts are also called absolute frequencies. Percentages are also 
called relative frequencies.

function A command that tells Survey Crafter Professional to perform a 
calculation. For example, the function MEAN( ) calculates the 
average value in a quantity variable. Functions are often included 
in expressions that define computed variables or values in table 
cells.

Function Wizard A dialog box that guides you through the process of inserting a 
function or operator in an expression.

gap analysis A type of cross tabulation that illustrates the difference between 
two category variables’ values. The two variables usually store 
data on customers’ need for an attribute like customer service and 
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their satisfaction with that attribute in a product they currently 
use.

The gap exists when customers are underserved (for example, 
customers who have a high need for customer service but low 
satisfaction with it) or overserved (customers who have a low 
need for customer service but high satisfaction with it). The gap 
analysis above suggests that 22% of the sample is underserved 
and 20% is overserved.

group In the Question Library, a collection of similar questions.

HTML Hypertext Markup Language. The standard language used to 
describe a web page's structure and content. Browsers read 
HTML and convert it to the web page users see in their browser's 
window.

heading A label appearing with a table’s row or column in the Analysis 
window. For example, a column containing information on male 
respondents might have the heading “Males.”

hypothesis An assertion about a sample that can be tested (for example, 
whether customers’ satisfaction with a soda is influenced more by 
its price than its flavor).

High Need 22% 16%

Low Need 42% 20%

Low Satisfaction High Satisfaction

Gaps exist in the low need/
high satisfaction and high 
need/low satisfaction 
quadrants.
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hypothesis test A statistical test for determining whether a hypothesis about an 
observed difference between a sample value and a hypothetical 
value or another sample value is due to chance. If the difference is 
not due to chance, the difference is termed “statistically 
significant.”

import file A file containing data to import into Survey Crafter Professional. 
The file typically comes from a web survey or a market research 
supplier although you also can create an import file.

imported variable A variable storing data you import into the study from a web 
survey data file or enter using the built-in Interviewer. Typically 
imported variables store responses to survey questions. An 
imported variable's values can be analyzed directly or used to 
create computed variables for further analysis.

individual responses 
wizard

A wizard that builds analysis tables that show actual responses 
stored by selected variables.

instructions-only 
block

A block that contains no questions is called an instructions-only 
block. Typically, instructions-only blocks contain instructions, 
pictures, section headings or other text. Survey Crafter 
Professional does not create and maintain any imported variables 
for an instructions-only block.

interval scale A scale whose points are equally spaced but whose values are 
arbitrarily defined. For example, the Celsius scale is an interval 
scale. The difference between 20 and 25 degrees Celsius is the 
same as the difference between 200 and 205 degrees Celsius and 
100 degrees Celsius has arbitrarily been defined as the boiling 
point of water. 

Equal spacing of scale points allows for calculating frequencies, 
percentiles, means, standard deviations, correlations and for 
performing more advanced techniques like cluster analysis.
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interviewer layout Use the Survey Designer window's Interviewer Layout mode to 
tailor your survey for the built-in Interviewer. When in 
Interviewer Layout mode, the Survey Designer window offers 
question block layouts that are compatible with the Interviewer. 
For example, you can choose a question block layout that uses 
drop-down, single selection or multiple selection list box 
controls.

intranet A company-wide internet. Only employees of the company have 
access to this network.

label The identification tag you associate with a block of a Survey 
Crafter Professional survey. You can use labels in skip logic to 
indicate the next part of the survey  respondents or interviewers 
should go to based on the answer to a previous question. Unlike 
question numbers, labels do not change if you add, delete, or 
rearrange questions.

language package A language package is a named collection of translations of built-
in messages, headings and labels. Every Survey Crafter 
Professional survey is assigned a language package. The 
language package provides the words on the survey's navigation 
buttons as well as in the survey's informational headings and 
built-in error and warning messages. You can customize existing 
language packages and/or create your own. Survey Crafter 
Professional ships with standard U.S. English, British English, 
French, Spanish, German and Dutch language packages.

link or hyperlink On a web page, text or graphics users can click on to initiate an 
action. Links often appear as underlined text. Commonly they 
take the user to another web page.

literal variable A variable storing text. Most often, literal variables store answers 
to open-end questions like "What is your name?"
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market research 
supplier

A firm that interviews respondents and compiles data using the 
survey you write. Also called a survey vendor.

maximum length The maximum acceptable length for a literal variable. Values 
stored in literal variables may be up to 32,767 characters long. If 
a value is more than 32,767 characters long, Survey Crafter 
Professional stores only the first 32,767 characters.

maximum value The largest value in a quantity variable. Marks the upper end of a 
quantity variable’s range.

mean The average value in a quantity variable. For example, if the 
quantity variable carsown stores the values 1, 1, 2, 3, 2, its mean 
is 1.8. 

median The value exactly in the middle of a quantity variable’s values 
when they are ranked lowest to highest. For example, if the 
quantity variable carsown stores the values 1, 1, 2, 2, and 3, its 
median is 2.

minimum value The smallest value in a quantity variable. Marks the lower end of 
a quantity variable’s range.

missing value Survey Crafter Professional considers a value missing when it is 
equal to NR (No reply) or NV (No value). A variable takes on 
one of these missing values when its associated survey question is 
either not asked (NV) or not answered (NR).

mode The most frequently occurring value in a quantity variable. For 
example, if the quantity variable carsown stores the values 1, 1, 1, 
2, 2, 3, and 4, its mode is 1.
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name (in the Question 
Library)

A string of text associated with a question in the Question 
Library. You can use the name to help find a question. For 
example, the question "How old are you?" might have the name 
"age".

No Reply (NR) If a respondent’s record contains this value for a variable, it 
means that the respondent was asked the question associated with 
the variable but refused to answer it.

Survey Crafter Professional ignores NR values when performing 
calculations but you can test whether a variable contains any NR 
values. 

Imported category variables feature a category called NR by 
default. Imported quantity variables feature a no reply value 
market research suppliers use that Survey Crafter Professional 
converts to NR when you import the data set. Imported literal 
variables do not have a no reply value:  If a respondent declines to 
answer a question that uses a literal variable, the market research 
supplier should enter a value like “Declined to answer” or “No 
answer”.

No Value (NV) If a respondent’s record contains this value for a variable, it 
means that no value was available for the variable. For example, 
the respondent was not asked the question associated with the 
variable or simply left the question blank. 

Survey Crafter Professional ignores NV values when performing 
calculations but you can test to check whether a variable contains 
any NV values. 

Survey Crafter Professional also assigns the value NV to 
computed variables before their values are calculated.

nominal scale A scale on which numbers or codes are arbitrarily assigned to 
responses solely for identification purposes. For example, 
answers to question “Do you own a VCR?” may be coded as 
follows:  0 for “Yes” and 1 for “No”. Values in category variables 
use nominal scales.
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Because the number or code assigned to a response has no 
inherent meaning, nominal scales are useful only for calculating 
frequencies.

normalized values Values calculated by subtracting a quantity variable’s mean from 
each of its values and dividing each difference by the variable’s 
standard deviation. Normalize values when you want to compare 
quantity variables with different means and variances.

open-end question A question that respondents answer in their own words rather 
than by selecting an answer from a list of choices or stating a 
number. For example, "What is your name?"

operand A term on which an operator acts in an expression. In the 
following expression, the quantity variables salary and bonus are 
operands of the + (addition) operator:  salary + bonus

ordinal scale A scale on which the numbers assigned to a choice have meaning 
relative to each other but the differences between scale values 
have no absolute meaning. Ordinal scales are used for rankings.

For example, suppose a respondent ranks three products based on 
quality. It is clear that the respondent thinks the top-ranked 
product has the highest quality. It is not clear, however, how 
much higher the respondent thinks the top-ranked product’s 
quality is than the second-ranked product’s.

Ordinal scales allow for calculating frequencies, medians, 
percentiles, and other order statistics.

percentage The proportion of respondents who meet a criterion you specify. 
For example, 59% of respondents said they read the Times daily. 
Also called relative frequency.



primary block A primary block is a block that serves as the primary source of 
information for its associated imported variables. Survey Crafter 
Professional uses primary blocks in the Survey Designer window 
to set the properties of the blocks' associated variables.

A newly inserted question block is by default a primary block. 
However, if you copy a block from one Survey Designer window 
and paste it inside another Survey Designer window from the 
stame study, the pasted block is by default a secondary block. A 
secondary block's associated variables are the same as those 
associated with the original primary block in the other Survey 
Designer window.

Secondary blocks are useful when you want to administer your 
survey in more than one language or you want to create another 
variation of your survey. Changes made to question and prompt 
text in a secondary block are not reflected in the block's 
associated variables.

To show when the cursor is inside a primary block, Survey 
Crafter Professional displays a blue rectangle around the block. 
To show when the cursor is inside a secondary block, Survey 
Crafter Professional displays a green rectangle around the block.

Identifiers for secondary blocks in the Blocks tab of the Survey 
Explorer toolbar are colored green.

You can click inside a secondary block and then click on Primary 
Block from the Block menu to convert the block to a primary 
block.

print layout Use the Survey Designer window's Print Layout mode to tailor 
your survey for printing. When in Print Layout mode, the Survey 
Designer window offers question block layouts that are 
compatible with printed surveys.

For example, you can choose a question block layout that has 
respondents circle the prompts. When in Print Layout mode, the 
Survey Designer window also offers page size and orientation 
options and automatic pagination. The Survey Designer window 
must be in Print Layout mode for you to print your survey.
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profile A list of descriptive statistics for category or quantity variables. A 
profile often shows the number of responses stored in variables, 
means and standard deviations for quantity variables, and counts 
or percentages for category variables. Also called a banner. 

prompt For a closed-end, all-that-apply or rating question, a prompt is 
one of the possible answers to the question. For a ranking or 
constant sum question, a prompt is one of the items to be ranked 
or assigned a value.

For example, the closed-end question "Which of the following 
fast food restaurants is your favorite?  Burger World, Marsha's 
Mex, Broilin' Bill's." has 3 prompts.

quantity question A question a respondent answers with a number. For example, 
“What is your age?”

quantity variable A variable storing numbers. Quantity variables store ordinally, 
intervally, or ratio scaled data. Often they store responses to 
quantity questions like “What is your age?” or rating questions 
like “Rate our customer service on a scale of 1 to 5.” They can 
also store values calculated from responses to questions like the 
normalized values of respondents’ ages.

question block A block that contains one or more survey questions is called a 
question block.

When you use a question block for a survey question, Survey 
Crafter Professional automatically creates and maintains the 
necessary imported variables in the study's database to store the 
responses to the question. These variables are called imported 
because they store data coming from outside Survey Crafter 
Professional.

A question block may be a primary block or a secondary block.
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randomize Rearranging questions or listed choices for each respondent. 
Randomizing is done to minimize any bias resulting from 
presenting the questions or choices in the same order every time.

range A quantity variable’s minimum and maximum values. For 
example, if the quantity variable carsown stores the values 1, 2, 1, 
3, 4, 2, 1, its range is 1 to 4.

ranking question Respondents reply to a ranking question by ordering a list of 
items according to some criterion. For example, "Please rank the 
following three fast food restaurants according to how likely you 
are to visit them (1 is most likely to visit, 3 least likely):  Burger 
World, Marsha's Mex, Broilin' Bill's."

ranking question 
block

A survey block containing a ranking question and two or more 
quantity variables for storing replies to the question.

ranking question 
wizard

An analysis wizard especially tailored for analyzing ranking 
questions. The Ranking Question wizard shows statistics for each 
item in a ranking question.

rating question A question respondents reply to by picking a point on a scale. For 
example, "Please rate the importance you place on customer 
service at fast food restaurants on a scale of 1 to 5. (1 = Not at all 
important, 5 = Extremely important.)" 

rating question block A survey block containing one or more rating questions and the 
associated quantity variables for storing replies to the questions.

ratio scale A scale on which the ratio between values is meaningful because 
0 represents the absence of an attribute. For example, $100 is 
twice as much as $50 and $0 is the absence of money. 
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A ratio scale allows for the same calculations as all other scale 
types (nominal, ordinal, and interval) plus other more specialized 
calculations.

record A row in the study’s data set. A record contains one respondent’s 
replies to the survey’s questions and associated computed values. 
You can view records in the Data window.

record delimiter The character used to separate one respondent’s replies (one 
record) from another respondent’s in an import file. The record 
delimiter is typically a carriage return.

regression A technique for estimating the change in the dependent variable 
(the Y axis on a chart) that is brought about by changes in the 
independent variable(s) (the X axis on a chart). 

regular expression A regular expression is a literal value that follows a set of rules. 
Survey Crafter Professional uses regular expressions to search 
literal values. Use the rules described below to construct a regular 
expression.

• Any character that is not a special character matches itself. For 
example, "abc" matches "abc".

• A backslash (\) followed by a special character matches the 
special character itself. For example, "\+" matches "+".

• Special characters are plus (+), asterisk (*), question mark (?), 
period (.), left bracket ([), right bracket (]), caret (^), dollar sign 
($), left and right parentheses (()) and the vertical line (|).

• Parentheses (()) group parts of an expression into sub-
expressions. For example, "(abc)+" matches "abc" and 
"abcabc".

• A vertical bar (|) allows a choice between sub-expressions. For 
example, "02143|02144|02146" matches "02143", "02144" and 
"02146". Another example, "mon(ey|ies)" matches "money" 
and "monies".
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• A period (.) matches any character except the newline 
character. For example, ".ed" matches "bed" and "fed".

• A character or a set of characters enclosed in brackets ([]) is a 
one-character expression that matches any of the characters in 
the set. For example, "[abc]" matches "a", "b", and "c". Use a 
dash (-) to indicate a range. For example, "[a-zA-Z]" matches 
any lower or upper case letter. Another example, "[0-9][0-9][0-
9][0-9]/(0[0-9]|1[0-2])/(0[1-9]|[1-2][0-9]|3[0-1])" matches 
"2010/05/27" but not "2010/13/27" or "2010/12/32".

• If the first character enclosed in brackets ([]) is a carot (^), then 
the characters that follow may not occur in the searched string. 
For example, "[^abc]" matches "d" but not "a", "b" or "c".

• A character or set of characters that is followed by an asterisk 
(*) may occur zero or more times in the searched string. For 
example, "[A-Z]*" matches zero or more upper-case letters.

• A character or set of characters that is followed by a plus (+) 
may occur one or more times in the searched string. For 
example, "[a-z]+" matches one or more lower-case letters.

• A character or set of characters that is followed by a question 
mark (?) may occur zero or one time in the searched string. For 
example, "[a-zA-Z]?" matches zero or one lower or upper case 
letter.

• If the first character of the expression or sub-expression is the 
caret (^), then the matched string must be at the beginning of 
the string being searched. For example, "^the" matches "the 
answer is" but not "and the answer is".

• If the last character of the expression or sub-expression is the 
dollar sign ($), then the matched string must be at the end of the 
string being searched. For example "is$" matches "the answer 
is" but not "the answer is 10". Another example, "^[0-9][0-
9][0-9][0-9]/(0[0-9]|1[0-2])/(0[1-9]|[1-2][0-9]|3[0-1])$" 
matches "2010/05/27" but not "before 2010/05/27" or "2010/
05/27 or after".
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relative frequency The proportion of respondents who meet criteria you specify. For 
example, 59% of respondents said they read the Times daily. Also 
called percentage.

research plan The document outlining the survey research project including its 
scope and objectives, hypotheses, and schedule. Also called the 
white paper.

row filter The expression you write that determines which respondents to 
include in the calculations in a row’s cells in the Analysis 
window. The expression must evaluate to TRUE or FALSE. 
Respondents for whom the expression is TRUE pass through the 
filter and are included in the row.

For example, the row filter gender = ’male’ AND age > 25 
includes only respondents who have the value ‘male’ stored in the 
category variable gender and values greater than 25 stored in the 
quantity variable age.

row percentage The number of respondents in a table cell divided by the total 
number of respondents in that cell’s row. Also called row 
frequency.

sample size The total number of respondents in the sample.

scale The measurement system that determines how a respondent 
replies to a survey question and what the reply means. Different 
kinds of scales allow for different analyses with the data they 
collect. 

There are four kinds of scales:  nominal, ordinal, interval, and 
ratio. Category variables store responses on nominal scales. 
Quantity variables store responses on ordinal, interval, and ratio 
scales.
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scale point A value on a scale. For example, 5 on a scale of 1 to 5. A scale 
point often has a label associated with it to explain what the value 
means. For example, 5 could mean “Very satisfied” and 1 could 
mean “Very dissatisfied”.

screening question A question asked at the beginning of a survey to test whether the 
respondent is appropriate for the survey. For example, in a survey 
targeting people interested in buying a house, a screening 
question might be “Do you plan to buy a house in the next five 
years?”

script A program that resides on a web server and processes completed 
surveys.

search engine A program that finds web pages containing keywords users enter.

secondary block A secondary block is a block that has been copied from another 
Survey Designer window. When you copy a primary or a 
secondary block from one Survey Designer window and paste it 
inside another Survey Designer window, the pasted block is by 
default a secondary block. A secondary block's associated 
variables are the same as those associated with the original 
primary block in the other Survey Designer window.

Secondary blocks are useful when you want to administer your 
survey in more than one language or you want to create another 
variation of your survey. Changes made to question and prompt 
text in a secondary block are not reflected in the block's 
associated variables.

To show when the cursor is inside a secondary block, Survey 
Crafter Professional displays a green rectangle around the block. 
To show when the cursor is inside a primary block, Survey 
Crafter Professional displays a blue rectangle around the block.

You can click inside a secondary block and then click on Primary 
Block from the Block menu to convert the block to a primary 
block.



      Glossary C - 27 
segmentation A method of dividing the sample into mutually exclusive groups. 
For example, a sample could be divided into respondents with 
annual incomes over $50,000 and respondents with annual 
incomes less than or equal to $50,000. Comparisons are often 
then made between segments. 

series A group of data points. For most chart types, a series corresponds 
to one column of numbers in the chart’s data table.

skip logic Instructions telling the respondent or interviewer to go to a 
different part of the survey or to stop the survey based on an 
answer to a question. Also called branching.

standard deviation A statistic that measures the spread of data around a quantity 
variable’s mean. All else held equal, a small standard deviation 
implies a low spread or strong central tendency and suggests the 
mean represents the data well. A large standard deviation implies 
high spread or weak central tendency in the data and suggests that 
the mean represents data poorly.

The standard deviation is the square root of the variance.

standard group A group that came preloaded in the Question Library. You cannot 
delete or rename a standard group.

standard question A question that came preloaded in the Question Library. You 
cannot delete or move a standard question.

standard template A set of predefined variable settings available to all Survey 
Crafter Professional studies. You can use templates to define 
imported variables quickly. You cannot overwrite a standard 
template’s settings. 
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standardized values Values calculated by subtracting a quantity variable’s mean from 
each of the variable’s values. Standardize values when you want 
to compare values in quantity variables with different means.

statistical significance Occurs when the difference between two measurements is large 
enough not to have occurred by chance. A difference is 
statistically significant only if the result of a significance test is 
greater than or equal to the significance level you choose for the 
test. Statisticians typically use significance levels of 0.95 and 
social scientists typically use  0.90.

study A study is a Survey Crafter Professional project file. A study is 
comprised of some or all of the following:  one or more surveys, 
one data set, multiple variables, and multiple analyses.

study window The Survey Crafter Professional window that organizes the 
components of a study into the following four tabs: Surveys, 
Data, Analyses, and Variables.

survey A document containing questions to ask respondents.

survey designer 
window

The Survey Designer window is where you enter and format your 
survey. It has many features that you can use to arrange and 
format the titles, instructions, pictures and questions that make up 
your survey.

survey field Insert a survey field at a location in your survey where you want 
to display the answer to a previous question or the result of 
evaluating an expression. You can insert any number of survey 
fields almost anywhere in your survey. Survey fields function 
only when your survey is on the Web or in the built-in 
Interviewer. 

Please note that if you do not want JavaScript in your web 
survey's HTML files, you can configure your survey to have only 
Survey Crafter Professional's web survey script update your 
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survey fields. If you configure your web survey this way, in order 
for a survey field to function properly, you will need to insert the 
field on a page that follows the page that contains the question 
block(s) with which the variable(s) referenced by the field are 
associated. Inserting the field on a following page gives the web 
survey script the opportunity to replace the field with the value to 
display before the respondent's browser shows the page to the 
respondent.

For example, let's say your web survey has an open-end question 
that asks for the respondent's first name. If you want to display 
the respondent's answer to the question elsewhere in the survey 
but do not want JavaScript in your web survey's HTML files, you 
would need to insert the survey field(s) on page(s) that follow the 
one that has the question. 

Another example, let's say your web survey has a question that 
asks the respondent to rate your customer service. If it is okay for 
your web survey's HTML files to use JavaScript, you can insert 
the survey field(s) that would display the answer to the question 
anywhere on the same page and/or on any page(s) that follow.

survey vendor A firm that interviews respondents using the survey you write and 
compiles the replies. Also called a market research supplier.

table filter A table filter is an expression you write that determines which 
respondents to include in an analysis table's calculations. The 
expression must evaluate to either TRUE or FALSE for each 
respondent in the data set. Respondents for whom the expression 
evaluates to TRUE pass through the filter and are included in the 
table's calculations.

For example, the expression

(EmploymentStatus = 'Part Time' AND income > 
40000)

includes only respondents who have the value 'Part Time' stored 
in the category variable EmploymentStatus and values greater 
than 40,000 stored in the quantity variable income.
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tails for significance 
tests

Use a two-tailed test when you want to test whether a value or the 
difference between values is equal to 0. Use a one-tailed test if 
you want to test whether a value or the difference between two 
values is not equal to 0.

target A target in the Survey Designer window is a named location that 
you can use as a destination for a hyperlink. Use a target as a 
hyperlink's destination when you want your respondents to click 
on a hyperlink to jump to another location in your survey.

Before you can insert a hyperlink for jumping to another location 
in your survey, you need to insert a target in your survey.

template A group of predefined settings for creating an imported variable. 
Using a template saves you from entering settings for variables 
with common response scales. For example, if a survey contains 
many yes/no questions, use the Yes/No template when creating 
variables to store responses to these questions.

You can create your own templates or use the standard templates 
Survey Crafter Professional includes.

text substitution table A text substitution table is a two-column table that contains one 
or more textual mappings. Each textual mapping consists of an 
answer to search for and the answer's replacement text. When you 
associate a text substitution table with an open-end question, 
Survey Crafter Professional's analysis wizards use the table's 
textual mappings to automatically substitute the answers to the 
open-end question in the headings of the resulting analysis tables 
and charts.

Suppose your survey has an open-end question that asks the 
respondent to characterize his or her experience at a fast food 
restaurant. Suppose also you decide to simplify data entry by 
translating the respondents' answers to this question into codes 
and enter the codes instead of the respondents' words. You can 
create a text substitution table that contains textual mappings 
between the codes and the words and associate the table with the 
open-end question. When you use Survey Crafter Professional's 
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analysis wizards to analyze the answers to the open-end question, 
the analysis wizards automatically substitute the codes with their 
corresponding words, making the resulting analysis tables and 
charts easier to read.

t-test A test used to determine whether a correlation between two 
quantity variables or the difference between two means or 
percentages is statistically significant. 

unary operator An operator that acts on only one term in an expression. For 
example, the - (negation) operator negates one quantity.

uniform resource 
locator (URL)

Universal Resource Locator. Standard notation for a site's 
location on the Web. For example, http://www.mycompany.com.

unexpected value A value lying outside the range of acceptable values for an 
imported quantity variable or a value that does not follow the 
rules of an all-that-apply, ranking or constant sum question. Even 
if a value is unexpected, Survey Crafter Professional can use it in 
calculations.

unreadable value A value Survey Crafter Professional cannot interpret. There are 
two cases in which values can be unreadable:

• A quantity variable receives a non-numeric value

• A category variable receives a code outside the range of 
acceptable codes

upload To post a file on the Web by copying it from your computer to a 
web server.

user-defined group A group you added to the Question Library. You can change a 
user-defined group's name and delete it from the Question 
Library.
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user-defined question A question you added to the Question Library. You can change a 
user-defined question's group and delete it from the Question 
Library.

user-defined template A set of editable variable settings you define. Use templates to 
define imported variables quickly. A user-defined template is 
available only to the study in which you created it. Unlike a 
standard template, a user-defined template’s settings can be 
overwritten.

variable Storage sites for values entered or imported into a Survey Crafter 
Professional study or computed within the study. Survey Crafter 
Professional has three types of variables: category, literal, and 
quantity.

variable name Each variable in a Survey Crafter Professional study must have a 
name that uniquely identifies it. Variable names are used in the 
Survey Crafter Professional expression language.

For example, if your study contains a variable named Gender, 
then the expression COUNT(Gender='male') would return the 
count of male respondents.

If a variable name is used in an expression, Survey Crafter 
Professional does not allow you to change the name.

variance A statistic that measures the central tendency or amount of spread 
in interval or ratio scaled data. All else held equal, a small 
variance implies a low spread in the data and suggests the mean is 
a good representation of the data. A large variance implies a large 
spread in the data and suggests the mean is a poor representation 
of the data. 

The variance is the square of the standard deviation.

web layout Use the Survey Designer window's Web Layout mode to tailor 
your survey for the World Wide Web. When in Web Layout 
mode, the Survey Designer window offers question block layouts 
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that are compatible with web surveys. For example, you can 
choose a question block layout that uses drop-down, single 
selection or multiple selection list box controls. The Survey 
Designer window must be in Web Layout mode for you to 
configure, preview and publish your survey for the World Wide 
Web.

web server A program that displays a web page when a user's browser 
requests it. Also the computer containing this program and the 
script for processing survey data.

webmaster The person responsible for maintaining a website.

weighting Multiplying survey responses by factors prior to analysis. 
Weighting is done to correct for oversampling and to ensure that 
the sample represents the survey's target population.

white paper The document outlining the survey research project including its 
objectives, hypotheses, and schedule. Also called the research 
plan.

wizard A series of dialog boxes designed to take you step-by-step 
through a task.

Survey Crafter Professional features the following wizards for 
creating tables common to survey research projects:

• All-That-Apply Question wizard

• Banner wizard

• Correlation Matrix wizard

• Counts and Frequencies wizard

• Cross Tabulation wizard

• Descriptive Statistics wizard

• Individual Responses wizard
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• Ranking Question Wizard

Survey Crafter Professional features the following wizards for 
creating charts common to survey research projects:

• Count or Percentage Chart wizard

• Quantity Variable Chart wizard

Survey Crafter Professional also features an Expression Builder 
for building expressions.

Finally, Survey Crafter Professional features the following 
wizards for creating computed variables:

• Category to Quantity Variable wizard

• Category to Weights Variable wizard

• Literal to Category Variable wizard

• Quantity to Category Variable wizard
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column and row filters
about 4 - 41–4 - 47
defining 4 - 41–4 - 50
examples of expressions for 7 - 42
saving time by using 4 - 45–4 - 46
syntax for 4 - 35
using, an example 4 - 42–4 - 45

column headings, defining in tables 4 - 31–4 - 34
column letters, printing on tables 1 - 30
columns

changing width of in tables 4 - 73
changing width of in the Data window 3 - 59
hiding and showing in the Data window 3 - 56–3 - 57
hiding in tables 4 - 71
inserting in tables 4 - 66



rearranging in the Data window 3 - 58
showing in tables 4 - 71

combination charts
example 5 - 10
selecting as the chart type 5 - 34
table configuration for 5 - 10

compacting studies 1 - 36
comparison operators, reference table of 7 - 16
computed value survey fields

examples of expressions for 7 - 36
computed variables

about 6 - 2
category, creating 6 - 39–6 - 42
examples of expressions for 7 - 38–7 - 41
literal, creating 6 - 45–6 - 49
quantity, creating 6 - 42–6 - 45
reasons for creating 6 - 4–6 - 6
rewriting expressions for 6 - 53
updating values in 6 - 68

CONCAT function 7 - 22
CONFIDENCE_MEAN function 7 - 21
CONFIDENCE_PERCENTAGE function 7 - 21
configurations, table required for chart types 5 - 6–5 - 16
constants, entering in expressions 7 - 6–7 - 7
CONTAINS function 7 - 22
CONTAINS_RE function 7 - 22
conventions used in this manual xi
copying

cell properties in tables 4 - 51–4 - 52
charts 5 - 30
entire surveys 2 - 167
instructions-only blocks 2 - 166
question blocks 2 - 166
table cells 4 - 75
tables 4 - 39

correcting errors in data sets 3 - 33–3 - 38
CORRELATION function 7 - 20
correlation matrices, creating using wizards 4 - 22–4 - 27



CORRELATION_SIGNIFICANCE function 7 - 21
COUNT function 7 - 18
creating

charts 5 - 21–5 - 23
custom tables 4 - 28–4 - 36
data dictionary files A - 14–A - 15
import files A - 5–A - 8
studies 1 - 2
surveys 2 - 44, 2 - 50
tables by using wizards 4 - 22–4 - 27

cross tabulations, creating using wizards 4 - 22–4 - 27
CURRENT_VALUE function 7 - 24
custom assignment rules

examples of expressions for 7 - 31
custom branching and skipping rules

examples of expressions for 7 - 29
custom opening and closing web survey rules

examples of expressions for 7 - 27
custom rules

adding 2 - 101, 2 - 137
assignment 2 - 114
branching, skipping and hiding 2 - 104
branching, skipping and hiding issues 2 - 134
commands 2 - 130
data cleaning 2 - 127
opening and closing web survey 2 - 101
set/get web cookie 2 - 118
validation 2 - 110

custom rules, assignment
examples of expressions for 7 - 31

custom rules, branching and skipping
examples of expressions for 7 - 29

custom rules, opening and closing web survey
examples of expressions for 7 - 27

custom rules, validation
examples of expressions for 7 - 29, 7 - 35

custom rules, web cookie
examples of expressions for 7 - 34



custom validation rules
examples of expressions for 7 - 29, 7 - 35

custom web cookie rules
examples of expressions for 7 - 34

cutting
instructions-only blocks 2 - 166
question blocks 2 - 166
table cells 4 - 75

D
data dictionary files

about A - 8–A - 13
creating A - 14–A - 15
Options section of A - 9
overview A - 2
structure of A - 8
Variables section of A - 11

data entry using the Interviewer 3 - 11–3 - 20
Data Error Log, using to isolate errors in data sets 3 - 30–3 - 32
data points

adding and removing markers on 5 - 111
applying fills to 5 - 108
labels for

creating 5 - 114
positioning 5 - 115

data sets
changing column widths in 3 - 59
checking spelling in 3 - 42
cleaning. See data sets, editing
color coding values in 3 - 41
creating records in using the Interviewer 3 - 11
deleting records from 3 - 46
displaying 3 - 10
editing 3 - 33–3 - 47
entering values in using the Interviewer 3 - 11
examples of expressions for values in 7 - 41
exporting 3 - 51–3 - 53
hiding and showing columns in 3 - 56–3 - 57
importing 3 - 21–3 - 29



isolating errors in using the Data Error Log 3 - 30–3 - 32
opening 3 - 10
purging records from 3 - 47
rearranging columns in 3 - 58
sorting respondent records in 3 - 60
weighting values in 3 - 48

Data tab of the Study window 1 - 6
Data window

about 3 - 4
changing display in 3 - 54–3 - 61
color coding of values in 3 - 6–3 - 8
records appearing in the 3 - 4

data,finding and replacing in 3 - 41
date / time functions, reference table of 7 - 25
date axes, scaling 5 - 77
date formats, applying to values in table cells 4 - 60
decimal places

changing number appearing in table cells 4 - 60
changing the number of for quantity variables 6 - 66

default formats, resetting charts to 5 - 60
deleting

categories from category variables 6 - 60
chart text 5 - 51
instructions-only blocks 2 - 173
prompts 2 - 158
question blocks 2 - 173
records from data sets 3 - 46
survey questions 2 - 173
table cells 4 - 77
variables 6 - 52

descriptions, changing variables’ 6 - 51
descriptive statistics, using a wizard to create tables of 4 - 15
display

changing in the Data window 3 - 54–3 - 61
changing in the Survey Designer window 2 - 184

displaying charts in 3D 5 - 61
doughnut charts

adjusting the number of sides in 5 - 92



arranging the sections of 5 - 90
changing the center diameter of 5 - 92
controlling the drawing direction of 5 - 89
defining the starting position of 5 - 89
example 5 - 13
specifying height of 3D 5 - 91
table configuration for 5 - 13
weighting 5 - 90

E
editing

categories in category variables 6 - 59
data sets 3 - 33–3 - 47
lists 2 - 42
prompt text 2 - 155
surveys 2 - 150–2 - 175
text in charts 5 - 50
values in table cells 4 - 34, 4 - 62
variables

all types 6 - 50–6 - 55
category 6 - 56–6 - 62
literal 6 - 67
quantity 6 - 63–6 - 66

elevating 3D charts 5 - 61
enlarging what you want to print 1 - 18
errors in data sets

color coding 3 - 41
correcting 3 - 33–3 - 38
finding 3 - 30–3 - 32

examples of expressions 7 - 27–7 - 44
excluding series from charts 5 - 94
exporting

charts 5 - 120, 5 - 122
data sets 3 - 51–3 - 53
surveys 2 - 190
tables 4 - 82, 4 - 84, 4 - 89

Expression Builder
using 7 - 10–7 - 12

expressions



about 7 - 2–7 - 5
entering functions in 7 - 7
entering operators in 7 - 8
entering values (constants) in 7 - 6–7 - 7
entering variables in 7 - 7
examples of 7 - 27–7 - 44
for table cell values, about 4 - 6
matching types of returned values in 7 - 8
nesting 7 - 8
parts of 7 - 3
rewriting for computed variables 6 - 53
values returned from 7 - 5
writing 7 - 6–7 - 9

F
filling

data points 5 - 108
series 5 - 96

filtering records appearing in the Data window 3 - 4, 3 - 54–3 - 55
examples of expressions for 7 - 43

filters, row and column
about 4 - 41–4 - 47
defining 4 - 41–4 - 50
examples of expressions for 7 - 42
saving time by using 4 - 45–4 - 46
syntax for 4 - 35
using, an example 4 - 42–4 - 45

finding and replacing values in the data 3 - 41
finding errors in data sets 3 - 30–3 - 32
fixed format import files

example A - 3
FLOOR function 7 - 18
fonts

changing in charts 5 - 51
changing in table cells 4 - 56

footers, creating for printed tables 1 - 24
footnotes

adding to charts 5 - 46
hiding and showing on charts 5 - 47



placing in custom locations on charts 5 - 49
resizing in charts 5 - 49

FORMAT_LOCALTIME function 7 - 25
FORMAT_TIME function 7 - 25
FORMAT_UTCTIME function 7 - 25
formats, specifying for numbers in table cells 4 - 60
formatting charts, accessing dialog boxes for 5 - 16–5 - 20
frames, drawing around chart elements 5 - 55
free format import files

example A - 3
functions

ABS 7 - 18
CEIL 7 - 18
CONCAT 7 - 22
CONFIDENCE_MEAN 7 - 21
CONFIDENCE_PERCENTAGE 7 - 21
CONTAINS 7 - 22
CONTAINS_RE 7 - 22
CORRELATION 7 - 20
CORRELATION_SIGNIFICANCE 7 - 21
COUNT 7 - 18
CURRENT_VALUE 7 - 24
entering in expressions 7 - 7
FLOOR 7 - 18
FORMAT_LOCALTIME 7 - 25
FORMAT_TIME 7 - 25
FORMAT_UTCTIME 7 - 25
IF 7 - 19
INDEX 7 - 22
INDEX_RE 7 - 22
IS_FALSE_OR_NV 7 - 19
IS_MISSING 7 - 19
IS_TRUE_NOT_NV 7 - 19
IS_TRUE_OR_NV 7 - 19
IS_UNEXPECTED 7 - 19
IS_UNREADABLE 7 - 19
IS_VALID 7 - 19
LEFT 7 - 22



LENGTH 7 - 22
LIST_CONTAINS 7 - 22
LIST_ELEMENT 7 - 22
LIST_INDEX 7 - 22
LIST_RANDOMIZE 7 - 22
LIST_REMOVE 7 - 22
LIST_REVERSE 7 - 22
LIST_ROTATE 7 - 23
LIST_SIZE 7 - 23
LIT_TO_QTY 7 - 23
LOCALTIME_PART 7 - 25
MAX 7 - 20
MEAN 7 - 20
MEANS_SIGNIFICANCE 7 - 21
MEDIAN 7 - 20
MIDSTR 7 - 23
MIN 7 - 20
MODE 7 - 20
NORMALIZE 7 - 20
OCCURS 7 - 24
PERCENTAGE 7 - 18
PERCENTAGE_SIGNIFICANCE 7 - 21
POWER 7 - 18
QTY_TO_LIT 7 - 23
RAND 7 - 18
RANK 7 - 20
RANK_PERCENT 7 - 20
RATIO 7 - 18, 7 - 19
RECORD_VALUE 7 - 24
RECORDNUM 7 - 24
RECORDS 7 - 24
reference tables for 7 - 18–7 - 21
REPLACE 7 - 23
REPLACE_RE 7 - 23
RIGHT 7 - 23
ROUND 7 - 18
SORTED_RECORDNUM 7 - 24
SORTED_RECORDS 7 - 24



SORTED_UNIQUE_RECORDS 7 - 24
SORTORDER 7 - 24
SORTORDER2 7 - 25
STANDARDIZE 7 - 20
STDEV 7 - 20
STRIP 7 - 23
SUBSTR 7 - 23
SUBSTR_RE 7 - 23
supported by variable types 7 - 13
TOLOWER 7 - 23
TOUPPER 7 - 23
TTEST 7 - 21
UNIQUE_RECORDS 7 - 25
UTCTIME_PART 7 - 25
VARIANCE 7 - 21
WEB_COLUMN_VALUE 7 - 26
WEBSERVER_ENV 7 - 26
XTAB_SIGNIFICANCE 7 - 21

G
gain and loss colors, setting for hi-lo-close charts 5 - 101
gantt charts

example 5 - 11
table configuration for 5 - 11

glossary C - 1–??
gradients, using as backdrops for chart elements 5 - 58
graphics

inserting in bars in 2D bar charts 5 - 97
using as backdrops for chart elements 5 - 59

graphs
creating from values in tables 4 - 79
See also charts

grid lines
adding and removing on axes 5 - 70
printing on tables 1 - 30

guidelines, adding and removing on series 5 - 104
H
headers, creating for printed tables 1 - 24
headings



about survey 2 - 67
defining in tables 4 - 31–4 - 34
deleting from surveys 2 - 173
editing survey 2 - 150
making nonscrolling in tables 4 - 61

hiding
axes’ scales 5 - 72
block components in the Survey Designer window 2 - 185
columns in the Data window 3 - 56–3 - 57
rows or columns in tables 4 - 71
second value (Y) axes 5 - 47
series 5 - 94

hi-lo charts
example 5 - 12
selecting hi-lo-close as the chart type 5 - 35
setting gain and loss colors for hi-lo-close charts 5 - 101
table configuration for 5 - 12

horizontal bar charts
example 5 - 9
table configuration for 5 - 9

hyperlinks
inserting 2 - 97

hyperlinks and targets
inserting 2 - 96

I
IF function 7 - 19
import files

creating A - 5–A - 8
fixed format, example A - 3
free format, example A - 3
overview A - 2
types of A - 3

imported variables
about 6 - 2
category, creating 6 - 9–6 - 13
changing templates for 6 - 52
creating 6 - 9–6 - 21
editing 6 - 50–6 - 66



literal, creating 6 - 17–6 - 21
quantity, creating 6 - 13–6 - 17
reasons for creating 6 - 7

importing data 3 - 22–3 - 29
about data dictionary files A - 8–A - 13
creating data dictionary files A - 14–A - 15
overview of data dictionary files A - 2
overview of import files A - 2
process overview 3 - 21–3 - 22

INDEX function 7 - 22
INDEX_RE function 7 - 22
individual responses, using a wizard to create tables of 4 - 17
inserting category variables in tables 4 - 67–4 - 70
instructions-only blocks

about 2 - 10
copying 2 - 166
cutting 2 - 166
deleting 2 - 173
editing 2 - 150
pasting 2 - 168

instructions-only blocks
inserting 2 - 73

instructions-only blocks
inserting 2 - 67

intersection, changing for axes 5 - 73
Interviewer

editing records using 3 - 33
entering new records using 3 - 11–3 - 20

interviewer
using to check spelling 3 - 42

interviewer layout mode
about 2 - 20

interviewing respondents. See Interviewer
introductions

about survey 2 - 67
deleting from surveys 2 - 173
editing survey 2 - 150

IS_FALSE_OR_NV function 7 - 19



IS_MISSING function 7 - 19
IS_TRUE_NOT_NV function 7 - 19
IS_TRUE_OR_NV function 7 - 19
IS_UNEXPECTED function 7 - 19
IS_UNREADABLE function 7 - 19
IS_VALID function 7 - 19
isolating errors in data sets 3 - 30–3 - 32
J
justifying values in table cells 4 - 53
L
labels

creating
for data points 5 - 114
for series 5 - 113

formatting axes’ 5 - 116
positioning

axes 5 - 116
data point 5 - 115
series 5 - 115

specifying formats for 5 - 118
landscape, choosing as a printing orientation 1 - 16
language packages

about 2 - 179
changing 2 - 179

LEFTfunction 7 - 22
legends on charts

adding 5 - 45
hiding and showing 5 - 47
placing in custom locations 5 - 49
resizing 5 - 49

LENGTH function 7 - 22
lighting 3D charts 5 - 64
limiting records appearing in the Data window 3 - 4, 3 - 54–3 - 55

example expressions for 7 - 43
line charts

example 5 - 13
table configuration for 5 - 13

lines, formatting series 5 - 102



list library
about 2 - 41

LIST_CONTAINS function 7 - 22
LIST_ELEMENT function 7 - 22
LIST_INDEX function 7 - 22
LIST_RANDOMIZE function 7 - 22
LIST_REMOVE function 7 - 22
LIST_REVERSE function 7 - 22
LIST_ROTATE function 7 - 23
LIST_SIZE function 7 - 23
lists

about 2 - 41
editing 2 - 42

LIT_TO_QTY function 7 - 23
literal functions, reference table of 7 - 22
literal variables

about 6 - 3
creating computed 6 - 45–6 - 49
creating imported 6 - 17–6 - 21
editing 6 - 50, 6 - 67
operators and functions supported by 7 - 13

literals, entering in expressions 7 - 6
loading data 3 - 21–3 - 29
LOCALTIME_PART function 7 - 25
logical functions, reference table of 7 - 19
logical operators, reference table of 7 - 16
logical values, entering in expressions 7 - 7
loss and gain colors, setting for hi-lo-close charts 5 - 101
M
maintaining studies. See compacting studies
markers

adding and removing on data points 5 - 111
formatting series 5 - 103

matching types in expressions 7 - 8
MAX function 7 - 20
MEAN function 7 - 20
MEANS_SIGNIFICANCE function 7 - 21
MEDIAN function 7 - 20



MIDSTR function 7 - 23
MIN function 7 - 20
MODE function 7 - 20
multiple copies, printing 1 - 31
N
naming variables, rules for 6 - 8
nesting expressions 7 - 8
No Reply (NR)

about 3 - 5
entering in expressions 7 - 7

No Value (NV)
about 3 - 5
entering in expressions 7 - 7

non-question text in surveys
deleting 2 - 173
editing 2 - 150

nonscrolling, making table headings 4 - 61
NORMALIZE function 7 - 20
NOT operator 7 - 16
NR (No Reply)

about 3 - 5
entering in expressions 7 - 7

numbering survey blocks 2 - 14
numbers, entering in expressions 7 - 6
NV (No Value)

about 3 - 5
entering in expressions 7 - 7

O
OCCURS function 7 - 24
open-end questions

about 2 - 58
opening

charts 5 - 29
data sets 3 - 10
studies 1 - 2
surveys 2 - 48
tables 4 - 37

operators



- (negation) 7 - 15
- (subtraction) 7 - 15
% 7 - 16
* (multiplication) 7 - 15
+ (addition) 7 - 15, 7 - 16
/ (division) 7 - 15
< (less than) 7 - 16
<= (less than or equal to) 7 - 16
<> (not equal to) 7 - 16
= (equal to) 7 - 16
> (greater than) 7 - 16
>= (greater than or equal to) 7 - 16
AND (conjunction) 7 - 16
entering in expressions 7 - 8
NOT (logical negation) 7 - 16
OR (union) 7 - 16
precedence among 7 - 17
reference tables of 7 - 15–7 - 16
supported by variable types 7 - 13

optional block components
about 2 - 13

Options section of data dictionary files A - 9
OR operator 7 - 16
orientation, setting for printing 1 - 16
orienting chart text 5 - 52
outlining series 5 - 96
P
page order, setting for printing tables 1 - 24
page size, setting for printing 1 - 16
Paste Special command

using in surveys 2 - 168
using in tables 4 - 51

pasting
instructions-only blocks 2 - 168
question blocks 2 - 168
survey blocks using the Paste Special command 2 - 168
table cells 4 - 75
table cells using the Paste Special command 4 - 51, 4 - 76



patterned backdrops, drawing for chart elements 5 - 56
patterns

applying to table cells 4 - 59
removing from table cells 4 - 59

PERCENTAGE function 7 - 18
PERCENTAGE_SIGNIFICANCE function 7 - 21
pictures

embedding or linking 2 - 91
inserting 2 - 5, 2 - 91

pie charts
arranging the sections of 5 - 90
controlling the drawing direction of 5 - 89
defining the starting position of 5 - 89
example 5 - 13
specifying the height of 3D 5 - 91
specifying the top radius of 3D 5 - 91
table configuration for 5 - 13
weighting 5 - 90

plots
adjusting bar spacing in 5 - 86
bases and walls, formatting 5 - 84
positioning 5 - 83
sizing 5 - 83

plotting values in tables 4 - 79
polar axes, scaling 5 - 78
polar charts

controlling the drawing direction of 5 - 89
defining the starting position of 5 - 89
example 5 - 14
table configuration for 5 - 14

portrait, choosing as a printing orientation 1 - 16
positioning plots 5 - 83
POWER function 7 - 18
precedence among operators 7 - 17
preferences, setting startup B - 2, B - 3
print layout mode

about 2 - 19
printers, selecting 1 - 10



printing
charts 1 - 14
column letters on tables 1 - 30
controlling alignment of tables and charts 1 - 20
controlling color in printed tables 1 - 31
enlarging what you want to print 1 - 18
grid lines on tables 1 - 30
multiple copies 1 - 31
ranges of pages from surveys or tables 1 - 15
reducing what you want to print 1 - 18
row numbers on tables 1 - 30
setting page order for tables 1 - 24
setting page size 1 - 16
specifying page orientation 1 - 16
surveys 1 - 14
tables 1 - 14

prompts
deleting 2 - 158
editing text of 2 - 155
rearranging 2 - 160

purging
records from data sets 3 - 47

purpose of this manual ix
Q
QTY_TO_LIT function 7 - 23
quantities, entering in expressions 7 - 6
quantity questions

about 2 - 60
quantity variables

about 6 - 3
adding scale points to imported 6 - 16
creating computed 6 - 42–6 - 45
creating imported 6 - 13–6 - 17
deleting scale points from imported 6 - 17
editing 6 - 63–6 - 66
operators and functions supported by 7 - 13

question block layouts toolbar
about 2 - 21



moving 2 - 23
question block wizard

about 2 - 30
all-that-apply tabs 2 - 34
closed-end tabs 2 - 35
constant sum tabs 2 - 36
open-end tabs 2 - 37
other tab 2 - 33
prompts 2 tab 2 - 32
prompts tab 2 - 31
quantity tabs 2 - 39, 2 - 41
questions tab 2 - 31
ranking tabs 2 - 40
type tab 2 - 30

question blocks
about 2 - 6
copying 2 - 166
cutting 2 - 166
deleting 2 - 173
editing 2 - 150
inserting 2 - 73–2 - 82
pasting 2 - 168

questions, survey
all-that-apply

about 2 - 58
closed-end

about 2 - 58
editing 2 - 150
open-end

about 2 - 58
quantity

about 2 - 60
rating

about 2 - 58, 2 - 60
R
radar charts

controlling the drawing direction of 5 - 89
defining the starting position of 5 - 89



example 5 - 15
selecting as the chart type 5 - 35
table configuration for 5 - 15

RAND function 7 - 18
ranges of pages, printing from surveys or tables 1 - 15
ranges, editing quantity variables’ 6 - 66
RANK function 7 - 20
RANK_PERCENT function 7 - 20
rating questions

about 2 - 58, 2 - 60
RATIO function 7 - 18, 7 - 19
rearranging

categories in category variables 6 - 61
columns in the Data window 3 - 58
prompts 2 - 160

recalculating
values for entire studies 1 - 33
values in computed variables 6 - 68
values in tables 4 - 78

RECORD_VALUE function 7 - 24
RECORDNUM function 7 - 24
records

deleting from data sets 3 - 46
displaying all in the Data window 3 - 54
editing using the Interviewer 3 - 33
entering using the Interviewer 3 - 11–3 - 20
example expressions for limiting those appearing in the Data window 7 - 43
limiting those appearing in the Data window 3 - 4, 3 - 54–3 - 55
purging from data sets 3 - 47

RECORDS function 7 - 24
reducing what you want to print 1 - 18
relationship between charts and tables 5 - 4
renaming variables 6 - 50
reordering

categories 6 - 61
prompts 2 - 160
series 5 - 40

REPLACE function 7 - 23



REPLACE_RE function 7 - 23
respondent functions, reference table of 7 - 24
responses to surveys questions, entering in a study 3 - 11–3 - 20
rewriting computed variables’ expressions 6 - 53
RIGHT function 7 - 23
rotating 3D charts 5 - 61
ROUND function 7 - 18
row and column filters

about 4 - 41–4 - 47
defining 4 - 41–4 - 50
examples of expressions for 7 - 42
saving time by using 4 - 45–4 - 46
syntax for 4 - 35
using, an example 4 - 42–4 - 45

row headings, defining in tables 4 - 31–4 - 34
row numbers, printing on tables 1 - 30
rows

changing height of in tables 4 - 73
hiding in tables 4 - 71
inserting in tables 4 - 64
showing in tables 4 - 71
sorting respondent records in the Data window 3 - 60

rules for naming variables 6 - 8
S
saving

your work 1 - 34
your work under a different name 1 - 34

scale points
editing 6 - 64

scales, hiding and showing scales on 5 - 72
scaling

category (X) axes 5 - 74
category (Z) axes 5 - 74
date axes 5 - 77
polar axes 5 - 78
printed surveys, tables, or charts 1 - 18
value (Y) axes 5 - 76

scientific notation



applying to values in charts 5 - 118
applying to values in table cells 4 - 60

selecting
cells in the Analysis window 4 - 5
different chart types 5 - 33
printers 1 - 10
records to appear in the Data window 3 - 54–3 - 55

series
adding and removing guidelines on 5 - 104
defining bubble diameters 5 - 100
displaying statistics on 5 - 106
excluding 5 - 94
filling 5 - 96
formatting lines 5 - 102
hiding and showing 5 - 94
labels

creating 5 - 113
positioning 5 - 115

markers, formatting 5 - 103
outlining 5 - 96
reordering 5 - 40
selecting 3D bar styles 5 - 99
setting gain and loss colors for hi-lo-close charts 5 - 101
smoothing 5 - 100
stacking and unstacking 5 - 41–5 - 43

setting startup preferences B - 2, B - 3
showing

axes’ scales 5 - 72
block components in the Survey Designer window 2 - 185
columns in the Data window 3 - 56–3 - 57
rows or columns in tables 4 - 71
second value (Y) axes 5 - 47
series 5 - 94

sizing plots 5 - 83
skip logic

about entering 2 - 15
editing 2 - 150

smoothing series 5 - 100



solid backdrops, drawing for chart elements 5 - 56
SORTED_RECORDNUM function 7 - 24
SORTED_RECORDS function 7 - 24
SORTED_UNIQUE_RECORDS function 7 - 24
sorting

table cells 4 - 80
SORTORDER function 7 - 24
SORTORDER2 function 7 - 25
space between bars, adjusting in bar charts 5 - 86
spelling

checking in data sets 3 - 42
using the interviewer to check 3 - 42

spelling dictionaries
changing 2 - 177

spelling, checking in surveys 2 - 174
stacking series 5 - 41
stand-alone text in surveys

deleting 2 - 173
editing 2 - 150

STANDARDIZE function 7 - 20
startup preferences, setting B - 2, B - 3
statistical descriptions functions, reference table for 7 - 20
statistical manipulation functions, reference table of 7 - 20
statistical test functions, reference table of 7 - 21
statistics, displaying on series 5 - 106
STDEV function 7 - 20
step charts

example 5 - 15
table configuration for 5 - 15

STRIP function 7 - 23
studies

closing 1 - 37
compacting 1 - 36
creating 1 - 2
opening existing 1 - 2
saving 1 - 34
saving under a different name 1 - 34
updating 1 - 33



Study window
about 1 - 4
Analyses tab 1 - 7
Data tab 1 - 6
Survey tab 1 - 5
Variables tab 1 - 8

SUBSTR function 7 - 23
SUBSTR_RE function 7 - 23
Survey Designer window, changing display of 2 - 184
survey explorer toolbar

about 2 - 24
moving 2 - 27

survey fields
computed value 2 - 140
copying and pasting 2 - 145
dragging and dropping 2 - 145
editing 2 - 142
limitations 2 - 148
removing 2 - 148
variable value 2 - 137

survey fields, computed value
examples of expressions for 7 - 36

survey layout modes
about 2 - 17

Survey tab of the Study window 1 - 5
surveys

about 2 - 6
about headings in 2 - 67
about introductions in 2 - 67
about types of questions in 2 - 58
changing appearance of in the Survey Designer window 2 - 184
checking spelling in 2 - 174
closed-end questions 2 - 58
creating 2 - 44, 2 - 50
deleting questions from 2 - 173
editing 2 - 150–2 - 175
exporting 2 - 190
formatting. See surveys, exporting



open-end questions 2 - 58
opening existing 2 - 48
printing entire 1 - 14
printing ranges of pages from 1 - 15
rating questions, about 2 - 58, 2 - 60

T
tables

about 4 - 3
about values in cells 4 - 6
aligning cell values in 4 - 53
aligning printed 1 - 20
borders, applying and removing on cells 4 - 57
calculating values appearing in cells 4 - 34–4 - 36
cell dimensions, changing in tables manually 4 - 73
cells, sizing to fit values automatically 4 - 74
charting 4 - 79
clearing cells 4 - 76
column width, changing 4 - 73
configurations required for chart types 5 - 6–5 - 16
controlling color in printed 1 - 31
copying 4 - 39
copying cell properties in 4 - 51–4 - 52
copying cells 4 - 75
creating by using wizards 4 - 22
creating custom 4 - 28–4 - 36
creating footers for printed 1 - 24
creating headers for printed 1 - 24
cutting cells 4 - 75
defining headings in 4 - 31–4 - 34
defining titles for 4 - 31–4 - 34
deleting cells 4 - 77
displaying data in as charts 4 - 79
editing text in cells 4 - 62–4 - 63
examples of expressions for values in cells 7 - 42
exporting 4 - 82, 4 - 84, 4 - 89
expressions for cell values, about 4 - 6
fonts, changing in cells 4 - 56
formatting 4 - 53–4 - 63



hiding and showing rows and columns in 4 - 71–4 - 72
inserting category variables in 4 - 67–4 - 70
inserting cells in 4 - 70
inserting columns in 4 - 66
inserting rows in 4 - 64
making row and column headings nonscrolling in 4 - 61
opening 4 - 37
pasting cells 4 - 75
patterns, applying and removing on cells 4 - 59
printing entire 1 - 14
printing ranges of pages from 1 - 15
recalculating values in cells 4 - 78
relationship with charts 5 - 4
resizing cells, rows, and columns in 4 - 64–4 - 74
row height, changing 4 - 73
sorting cells 4 - 80
specifying number formats in 4 - 60
updating values in 4 - 78
viewing charted data as 5 - 32

targets
inserting 2 - 96

templates, variable
changing for imported variables 6 - 52

text
copying 2 - 172
dragging and dropping 2 - 172
moving 2 - 172
rearranging 2 - 172

text in table cells, editing 4 - 62–4 - 63
thickness, changing axes’ 5 - 68
3D charts

adjusting viewing distance for 5 - 61
controlling proportioning of 5 - 61
displaying 5 - 61
elevating 5 - 61
formatting bases in 5 - 84
lighting 5 - 64
rotating 5 - 61



selecting a style for bars in 3D bar charts 5 - 99
specifying the height of doughnut charts 5 - 91
specifying the height of pie charts 5 - 91
specifying the top radius of pie charts 5 - 91

tick marks, adding and removing on axes 5 - 80
titles

adding to charts 5 - 45
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